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Chapter 9 - Typical Sections

Whether you work on roadways or retaining walls, typical sections (known as templates in InRoads V8i) 
provide the tools necessary for creating 3D models for your proposed designs. Anything that can be defined by 
a typical cross section and horizontal and vertical alignments (not just roadways) can be modeled with 
templates. For example: channels, walls, ditches and dams can all be modeled using this approach.

The way a template and its points are defined is critical to how it will behave during the modeling process. The 
resulting model created from the templates is used to provide critical information to Construction. This 
information is generated from various reports like the Cross Section staking report (see the Roadway Modeling 
and Reports chapters for more information). 

Typical sections are stored in a template library (ITL) which is saved on the hard drive with an extension of 
*.itl. A standard template library file is based on the CDOT Roadway Design Guide 2005 and the CDOT M&S 
Standard Plans 2006 Edition. 

Chapter Objectives:

 To become familiar with how typical sections fit into CDOT’s design process.

 To learn how to match the CDOT standard templates to your design criteria.

 To gain an understanding of when to use the completed templates included in the default 
template library on your projects.

 To learn how to prepare typical sections that match your design criteria if the standard ones 
do not.

Template Library

Section Objectives:

 To create a project-specific template library using the CDOT standard template library.

 To copy templates from other jobs for use in a project-specific template library.

 To become familiar with the Create Template interface for creating and editing templates.

Templates are stored in a template library (.itl). CDOT has created a standard template library 
that contains several CDOT-specific templates. These CDOT standard templates are based on:

 Typical sections shown in the CDOT 2005 Roadway Design Guide manual

 Roadway components or features shown in the CDOT M&S Standard Plans 2006 Edition

 Clear Zone criteria

 CDOT’s Cut and Fill slope requirements

Standard Template Library

The CDOT standard templates are developed and maintained to facilitate the design process for 
CDOT projects. The path for CDOT’s standard template library is C:\Workspace\Workspace‐
CDOT_V8i\Standards‐Global\InRoads\Templates\ CDOT_Template‐Library.itl. The library 
consists of models of typical sections as defined in the CDOT 2005 Roadway Design Guide 
and other typical sections commonly encountered by CDOT designers. 
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Project Template Library

The CDOT library should be copied to the project folder and modified as needed for a 
particular project or design situation. This is accomplished by copying the CDOT_Template‐
Library.itl to the C:\Projects\JPC#\ Discipline\InRoads\ folder before editing. 

Important! Changes made to the standard CDOT_Template‐Library.itl in the \Standards‐
Global folder will be overwritten by CDOT’s file management software 
ServerCop during log in. 

Creating a Project Template Library

To create a project specific template library:

1. From the InRoads main menu, select the Templates bottom tab.

2. <R> on Template Library in the InRoads Explorer and select Open from the menu.

3. Navigate to C:\Workspace\Workspace-CDOT_V8i\Standards-
Global\InRoads\Templates.

4. Highlight the CDOT_Template‐Library.itl file and <D> Open.

5. <R> on the CDOT_Template_Library.itl file in the information pane and select Save As.
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6. Navigate to the project’s InRoads folder (C:\Projects\12345\Design\InRoads\ in this 
example).

7. In the Save As dialog box, key in the desired Name such as 12345_Template‐Library.itl.

8. <D> Save.

Note: The file may also be copied using Windows commands.

Update the *.rwk file to load the new template library. This ensures the new template library 
will open with the other InRoads data for the project.

9. From the InRoads main menu choose File > Save As.

10. In the Project Save As dialog box, navigate to the design folder 
(C:\Projects\12345\Design\InRoads\ in this example).

11. Choose Projects (*.rwk) from the Save as type: field 

12. Choose an existing project file from the Save As dialog box by highlighting it or key in the 
name of a new project file. (For this example 12345.rwk is used.)

13. Click on the Options button.
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14. From the Template Library tab of the Project Options dialog box, verify the filename of the 
template library is correct and toggle on Update. (The Add automatically toggles on as 
well.)

15. Click OK to accept the changes in the Project Options dialog box.

16. Click Save to save the InRoads Project file.

17. Click Cancel to dismiss the Save As dialog box.

18. To load the project template library from this point on, open the Project file (12345.rwk).

Copying existing Templates to a Project Template Library

Templates created for previous projects can be used in the current project. These templates 
should be copied from their original libraries into the current project’s library. This avoids 
confusion and the possibility of altering the wrong template.

To copy a template into the project template library from another library:

1. Select Modeler > Create Template from the InRoads menu bar.

2. From the Create Template menu bar, select Tools > Template Library Organizer.

3. In the Template Library Organizer dialog box, <D> the  button.
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4. In the Open Template Library dialog box, navigate to the folder of the source template 
library (C:\Projects\55555\Design\InRoads\ in this example).

5. Highlight the source template library and <D> Open. The selected library is displayed in 
the right Available In area of the Template Library Organizer dialog box.

6. Expand the right template library to show the template you want to copy.

7. Expand the left template library to show where you want the template to reside.

8. Drag the desired template from the right library and drop it in the left (55555_HMA_4Lane 
in this example).

Note: Be certain to drop the template in the correct location. If it is dropped ‘in space’ 
and not in a folder, the template is not copied.

9. Repeat for any other templates you need to copy.
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10. <D> OK when finished.

Note: The left Available In pane is the library currently loaded in InRoads. Templates can 
be copied from the left library to the right as well.

Note: Templates are copied into the IRD file when setting up Template Drops (see the 
Roadway Modeling chapter for details). If a template you need resides in the IRD, 
you can open the IRD file here and copy template(s) from the IRD into your ITL.
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Create Template

The Create Template dialog (accessed from Modeler > Create Template) is used to create 
or edit templates within the loaded template library. It is a visual interface that allows you to see 
the template as it’s being created and to test the end conditions prior to using the template in 
Roadway Designer.

The Create Template dialog contains several areas as shown and described below.

Menu Bar

      

The Menu Bar consists of four pull-down menus.
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File Menu

The File menu is used to create, load and save the template library (ITL).

Important! While working in Create Template, you are working in your computer’s 
memory and you should periodically save your ITL file, such as after any 
major template edits. If you do not save changes to your ITL file, you will 
be asked to save upon exiting from the dialog. Once you have closed the 
dialog, unsaved changes are lost.

To translate a previous InRoads version TML file (InRoads V8.5 and earlier) to the new 
ITL format, select File > Import TML and specify the TML file.

Important! Be careful! Templates are drastically different in this version of InRoads 
than in 8.5 and prior versions. If you convert a template you must carefully 
check every aspect of the components and points to ensure they converted 
properly. In most instances, you are better off creating the template in the 
current version rather than converting.

To import a template from graphics, you can use File > Import Template. You must first 
draw the template with MicroStation, then make a selection set from the graphics before 
selecting this option. 

Edit

♦ The Edit menu contains standard edit functions that apply to the highlighted template 
or folder. See the Edit Commands section in the InRoads Online Help for more 
information.

Add

♦ Add > Simple, Constrained, Unconstrained, Null Point, End Condition and 
Overlay/Stripping: Used to create new components in the active template. 

Note: Each of the above Add options is described in greater detail in the Components 
section of this chapter.

Tools

♦ Tools > Template Library Organizer: Allows templates, point names and folders 
to be copied between two libraries. See the previous section on Copying existing 
Templates to a Project Template Library for additional details.
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♦ Tools > Apply Feature Name Override: Allows multiple point names in a 
template to create one feature in the resulting surface. Highlight the point names in the 
dialog and key in the name you want the combined feature to have, then <D> Apply. 
For example, use this when multiple Cut or Fill slopes would normally result in 
multiple features, but the desired result is one continuous feature instead. The feature 
names turn red in the template display to note the override is used. This can also be 
accomplished in the Point Properties for each of the points in question.

    

This option may also be useful when transitioning between two templates using 
different named points that you want to result in one continuous feature. For example, 
if the two templates use CL and Centerline, respectively, you may toggle on Apply 
Feature Name Override for both and use the same name for the resulting feature.

♦ Tools > Options: Allows the setting of default naming options for components and 
points. It also controls whether Affixes are used and if so, what they are. Steps can be 
set here for the placement of points and components on a grid, similar to 
MicroStation’s Grid lock.

♦ Tools > Dynamic Settings: Toggles on or off the Dynamic Settings box. See the 
Dynamic Settings section of this chapter for additional information.
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Library Tree

The Library tree is shown on the left pane of the Create Template dialog. Folders may be 
expanded or collapsed as necessary to see the template(s) available for copying or editing. The 
active template has a red box around its icon and is shown in the large template view at right. 
The highlighted template is shown in the Preview below the tree.

 Right-click on a folder to create a new folder or template, or access several of the Edit 
functions. See the Edit Commands section in the InRoads Online Help for more 
information.

 Right-click on a template to access several of the Edit functions. In addition, you can use:

♦ Set Active: Makes the template active (available for editing and shown in the large 
template view at right).

♦ Template Documentation Link...: Assigns a link to the template. This is very 
useful for documenting the template, section or individual component in the template. 
You can link a template to almost any type of file, including a word processor 
document, spreadsheet, text files or web page that explains or defines the template. The 
file is for reference only and does not affect the processing of the template.
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♦ Display: Brings up the template display dialog, allowing the display of the template 
on a grid in the MicroStation file. This can be used as the basis for your typical section 
drawing as an alternative to the CDOT Typical Section Program.

Active Template Tree

The pane on the left of Create Template can also be used to access the Active Template tree. At 
the bottom of the pane, select Active Template. Then, expand the portion of the template you 
want to access: either Points, Components or Display Rules. For each option, you can right-
click and Edit or Delete the individual items.

Note: This is the only place where you can change the name of a Display Rule.

At the bottom of the pane, there is an box displaying information about the highlighted item. It 
is informational only.

Preview

The pane at the left bottom of Create Template displays a preview of the highlighted template. 
From this pane, you can drag the template into the Active Template view to make a copy. You 
can drag it by the default drag-point (shown as a cyan box) or by any other point in the 
template. Dragging a template into itself is allowed.

http://www.google.com
http://www.google.com
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Current Template Information

The Current Template information is listed for the active template. In this area, you can add or 
change the template description but not the name. To change the name, right click the template 
in the library tree and choose Rename.

Display Options

The active template may be shown as Components (typical) or as Constraints (usually used 
when analyzing the constraints assigned). Point Names may be toggled on or off as desired. 
Display All Components will show any components in the template that are currently not 
displayed because of Display Rules. These components appear as dashed lines.

Important! When reviewing an unfamiliar template, it is always good to toggle on Display 
All Components so you can see any hidden components. 

Active Template Display

This view shows the active template. You may delete or rename templates in the list at left, but 
in order to make changes to a template it must be shown in this view. A template can be 
activated by double-clicking it in the library tree or by right-clicking on the template and 
choosing Set Active.

 At the bottom left of the view are the active template View Controls

These MicroStation-like controls allow you to Zoom In, Zoom Out, change the 
exaggeration in X or Y, Window Area and Fit the template in the window. Also on this set 
of commands are short-cuts to Undo and Redo as well as the toggle for Dynamic Settings. 
The Undo and Redo buffers are cleared when another template is activated or you close the 
dialog. 
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 Mouse Controls

The mouse wheel may be used to zoom in and out in this view. Clicking the wheel and 
holding it down while moving the mouse pans.

 Hover Options

♦ Over a Point

Hovering over a point brings up a pop-up of point information.

♦ Over a Line (component)

Hovering over a line of a component brings up a pop-up of component and segment 
information.

 Right-click menus

Right-clicking in the Active Template Display area brings up a menu. There are different 
menus available, depending upon where and when you click: in a clear area, on a point, on 
a line (component), while creating a component or while dragging component. Some of the 
commands are also found on the pull-down menus. When a right-click menu is active, the 
commands may be selected using either the left <D> or right <R> mouse button.
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♦ Right-click in a clear area.

○ Add New Component > Simple, Constrained, Unconstrained, Null, 
End Condition and Overlay/Stripping: Used to create a new component in 
the active template. See the Component section for details.

○ Template Documentation Link...: Assigns a link to the template. See the 
description in the previous section.

○ Check Point Connectivity...: Checks the template to see if any two points are 
closer together than the specified Tolerance. If there are, a box appears that lists the 
points for a specific location and allows you to choose which is to be deleted. If 
you want to keep both, choose <Esc>. Then, the next set of points are brought up. 
This is the same as Merging Points, but it seeks out the points for merging rather 
than having to select them individually.

○ Delete Components: Notice this is plural, which means you can <D> and drag 
your cursor across any number of components and they are deleted when you ‘let 
go’.

○ Change Template Origin: While this command is on all three right-click 
menus, it functions differently depending upon whether it is selected while right-
clicking on a point or not. On a point, it moves the template so that the point 
selected is at the 0,0 coordinate. If not on a point, it prompts you to identify the 
point you want to move to the 0,0 coordinate. 

Note: Remember, the 0,0 coordinate is where the template is applied to the 
horizontal and vertical alignment.

○ Delete Constraints from All Points: Removes all constraints from all points 
regardless of how they are set.

○ Set Dynamic Origin: This allows the Dynamic Origin (magenta box) to be 
moved to a different location. See the Dynamic Settings section later in this 
chapter for more details.

Important! The Dynamic Origin (magenta box) is not where the template is 
applied to the horizontal and vertical alignment.
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♦ Right-click on a point.

All of the clear area right-click options, plus:

○ Move Point: Allows the point to be moved graphically, or if Dynamic Settings is 
active the key-ins can be used. This command is only available for points that have 
no constraints (appear green and can be moved anywhere) or one constraint 
(appear yellow and must hold the value of the one constraint, e.g. if it has a slope 
constraint, it must be moved along that slope). 

Note: Red points cannot be moved unless at least one constraint is released. You 
can, however, Edit the constrained point and move it by changing the 
constraint value(s).

○ Edit Point: Brings up the Point Properties dialog and allows the editing of 
Names, Styles, Constraints, etc. See the section on Points for details.

○ Add Constraint: Allows the addition of a constraint to the point and prompts for 
the identification of the parent for the constraint, along with the value for the 
constraint. Add Full Constraint adds Horizontal and Vertical constraints at the 
same time. See the section on Point Constraints for additional details on available 
constraints and when to use each.

○ Delete Constraints: Menu options change depending upon the constraints 
currently assigned to the point. Allows the deletion of both or of individual 
constraints.

○ Delete Point: Removes the point from the template. If the point is between two 
points in a component, the remaining points are connected.

○ Delete From Components (Make Null): Removes the association of the 
point from the its component(s), but leaves the point along with its constraints 
intact.

○ Test Point Controls: Allows testing of constraint behavior as if external controls 
are applied to the point.
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♦ Right-click on a line.

All of the clear area right-click options, plus:

○ Edit Component: Brings up the Component Properties dialog and allows the 
editing of Name, Description, Styles, etc. See the section on Components for 
details.

○ Insert Point: Allows the placement of a new point in between two existing points. 
The point may be placed graphically or with key-ins using the Dynamic Settings 
box.

○ Add Point: Only available when right-clicking on a segment of an open 
component. Allows the placement of a new point at the end of the component 
closest to where you click.

○ Unmerge Component Points: Any common points between the component 
selected and other components are copied so that each component has only unique 
points. The copied points are named Copy of [original name]. Has no effect if the 
component does not share points with other components.

○ Set Component Display Rules: Brings up the Component Display 
Conditional Expressions dialog, which allows the creation or editing of Display 
Rules, and/or the assigning of Rules to the component selected. See the section on 
Display Rules for additional details.

○ Delete Component: Notice this is singular, which means it will delete only the 
component selected. If the line selected is common to multiple components, you 
are prompted for which you want to delete.
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♦ Right-click while using Add > Simple: 

○ Change Placement Point: By default, the Add > Simple command places 
the component by the upper left point of the parallelogram. Choosing this 
command moves the placement point to each of the other points successively 
around the component.

○ Mirror: Creates a second identical component (except for naming) mirrored about 
a vertical line at the 0 horizontal coordinate.

○ Reflect: Creates the component in the opposite direction.

○ Cancel: Stops the command without creating a component.

○ Set Dynamic Origin: See the Dynamic Settings section later in this chapter for 
more details.

♦ Right-click while using Add > Constrained, Unconstrained: 

○ Finish: Stops the placement of the component. Use this after the last point is 
entered.

○ Closed Shape: Makes the component being placed a closed shape. 

Important! Leaving Closed Shape toggled off and drawing the component closed 
is NOT the same as having Closed Shape toggled on. This is a 
component property and may be changed later, however. Components 
must be listed as Closed in order for them to be used in end-area 
volume calculations.

○ Mirror: Creates a second identical component (except for naming) mirrored about 
a vertical line at the 0 horizontal coordinate.

○ Undo Last: Removes only the last point created. This is very useful when you 
enter a wrong point, but don’t want to start over or wait until finished to correct the 
error in point properties.

○ Cancel: Stops the command and does not keep any entered points.

○ Set Dynamic Origin: See Dynamic Settings below.

♦ Right-click while dragging a template into the Active Template View. All of these 
commands are the same as described in the Right‐click while using Add > Simple 
section above.
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Dynamic Settings

The Dynamic Settings dialog can be very helpful when creating and editing templates. You can 
toggle on the dialog by selecting Tools > Dynamic Settings or by choosing the Dynamic 
Settings icon on the view controls toolbar in the Active Template view. The dialog changes 
depending upon if you are dealing with general components (as shown on the left) or end 
conditions (as shown on the right).

   

There are several options within the Dynamic Settings:

♦ The read-out can be shown as either X: and Y: or <D> on the label and it converts to X: 
and Slope:. This readout is from the Dynamic Origin which is shown as the small 
magenta box.

♦ Steps: Lists the steps or intervals as defined in Tools > Options and may also be 
entered here, either in X and Y master units or in X and Slope, depending upon the 
readout selected.

♦ Point Name: When creating a new point, the name listed is used. It may be chosen 
from the drop-down (which comes from the Point Name List) or keyed in. If a 
component is created, this name is used as the seed name for all the points.

♦ Point Style: If the Name is chosen from the drop-down, the Style is populated 
automatically from the Point Name List. If the name is keyed in, the Style may be 
chosen from the drop-down (which comes from the Styles in the current XIN). This 
style is assigned to the corresponding feature when the design surface is created by 
Roadway Designer.

♦ Apply Affixes: Toggles on or off the Affixes, which are set in Tools > Options.

♦ Key-ins: The drop-down menu lists the different key-ins that can be used when 
locating a point or component:

○ xy= x-value,y-value – based on the template grid

○ dl= delta x-value,delta y-value – from the previous point

○ hs= delta x-value,slope – from the previous point

○ vs= delta y-value,slope – from the previous point

○ ol= delta x-value,delta y-value – from the Dynamic Origin (magenta box)

○ os= delta x-value,slope – from the Dynamic Origin (magenta box)
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♦ Set Dynamic Origin: This allows the Dynamic Origin (magenta box) to be moved to 
a different location. Use this when the point being placed is offset a known x and y or x 
and slope from a point that is not the previous one located. Set the Dynamic Origin on 
the reference point, then use the ol or os key-ins listed above to locate the new point.

Important! The Dynamic Origin is not where the template is applied to the horizontal 
and vertical alignment. The template is applied at the 0,0 coordinate in the 
template grid. For clarity, you can keep the Dynamic Origin at the 0,0 
coordinate when not using it as noted above.

Additional options for End Condition Points are described in the CDOT End Conditions area of 
this chapter.

Test Mode

This command activates the Test End Conditions dialog as shown. 

To test the end conditions:

1. Choose the command while the template in question is active. If there are priority conflicts 
you will first be asked to choose the order of processing for the end conditions.

2. Select a target from the list of Available Targets (generated from the active template’s end 
conditions). 

3. Choose Draw and place the target in the desired position. If more than one target is listed, 
you may need to place all the targets before seeing a result.

4. After drawing the targets, you may select Failure Report for a list of end conditions that 
did not meet their targets.

5. Check Priorities allows the order of end conditions to be changed.

6. Check Duplicates checks the solution to see if there are multiple occurrences of the 
same feature name.
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7. In the Display Rules area, there is a list of the Display Rules found in the template. To 
force a temporary True or False results to see the outcome, select the rule and <D> on the 
True/False toggle.

8. Reset removes the targets and starts the process of testing over again.

Section Summary:

 The CDOT standard template library can be copied to start your project-specific library.

 Templates can be copied from previous projects.

 The Create Template dialog is used to create and edit templates.

 Right-click menus are available in the Create Template dialog. The commands they 
contain are context sensitive and depend upon where you are and what you are doing when 
you right click, for example: in a clear area, on a point or on a line of a component.

 The Dynamic Settings box allows you to use key-ins for precision placement of points and 
components.

 The Dynamic Origin (magenta box) is not where the template is applied. The 0,0 coordinate 
of the template is applied to the horizontal and vertical alignments.
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Organization of the Template Library

Section Objectives:

 To learn how the CDOT standard template library is structured and where to look for the 
necessary templates for your project.

 To learn how to modify the standard templates if necessary to meet your design criteria.

 To become familiar with the standard templates, sections and components available by 
reviewing how the standard templates are put together.

 To learn how the templates will work based on their component and point properties.

The CDOT_Template‐Library is structured with complete templates at the top of the folder 
structure and individual template pieces (called components) at the bottom. The purpose of this 
folder structure is to: 

1) Make completed templates more accessible in Roadway Designer and 

2) To emphasize that when building a new template, the first step is to create an empty 
template.

Note: In InRoads terminology, a template refers to everything in the template library that is 
not a folder or the point name list. To help with communication and training, CDOT 
has further categorized the contents of the template library into templates, sections, and 
components based on the completeness of the data they contain.

Each folder level in the template library (Templates, Sections, and Components) refers to the 
completeness of the template as follows:

 1 – Templates folder contains complete templates with the basic components of roadway 
cross sections.

 2 – Sections – Pavement folder contains portions of a roadway cross section including 
pavement and sub base for lanes, shoulders, curb and gutter, and medians.

 3 – Sections ‐ End Conditions folder contains Z-slope components, cut and fill slopes, and 
curb and gutter templates. 

  4 – Components contain individual building blocks for defining sections or templates. 

 The illustration below shows the standard template library’s top level folder structure as it 
appears in the Create Template dialog box.
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Templates

This folder contains standard templates based on the CDOT 2005 Roadway Design Guide. 
Modify these templates as needed. Save new or copied complete templates to this folder. 
InRoads V8i allows great flexibility in designing templates. With the advent of components, 
the design models used for CDOT’s V04.00.00 configurations adhere as much as possible to 
the CDOT 2005 Roadway Design Guide and the CDOT Standard Plans- M&S Standard 2006 
Edition.

The illustrations on the next several pages show the six templates included in the Templates 
folder as they appear in the Create Template dialog box.

 HMA_Divided_TypeA_4Lane – This is the typical design for a four lane divided highway 
based on Figure 4‐1 of the 2005 Roadway Design Guide. Each Pavement Section contains:

♦ 12 ft lanes (two lanes)

♦ 4 ft inside shoulders

♦ 12 ft outside shoulders

♦ Normal Crown Cross slope

Figure 1: HMA_Divided_TypeA_4Lane
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♦  The Hot Mix Asphalt pavement is 15” thick, made up of five lifts: 

○ 2 in top lift

○ 3 in middle lifts (three lifts) 

○ 4 in bottom lift

○ 6 in layer of Aggregate Base Course Class 6

The end conditions show the clear zone treatment and possible cut and fill slopes 
based on 6:1, 4:1 and 3:1 slopes. Please refer to the End Conditions section of this 
manual for a detailed discussion on the subject.

Figure 2: Pavement Section Detail from “Figure 
1:HMA_Divided_TypeA_4Lane” on page 200

Figure 3: End Conditions Detail
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“Figure 3:End Conditions Detail” on page 201 defines possible cut and fill solutions 
that tie the pavement section to the existing ground and are based on Table 4‐2 Fill 
Slopes of the 2005 Roadway Design Guide. This end condition includes:

♦ Z-Slope with a horizontal measurement of 12’ from the edge of pavement and a slope 
of 6 to 1

♦ (3) fill slopes; 6 to 1, 4 to 1, and 3 to 1

♦ (3) cut slopes; 6 to 1, 4 to 1, and 3 to 1

 CONC_Divided_TypeA_4Lane – This is the typical design for a four lane concrete highway 
based on Figure 4‐2 of the 2005 Roadway Design Guide. Each pavement section contains:

♦ 12 ft lanes (two lanes)

♦ 4 ft inside shoulders

♦ 12 ft outside shoulders

♦ The concrete thickness is 9 in

♦ 12 in ABC Class 6 base extends 2 ft past the edge of concrete and tapers down to the 
POSS as shown in the detail below

♦ End condition treatments are as shown from HMA_Divided_TypeA_4Lane

Figure 4: CONC_Divided_TypeA_4Lane
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 CONC_Ramp – The ramp template based on Figure 4‐3 of the 2005 Roadway Design 
Guide. The typical standard pavement section for single lane ramp for CDOT has a 15 ft 
lane, 4 ft and 6 ft shoulders. The pavement section contains:

♦ 15 ft lane

♦ 12 ft inside shoulder

♦ 6 ft outside shoulder

♦ The concrete pavement is 11 in thick

♦ 3 ft wide Hot Mix Asphalt pavement for guardrail type 3, 2 in thick, is placed along the 
shoulder edge. Refer to CDOT M&S Standards M-606-1.

♦ End condition treatments are as shown for HMA_Divided_TypeA_4Lane

Figure 5: CONC_Ramp
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 HMA_Urban_4Lane – This urban highway template is based on Figure 4‐4 of the 2005 
Roadway Design Guide. It contains:

♦ 12 ft lanes in each direction in a normal crown (two lanes)

♦ The asphalt pavement is 8 in thick, made up of:

○ 2 in top lift

○ 3 in middle lift

○ 3 in bottom lift

♦ 6 in layer of ABC Class 6 base runs under the asphalt to 12 in past the curb and gutter

♦ Type2-IIB curb section is used at the edge of pavement. This type of curb and gutter 
section allows the slope of the gutter pan to match the pavement cross slope for cross 
slopes greater than +4% or less than -4%

Note: To see the all the attached sections toggle on Display All Components in the 
Display section of the Create Template dialog box. The template is developed 
this way so that the end conditions connect properly to the top back of curb. 
Refer to Curb and Gutter discussions under the Pavement Sections of this 
manual for additional discussion on Curb and Gutter.

Figure 6: HMA_Urban_4Lane

Figure 7: Type2-IIB Curb Section
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 HMA_Crowned_B10 – This is a typical two lane normal crown template based on Figure 4‐
5 of the 2005 Roadway Design Guide. It contains:

♦ (1) 12 ft lane in each direction

♦ 12 ft Shoulders

♦ The asphalt pavement is 8 in thick, made up of:

○  2 in top lift

○ 3 in middle lift

○ 3 in bottom lift

♦ A 6 in layer of ABC extends 2 ft past the bottom lift on each side

♦ End condition treatments are as shown for HMA_Divided_TypeA_4Lane

Figure 8: HMA_Crowned_B10



Page 206 Colorado Department of Transportation

Chapter 9 - Typical Sections A Practical Guide for Using InRoads V8i SS2

 HMA_Full_Depth_Widening_2Lane – This template is for use on widening and resurfacing 
projects based on the Edge of Pavement Detail in Figure 4‐5 of the 2005 Roadway Design 
Guide. It contains:

♦ 12 ft lane overlay to each side of the centerline

♦ 12 ft shoulders built to a full depth of 8 in of asphalt

♦ HMA is a 2 in thick overlay pavement and 8 in thick at the shoulders. It is made up of:

○ 2 in top lift that extends 24 ft to each side of the centerline

○ 4 in leveling layer under the 2 inch top lift 12 ft to each side of centerline

○ A stripping component that can be adjusted to define milling depth.

○ 3 in middle lift under the new 12 ft shoulders

○ 3 in bottom lift under the new 12 ft shoulders

○ A 6 in layer of ABC Class 6 under the shoulders extends 2 ft past the bottom lift on 
each side 

♦ End condition treatments are as shown for HMA_Divided_TypeA_4Lane

Figure 9: HMA_Full_Depth_Widening_2Lane
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Pavement Sections 

The 2 ‐ Sections ‐ Pavement folders contain full depth segments of the roadway pavement 
cross section of a template. Pavement sections are partial templates. They represent one 
segment of the total pavement. For example, sections from the Driving Lane Sections folder 
represent a single pavement section from the finished grade to the subgrade. The reader is 
encouraged to explore the contents of the Pavement Sections sub-directories since only some 
of the sections are displayed or discussed below. The folder structure for pavement sections is 
shown in the illustration below.

Curb and Gutter

The Curb and Gutter Sections folder shown above contains Curb and Gutters as defined in the 
CDOT Standard Plans-M&S Standards M-609-01.

In the folder;

♦ C/G_Type2‐IB is curb and Gutter Type 2 (Section IB)

♦ C/G_Type2‐IIB, is curb and Gutter Type 2 (Section IIB)

♦ C/G_Type2‐IM is curb and Gutter Type 2 (Section IM) and

♦ C/G_Type2‐IIM is curb and Gutter Type 2 (Section IIM)

The Curb and Gutters are modeled such that:

1. When the curb and gutter is attached to pavement with cross slope of less than 4% 
while more than -4%, the gutter cross slope will be as defined in CDOT M&S 
Standards M-609-1.

2. When the curb and gutter is attached to pavement with cross slope greater than 4% or 
less than -4%, the gutter cross slope will match the cross slope of the pavement.

Important! The desire to have the gutter match the cross slope of the pavement is not a 
given. This is a design decision left up to the CDOT designer or engineer in 
charge of the project. While the curb and gutter sections in the CDOT standard 
template library reflect this decision, they can be modified for other design 
situations. See the section Display Rules and Parent Components on how to 
use different design criteria with these sections.
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Gutter Pan Cross Slope example

The CDOT M&S Standard M-609-1 was used to model the Type2‐IIB curb and gutter 
section.   The Type2‐IIB curb and gutter section shown here is a good example of how the 
new software is used to accommodate CDOT design decisions.

♦ Figure 10:C/G_Type2-IIB Pavement Less Than 4% - 10 shows C/G_Type2‐IIB in a 
normal cross slope condition and

♦ Figure 11:C/G_Type2-IIB Pavement Greater Than 4% - C/G_Type2‐IIB Pavement 
Greater Than 4% shows C/G_Type2‐IIB in a superelevated cross slope condition. 

Figure 10: C/G_Type2-IIB Pavement Less Than 4%

Figure 11: C/G_Type2-IIB Pavement Greater Than 4%
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Shoulder Sections

Shoulders

The figure below shows standard shoulder sections and how they are applied to a template 
design.

 HMA_Inside_Shoulder_5Lifts‐12z and HMA_Outside_Shoulder_5Lifts‐12z – The “stair-
step” design of the pavement edge is based on the Edge of Pavement Detail in Figure 4‐5 
of the CDOT 2005 Roadway Design Guide. Both sections contain:

♦ 12 ft wide outside shoulder

♦ The Hot Mix Asphalt pavement is 15 in thick, made up of five lifts: 

○ 2 in top lift 

○ 3 in middle lifts (three lifts)

○ 4 in bottom lift

♦ 6 in layer of ABC, Class 6 base

Both inside and outside shoulders are created for the right side of the pavement section. 
The Mirror or Reflect command is used to place the left side version for this shoulder 
section. 
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End Conditions Sections 

The 3 ‐ Sections – End Conditions folder contains predefined sections for end conditions 
complete with multiple cut and fill solutions. This folder is divided into groups for Curb and 
Gutter side slopes and Z slopes.

End conditions refer to roadside designs associated with the unpaved clear zone area or 
roadside safety items like Guardrail type 7, Guardrail type 3 and cut and fill slopes.

End Conditions treatment or the selection of roadside safety items is influenced by several 
factors. These factors will vary even within the project.

Below are some of the factors that will influence End conditions or component selection:

1. Clear Zone requirements

2. Design Speed and traffic volumes

3. Roadway Category or designation

4. Local terrain

5. Structures and obstructions

6. Right of Way limitations

7. Drainage requirements

8. Project budget

9. Local preferences

For CDOT, the primary reference material for the determination of End Conditions 
requirements based on Clear Zone, design speed and traffic volume is the Roadside Design 
Guide, 2006 Edition, published by American Association of State Highway and Transportation 
Officials (AASHTO). Other references include:

 CDOT 2005 Roadway Design Guide

 CDOT Standard Plans - M&S Standards

The designer needs to be familiar with the project, factors influencing design decisions and the 
above references.
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Z-Slope End Conditions

Z‐Slope End Condition sections describe the horizontal width and slope of the Z-Slope 
component. For Example,  Z12_6_to_1 defines a Z-Slope component that measures 12’ 
horizontally and has a slope of 6 to 1. The dimensions for the Z-Slope components come from 
Figures 4‐1 and 4‐5 of the CDOT 2005 Roadway Design Guide. Cut and fill slopes are based 
on Table 4‐2 Fill Slopes of the CDOT 2005 Roadway Design Guide.

Component and Point Properties

Component and Point Properties are major factors in determining how components are 
modeled. These properties are covered in more detail in later sections of this document but for 
now it is necessary to mention a few details regarding some of these properties.

In the Component Properties dialog, all of the cut and fill components have their Target set to 
the active surface. This allows the same end condition to be used on multiple projects without 
having to edit each component that lists the target.

When multiple end condition components begin at the same location in the template, the 
Priority determines the order of processing. The lowest numbered Priority is used first. If the 
slope does not intercept the existing ground (or other listed target), the next lowest priority is 
tried, and so on. Once a solution is found, processing stops for that location and no other slopes 
are tried. If no solution is found, the end condition fails and no sideslope is formed for that 
location. Processing occurs at each station where a template is ‘dropped’. See the Roadway 
Modeling chapter for more details on Template Drops.
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One differentiating factor for end condition sections is whether or not the checkbox for End 
Condition Is Infinite point property is toggled on. 

♦ When toggled off, the maximum length of the end condition is determined by its 
constraint. 

♦ When on, the end condition can extend past the distance defined in the constraint.

Standard fill height maximums for each slope were used to determine the default horizontal 
measurement (the horizontal constraint value in the Point Properties dialog box) for each slope. 
The horizontal measurement is not important for slopes that are allowed to be infinite, although 
it cannot be 0.00.
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Following is an example end condition section.

 Z12_6_to_1 – This section contains:

♦ (1) Fixed Z-Slope component measuring 12’ horizontally and a slope of 6 to 1.

♦ (1) 6 to 1 fill slope measuring 12’ horizontally.  Priority is set to 1.

♦ (1) 4 to 1 fill slope measuring 58’ horizontally.  Priority is set to 2.

♦ (1) 3 to 1 fill slope measuring 60’ horizontally.  End Condition is Infinite is toggled on. 
Priority is set to 3.

♦ (1) 6 to 1 cut slope measuring 12’ horizontally.  Priority is set to 4.

♦ (1) 4 to 1 cut slope measuring 58’ horizontally.  Priority is set to 5.

♦ (1) 3 to 1 cut slope measuring 60’ horizontally.  End Condition is Infinite is toggled on. 
Priority is set to 6.

Figure 12: Z12_6_to_1 End Condition Detail
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Components

This folder contains the components used to build sections and complete templates. They are 
sorted into subfolders based on their use. The illustration below shows the subfolder structure 
of the 4 – Components folder of the standard template library as it appears in the Create 
Template dialog box.

The standard components can be grouped into three functional categories: 

 linear elements

 fixed shape elements

 variable shape elements

The examples below represent typical component designs from each of these categories and the 
unique elements of the different component types.

Linear Elements

Components in the End Conditions folder fall into the linear elements category. These 
components are simple linear elements generally used to define options for side slopes. 
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A typical end condition component, like the one illustrated below, is a single line segment. The 
right point is constrained to the origin (the left point) with a horizontal and a slope constraint. 
The information for defining end condition components comes from Chapter 4 of the 2005 
Roadway Design Guide.

♦ Fill_6_to_1 – The typical end condition component, like the one illustrated above, is a 
single line segment. Its properties are:

○ Check for Interception

○ Place Point at Interception

○ Horizontal constraint with a Value of 12

○ Slope constraint with a Value of -16.67%

○ Both constraints have the point POSS as the Parent

Figure 13: Fill_6_to_1
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Fixed Shape Elements

The majority of the remaining components are classified as fixed shape elements. Fixed shape 
elements typically remain constant throughout a model unless design criteria dictates 
otherwise, in which case they are modified by Superelevation Controls, Points Controls or 
Parametric Constraints. See the Roadway Modeling chapter for additional details. The shape 
may be a polygon or it may be more complex like curb and gutter.

Important! These components have the component property Close Shape toggled on in 
order to be used in End-Area Volume calculations.

 ABC_Lane – This component is typical of most surfacing and subbase components. It 
contains:

♦ 4 points

♦ The top right point is constrained to the origin with horizontal and slope constraints. 
The value of the horizontal constraint is 12. The value of the Slope constraint 
is -2.00%. 

♦ The two bottom points are constrained to the points above by horizontal and vertical 
constraints. The value of the horizontal constraint is 0. The value of the vertical 
constraint is -0.50. These values are the same on both points.

Figure 14: Typical Fixed Shape Element
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Variable Shape Elements

There are few exceptions to the previous example. Currently those exceptions are limited to the 
Guardrail Type 7‐CE component in the \Barriers & Misc Components\Guardrail Type 7 folder 
and both Wing Wall_Cast‐in‐Place components in the \Barriers & Misc Components\Walls 
folder. 

Shapes of variable components are not fixed but depend on other design criteria and are used in 
areas of the project where a variety of field conditions require on-demand changes to the 
component design. The two component types previously mentioned are illustrated below.

Median Barrier Example

Guardrail_Type 7‐CE – This illustration shows how the shape of the barrier varies with the 
elevation changes of the travelways on either side of the median in a divided highway. This 
barrier has base width of 23” at a height of 34”or less. When the height is 34” or more, the 
base varies in width from 23” to a maximum of 26.75”. The design is based on the CDOT 
M‐606‐13 Guardrail Type 7 F‐Shape Barrier standard. 

Details of this component include:

♦ Two points on the bottom of the barrier are tied to the elevation on their respective side 
of the median. 

♦ The barrier height and width vary with the elevation difference between the two sides.

♦ To learn how to apply this median barrier, see Lab 3.4 in the Labs for InRoads V8i 
guide.

Figure 15: Guardrail Type 7-CE
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Wing Wall Example

WingWall_Cast‐in‐Place‐Fixed‐Base - This component is set up to adjust the wall height 
from pavement surface to the top of the wall based on maximum fill heights. It is used 
when the wall rises above the level of the roadway surface. Its sister component, 
WingWall_Cast‐in‐Place‐Fixed‐Top is used when the wall drops below the level of the 
roadway surface.

♦ The design of this component is based on the CDOT M‐601‐20 Wingwalls for Pipe or 
Box Culverts standard. As the maximum fill height for a wall height is reached, the wall 
height rises and the base of the wall expands to set base widths. 

○ Is made up of 10 wall components with different base widths.

○ Display Rules are used that only allow the display of the proper wall component 
based on the height of the wall.

Section Summary:

 The CDOT standard template library is organized into Templates, Pavement Sections, End 
Condition Sections and Components.

 There are several example templates in the completed template folders that you can use ‘as-
is’ or modify to fit your design criteria.

 Pavement Sections contain multiple components and can be used to build completed 
templates if one of the standard templates does not fit your design criteria.

 End Condition Sections match CDOT’s the standard sideslope design criteria.

 Components are the basic building blocks that can be used to build sections and templates. 

Figure 16: WingWall Cast-in-Place Fixed Base
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Template Development

Section Objectives:

 To become familiar with the different areas of the standard template library and how the 
sections and components can be used to create templates.

 To develop a background knowledge of how Points and Point Constraints work so the 
CDOT standard templates can be used more effectively.

 To learn the differences between Component types and how each is used in the CDOT 
template library.

 To learn how to apply basic Component Properties to control their display in the plan and 
cross sections.

 To learn how to create more complex components using the Parent and Display Rule 
component properties.

When constructing a template in InRoads, it is best to use the largest assembly that meets the 
design criteria. For example, if a 2 lane road with paved shoulders is required, the 
HMA_Crowned_B10 template may be used and lane, shoulder widths and lift thicknesses 
adjusted as required. If a standard template is used, it should be copied and renamed prior to 
editing. This will identify the template as being used for the project. 

It should be noted, however, that because the surfacing components are merged most templates 
are not suitable for a major overhaul. It would be tedious to add an additional lane to the 
HMA_Crowned_B10 template, for example. Therefore, the sample templates should only be 
used if they are very close to the desired design.

If there is not a template that will work, the sections should be used to create the desired 
template. There are sections available that cover most design situations with minor 
modifications. Modifications to the sections should be done prior to placing the section in the 
template. Editing the section before placing it in the template will reduce the amount of editing 
required if the section is used more than once.

It should be noted that most sections are set up to be placed on the right side of the origin. To 
place a section to the left of the origin, Reflect the section during placement. If the template 
design is symmetrical, the section can be placed on both sides using the Mirror option.

Certain specialty components may be required for a project (Type 7 Guardrail and Walls, for 
example). The component folders also contain these special components as well as all of the 
parts used to create the sections and templates. Components can be used in the template or used 
to build a new section, if required.

Finally, if there is not a component that can be used, a new component can be built. If the new 
component is a single unique part, it can be built directly in the template. If the new component 
is used multiple times, it should be created by itself in the proper component folder. This makes 
it easier to place the component in a template multiple times, or to place the component in 
multiple templates.

The information presented below is in reverse order to the sequence presented above. This was 
done so that the templates can be explained from the smallest building block to the complete 
template.
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Components

This section describes how template components are made and how they are edited. Examples 
from the template library are used to highlight key points.

Template Points

All components are made up of points. The points used to define a template become breakline 
features in the resulting design model. A template point is assigned a name and a style (which, 
in turn has a named symbology assigned) that determine the name and the style of the feature 
when the design surface is created with Roadway Designer. The features are then saved as part 
of the surface. Each point on the template must have a unique name. If the same name is used 
twice, it is appended with a numeric counter.

Point Constraints

Each point in a template can have constraints to determine how the points are allowed to move 
and their connectivity within a template. Many of the constraints have values such as distances 
or slopes from reference points. These reference points are called Parents. When a point 
moves, any point that lists it as a Parent is affected. Since the affected point may also be a 
parent for other points, there is a domino-type effect. Depending upon the constraint, 0, 1 or 2 
parent(s) may be required. Parent points do not have to reside in the same component as the 
affected point.

Important! Point Controls and Parametric Constraints override Point Constraints. For 
more information, see Point Controls and Parametric Constraints in the 
Roadway Modeling chapter.

Points may be:

 Fully constrained (two constraints). Fully constrained points appear as RED plus signs on 
the template. Most points on a standard template should be fully constrained. 

    

An example of a fully constrained point is shown here. The SubBase_Laneline‐Top point is 
constrained Horizontally and Vertically to the Conc_Laneline‐Top point. When the 
Conc_Laneline‐Top moves, the SubBase_Laneline‐Top point moves with it, maintaining 
horizontal and vertical distances as defined by the constraint values.



Colorado Department of Transportation   Page 221

A Practical Guide for Using InRoads V8i SS2 Chapter 9 - Typical Sections

 Partially constrained (one constraint). Partially constrained points appear as YELLOW plus 
signs on the template. It is sometimes beneficial to remove one constraint from a fully 
constrained point just for testing. 

For example, you may remove the slope constraint, then move a point to ensure the points 
below follow (as during superelevation), or that a Display Rule works correctly.

 Unconstrained (no constraints). Unconstrained points appear as GREEN plus signs on the 
template. 

Typically unconstrained points are points that will be assigned to follow a certain path, 
such as the Centerline of the template which follows the horizontal and vertical alignments. 
Other points that you know are to be controlled with point controls, such as the centerline 
of another set of lanes (as in a divided highway) following different horizontal and vertical 
alignments may also be unconstrained.

In general, points other than the centerline should be fully constrained unless there are special 
circumstances dictating otherwise. For an example, see the Point Controls section of the 
Roadway Modeling chapter.
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There are several different types of constraints you can place on points:

 Horizontal: Requires 1 Parent. The point is locked by a horizontal distance from the parent, 
as specified by the Value entered. 

  

An example can be found in most of the CDOT templates including the Section 
HMA_DrivingLane‐2Lifts. Here, the HMA_Lift2_Laneline‐Top point is horizontally 
constrained to the HMA_Lift1_Laneline‐Top parent point by a value of 0.00, meaning it will 
always have the same width from centerline as its Parent.

 Vertical: Requires 1 Parent. The point is locked by a vertical distance from the parent, as 
specified by the Value entered. 

   

An example can be found in most of the CDOT templates including the Section 
HMA_DrivingLane‐2Lifts. Here, the HMA_Lift2_Laneline‐Top point is vertically 
constrained to the HMA_Lift1_Laneline‐Top parent point by a value of -0.167, meaning it 
always maintains this depth from the top.

 Slope: Requires 1 Parent. The point is locked by a slope from the parent, as specified by the 
Value entered. 
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An example can be found in most of the CDOT templates including the Section 
HMA_DrivingLane‐2Lifts. Here the HMA_Lift1_Laneline‐Top point is slope constrained to 
the HMA_Lift1_Centerline‐Top parent point by a value of -2.0%.

 Vector Offset: Requires 2 Parents. The point is locked onto a vector as defined by the 2 
parents. The point may be offset perpendicular from the vector by entering a Value. 
Positive values are offsets to the right of the vector, Negative values to the left. 

   

An example can be found in many of the CDOT templates including HMA_Crowned_B10. 
Here the RT_HMA_Lift1_Laneline‐Top point is locked onto the vector defined by 
HMA_Lift1_Centerline‐Top to RT_HMA_Lift1_EOP‐Top, with a 0.00 Offset.

Note: The Parent points defining the vector do not have to be on either side of the 
constrained point, nor do they have to be in the same component. They are simply 
used to define a vector and can be anywhere in the template. This is most often 
used when the Parents form a vector that is variable during modeling, such as in 
superelevation, and you want the constrained point to follow the variable vector.

 Project to Surface: No Parent point is required, but a parent direction and a surface value 
must be specified. The point projects in the direction selected until it intercepts the surface 
listed. 

   

An example can be found in several of the CDOT templates.

Important! If two adjacent points in the same component project to the same surface, 
the component will ‘trace’ the surface in between the points. 
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 Project to Design: No Parent is required. The point is projected at the slope or vector 
defined by the second constraint and stops when it encounters the design model. This is 
most often used when a subgrade must tie to a variable sideslope. The Value listed 
determines the maximum distance the projection can go and a positive value forces the 
projection to the right, negative to the left. A zero Value allows an unlimited distance to 
either the right or left, whichever interception is closer.

 Horizontal Maximum: Requires 2 Parents. The point is locked to a horizontal distance 
from whichever parent is further to the right, with the distance specified by the Value. 

 Horizontal Minimum: Requires 2 Parents. The point is locked to a horizontal distance from 
whichever parent is further to the left, with the distance specified by the Value. 

 Vertical Maximum: Requires 2 Parents. The point is locked to a vertical distance from 
whichever parent is higher, with the distance specified by the Value. 

   

An example can be found in the CDOT template Guardrail_Type 7‐CE. This barrier is 
designed to be used as a median barrier in a divided highway. The barrier changes height 
based on the elevations of the different connect points, but must maintain a certain height 
above whichever connect point is higher. The constraints for the Barrier Top are shown. 
When this barrier is used between sets of lanes that follow different verticals, the top of the 
barrier will always remain a set height above the higher of the vertical alignments.

 Vertical Minimum: Requires 2 Parents. The point is locked to a vertical distance from 
whichever parent is lower, the distance specified by the Value. 

   

An example can be found in the CDOT template Guardrail_Type 7‐CE. This barrier is 
designed to be used as a median barrier in a divided highway. The barrier changes height 
based on the elevations of the different connect points, but the base must be below 
whichever connect point is lower. The constraints for the Barrier Toe are shown. (The 
parents are the Barrier Toe points which are derived from the Connect points.)
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 Angle Distance: Requires 2 Parents. The point is locked to an angle from the line defined 
by the two parents and a distance along the defined angle from Parent 1. This is used when 
you want to maintain a rigid shape, even when the base rotates. An example would be a 
rigid barrier sitting on pavement that rotates in superelevation.

 Style: No Parent is required. The Style constraint overrides the other constraints as needed. 
When toggled on, a Style is specified. When the template is used in Roadway Designer, the 
active surface and geometry project are searched for an alignment or feature with the 
specified style. If found, the template point follows the feature or alignment. If the 
Horizontal toggle is on, this overrides the constraint controlling the horizontal placement of 
the point. If the Vertical toggle is on, this overrides the constraint controlling the vertical 
placement of the point. If the Both toggle is on, this overrides both of the listed point 
constraints and a variable slope and width is used to connect with the feature or alignment. 
A negative range value sets a horizontal limit and forces a search to the left, positive to the 
right. If the range is set to 0, the closest instance of the Style is found. 

Labels

All of the constraints with the exception of Style and Project to Design can have a Label. A 
Label is a variable that can be assigned start and stop values (by station range) in Roadway 
Designer using Parametric Constraints. If a Parametric Constraint is assigned for the label, 
the value in the template is ignored. If no Parametric Constraint is assigned for the label, the 
value listed for the constraint in the template is used.

For example, you can assign the same label to each of the lower points in a lift, then with one 
entry in the Parametric Constraints dialog, you can change the lift depth for the entire 
alignment or any station range, even across multiple templates as long as the same labels are 
used in the different templates.

Labels must be keyed in for the first use in a template, then are available in the drop-down in 
for future use in that template.

See the Parametric Constraints section of the Roadway Modeling chapter for details.

Creating Components

A component is a series of points that forms either an open or closed shape used in defining a 
typical section or template. Components typically represent different types of roadbed 
materials or sideslopes (asphalt lifts, aggregate base, subgrade, cut, fill, etc.). Components are 
named and assigned styles (materials). 

The Style assigned to the component controls its display in Create Template, Roadway 
Designer and Cross Sections. In addition, the Style associated with the component assigns the 
category of the volume if the component is used in end-area volumes.

There are six different methods of adding new components: Simple, Constrained, 
Unconstrained, Null Point, End Condition and Overlay/Stripping.
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The first three of these methods create standard components. With each, the first point placed is 
unconstrained unless it is snapped onto an existing point that already has constraints. The 
method used to create a general component does not stay with the component once it is created. 
The points created with either of these methods can be edited or deleted and new points can be 
inserted.

 A component created with the Simple command initially consists of four points that form a 
parallelogram. The shape is defined by slope, width and thickness (default values: 2%, 12 
ft and 0.4 ft, respectively). The Simple method can be used to create a pavement lift, for 
example. The upper-right point is constrained to the placement point by slope and 
horizontal constraints, while the two lower points are constrained to the points above them 
by horizontal and vertical constraints.

With the following options, you can either sketch in the points that you want, then edit or add 
constraints to determine the precise locations of each point, or you can use the key-ins available 
through the Dynamic Settings. See the previous section on Dynamic Settings for key in details.

 A component created with the Constrained command is initially made up of points where 
each is constrained to the previous one with horizontal and vertical constraints, so that if 
the initial point is moved, all of the other points move as well.

 A component created with the Unconstrained command consists of points with no 
constraints (the points can move independent of each other).
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There are three specialized components:

 A Null Point is a component made up of one point that is initially unconstrained. Null 
Points can be Parents for points in other components, in effect being used for reference. For 
example, a Null Point can be assigned to follow a right-of-way limit (alignment or feature) 
using Point Controls in Roadway Designer, then used as the horizontal constraint for a 
sideslope preventing it from exceeding the limit. 

Another example is when the control point on a divided highway is the imaginary point 
where the two pavement sections would intercept in the middle, such as the Control point 
in the HMA_Divided_TypeA_4Lane CDOT template. In this case, the template is based off 
the Control point, but the point is not part of any of the components.

Note: Null Points, by definition, are not triangulated. They may, however, be added to the 
design surface as non-triangulated features when using the Create Surface 
command. See the Roadway Modeling Chapter for additional details.

 End conditions are components that can seek targets like surfaces, alignments or features, 
and typically form the sideslopes of the design. 

Multiple end conditions may be used together to form a complete sideslope and multiple 
sideslopes or alternates may begin at the same location on the template. When this occurs, 
the end conditions are assigned a priority determining the order in which they are processed 
with the first one able to form a complete sideslope being the one that is used at that 
location while any other sideslopes are discarded. CDOT End Conditions are discussed in 
the following section.
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 Overlay/Stripping components can be built to either add leveling courses below pavement 
overlays or as stripping components to mill existing pavement. 
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Typical CDOT Surfacing Component

The average surfacing component is a closed shape of four points. It defines a single layer of a 
specific material (in this example it’s hot mix asphalt). Both the points and the shape itself have 
a list of attributes called properties.

Component Properties

The following steps illustrate how to change component attributes. To edit the component 
properties:

1. <R> on a line of the shape and choose Edit Component from the menu (you can also 
<D><D> on the line to display the Component Properties dialog).

2. Key in the desired Name.

3. Key in the desired Description.

4. Select the desired Style from the drop down menu.

5. <D> Apply to accept the changes.

Note: Components use generic styles for the material they represent. Access styles 
for specific grades of material (based on the Pay Item Code Book) through the 
Component Properties dialog.
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Point Properties

The following steps illustrate how to change point attributes. 

1. <R> on the point and choose Edit Point from the menu to access the Point Properties. 
(You can also <D><D> on the Point to display the Point Properties dialog.)

2. Key in the desired Name. The name can also be selected from the drop down menu. 
Selecting a name from the menu also changes the Surface Feature Style. Names 
selected from the menu can then be edited if necessary.

3. Select the desired Surface Feature Style.

4. Select a Type for Constraint 1. See the previous section on constraints for additional 
information on the options available.

5. Select a Parent 1 using the drop down menu or the target button. Select the Parent 2 if 
required by the constraint type.

6. Key in a Value.

7. Key in a Label if desired. See the previous section on Labels for more information.

8. <D> Apply to accept the change.

9. <D> Close to dismiss the Point Properties dialog.
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Point properties for the example surfacing component:

♦ The point HMA_Lift1_Laneline‐Top has two constraints (which makes it fully 
constrained).

○ Constraint 1 is a Horizontal constraint measured from the point 
HMA_Lift1_Centerline‐Top with a Value 0f 12. This sets the width of the 
component.

○ Constraint 2 is also measured from HMA_Lift1_Centerline‐Top. It is a Slope 
constraint that defines the cross-slope of the component, which is set to a Value of        
‐2.00%. Horizontal and slope constraints are typically used when defining the top 
point of a component.

♦ The point HMA_Lift2_Centerline‐Top also has two constraints.

○ Constraint 1 is a Horizontal constraint with a Value of 0, which places the point 
directly under its Parent 1 (HMA_Lift1_Centerline‐Top).
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○ Constraint 2 has a Value of 0.17 (2”) that defines the thickness of the component 
(measured from its Parent 1 point, HMA_Lift1_Centerline‐Top). The point 
HMA_Lift2_Laneline‐Top has the same constraints as HMA_Lift2_Centerline‐Top, 
except the Parent 1 is HMA_Lift1_Laneline‐Top for both constraints.

♦ This configuration of point constraints is the most efficient set-up for pavement 
components. It allows the user to change the width of the component by controlling a 
single point (HMA_Lift1_Laneline‐Top) while maintaining a constant pavement 
thickness.

Complex Surfacing Component

On resurfacing projects its common that a leveling course is required below the pavement 
overlay lift. Additionally pavement stripping (milling) is also a common requirement.
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A leveling course or courses can be added to define the depth and composition (component 
style) of material to be placed. 

The above illustration contains a single leveling course designed to a maximum depth of 4 
inches.  Based on project needs this component can be configured to achieve either a maximum 
depth or achieve variable depths. Through various top/bottom options it allows the flexability 
to provide a multitude of solutions. The intent of the shown component is to have the top 
constrained to a overlay component allowing the leveling course to follow superelevation or 
other controls applied to the overlay course. The bottom option can specifiy  a defined depth or 
be configured with a zero depth causing the bottom of the leveling course to follow existing 
conditions at any depth.  As defined, the bottom of the  leveling course will tie into the higher 
of existing conditions, or 4 inches below the bottom of the overlay.
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A stripping component is unique that it is defined by it’s bottom, constructs vertically and 
overlays other components in the template.  This component also contains options for 
contraining it’s vertical limit to meet project needs. The critical part of building a stripping 
component is to activeate the toggle that defines it as a stripping component (vs. a leveling 
component).
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A variation of a typical surfacing component is HMA_Outside_Shldr‐Lift2. This component has 
two additional points that define the stair-step found at the edge of asphalt.

The three bottom points are defined in the same manner as a typical surfacing component for 
the point HMA_Lift2_Laneline‐Top. Also, HMA_Lift2_Hinge‐Top is defined like 
HMA_Lift1_Laneline‐Top above. However, the constraints on point HMA_Lift2_EOP‐Top are 
different. Constraint 2 uses Vector‐Offset. This type of constraint projects a line through the 
two parent points (HMA_Lift2_Shoulder‐Top and HMA_Lift2_Hinge‐Top). The Value defines a 
perpendicular offset to that projected line (a positive value is to the right and a negative value is 
to the left). Because the value in this example is ‘0’, the child point is placed on the projected 
line. 

This constraint forces the segment between points HMA_Lift2_Hinge‐Top and 
HMA_Lift2_EOP‐Top to match the cross-slope of the segment to its left and maintain the 
continuity of the cross-slope, even through transitions for super elevation.
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Subbase component

Subbase components have many of the same features used in surfacing components. The 
SubBase_Outside_Shoulder component has five points that define the subbase under the 
shoulder. They are set up like the corresponding points in Surfacing Example 2. However, the 
POSS uses a Horizontal and a Slope constraint. This is done in order to maintain the slope from 
the Subbase_EOP‐Top to the POSS.
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End Condition components

End condition components are used to form the sideslopes of the design. For example, they 
project from the design pavement to the existing ground. Therefore, they have some unique 
component and point properties.

Component Properties

The component properties for End Conditions have an additional area for End Condition 
Properties. These properties list the Target Type and Priority for processing end condition 
components.
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Target Type 

This property determines what the end condition will try to intercept. The Target Type  
affects the way the side slope is constructed. Feature XYZ, Alignment XYZ, and Style XYZ 
will override the slope constraint and use whatever slope is necessary to tie to the target 
location. All other Target Types observe the slope constraint to locate the point.

Additional drop down menus are displayed below the Target Type. These are used to list 
the target of the type specified in the Target Type. 

The information required for each Target Type is:

♦ Surface – Set to Active (which will tie to whatever surface is active) or to a specific 
surface. Surface is the most common Target Type and used by most CDOT standard 
sideslopes.

♦ Elevation – Enter the target elevation in the Vertical Offset field. This can be useful for 
setting elevations of benches, for example.

♦ Feature XY, Feature Elevation, and Feature XYZ – Identify a surface (Active can be 
used) and the Feature Name that you want to seek. For example, you may need to tie 
into an existing curb or an existing ditch feature.

♦ Alignment XY, Alignment Elevation, and Alignment XYZ – All must have a horizontal 
alignment specified. Alignment Elevation and Alignment XYZ also need the Vertical 
Alignment identified. For example, Alignment Elevation can be used to tie a special 
ditch into the elevation of a vertical alignment.

♦ Style XY, Style Elevation, and Style XYZ – Specify a Style. These targets work just like 
the previous Feature and Alignment targets, except the sideslope looks for a Style used 
in the active surface or geometry project instead of a specific feature or alignment 
listed by name. For example, if you are wanting to tie into an existing curb, but the 
curb is made up of multiple features, you can tie into the style for the curb and the 
sideslope finds the first occurrence at each template drop.

Note: The most often used Target Type is Surface.
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Priority 

♦ This property determines the order in which end condition components are processed. 
The processing order is from the lowest numbered priority to the highest. The flattest 
slopes are set to the lowest numbered priority so that they are processed first. If you do 
not set the priorities ahead of time, they can be set when the end conditions are tested.

Point Properties

For points that are part of an end condition, four additional check boxes for End Condition 
Properties are added to the Point Properties.

♦ Check for Interception -   If on, the point checks for an interception of the target 
between the previous point and this one. In general, turn this option on for the last point 
in a cut or fill definition. An example of where it would be turned off is for the 
foreslope of a ditch that has a flat bottom. 

♦ Place Point at Interception - When on, the point will be constructed where it contacts 
the target. When off, the point is constructed as defined by its constraints. Turn on this 
option in most cases when Check for Interception is on.

♦ End Condition is Infinite – When on, the point will extend past its defined width in 
order to contact its target. When off the point must reach its target within its defined 
width in order to be constructed. This option is used for the steepest cut and fill slope 
defined in the template. Since it is off for shallower sideslopes, they will not extend 
beyond their constrained horizontal distance.

♦ Do Not Construct – When on, the point will be solved for as normal, but will not be 
used when creating the component.
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Display Rules and Parent Components

Display Rules and Parent Components are component properties that determine when a 
component is displayed. They are often useful for turning off and on different components 
based on what is happening in other areas of the template and therefore can be used to assist in 
changing the template based on certain CDOT design decisions.

Display Rules are conditional expressions defined by horizontal or vertical offsets between 
specified points, the slope between two points, or the display of another component. For 
example, when the distance between two inside edges in a divided template is > X, a median 
ditch component can be ‘turned on’; when it is < X, a barrier can be ‘turned on’ and the median 
ditch ‘turned off’.

 A Parent Component controls the display of associated components. For example, a specific 
component is displayed only when its Parent component is displayed.

 Use Display Rules to change the basic shape or type of a component used under certain 
conditions, as in the Curb & Gutter through superelevation example below. 

 Use Display Rules to have InRoads decide between a series of components, such as testing 
the height of wall needed and using different, but standard width bases based on that 
height, as in the Wing Wall example below.

 Use Parent components for a group of components that operate as a unit and are turned on 
or off together, as illustrated in the Benching example. 

Curb & Gutter through superelevation

An example of a design decision being built into a template can be found in the CDOT 
typical section library in the curb and gutter sections. The Curb and Gutters are modeled 
with unique elements.  The elements unique to the Curb and Gutter section are the two curb 
components attached; one component is modeled with a standard cross slope for the gutter 
pan and the other is modeled to match the cross slope of the pavement. If this is not desired, 
see the note at the end of the section on changing or eliminating this decision.

The assumed design decision is:

○ When the cross slope is between +4% and - 4%, a -1” per foot slope is used for the 
gutter.

○ When the cross slope is greater than +4% or less than - 4%, the slope of the gutter 
pan matches the cross slope of the driving lanes.

Conforming to the design standard or design decision in this case is accomplished using 
Display Rules. Display Rules are a list of criteria that determine when a particular 
component is displayed. The Parent Component property is also used. Components that 
are associated with a Parent component are only displayed when the Parent Component is 
displayed. In this example the curb components are parents to the ABC components. This 
insures that the proper ABC components are displayed together with their respective curb 
components. This is necessary due to the different slope constraints of the two components 
described in the previous section.

In this example, using the component C/G_Type2‐IIB, the slope of the gutter pan changes 
based on the cross slope of the driving lanes (typically needed through superelevated 
areas). This would be extremely difficult to modify the component using point controls. 
However this can be accomplished easily using Display Rules. 
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To create a Display Rule:

1. <R> on the component and select Edit Component.

Note: Display Rules can be created while editing any component in the template, 
then assigned to other components as necessary.

2. <D> the Edit button next to the Display Rules field. This displays the Component 
Display Conditional Expression dialog box.

3. To create a new rule, <D> Add. This will bring up the Display Rule dialog box.

Note: The Template Display Rules at the bottom of this dialog list all the rules 
available in the active template. The area at the top of the dialog show the rules 
assigned to the particular component being edited.
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4. Key in a Name for the rule (spaces are removed from the name automatically). 

Note: The Display Rule name cannot be changed in this dialog once it has been 
created. To change the name, go to the active template tree, right-click on the 
Display Rule and choose Edit.

5. Key in a Description.

6. Select the Type from the drop down menu. Select the component or point names as 
required. For the Component Is Displayed type, a component name is selected. For all 
other types, first and second points are selected.

Note: For a list of the different Types available and how they are used, see the 
Display Rule section of the InRoads Online Help.

7. Select the mathematical expression to be used.

8. Key in the Value that the expression is tested against.

9. <D> OK. This dismisses the Display Rule dialog box.

In the rule displayed above, if the slope between point Laneline‐Top and point Curb‐
Gutter‐top is less than or equal to +4.00% or -4.00% (because Absolute Slope is used) 
then the component will be displayed. This is determined at every template drop during 
processing.

10. Back on the Component Display Conditional Expression dialog box, highlight the 
desired rule from the Template Display Rules list.

11. <D> the Selected Rule button. This adds the rule to the Conditional Expression.
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12. <D> OK.

13. In the Component Properties dialog box, <D> Apply.

14. <D> Close to complete the process.

This component will now be displayed while the pavement component has a cross 
slope between +4% and -4%.

Important! If the decision is made that the gutter must match the pavement cross slope at a 
different slope, edit each of these rules and change the value to a different 
slope. If you do not want the match the pavement slope in super, edit the 
section, toggle on Display All Components and delete the two dashed-line 
components. Then, Delete the two Display Rules or remove them from the two 
components.
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Wing walls

Multiple Display Rules can be used to further define when a component is to be displayed. 
In the component WingWall_Cast‐in‐Place‐Fixed‐Base, a number of separate components 
have been used to define the base of the wall. The particular component used is determined 
by the height of the wall. As in the previous example, this involves an assumed design 
decision and can be changed as needed.

 The component WingWall‐h3 uses two Display Rules.

○ Greater_2.5ft, displays the component if the vertical difference between points 
Wall_Top‐Front and Swale Toe is greater than 2.5 feet.

○ Less_3.5ft, displays the component if the difference between the points Wall_Top‐
Front and Swale Toe is less than or equal to 3.5 feet.

The And between the rules means that both rules must be true before the component can be 
displayed.

To add multiple display rules to a component:

1. <R> on the component and select Edit Component.

2. <D> the WingWall‐h3 component.

3. <D> the Edit button next to the Display Rules field. This displays the Component 
Display Conditional Expression dialog box.

4. Highlight the desired rule from the Template Display Rules (Greater_2.5ft in the 
example).

5. <D> the Selected Rule button.
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6. <D> the desired Boolean Operator button (AND in the example).

7. Highlight the next display rule to be used (Less_3.5ft in the example).

8. <D> the Selected Rule button.

9. Repeat steps 5, 6, and 7 until all the desired rules are added.

10. <D> OK.

11. <D> Apply on the Component Properties to save the display rule.

Note: Rules can also be grouped using the parentheses.
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Benching

The display of one component can be tied to the display of another by setting a Parent 
Component. Using the HMA_Urban_4Lane template as an example, the Benching 
components are children of the C/G_Type2‐IIB components (and the cut and fill 
components are children of the benching components). This displays the sideslopes 
attached to the curb with the 1” per foot gutter slope only when that curb is displayed. The 
parent component must exist within the template. 

To select a parent component:

1. <R> on the ‘child’ component and select Edit Component.

2. Select the Parent Component using the drop down menu or the target button.

3. <D> Apply on the Component Properties dialog box to save the change.

4. <D> Close to dismiss the Component Properties dialog box.
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Sections

Components are used to build larger assemblies in the CDOT standard ITL called Sections 
(which are used in turn to build templates). A section is a combination of components that are 
copied from within the template library and pasted into the new section. Any time a group of 
components will be used more than once (in the same template or in other templates) it should 
be built as a section. Building sections makes it easier to assemble templates because multiple 
components are placed at one time. 

Using Components to Build a Section

This example illustrates the steps used to create an 11’ driving lane section with three lifts of 
asphalt and an aggregate base.

1. Expand the template library folder structure to show 2 – Sections –Pavement > 
Driving Lane Sections > Hot Mix Asphalt.

2. <R> on the Hot Mix Asphalt folder and select New > Template from the menu.

3. Key in the name for the new section (HMA_11ft_DrivingLane-3Lifts in this 
example).
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4. Expand the template library folder structure to show 4 – Components > Aggregate 
Bases > Driving Lanes.

5. <R> on ABC_Lane and select Rename.

6. Key in the new name (ABC_11ft-Lane for this example).

7. <D> <D> on the ABC_11ft-Lane component in the template library to make the 
ABC_11ft-Lane active.

8. <D> <D> on the ABC_Laneline-Top point to edit the Point Properties.

9. Change the Value of Constraint 1 (the Horizontal constraint) to 11.

10. <D> Apply, then <D> Close.

Note: To change the thickness of the component, edit the Vertical constraint on the two 
bottom points of the component.

Figure 17: Set Horizontal Constraint
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The aggregate base component is ready for use. Next, modify the asphalt lane components.

11. Expand the template library folder structure to show 4 – Components > Pavements > 
Hot Mix Asphalt > Lanes.

12. Repeat steps 5 through 10 above for HMA_Lane-Lift1, HMA_Lane-Lift2, and 
HMA_Lane-Lift3. Rename the lanes and change the value of Constraint 1 to 11.

13. Select Tools > Options from the Create Template menu bar.

14. Turn off the Apply Affixes check box.

15. Set the Step Options to 0.1 for both X and Y.
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16. <D> OK.

17. Select Tools > Dynamic Settings.

Steps 13 through 17 make it easier to place data into a new section. Turning off the affixes 
prevents getting LT_LT_ and RT_LT_, etc. appended to point names. The Step options 
create an invisible grid that helps when placing components. The Dynamic Settings is a 
dialog box where the step interval can be changed and precision key-ins can be used to 
place components.

The next steps place the components into the new section.

18. <D> <D> on the new section (HMA_11ft_DrivingLane‐3Lifts).
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19. <D> on the HMA_11ft- Lane-Lift1. This will display the component in the Preview 
window.

20. <D> and hold on the green”+” in the Preview window.

Figure 18: HMA_11ft-Lane-Lift1 Component
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21. Move the pointer into the magenta square in the Template View Window. The Dynamic 
Settings dialog box will show “0.00” for X and Y when the pointer is on the template 
origin.

Important! This assumes the magenta square is located at the 0,0 coordinate in the 
template view. If it is not, you can use Set Dynamic Origin to move it 
there, or make certain you drop the template on the 0,0 coordinate. You 
can also right-click on the insertion point after it’s dropped and choose Set 
Template Origin to move it to 0,0.

22. Release the left mouse button to place the component.

23.  <D> on the HMA_11ft- Lane-Lift2. This will display the component in the Preview 
window

24. <D> and hold on the green”+” in the Preview window.

Figure 19: Place First Component
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25. Move the pointer onto the HMA_Lift2_Centerline‐Top point. The “+” turns white to 
indicate that the points are in the same location.

26. Release the left mouse button to place the component.

27. Repeat steps 23 through 26 for HMA_11ft‐ Lane‐Lift3 and ABC_11ft‐Lane.

28. All of the components that make up the section are now placed. However, the point names 
used between lift 3 and the ABC need to be changed. When components are connected, 
shared points take the point name of the component placed first.

29. <D> <D> on the point HMA_Lift4_Centerline-Top to display the Point Properties 
dialog box.

30. Use the Name drop down menu to select ABC_Centerline-Top.

31. <D> Apply.

32. <D> Close to dismiss the Point Properties dialog box.

Figure 20: Place Second Component
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33. <D> <D> on HMA_Lift4_Laneline-Top to display the Point Properties dialog box.

34. Use the Name drop down menu to select ABC_Laneline-Top.

The section is now ready for use in a template.

Figure 21: Change Point Properties

Figure 22: Final HMA_11ft_DrivingLane-3Lifts
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Templates

Building a symmetrical template

This example uses the lane section created above along with modified shoulder sections and 
end conditions to create a complete two lane template.

Select Tools > Options from the Create Template menu bar.

1. Turn on the Apply Affixes check box.

2. <D> OK.

When Sections and Components are placed, the point names are appended with LT_ and RT_. 
This will replace the default 1, 2, etc. that is affixed to duplicate point names.

3. Expand the template library folder structure to show 1 – Templates.
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4. <R> on the 1- Templates and select New > Template.

5. Key in a Name for the template (HMA_2Lane-11ft_Shldr-4ft).

6. <D> <D> on HMA_2Lane-11ft_Shldr-4ft. This makes the new template active.

7. Expand the template library folder structure to show 2 – Sections - Pavements > 
Driving Lane Sections > Hot Mix Asphalt.

8. <D> on the HMA_11ft_DrivingLane-3Lifts section so that it is displayed in the Preview 
window.
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9. In the Preview window, <D> and hold the green “+”.

10. Move the pointer into the Template View window and <R> while still holding the left 
mouse button. This displays a right click menu. When the right click menu is displayed, the 
left mouse button can be released.

11. Select Mirror (using either the left or right mouse button).

12. Move the pointer to the template origin (magenta square). The Dynamic Settings dialog 
box will show “0.00” for X and Y when the pointer is on the template origin.
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Important! This assumes the magenta square is located at the 0,0 coordinate in the 
template view. If it is not, you can use Set Dynamic Origin to move it there, 
or make certain you drop the template on the 0,0 coordinate. You can also 
right-click on the insertion point after it’s dropped and choose Set 
Template Origin to move it to 0,0.

13. <D> to place the sections.

By selecting Mirror from the right click menu, both the left and right driving lanes were 
placed at the same time. Turning on the Affixes labeled the left side points with the LT_ 
prefix and the right side points with the RT_ prefix.

14. Expand the template library folder structure to show 2 – Sections - Pavements > 
Shoulder Sections > Hot Mix Asphalt.

15. <D> <D> on the HMA_Outside_Shoulder_3Lifts-12z. The section is displayed in the 
window.

This section models a shoulder to match the pavement section as well as the proper edge of 
pavement configuration. However, the 12 foot width must be reduced to 4 feet.

16. <D> <D> on the point HMA_Lift1_EOP-Top to display the Point Properties dialog box.

17. Change the Value of Constraint 1 (the Horizontal constraint) to 4.00.

18. <D> Apply.
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19. <D> Close.

Notice that by changing a single point (HMA_Lift1_EOP‐Top), all of the lifts in the section 
were modified.

The width of the ABC lift must be modified, otherwise, it will protrude above the finished 
grade of the side slope.

20. <D> <D> on the point ABC_EOP-Top to display the Point Properties dialog box.

21. Change the Value of Constraint 1 (the Horizontal constraint) to 1.50.

22. <D> Apply.
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23. <D> Close.

Next, add the shoulders to the driving lanes.

24. <D> <D> HMA_2Lane-11ft_Shldr-4ft. 

25. <D> on the HMA_Outside_Shoulder_3Lifts-12z. 

26. In the Preview window, <D> and hold on the green “+”.

27. Move the pointer onto the point RT_HMA_Lift1_Laneline-Top so that the “+” turns white 
then release the left mouse button.

Note: Mirror is still on, so both shoulders are placed.

All of the components that make up the driving surface have been placed. Next, the vertical 
lines inside the template are removed. This will make each lift a single component.
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28. Place the pointer on one of the vertical lines and <R> to display the right click menu.

29. Select Merge Components. This removes the vertical line from the template.

30. Repeat steps 25 and 26 for all of the vertical lines inside the template. The final result is 
illustrated below:

Finally, the end conditions are added to the template.

31. Expand the template library folder structure to show 3 – Sections – End Conditions > 
Z-Slope End Conditions > Low Speed End Conditions.

32. <D> on the Z12_4_to_1 section.

33. In the Preview window, <D> and hold on the green “+”.
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34. Move the pointer onto the point RT_HMA_Lift1_EOP-Top so that the “+” turns white then 
release the left mouse button.

Both end conditions are placed and the template is complete.

Note: The vertical lines that appear inside the template in the illustration above are 
actually the point symbols. The points themselves are not connected vertically 
since the components were merged.
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Building an Asymmetrical Template

This example builds one half of a divided highway. It has two 12’ driving lanes, a 4’ shoulder 
on the right and a 10’ shoulder on the left. The pavement is 12” concrete. 

Start by creating an empty template.

1. Expand the template library folder structure to show 1 – Templates.

2. <R> on the 1- Templates folder and select New > Template.

3. Key in a name for the template (CONC_Divided_4Lane_Left-Side).

Make a copy of a concrete pavement section and edit the copy to match the pavement design.

4. Expand the template library folder structure to show 2 – Sections - Pavements > 
Driving Lane Sections > Concrete.

5. <R> on the CONC_Pvmt_12ftx13in section and select Copy from the right click menu.
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6. <R> on the Concrete folder and select Paste from the right click menu.

7. <R> on the CONC_Pvmt_12ftx13in1section (this is the copy created in steps 5 and 6) 
and select Rename from the right click menu.

8. Key in a new name (CONC_Pvmt_12ftx12in).

9. <D> <D> on the CONC_Pvmt_12ftx12in section.

10. <D> <D> on the SubBase_Centerline-Top point.

11. Change the Value for Constraint 2 (the Vertical constraint) to -1.00.

12. <D> Apply.

13. <D> Close.
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14. Repeat steps 10 through 13 for the point SubBase_Laneline-Top, 
SubGrade_Centerline-Top, and SubGrade_Laneline-Top.

Edit existing concrete shoulder sections to match the pavement design.

15. Expand the template library folder structure to show 2 – Sections - Pavements > 
Shoulder Sections > Concrete.

16. <D> <D> the CONC_Inside_Shoulder-4ft-12z Section.

17. <D> <D> on the SubBase_Shoulder-Top point.

18. Change the Value for Constraint 2 (the Vertical constraint) to -1.00.

19. <D> Apply.
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20. <D> Close.

21. Repeat steps 10 through 13 for the point SubBase_Hinge-Top.

22. <D> <D> on the CONC_Outside_Shoulder-10ft-12z section.

23. Repeat steps 17 through 21 for the same points in this section.

Assemble the template from the modified sections and add the appropriate end conditions.

24. Expand the template library folder structure to show 1 – Templates.

25. <D> <D> on the CONC_Divided_4Lane_Left-Side template.

26. <D> on the CONC_Pvmt_12ftx12in section.

27. In the Preview window, <D> and hold on the green “+”.

28. Move the pointer into the Template View window and <R> while still holding the left 
mouse button. This displays a right click menu. When the right click menu is displayed, the 
left mouse button can be released.
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29. Select Reflect (using either the left or right mouse button).

30. If Mirror is on, <R> on Mirror to turn it off.

31. Move the pointer to the template origin and <D> to place the section.

32. In the Preview window, <D> and hold on the green “+”. Note: the same section is used 
to place the second driving lane.

33. Move the pointer onto the LT_Conc_Laneline-Top point and release the left mouse 
button to place the section.

34. <D> on the CONC_Outside_Shoulder-10ft-12z section.

35. In the Preview window, <D> and hold on the green “+”.

36. Move the pointer onto the LT_Conc_Laneline-Top1 point and release the left mouse 
button to place the section.

37. <D> the CONC_Inside_Shoulder-4ft-12z section.

38. In the Preview window, <D> and hold on the green “+”.

39. Move the pointer into the Template View window and <R>. Select Reflect. This turns the 
reflect option off.
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40. Move the pointer onto the Conc_Centerline-Top point. <D> to place the section. All of 
the components for the driving surface have been placed. The template looks like the   
illustration below. 

Remove the vertical lines from inside the template. 

41. Place the pointer on one of the vertical lines and <R> to display the right click menu.

42. Select Merge Components. This removes the vertical line from the template.

43. Repeat steps 41 and 42 for all of the vertical line inside the template. 

44. Rename points (indicated in the illustration below) to reflect their location.

45. <D> <D> on the Conc_Centerline-Top point.

46. Select Conc_Shoulder-Top from the Name drop down menu.

47. Change the name to Conc_ Inside_Shoulder-Top.
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48. <D> Apply.

49. Repeat steps 44 through 47 for the other five points. Select the appropriate material name 
for each point. Substitute Outside_ for the three left-most points and Inside_ for the 
three right-most points. The template should look like the illustration below.

50. <D> Close to close the Point Properties dialog.

Finish the template by attaching the end conditions.

51. Expand the template library folder structure to show 3 – Sections – End Conditions > 
Z-Slope End Conditions > High Speed End Conditions.
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52. <D> on the Z12_6_to_1 section.

53. In the Preview window, <D> and hold on the green “+”.

54. Move the pointer onto the RT_Conc_EOP-Top point. Release the left mouse button to 
place the end condition. 

55. Using the same end condition section in the Preview window, <D> and hold on the green 
“+”.

56. Move the pointer into the Template View window and <R>. Select Reflect. This turns the 
Reflect option on.

57. Move the pointer onto the LT_Conc_EOP-Top point. <D> to place the section. This 
completes the template.
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Modifying Templates to Fit a Project

In some instances, the sample templates can be used for a project with only minor 
modifications. The first example uses the HMA_Urban_4Lane template and modifies it by 
adding a sidewalk component behind the curb. The second example starts with the 
HMA_Crowned_B10 template and adds a new component for Lime Treated Subgrade.

Adding Sidewalk to a Curb & Gutter Template

This example builds a new section containing the 4"_CONC_Sidewalk component with the 
Bench_4_6_to_1 end condition section attached. Next, the HMA_Urban_4Lane template is 
copied and the end conditions are deleted from the copy. Finally, the Sidewalk and End 
Condition section is added to the template.

1. Select Tools > Options from the Create Template menu bar.

2. Turn off the Apply Affixes check box.

3. Set the Step Options to 0.10 for both X and Y.

4. <D> OK.

5. Expand the template library folder structure to show 4 – Components > Sidewalks 
& Bike Paths > Sidewalks.

6. <R> on the 4"_CONC_Sidewalk component and select Copy from the menu.
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7. Expand the template library folder structure to show 3 – Sections – End Conditions 
– Curb & Gutter Sections.

8. <R> on the Curb & Gutter Sections folder and select Paste.

9. <R> on the 4"_CONC_Sidewalk component, that is in the Curb & Gutter Sections 
folder, and select Rename.

10. Key in a Name (4"_CONC_Sidewalk_End-Cond for this example).

11. <D> <D> on the 4"_CONC_Sidewalk_End-Cond section.

12. <D> on the Bench_4_6_to_1 section.

13. In the Preview window, <D> and hold on the green “+”.

14. Move the pointer onto the CONC_Sidewalk_Back-Top point. Right-click and 
toggle make certain Reflect and Mirror are both off. Release the left mouse button to 
place the end condition. 

15. <D> <D> on the Benching component to display the Component Properties 
window.

16. Set the Parent Component to CONC_Sidewalk-4”.

17. <D> Apply.

18. <D> Close.

Setting up the parent/child relationships for the section will make it easier to continue 
the process when the sections are added to the template. Each Curb & Gutter section 
has two Curb components (one for a normal cross slope and one to match the cross 
slope of the driving lanes) and the sidewalk/end condition section has to be attached to 
each. By setting the parent/child relationship in the section, when the section is placed 
in the template, only one component will have to be edited to make the template work 
properly.
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Next, the HMA_Urban_4Lane template is copied and the existing end conditions are 
removed.

19. Select Tools > Options from the Create Template menu bar.

20. Toggle on the Apply Affixes check box.

21. <D> OK.

22. Expand the template library folder structure to show 1 – Templates.

23. <R> on the HMA_Urban_4Lane template and select Copy from the menu.

24. <R> on the 1 – Templates and select Paste from the menu.

25. <R> on the HMA_Urban_4Lane1 template and select Rename from the menu.

26. Key in a Name (12345_ HMA_Urban_4Lane for this example).

27. <D> <D> on the 12345_ HMA_Urban_4Lane template.

28. Toggle on the Display All Components check box. This will show components 
currently hidden by Display Rules.

29. Move the pointer into the Template View window (but not on a component) and <R>.

30. Select Delete Components from the menu.
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31. Position the pointer near the component(s) to be deleted, <D> and hold. Drag 
through the component(s). Release the left mouse button to complete the process.

Important! Be careful not to touch components that are to be kept. The Delete 
Components command is only in effect through one drag operation. 
Once the left mouse button is released, the command must be picked 
again to delete more components.

Note: If a component is deleted by mistake, select Edit > Undo (or Ctrl+Z) to 
replace the deleted components.

To complete the template, add the sidewalk/end condition section and make the 
sidewalk component a child of the curb.

32. Expand the template library folder structure to show 3 – Sections – End Conditions 
– Curb & Gutter Sections.

33. Make certain Apply Affixes is toggled on.

34. <D> on the 4"_CONC_Sidewalk_End-Cond section.

35. In the Preview window, <D> and hold on the green “+”.

36. Move the pointer into the Template View window and <R> while still holding the left 
mouse button. This displays a right click menu. When the right click menu is 
displayed, the left mouse button can be released.

37. Select Mirror (using either the left or right mouse button).
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38. Move the pointer onto the RT_Curb-Back-Top point and release the left mouse 
button to place the section.

39. <D> <D> on the RT_CONC_Sidewalk-4" component.

40. In the Component Properties dialog box, set the Parent Component to RT_C/
G_Type2-IIB.

41. <D> Apply.

42. <D> Close.

43. Repeat steps 38 through 41 on the corresponding components on the left side.

44. <D> <D> on the RT_Curb_Gutter-top point.

45. Change the Value of Constraint 2 (the Slope constraint) to 5.00%.

46. <D> Apply.
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47. <D> Close.

48. Repeat steps 43 through 46 on the LT_Curb_Gutter-top point (the slope Value will 
be -5.00% on this side).

Changing the slope constraint will imitate a supered condition causing the normal curb 
and its child components not to be displayed. It will activate the display of the supered 
curb. These steps will form the pavement into a “V”. This will make it easier to place 
the remaining sidewalk/end condition sections. The pavement will be rotated back to 
its normal position after the sections are placed.

49. Using the same section in the Preview window, <D> and hold on the green “+”.

50. Move the pointer onto the RT_Curb-Back-Top1 point and release the left mouse 
button to place the section.

51. <D> <D> on the RT_CONC_Sidewalk-4"1 component.

52. In the Component Properties dialog box, set the Parent Component to RT_C/
G_Type2-IIB1.

53. <D> Apply.

54. <D> Close.

55. Repeat steps 50 through 53 on the corresponding components on the left side.

56. <D> <D> on the RT_Curb_Gutter-top point.

57. Change the Value of Constraint 2 (the Slope constraint) to -2.00%.

58. <D> Apply.

59. <D> Close.

60. Repeat steps 43 through 46 on the LT_Curb_Gutter-top point (the slope Value will 
be 2.00% on this side).
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The template is now complete.

Adding a Subgrade Component to a Template

The HMA_Crowned_B10 template will be modified by creating a new component. This 
component, representing lime treated subgrade, will be 1’ thick and the width of the ABC 
component that is already in the template.

1. Expand the template library folder structure to show 1 – Templates.

2. <R> on the HMA_Crowned_B10 template and select Copy from the menu.

3. <R> on the 1 – Templates and select Paste from the menu.

4. <R> on the HMA_Crowned_B101 template and select Rename from the menu.

5. Key in a Name (12345_ HMA_Crowned_B10 for this example).

6. <D> <D> on the 12345_ HMA_Crowned_B10 template.

7. Move the pointer into the Template View window (but not on a component) and <R>.

8. Select Add New Component > Constrained from the menu.

9. In the Name field of the Current Component area, key in a name for the new 
component (Lime_Treated_Subgrade in this example).
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10. Use the drop down menu to select the desired Style (D_Subbase for this example). 

11. Move the pointer onto the LT_SubBase_EOP‐Top point and <D>.

12. Continuing to the right, <D> on each point across the bottom of the existing ABC 
component. 

13. <D> the same number of new points (in this case 7) below the ABC component.

14. <R> in the Template View window (but not on a component).

15. Select Finish from the menu.

All of the points are contained in the new component. Editing the point constraints will 
move each point to its proper location.
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16. <D> <D> on the point LT_3 to display the Point Properties dialog box.

17. Select SubGrade_EOP-Top from the Name drop down menu.

18. Append LT_ to the name so that it reads LT_SubGrade_EOP‐Top.

19. Under Constraint 1 (the Horizontal constraint), set the Parent 1 to 
LT_SubBase_EOP-Top.

20. Set the Value to 0.

21. Under Constraint 2 (the Vertical constraint), set the Parent 1 to LT_SubBase_EOP-
Top.

22. Set the Value to -1.

23. <D> Apply.

24. <D> Close.

25. Repeat steps 16 through 24 for each of the remaining points. Choose an appropriate 
name for each of the points. The Parent 1 is the same for the Horizontal and the 
Vertical constraint. The parent point is the point directly above the edited point. The 
Values for the constraints are the same for all points.
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The completed template is shown below.

Section Summary:

 Components are the building blocks for Sections and Templates.

 There are 5 methods of creating components, but only 3 types of components: General, 
Null and End Conditions.

 Component Properties allow the editing of names, styles, etc. and help define how the 
components react in different situations.

 Component Properties for End Condition components contain the target information.

 Components are made up of Points.

 Points are constrained to other points to define the shape of the components and therefore 
the template. Changing the constraints may affect more than one point, since the 
constrained point may also be a parent of another point.

 There are many different types of Constraints and it is very important to use the correct 
ones when creating a new point.

 Display Rules and Parent/Child components can be used to turn on and off components 
during modeling based on the occurrence of other components, or the result of a 
mathematical expression derived from the differences between points (horizontal, vertical, 
slope, etc.)

 Start a new template with the most complete example available that fits your design needs.

 Standard templates may be copied and modified by changing component properties and/or 
point properties.

 Standard sections may be copied into a new template to create a project-specific design.

 Standard components may be copied into a new template to create a new section.

 Even if your design requires a template that is not completed, many of the components and 
sections are found in the standard template library and may be used to create new 
templates.
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Chapter Summary:

 The default template library is located in the C:\Workspace\Workspace‐
CDOT_V8i\Standards‐Global\InRoads\Templates folder

 The CDOT template library contains several categories of templates in various stages of 
development, including: Components (the building blocks), Sections (multiple 
components forming partial templates, such as all the lifts for a lane), and Finished 
Templates (multiple components that form a complete typical section).

 When evaluating the typical sections needed for a project, you should look first to the 
standard template library to save time and effort in building your typicals.

 For non-standard and more complex typicals, the building blocks and /or tools are available 
to create your own templates to accomplish your design.
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