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Chapter 3 - Interchange Project

As part of the Federal Blvd. and 6th Ave. interchange reconstruction project, access from Federal Blvd. to 6th 

Ave. and Bryant Street is being added. The ramp from Federal Blvd. to 6th Ave (called the SE Ramp) splits to 
provide access to Bryant Street. This lab illustrates the InRoads design process for creating this interchange. 
This lab is concerned with the mergers of the SE Ramp with the 6th Ave. edge of pavement and the mergers of 
the Bryant Street ramp with the SE Ramp. Therefore, the intersections of the ramps at Bryant Street and 
Federal Blvd. will not be modeled.

Chapter Objectives:

 Give a project overview

 Create a corridor for the SE Ramp.

 Define Point Controls to tie to the existing 6th Ave. edge of pavement.

 Create a corridor for Bryant Ramp.

 Create initial design surfaces for SE Ramp and Bryant Ramp.

 Determine key stations for ramp mergers.

 Define Point Controls for street returns in both corridors

 Modify Bryant Ramp template for the area in the intersection.

 Create a combined surface of SE Ramp and Bryant Ramp.

Project Overview
Project Description
This project creates accesses to 6th Ave. and Bryant Street from Federal Blvd. The Ramp from 
Federal Blvd. merges into the existing edge of pavement of 6th Ave. The ramp from Bryant 
Street merges into the SE Ramp (from Federal to 6th).

Project Data
 Existing_Ground.dtm – This contains the survey data for the existing terrain.

 Interchange.alg – This contains all of the horizontal and vertical alignments used for 
this project.

 Interchange.itl – The initial templates are stored in this file.

InRoads Design Process
1. Open Data files.

2. Initial Modeling for SE Ramp and Bryant Ramp.

3. Determine Key Stations for ramp mergers.

4. Modify templates for merger areas.
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5. Make changes to corridor data.

6. Create the combined design surface.

7. Review the results 

Getting Started
1. Open the Interchange.alg. 

2. Open the Interchange.itl template library. 

3. Open the Existing Ground.dtm.

Initial Modeling
There are two areas of special importance on this project, where the SE Ramps merges with the existing 6th 
Ave. edge of pavement and where the Bryant Ramp merges with the SE Ramp. In these areas, the templates 
change to accommodate the narrowing pavement width. To determine the stations where template changes 
occur, initial design surfaces are created for the SE Ramp and the Bryant Ramp.

Initial SE Ramp Corridor Model
The initial run of the SE Ramp is primarily concerned with locating stations for template 
changes. Do not be concerned that the template crosses into the 6th Ave. driving lanes, as this 
will be corrected in the final modeling.

Section Objectives:

♦ Create a corridor for the SE Ramp alignment

♦ Add template drops to the corridor

♦ Create the initial SE Ramp surface

Build the SE Ramp Corridor

1. Select Modeler > Roadway Designer from the InRoads menu bar. This displays the 
Roadway Designer dialog box.

2. In the Roadway Designer dialog box, select Corridor > Corridor Management or 

<D> the  button. This displays the Manage Corridors dialog box.

3. In the Manage Corridors dialog box, key in SE Ramp for the Name.

4. In the Surface Symbology field, select D_Finished-Grade.

5. Set the Type to Alignment.

6. Select SE Ramp as the Horizontal Alignment.

7. Select SE Ramp_V as the Vertical Alignment.

8. <D> Add to complete the corridor.
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9. <D> Close to dismiss the Manage Corridors dialog box.

Add the SE Ramp Template Drops

1. In the Roadway Designer dialog box, select Corridor > Template Drops or <D> the  
button. This displays the Template Drops dialog box.

2. In the Template Drops dialog box, Key in 0+00.00 for the Station.

3. Key in 25 for the Interval.

4. In the Library Templates area, expand the 1 – Templates folder.

5. Highlight the SE Ramp template.

6. <D> Add.
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7. <D> Close. 

Create the Initial SE Ramp Design Surface

1. In the Roadway Designer dialog box, select Corridor > Create Surface or <D> the  
button. This displays the Create Surface dialog box.

2. Key in SE Ramp for the Name.

3. Select Proposed for the Default Preference.
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4. The remaining settings should be correct. If not, set them to match the illustration below.

5. <D> Apply.

6. <D> Close.

Initial Bryant Ramp Corridor Model
As with the SE Ramp, do not worry about the Bryant Ramp crossing into the SE Ramp. In fact, 
this has to occur in order to determine the stations required for new template drops.

Section Objectives:

♦ Create a corridor for the Bryant Ramp alignment

♦ Add template drops to the corridor

♦ Create the initial Bryant Ramp surface

Build the Bryant Ramp Corridor

1. In the Roadway Designer dialog box, select Corridor > Corridor Management or 

<D> the  button. 

2. In the Manage Corridors dialog box, key in Bryant Ramp for the Name.

3. In the Surface Symbology field, select D_Surface_2.

4. Set the Type to Alignment.
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5. Select Bryant Ramp as the Horizontal Alignment.

6. Select Bryant Ramp_V as the Vertical Alignment.

7. <D> Add to complete the corridor.

8. <D> Close to dismiss the Manage Corridors dialog box.

Add the Bryant Ramp Template Drops

1. In the Roadway Designer dialog box, select Corridor > Template Drops or <D> the  
button. 

2. In the Template Drops dialog box, Key in 0+00.00 for the Station.

3. Key in 25 for the Interval.

4. In the Library Templates area, expand the 1 – Templates folder.

5. Highlight the Bryant Ramp template.

6. <D> Add.

7. <D> Close.

Create the Initial Bryant Ramp Design Surface

1. In the Roadway Designer dialog box, select Corridor > Create Surface or <D> the  
button. 

2. Key in Bryant Ramp for the Name.

3. In the Create Surface(s) from area, highlight Bryant Ramp only.

4. The remaining settings should be correct. If not, set them to match the illustration below.

5. <D> Apply.
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6. <D> Close.

7. <D> File > Save from the Roadway Designer menu bar.

8. In the Save As dialog box, navigate to the InRoads folder.

9. Key in SE Ramp and Bryant Ramp for the File Name.

10. <D> Save.

11. <D> Cancel to dismiss the Save As dialog box.

12. <D> Close to dismiss the Roadway Designer dialog box.

Determine Key Stations for Ramp Mergers
It was determined that the gore between the merger of SE Ramp and 6th Ave would end at the intersection of 

the RT_POSS and the existing edge of pavement of 6th Ave. the gore between the merger of SE Ramp and 
Bryant St ends at the intersection of SE Ramp’s LT_POSS and Bryant Ramp’s RT_POSS. The stations of these 
intersections, along with the intersection of the SE Ramp’s LT_POSS and Bryant Ramp’s LT_POSS, must be 
determined for the additional template drops needed in the final surface.

Display Design Data
The relevant horizontal alignments are displayed in the dgn file to give a reference location 
when determining the key stations.
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Section Objectives:

♦ Display the horizontal alignments

Display Horizontal Alignment Data

1. <D> the Geometry tab in the InRoads Explorer.

2. <R> on the Interchange geometry project.

3. Select View All Horizontals from the menu.

The illustration below identifies each of the alignments displayed

Key Station Locations
To determine the key stations, the POSS and EOP features of both initial design surfaces are 
displayed. Then tracking is used on both the SE Ramp alignment and the Bryant Ramp 
alignment. The stations are needed on each alignment so that template drops can be entered 
correctly.
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Section Objectives:

♦ Display the required surface features from the initial design surfaces

♦ Use Tracking to identify the key stations

Locate Key Stations for SE Ramp at 6th Ave.

Each point on a template creates a feature in the design surface which can make it difficult to 
find the desired features for display. To reduce the number of features that have to be combed 
through, feature filters are used. There is a predefined filter that excludes untriangulated 
features. This is used reduce the number of features in the dialog box to a manageable number.

1. On the InRoads Locks toolbar, set the Feature Filter to XS_Excluded from 
Triangulation.

2. Toggle on the Feature Filter Lock.

3. On the InRoads menu bar, select Surface > Update 3d/Plan Surface Display.

4. In the Update 3d/Plan Surface Display select the SE Ramp surface.

5. In the Features list, select the features with EOP or POSS in the name. Hold the Ctrl key 
to highlight each of the features. Highlighted features are automatically displayed.

6. <D> Close.
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After the features are displayed, tracking is used to determine the key stations for the SE Ramp 
along the 6th Ave. edge of pavement.

7. Using the MicroStation view controls, zoom in on the left end of the 6th Ave alignment.

8. Set the SE Ramp alignment active.

9. From the InRoads menu bar, select Tools > Tracking > Tracking.

10. <T> where the feature RT_Conc_EOP-Top crosses the US6_EOP1 alignment and note 
the station.

Note: Use the Intersection snap  to locate the station

11. <T> where the feature RT_POSS crosses the US6_EOP1 alignment and note the station.

The stations for the two points above are:

♦ RT_Conc_EOP‐Top and US6_EOP1 – 7+37.39
♦ RT_POSS and US6_EOP1 – 8+23.46

12. <D> Close on the Tracking dialog box.

Locate Key Stations for Bryant Ramp at SE Ramp

The same procedure is used for locating the key stations at the merger of the SE Ramp and the 
Bryant Ramp.

1. On the InRoads menu bar, select Surface > Update 3d/Plan Surface Display.

2. In the Update 3d/Plan Surface Display select the Bryant Ramp surface.

3. Toggle on the Features check box.

4. In the Features list, select the features with EOP or POSS in the name.
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5. <D> Apply and <D> Close.

6. Using the MicroStation view controls, zoom in to the area where SE Ramp and Bryant 
Ramp intersect.

7. Set the Bryant Ramp alignment active.

8. From the InRoads menu bar, select Tools > Tracking > Tracking.

9. <T> where the feature RT_POSS from the Bryant Ramp crosses the LT_POSS from the SE 
Ramp and note the station.

♦ Intersection of RT_POSS and LT_POSS – 5+07.51

10. <T> where the feature LT_POSS from the Bryant Ramp crosses the LT_POSS from the SE 
Ramp and note the station.

♦ Intersection of LT_POSS and LT_POSS – 8+39.60

11. Set the SE Ramp alignment active and determine the stations for the locations in 9 and 10 
above for this alignment also.

♦ Intersection of RT_POSS and LT_POSS – 3+92.92
♦ Intersection of LT_POSS and LT_POSS – 7+27.40

12. <D> Close on the Tracking dialog box.

Template Modifications
As designed, the SE Ramp and Bryant Ramp templates have curb and end conditions on both sides. Templates 
must be created for the merger areas that do not have the restrictive components.

SE Ramp Template at 6th Ave.
♦ Copy the SE Ramp template
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♦ Modify the copy for the 6th Ave merger area

Copy the SE Ramp Template

The basic SE Ramp template is used once all of the merger areas are cleared. A copy of this 
template is made so that one can be modified and the other left intact.

1. On the InRoads menu bar, select Modeler > Create Template.

2. In the Create Template dialog box, expand the template library to show the contents of the 
1‐ Templates folder.

3. <R> on the SE Ramp template and select Copy from the menu.

4. <R> on the 1 – Template folder and select Paste.
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5. <R> on the SE Ramp1 template and select Rename. Key in SE Ramp at 6th Ave for 
the name.

Modify the SE Ramp at 6th Template

This template needs to be modified on the right (6th Ave.) side only.   

1. <D> <D> SE Ramp at 6th template to make it active.

2. Zoom in on the right side of the template.

3. <R> in the Template view and select Delete Components from the menu.

4. Drag a line through the RT_C/G_Type2-IIB and the RT_Benching components.

Note: The end conditions are also deleted because of the parent/child relationship they 
have with RT_Benching.

5. <R> on the RT_ABC_EOP-Top and select Delete Point from the menu.

6. Delete the RT_SubBase_EOP-Top point also. The illustration below shows the template 
completed to this point.

Add an End condition to the SE Ramp at 6th Ave template

This end condition is used to create the gore after the SE Ramp edge of pavement separates 
from the 6th Ave. pavement edge.
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1. Select Tools > Dynamic Settings from the Create Template menu bar or <D> 
the Dynamic Settings  button.

2. Select Tools > Options from the Create Template menu bar.

3. Toggle on Apply Affixes.

4. Set the X and Y Step Options to 0.1.

5. <D> OK.

6. <R> in the Template view and select Add New Component > End Condition.

7. In the Component Properties area, key in Tie_6th_EOP for the Name.

8. Set the Target Type to Alignment XYZ.

9. Select US6_EOP1 for the Horizontal Alignment. This automatically sets the vertical 
alignment.

10. Set the Style to D_Toe-of-Fill.

11. <D> on the RT_Conc_EOP-Top point to place the first point.

12. In the Dynamic Settings dialog box, toggle on End Condition Is Infinite.

13. Select Toe-of-Fill for the Point Name. This automatically sets the Point Style.

14. Select hs= for the key in type.
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15. Key in 2,0.25 and press Enter.

16. <R> and select Finish.

SE Ramp Template at Bryant St.
The merger areas for the SE Ramp at 6th Ave. and the SE Ramp at the Bryant ramp overlap. A 

copy of the SE Ramp at 6th Ave template is modified for use in this merger area. A separate 
template is used here because using target aliasing and clipping options would result in the loss 
of the ABC component in the clipped template.

Section Objectives:

♦ Copy the SE Ramp at 6th Ave template

♦ Modify the copy for the Bryant Ramp merger area

Copy and Modify the SE Ramp at 6th Ave Template

1. Make a copy of the SE Ramp at 6th Ave and key in SE Ramp at Bryant for the name.
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2. Modify the SE Ramp at Bryant template as described above deleting the curb and end 
condition components and sub base points on the left side of the template. The illustration 
below shows the completed template.

Bryant Ramp at the SE Ramp
A copy of the Bryant Ramp template is also modified to work in the merger area.

Section Objectives:

♦ Copy the Bryant Ramp template

♦ Modify the copy for the SE Ramp merger area

Copy and Modify the Bryant Ramp Template

1. Make copy of the Bryant Ramp template as described above. Name it Bryant Ramp 
at SE Ramp.

2. Modify the Bryant Ramp at SE Ramp template as described above making the changes on 
the right side of the template. The illustration below shows the completed template.
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Set Up For Final Modeling
With the key stations determined and the new templates created, the corridors are modified to use this data. 
Changes in corridor stations, additional template drops, point controls, and target aliasing are used to 
incorporate this data. Also, after reviewing the initial design surface data, some sideslopes require modification

Set Up for the SE Ramp
Section Objectives:

♦ Add template drops for the new SE Ramp templates

♦ Add point controls to match the template to the 6th Ave edge of pavement

♦ Modify sideslopes in the template view

Adding Template Drops 

These are added to include the new templates into the corridor.

1. Open Roadway Designer.

2. Set the Corridor to SE Ramp and the Active Surface to Existing_Ground.

3. Open the Template Drops dialog box.

Because this alignment runs west to east, the first template drop is at the edge of 6th Ave. 
Therefore, the template for this drop is changed to use the SE Ramp at 6th Ave template.

4. Highlight the template drop in the Current Template Drops list.

5. In the Library Templates area, expand the 1 – Templates folder and select the SE Ramp 
at 6th Ave template.
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6. <D> Change.

The next two template drops define the change from the SE Ramp at 6th Ave to the SE Ramp at 
Bryant Ramp template. This change occurs in 0.01 feet so that there is an abrupt change from a 
template with a curb to a template without one.

7. Key in 3+88.03 for the Station.

8. Key in 25 for the Interval.

Note: The interval for this template drop could be anything greater than 0.01.

9. In the Library Templates area, highlight the SE Ramp at 6th Ave template.

10. <D> Add.

11. Key in 3+88.04 for the Station.

12. Key in 25 for the Interval.

13. In the Library Templates area, highlight the SE Ramp at Bryant Ramp template.

14. <D> Add.

The next transitions define the end of the Bryant ramp merger. Again, an abrupt change 
between templates is needed so the transition occurs in 0.01 feet.
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15. Key in 7+72.78 for the Station.

16. Key in 25 for the Interval.

17. In the Library Templates area, highlight the SE Ramp at Bryant Ramp template.

18. <D> Add.

19. Key in 7+72.79 for the Station.

20. Key in 25 for the Interval.

21. In the Library Templates area, highlight the SE Ramp at 6th Ave template.

22. <D> Add.

Finally the transition to an independent SE Ramp is defined.

23. Key in 8+23.46 for the Station.

24. Key in 25 for the Interval.

25. In the Library Templates area, highlight the SE Ramp at 6th Ave template.

26. <D> Add.

27. Key in 8+23.47 for the Station.

28. Key in 25 for the Interval.

29. In the Library Templates area, highlight the SE Ramp template.
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30. <D> Add. The completed Template Drops dialog box is shown below.

31. <D> Close.

Add Point Controls for the SE Ramp

A point control is used to match the right edge of pavement of the SE Ramp templates to the 
existing pavement edge of 6th Ave. (defined by the US6_EOP1 alignment).

1. Select Corridor > Point Controls from the InRoads menu bar. This displays the Point 
Controls dialog box.

2. In the Control Description field, key in SE Ramp EOP RT at 6th Control.

3. Select RT_Conc_EOP-Top for the Point.

4. Toggle on Both for the Mode.

5. Set the Control Type to Alignment.

6. Select US6_EOP1 for the Horizontal Alignment. The vertical alignment is automatically 
set.
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7. In the Station Limits area, leave the Start at 0+00.00 and key in 8+23.46 for the Stop 
station. 

8. <D> Add and Close.

Modify Side Slopes for SE Ramp

There is a area in this corridor where the computed end condition created an undesirable result. 
Because this area only covers two template drops, it is corrected by modifying the templates at 
those stations. If this area were larger, an end condition override or a new template should be 
used.

1. Set the Station Indicator to 7+72.79.

2. <D> <D> in the Template View to open the Edit Template at Station 7+72.79 Only dialog 
box.

3. Open the Dynamic Settings dialog box.

4. <D> on the Readout button to change it to X and Slope.
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5. Key in 10.00% for the slope Step.

6. <R> on the LT_Top-of-Cut point and select Move Point from the menu.

7. Move the point to the location shown in the illustration below. <D> to place it.

Note: The point will snap to the Existing Ground line when the cursor is moved 
next to the line.

8. <D> OK to accept the change and dismiss the dialog box.
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9. Modify station 7+75.00 in a similar manner as shown in the illustration below.

Set Up for the Bryant Ramp
Section Objectives:

♦ Change the end station for the Bryant Ramp corridor

♦ Add template drops for the new Bryant Ramp templates

♦ Add point controls to match the template to the SE Ramp edge of pavement

♦ Define target aliasing to target the SE Ramp surface

♦ Modify sideslopes in the template view

Edit Corridor Stations

The Bryant Ramp alignment runs past the point where the Bryant Ramp template is no longer 
used. The corridor is modified to end at the same place where the template needs to end.

1. Set the Corridor to Bryant Ramp.

2. Select Corridor > Corridor Management from the InRoads menu bar. This displays 
the Manage Corridors dialog box.

3. In the Manage Corridors dialog box, highlight the Bryant Ramp entry from the Corridors 
list.

4. In the Limits area, toggle on Station.

5. Key in 8+85.00 for the Stop station.
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6. <D> Change and Close.

Adding Template Drops 

The additional template drops are added to include the modified template properly as explained 
above.

1. Open the Template Drops dialog box.

2. Key in 5+02.76 for the Station.

3. Key in 25 for the Interval.

4. In the Library Templates area, highlight the Bryant Ramp template.

5. <D> Add.

6. Key in 5+02.77 for the Station.

7. Key in 25 for the Interval.

8. In the Library Templates area, highlight the Bryant Ramp at SE Ramp template.
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9. <D> Add and Close. The completed Template Drops dialog box is shown below.

Add Point Controls for the Bryant Ramp

This point control matches the right edge of pavement of the Bryant Ramp to the left edge of 
pavement of the SE Ramp. It causes the Bryant ramp to transition to 0 by the end of the merger.

1. Select Corridor > Point Controls from the InRoads menu bar. 

2. In the Control Description field, key in Bryant Ramp EOP RT at SE Ramp 
Control.

3. Select RT_Conc_EOP-Top for the Point.

4. Toggle on Both for the Mode.

5. Set the Control Type to Corridor Point.

6. Select SE Ramp for the Corridor. 

7. Select LT_Conc_EOP-Top for the Reference Point.

8. In the Station Limits area, key in 5+02.77 for the Start station and key in 8+85.00 for 
the Stop station. 
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9. <D> Add and Close.

Create Target Aliasing for the Bryant Ramp

Target aliasing is used to tie the Bryant Ramp sideslope to the SE Ramp sideslope in the area 
before the merger. Without this, the combined surface will not triangulate properly in areas 
where the toes overlap.

1. Select Tools > Target Aliasing from the Roadway Designer menu bar.

2. Highlight Surface – SE Ramp in the Surface or Corridor list.

3. <D> Add.

4. Highlight Surface – Existing_Ground in the Surface or Corridor list.
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5. <D> Add. The dialog box looks like the illustration below.

6. <D> OK. 

Modify Side Slopes for Bryant Ramp

This corridor also has an undesirable result on a sideslope. Again, because this result occurred 
in a limited area, the template at the station is edited.

1. Set the Station Indicator to 8+50.00.

2. <D> <D> in the Template View to open the Edit Template at Station 8+50.00 Only dialog 
box.

3. Move the point LT_Toe-of-Fill as shown in the illustration below.

4. <D> OK to accept the change and dismiss the dialog box
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Create the Final Combined Design Surface
The two corridors are combined into one surface of the interchange.

Section Objectives:

♦ Create a combined surface from the SE Ramp and Bryant Ramp corridors

1. Open the Create Surface dialog box.

2. In the Name field, key in SE-Bryant Ramps.

3. Set the Default Preference to Proposed.

4. In the Create Surface(s) From list box, highlight both Bryant Ramp and SE Ramp.

The clipping options are used to modify the combined surface where the end conditions overlap 
prior to the merger.

5. <D> the Clipping Options button.

6. Set the Clipping Option to End Conditions Only.

7. <D> OK to accept the change and close the Clipping Options dialog box.

8. Verify that Add Exterior Boundary, Triangulate, and Remove Loops are toggled on.
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9. <D> Apply and Close. Also, close the Results window if it is displayed.

10. Select File > Save from the Roadway Designer menu bar.

11. <D> Close to dismiss the Roadway Designer dialog box.

Review the Results
Once the design surface is created a review of that surface will determine if additional work is required.

Cross Sections
Cross sections are one of the standard design surface review tools.

Section Objectives:

♦ Create a set of cross sections

Display Cross Sections with the SE Ramp Alignment

The SE Ramp alignment is the main alignment for this project, so it is used when reviewing the 
data.

1. Set the SE Ramp alignment active.

2. Open the Create Cross Sections dialog box.

3. Set the Left Offset to -150 and the Right Offset to 100.



Page 730 Colorado Department of Transportation

Chapter 3 - Interchange Project Labs for InRoads V8i SS2

4. Select the Existing_Ground and SE-Bryant Ramps surfaces

5. <D> Apply and <D> to place the set.

6. Close the Create Cross Sections dialog box.

7. Review the cross sections paying particular attention to the merger areas.

View 3D Components

With the advent of template components, a new option has been added to the view surface 
commands. Viewing the design surface components in 3d is a new tool for reviewing surfaces.

Section Objectives:

♦ Display surface components into the MicroStation file

1. Select Surface > View Surface > Components from the InRoads Menu.

2. In the View Surface Components dialog box, select SE-Bryant Ramps for the Surface.

3. In the Component list, <R> and choose Select All from the menu.

4.  Hold the Ctrl key and <D> on the ABC components to deselect them.

5. <D> Apply and Close.

6. Examine the components, rotating the view to see different perspectives. 


