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LAB 7 - Feature Based Modeling

This section covers how to use Surface Modeling tools for excavation and backfills. You will also use these 
tools to create pier features.

Chapter Objectives:

 Learn how to create excavation and backfill surfaces for footers (piers, walls, etc.).

 Learn how to use the Generate Sloped Surface command to create proposed surfaces by 
intercepting existing or design surfaces.

 Learn how to profile excavation and backfill surfaces.

 Learn how to set the elevation of elements or features.

 Learn how to import MicroStation graphics into a surface.

 Learn how to create pier features and a pier surface for volume computations.

The following files are used in this lab:

 C:\Projects\12345\Bridge\Working \CU12345BRDG_Model.dgn

 C:\Workspace\Workspace-CDOT_XM\Standards-Global\InRoads\Preferences\ 
CDOT_Civil.xin

 C:\Projects\12345\ROW_Survey\InRoads\DTM\12345 existing ground for interchange

 C:\Projects\12345\Design\InRoads\12345 SH119

 C:\Projects\12345\Design\InRoads\12345 SH119 SH52 Interchange.alg

 C:\Projects\12345\Bridge\Drawings\Reference_Files\12345BRDG_Model_D-16-DU.dgn

 C:\Workspace\Workspace-CDOT_XM\Standards-Global\InRoads\Templates\ 
CDOT_Template-Library.itl

Lab 7.1 - Open Project Data 

1. Open MicroStation and InRoads using the C:\Projects\12345\Bridge\Working 
\CU12345BRDG_Model.dgn file.

2. Delete any MicroStation graphics currently in the design file.

3. Verify the correct XIN file is loaded.

4. Select File > Open from the InRoads menu.

5. Open C:\Projects\12345\Design\InRoads\12345 SH119 and 12345 SH119 SH52 
Interchange.alg. 

6. Open C:\Projects\12345\ROW_Survey\InRoads\DTM\12345 existing ground for 
interchange.
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Lab 7.2 - Create an Excavation Surface for a Pier Footer

In this section, surfaces are created for the excavation and backfill for a pier footer for bridge 
D-16-DU. The primary commands used are Generate Sloped Surface and Generate 
Longitudinal Feature. For more information on either of these commands, please see the 
Surface Editing chapter of A Practical Guide for Using InRoads XM. 

In a later lab, these surfaces will be used to calculate volumes.

1. In MicroStation, select Settings > Level > Display.

2. Toggle View Index 1 on and all others off.

3. Toggle Show Level Name or Filters to Levels.

4. Highlight the 12345BRDG_Model_D-16-DU.dgn file.

Note: This is the reference file that was attached in Lab 2. If it is not listed in this dialog, 
re-attach the reference file now.
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5. Turn on the BRDG_Outline-Foundation-Footer level.
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6. Select MicroStation’s Copy tool.

7. Snap to a corner of the outline to choose it to copy.

8. Snap to the same corner to place it at the same location in the current working file.

9. In MicroStation, select File > Reference.

10. Highlight the 12345BRDG_Model_D-16-DU.dgn file and toggle the Display off.
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The new copy of the outline should still be showing in the current file.

Note: The outline is currently at elevation 0. Next, the outline must be moved to the 
appropriate elevation.

11. Select Surface > Design Surface > Set Elevation.

12. Make certain the current Locate Mode is Graphics. If not, toggle it on your Locks toolbar.

13. In the Set Elevation dialog box, set the Input Mode to Single.

14. Toggle off the Destination Level.

15. Key in 5152 for the Elevation.
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16. <D> Apply.

17. <D> the outline.

18. <D> to Accept.

Note: The outline may disappear because elevation 5152 is not within your display 
depth. If it does, Fit your view with MicroStation.

19. Select MicroStation’s Move Parallel tool.

  

20. Toggle on Distance and key in 1.5.

21. Toggle on Make Copy.

22. <D> on the outline.

23. <D> to Accept on the outside of the footer outline.
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24. <R> to stop copying.

25. Select Surface > Design Surface > Generate Sloped Surface.

26. Verify that the current Locate Mode is Graphics. If not, toggle Locate Feature / Locate 
Graphics to Locate Graphics on the Locks toolbar.

27. Verify that Generate Graphics Only is toggled off.

28. Set the Intercept Surface to 12345 existing ground for interchange.

29. Key in 12345 excavation for pier footer as the Destination Surface.

30. Set the Cut Slope to 1:1.

Note: The ratio is automatically converted into a percentage.

31. Toggle on Triangulate Surface.

32. Toggle on Source and key in Excavation break.

33. Set the Style to Breakline.

34. Toggle on Catch Point and key in Excavation Cut.

35. Set the Style to D_Top-of-Cut.

36. Set the Point Type to Breakline.

37. <D> Apply.
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38. <D> on the outer pier outline.

39. <D> to Accept.

40. <R> for Entire (the entire element).

Important! If you <D> again instead of <R>, that location is the starting point for the 
slope and the excavation will not be completed around the pier.

41. Move your cursor to the outside until the temporary graphic looks like shown here, then 
<D> to Accept the location.

<R> out of the command.
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Note: The Generate Sloped Surface command is very useful for creating sloped surfaces 
from features or graphical elements that intercept other surfaces. The intercepts 
can be existing ground surfaces, design surfaces or even surfaces previously 
created with this command. 

42. Select Evaluation > Profile > Create Profile.

43. Toggle on 12345 existing ground for interchange, 12345 SH119 and 12345 excavation 
for pier footer.

44. Highlight 12345 excavation for pier footer and choose Properties.

45. Set the Profile Symbology to D_SURFACE_3.

46. <D> Apply, then Close.

47. Back on the Create Profile dialog box, select the Source branch
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48. Set Alignment to SH52-H

49. Select the Controls branch.

50. Set the Station Limits to 106+00 to 109+00.

51. <D> Apply.
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52. <D> a clear area in the design file for the location of the profile.

53. Window in to see the excavation surface.

54. Right-click on the 12345 excavation for pier footer surface in the Explorer part of the 
menu and choose Save.

Note: Verify the Active Surface is 12345 excavation for pier footer
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55. If the File name is blank, use the Active drop-down to again choose 12345excavation for 
pier footer and the name appears in the File name field as well.

56. Verify the Save In path is C:\Projects\12345\Bridge\InRoads.

57. <D> Save then Cancel.

Lab 7.3 - Create a Backfill surface for a Pier

Next, the surface for the backfill is created, using the same procedure.

1. Select Surface > Design Surface > Generate Sloped Surface if you previously 
closed it.

2. Verify that the current Locate Mode is Graphics. If not, toggle Locate Feature / Locate 
Graphics to Locate Graphics on the Locks toolbar.

3. Verify that Generate Graphics Only is toggled off.

4. Set the Intercept Surface to 12345 SH119.

5. Key in 12345 backfill for pier footer as the Destination Surface.

6. Set the Cut Slope to 1:1.

Note: The ratio is automatically converted into a percentage.

7. Toggle on Triangulate Surface.

8. Toggle on Source and key in Backfill break.

9. Set the Style to Breakline.

10. Toggle on Catch Point and key in Backfill.

11. Set the Style to D_Top-of-Fill.
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12. Set the Point Type to Breakline.

13. <D> Apply.

14. <D> on the outer pier outline.

15. <D> to Accept.

16. <R> for Entire (the entire element).

Important! If you <D> again instead of <R>, that location is the starting point for the 
slope and the backfill will not be completed around the pier.
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17. Move your cursor to the outside until the temporary graphic looks like shown here, then 
<D> to Accept the location.

18. <R>.

19. <D> Close on the Generate Sloped Surface dialog.

20. Right-click on the 12345 backfill for pier footer surface in the Explorer part of the menu 
and choose Save.

Note: Verify the Active Surface is 12345 backfill for pier footer

21. If the File name is blank, use the Active drop-down to again choose 12345 backfill for pier 
footer and the name appears in the File name field as well.
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22. Verify the Save In path is C:\Projects\12345\Design\InRoads.

23. <D> Save then Cancel.

24. Select Evaluation > Profile > Update Profile.

25. Verify the Profile Set is the one used in the previous section if you have more than one in 
your file. A box is drawn around the Profile Set listed.

26. Toggle Mode to Display Off.



Page 174 Colorado Department of Transportation

LAB 7 - Feature Based Modeling Bridge Essentials Using InRoads XM

27. Highlight the 12345 excavation for pier footer.

28. <D> Apply.

Note: The excavation surface is no longer shown on the profile.

29. Toggle Mode to Display On.
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30. Highlight the 12345 backfill for pier footer.

31. <D> Apply.

Note: The backfill surface is now shown on the profile.

32. <D> Close on the Update Profile dialog.

Lab 7.4 - Create Pier Features

The footer and pier must be excluded from the backfill quantities. This can be accomplished by 
manually calculating the quantity and deducting it from what will be calculated from the 
surface as it exists now. Or, features may be added to the surface that take the footer and pier 
into account when InRoads computes the quantity. In the next series of steps, the second option 
is shown, creating four breaklines: bottom of footer, top of footer, bottom of pier, and top of 
pier. Since DTMs do not support overhangs or true verticals, the footer and pier are represented 
as ‘near’ verticals.
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1. Turn off the BRDG_Outline-Foundation-Footer level.

2. Delete all of the remaining plan graphics to make it easier to see the features as they are 
developed (do not delete the profile graphics).

3. Select Surface > View Surface > Features.

4. Set the Surface to 12345 backfill for pier footer.
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5. Highlight both features.

6. <D> Apply, then Close.
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7. Turn on the BRDG_Outline-Foundation-Footer level.

8. Window in to the corner of the footer.
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Note: This element represents the bottom of the footer. In the next series of steps, 
MicroStation is used to create 3 parallel copies of this element. 

9. Select MicroStation’s Move Parallel tool.

10. Toggle on Distance and key in 1.50.

11. Toggle on Make Copy.

12. <D> on the footer outline.

13. <D> to Accept inside the footer outline.

14. <R> to end the copy.

Note: This is the bottom of the pier.
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15. In the Move Parallel command, change the Distance to 0.01.

16. Make a copy of each line, to the inside.

Note: These lines represent the top of the footer and the top of pier.



Colorado Department of Transportation   Page 181

Bridge Essentials Using InRoads XM LAB 7 - Feature Based Modeling

Note: There are now four concentric rectangles representing the footer and pier. In this 
case, one monolithic pier is being used; for multiple piers this procedure would be 
repeated for each.

Each of these MicroStation shapes must now be made into a feature, then moved to the correct 
elevation.

17. Select File > Import > Surface.

18. Select the From Graphics tab.

19. Set the Surface to 12345 backfill for pier footer.

20. Set Load From to Single Element.

21. Set Elevations to Use Element Elevations.

Note: All of these shapes are at the same elevations. After importing them, the proper 
elevations will be set.

22. Key in Bottom of footer for the Seed Name.

23. Set the Feature Style to Breakline.

24. Set the Point Type to Breakline.
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25. Toggle on Point Density Interval and key in 10.00 for the value.

26. <D> Apply.

27. <D> on the bottom of footer line.

28. <D> to Accept.
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29. Key in Top of footer for the Seed Name

30. <D> Apply.

31. <D> on the top of footer line.

32. <D> to Accept.
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33. Key in Bottom of pier for the Seed Name.

34. <D> Apply.

35. <D> on the bottom of pier line.

36. <D> to Accept.



Colorado Department of Transportation   Page 185

Bridge Essentials Using InRoads XM LAB 7 - Feature Based Modeling

37. Key in Top of pier for the Seed Name.

38. <D> Apply.

39. <D> on the top of pier line.

40. <D> to Accept.

41. Select Surface > Design Surface > Set Elevation.
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42. If the current Locate Mode is not set to Features, toggle Locate Graphics/Locate Features 
on the locks toolbar to Locate Features.

Note: This command can set the elevation of either graphical elements or features. Since 
the shapes have already been loaded into the surface, they are already features.

43. Highlight the Bottom of footer feature.

44. Key in an Elevation of 5152.

45. <D> Apply.

46. Highlight the Top of footer feature.

47. Key in an Elevation of 5153.5.

48. <D> Apply.

49. Highlight the Bottom of pier feature.

50. Leave the Elevation set to 5153.5.

51. <D> Apply.

52. Highlight the Top of pier feature.

53. Key in an Elevation of 5180.

54. <D> Apply then Close.
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Note: Alternately, you can set the MicroStation graphics to the correct elevation using the 
Set Elevation command prior to importing the graphics as features into 
InRoads.The Set Elevation command works on either graphics or features based 
on the Locate mode.

55. Select Surface > Triangulate Surface.

56. Verify the Surface is 12345 backfill for pier.

57. <D> Apply then Close.

Note: This has basically created a footer and pier sitting in a trough. The triangles and/or 
contours may be displayed to review the surface if desired. This image shows a 
rotated view of the triangles that has been shaded using MicroStation’s Utilities > 
Render > Smooth.
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58. Save the 12345 backfill for pier footer surface to the directory 
C:\Projects\12345\Bridge\InRoads.

59. Window in to the previously displayed profile.

60. Select Evaluation > Profile > Update Profile.

Note: If there is more than one profile in the design file, make certain the correct Profile 
Set is listed.

61. Set the Mode to Refresh.

62. Highlight the 12345 backfill for pier surface.

63. <D> Apply, then Close

Note: This surface, along with the excavation surface will be used in a later lab to 
calculate volumes.
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Chapter Summary:

 The Generate Sloped Surface command is very useful for creating sloped surfaces from 
features or graphical elements that intercept other surfaces. 

 The intercepts can be existing ground surfaces, design surfaces or even surfaces previously 
created with this command.

 Features can be added to a proposed surface representing footers, piers, walls, etc.), which 
can be used for volume computations.

 MicroStation elements or surface features can be placed at the correct elevation using the 
Set Elevation command in InRoads.

 MicroStation elements can be imported as surface features using the Import Surface 
command in InRoads; if they are not at the correct elevation, the elevation can be set using 
the InRoads Set Elevation command.
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