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LAB 2 - Reviewing Roadway Design Data

Chapter Objectives:

 Develop an understanding of the roadway design data.

 Learn InRoads’ tools that are used to display and evaluate surfaces.

 Learn InRoads’ tools that are used to display and evaluate alignments.

The following files are used in this lab:

 C:\Workspace\Workspace-CDOT_XM\Standards-Global\InRoads\Preferences\ 
CDOT_Civil.xin

 C:\Projects\12345\Bridge\Working\12345BRDG_Model-Drain.dgn

 C:\Projects\12345\Design\InRoads\12345 SH52

 C:\Projects\12345\Design\InRoads\12345 SH119 SH52 interchange.alg

 C:\Projects\12345\ROW_Survey\InRoads\DTM\12345 existing ground for interchange

Lab 2.1 - Requesting InRoads Design Data

See Section 1.5 Requesting InRoads Design Data to determine which InRoads data files are 
needed to start your work. The labs assume that you have been provided the appropriate 
InRoads data files from the responsible groups noted in Section 1.5.

Lab 2.2 - Using InRoads Surface and Geometry Tools

This section covers how to use surface and geometry viewing, annotation, tracking, and 
reporting tools to review InRoads data that is provided to the Bridge group by the Roadway 
Design group. A “working” file will be used to view geometry, cross sections, and profiles.

1.  Open MicroStation and InRoads using the C:\Projects\12345\Bridge\Working 
\CU12345BRDG_Model.dgn file.

Note: The standard filename for working files includes the user’s initials in front of the 
filename. In this case, “CU” stands for CDOT User.

2. Delete any MicroStation graphics currently in the design file.

3. Verify the correct *.xin file is loaded.

4. Select File > Open from the InRoads menu.

5. Open C:\Projects\12345\Design\InRoads\12345 SH52 and 12345 SH119 SH52 
interchange.alg. 

6. Open C:\Projects\12345\ROW_Survey\InRoads\DTM\12345 existing ground for 
interchange.
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Review the surfaces

1. Select Surface > View Surface > Contours.

2. Select Preferences.

3. Highlight the Existing 5’ Mjr – 1’ Minor preference.

Note: The Preference controls the interval of the contours, number of minors per major 
contour, labeling, levels the contours are displayed on, etc.

4. <D> Load, then Close.

5. Set the Surface to 12345 existing ground for interchange.

6. <D> Apply.
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7. Review the contours and zoom into the proposed bridge area.

8. Use MicroStation to Delete the contours when done reviewing.

Note: The contours are a graphic group, so make certain graphic group lock is on.

9. Select Preferences from the View > Contours dialog.

10. Highlight the Proposed 5’ Mjr – 1’ Minor preference.
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11. <D> Load.

12. Switch the surface to 12345 SH52.

13. <D> Apply.

14. Close the Preferences dialog.

Note: Loading the preference changes the contour settings so this display uses the 
proposed symbology.

15. Review the contours and window in as shown.



Colorado Department of Transportation   Page 23

Bridge Essentials Using InRoads XM LAB 2 - Reviewing Roadway Design Data

Note: In this case, the design model does not have sideslopes in the area where the 
proposed bridge will be located.

16. Close the View Contours dialog.

17. Use MicroStation to Delete the contours when done reviewing.

18. Select Surface > Update 3D/Plan Surface Display.

Note: This command is useful since it provides access to most surface viewing 
commands in one dialog, and it allows you do delete the displays without using the 
MicroStation Delete command.

19. Toggle Display On and highlight the existing ground surface.

20. Toggle on Perimeter.

21. <D> Apply.

22. Fit the MicroStation view to see the perimeter of the surface.
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Note: The perimeter of the existing ground is useful to review the limits of the survey.

23. Repeat for the SH52 surface.

Note: You can highlight more than one surface at a time. These were done separately to 
more easily tell which surface is which.

24. Toggle Display Off.
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25. Highlight both surfaces.

26. <D> Apply.

27. Toggle Display On.

28. Toggle on Contours.

29. Toggle off Perimeter.

30. Highlight the existing ground surface.

31. <D> Apply.

32. Review the contour display.
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33. Toggle Display Off.

34. <D> Apply.

Note: You are not given a choice on the preference when using this command for 
displays, but you were able to delete the perimeter and contours without using the 
MicroStation delete command.

35. <D> Close.

Review alignments using Viewing, Tracking and 
Stationing

The following InRoads tools will be used in this lab to review alignments that are created by 
the Roadway Design group.

♦ Geometry > View Geometry > All Horizontals which displays all horizontal 
alignments in the active geometry project with no annotation.

♦ Tools > Tracking > Tracking which displays the Station and Offset for a specific 
point, along with surface data.

♦ Tools > Tracking > Horizontal Alignments which provides a readout of the 
Station, Offset and Curve radius (if applicable) for a specific point, along with 
elevation of the active vertical alignment.

♦ Geometry > View Geometry > Active Horizontal which displays only the 
active horizontal with no annotation.

♦ Geometry > View Geometry > Horizontal Annotation which displays the 
specified alignment or alignments along with annotation of the tangent and curve data.

♦ Geometry > View Geometry > Stationing which displays station for the 
specified horizontal alignment.

1. Select Geometry > View Geometry > All Horizontals.

2. Fit the MicroStation view.
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Note: This geometry file contains horizontal and vertical alignments for SH119 NB and 
SB, SH52, Ramps A-D, and several walls.

3. In the Explorer part of the InRoads menu, <D> on the Geometry tab and <D> on the ‘+’ 
next to the geometry project to expand the list of alignments. 
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Note: You may need to use the arrows to scroll across to see the Geometry tab.

 

4. Right-click on SH52-H and select Set Active if it’s not already.

Note: The active alignment has a red box around its icon.
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5. Select Tools > Tracking > Tracking.

6. <D> Activate.

7. Move your cursor in the vicinity of the wall alignments as shown.

Note: The readout of Station, Offset, etc is shown in the dialog box. Using this command 
gives you a readout of the stationing on the alignment, the perpendicular offset to 
your cursor location the coordinates of your cursor location, and the Elevation 
(along with other data) of the active surface at your cursor location. 
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8. Snap to the end point of the wall alignment as shown.

Note: You may snap using <T> <D> just as you would in MicroStation or if you want to 
use AccuSnap, hold down your <Ctrl> and <Shift> keys on your keyboard. This 
is true whenever you need to use AccuSnap within an InRoads command.

Note: The readouts are written to the design file. The text is written perpendicular to the 
alignment being tracked and is top-left justified on the point where you snapped.

In the next series of steps you’ll attach a reference file containing the SH52 bridge pier and 
abutment graphics and then use these graphics to obtain additional tracking information.

9. Select File > Reference from the MicroStation menu.

10. Select Tools > Attach.
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11. Select C:\Projects\12345\Bridge\Drawings\Reference_Files\12345BRDG_Model_D-16-
DU.dgn.

12. <D> OK to accept the default reference settings.

13. Close the Reference dialog box.

Note: Abutment and Pier centerlines are shown in the file.
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14. Window in on the area shown to see the abutment centerline.

15. Select Tools > Tracking > Tracking.

16. <D> Activate.
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17. Move your cursor in the vicinity of the abutment graphic as shown.

18. Select MicroStation’s Intersection snap mode.
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19. Snap to the intersection of the abutment centerline and the SH52 centerline alignment.
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Note: The readouts are written to the design file. Note that the abutment centerline is 
located at station 108+73.63 on the SH52 alignment. Tracking is a convenient tool 
for obtaining station locations of abutment centerlines or backfaces. 

20. <D> Close to exit the Tracking command.

21. Delete the readout with MicroStation.

22. Turn off the display of the bridge reference file.
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23. Select Tools > Tracking > Horizontal Alignments.

.

Note: The Station, Offset, Elevation and curve Radius is shown in both the InRoads and 
MicroStation message fields. Using this command gives you a readout of the 
stationing on the alignment, the perpendicular offset to your cursor location and the 
elevation of the active vertical alignment associated with the horizontal you’re 
tracking (as opposed to the DTM elevation in the Tracking command).

24. Make Wall D-16-L active.

25. Track the Alignment with Horizontal Alignment Tracking.

26. Toggle Point Snap on.

27. Track the alignment and note that the cursor only tracks from the beginning, ending and 
angle points or PIs of the alignment.
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Note: This can be used to easily check the stationing of the angle points for the wall to 
see if the wall segments are of even lengths.

28. Toggle Point Snap back to No Snap.

Next, you will station an alignment. The Text Scale Factor is applied to all text, ticks and 
offsets created by InRoads and may be changed at any time. 

29. Choose Tools > Options > Factors.

Note the default settings.

30. <D> the lock icon to unlock the three settings so they can be set individually.
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31. Change the Text Scale Factor to 50.

32. <D> Apply.

33. <D> Close.

Note: If you Apply without saving a preference, the change only remains active until 
you exit InRoads.

34. Select Geometry > View Geometry > Stationing.

35. Toggle the Horizontal Alignment to SH52-H.

Note: The Horizontal Alignment defaults to the active alignment. Changing it here also 
changes the active alignment.
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36. Load the preference PROPOSED-100 Ft Interval.

37. <D> Apply.

38. Select Tools > Options > Factors and set the Text Scale Factor to 100. (Don’t forget 
to Apply.)
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39. <D> Apply on the Stationing dialog, then Close.

Note: Since you are in Pencil mode, the second set of stationing replaces the first set.

Note: The display of the stationing on the alignment honors the Text Factor as you can 
see. In general, you use a text factor equal to the scale you plan to plot. When 
reviewing data that you do not plan to plot, as you are here, you may choose a 
different text scale to make the text more legible in the file.

40. Use MicroStation to Delete the Stationing.

Note: The stationing is made up of graphic groups, making it easier to delete.

41. Choose Geometry > View Geometry> Horizontal Annotation.

42. In the Horizontal Alignments Include field, select the SH52-H alignment.

You may either:
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♦ Use the target button next to the Include field and graphically pick the alignment,

  

♦ Type the alignment name in the Include field (wildcards are allowed), or
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♦ <D> in the Include field and choose Filter to pick the alignment from a list and select 
Add and then OK.

   

43. <D> Apply and the alignment is annotated.

44. Window in and review the annotation.
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Note: You may also <D> Interactive and then choose one piece of any alignment at a 
time to annotate (whether or not it is currently active or displayed).

45. Choose Geometry > Review Horizontal.

Note: You can also right-click on the horizontal in the Explorer portion of the menu and 
choose Review.

Note: The Review lists all the information about the active horizontal alignment. This 
report can be saved as a text file, displayed in the design file or printed if necessary. 
You can also switch to a different alignment using the drop-down list at the top of 
the dialog.

Important! The Print command allows the report to be printed to any printer that can 
be accessed on the current machine.

46. <D> Close when you are finished evaluating the alignment.

47. Choose Geometry > Review Vertical.
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Note: You can change Geometry Projects, Horizontal Alignments, or Vertical 
Alignments using the drop-down list at the top of the Review dialog. You can also 
use the target buttons to graphically identify alignments.

Note: The Review lists all the information about the active vertical alignment. In this 
case, the vertical is the top of wall elevation.

48. <D> Close when you are finished evaluating the alignment.

49. Continue to review other alignments as desired.

50. Select Tools > XML Reports > Geometry.

51. Select the SH52-H alignment.

As described earlier, you may either:

♦ Use the target button next to the Include field and graphically pick the alignment,

♦ Type the alignment name in the Include field (wildcards are allowed), or

♦ <D> in the Include field and choose Filter to pick the alignment from a list.

52. Toggle on Include Vertical Alignments.

53. Toggle on Active.
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54. Toggle all other options off.

55. <D> Apply.

Note: When you create a report using one of the XML Report commands, an *.xml data 
file with the results is created in the user’s Local Settings\Temp folder. This XML 
file is formatted in the Report Browser using an XSL style sheet, or format. Most 
reports have a default format, but you can choose between other formats as desired.

56. In the Report Browser that appears, available formats are listed on the left side. Choose the 
format: Geometry > HorizontalAndVerticalAlignmentReview.xsl.

Note: All XML reports use this same browser, so the folder structure at left lists all 
different types of reports. Here, you are looking at an alignment, so you choose a 
report format from the Geometry folder. If you are reporting on Stations and 
Offset, you would use formats from the StationOffsets folder, and so on.
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57. Review the report.

Note: If you right-click a format and choose Style Sheet Help, a dialog will pop up 
describing the data required to complete that particular format.

Important! Just like in the Review command, reports may be printed directly from this 
dialog. Select File > Print to access this function.

58. Choose Tools > Format Options. 

Note: Much of the formatting of the report can be modified on the fly by changing the 
settings in this dialog box.
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59. Change the Northing Easting Precision to show four decimals.

60. <D> Close on the Format Options dialog.

61. Close the Report.
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62. Back in the Geometry Report dialog, <D> in the Include field and key in Wall* to select 
all the Wall alignments.

63. <D> Apply.

In the Report Browser, note the reports now shows each of the wall alignments.

64. Close the Report Browser when you’re done reviewing the report.

Lab 2.3 - Using InRoads Evaluation Tools

Next, you will be creating profiles and cross sections to analyze geometry and surface data 
provided by Roadway Design. This includes annotating information on the profiles and cross 
sections. For this annotation the text scale factor is applied to all the text, ticks and offsets for 
the cross sections as well as profiles. 
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Note: Each time you create profiles or cross sections, you create a new set and it is given 
a name, which by default is derived from the alignment name with a counter on the 
end. Later, you will use this set name when identifying the profile or section set to 
view, annotate, etc.

1. For this example, set the Text Scale Factor to 40.

2. Choose Evaluation > Profile > Create Profile.

3. <D> Preferences and Load the 2x Vertical preference.

4. <D> Close on the Preferences dialog.
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5. In the Surfaces area, toggle on both the existing ground and SH52.

6. <D> on the Source branch on the left of the dialog.

7. Make certain Alignment is toggled on and set to Wall D-16-L. 
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8. <D> on the Include branch.

Note: If you want to display crossing features on your profile like pipes or utilities, 
toggle on Crossing Features. These features must first exist in the surface(s) 
you’re profiling. The feature’s style controls if the feature can be shown on the 
profile.

Note: If you want to show features that fall outside the profile window, toggle on 
Projected Features. This will show the orthogonal projection of the features onto 
the profile. You also have the option of specifying a Bandwidth to either side of the 
profile to project the features.

9. For this exercise, leave these options toggled off.

10. <D> on the Controls branch and toggle off all Controls.
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Note: The Elevation option is used to set absolute values for the left axis. With it off, the 
left axis elevations are determined by the high and low elevations of the surfaces. 
The Station option allows you to create a partial profile. With it off, the entire 
alignment is profiled. The Window Clearance option is used when you want to add 
grid to the top or bottom of the profile for annotation, which we do not need here.

11. <D> Apply and <D> a clear area in your design file when prompted to Identify Location.

Note: This is the location of the lower left corner of the profile grid, so make certain there 
is room above and to the right of the point you select. You do not need to click near 
the horizontal alignment.

The profile is displayed with the two surfaces showing. Offsets can also be shown on the 
profile.

12. Use MicroStation to delete the profile.

13. Under General, highlight the existing ground surface and choose Properties.

14. On the Advanced tab of Surface Properties, set Offset 1 to -1.50 and the Symbology to 
D_Surface1.

Note: A negative offset is to the left of the alignment.
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15. <D> Apply.

16. Toggle the Surface to 12345 SH52 and select Properties.

17. On the Advanced tab, Set Offset 1 to 1.00 and the Symbology to D-Surface3.

18. <D> Apply then Close.

19. Choose Offsets on the Profile dialog.

20. Set the Surface to 12345 SH52 and toggle on Offset 1.
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21. Set the Surface to 12345 existing ground for interchange and toggle on Offset 1.

22. <D> Apply and <D> a clear area in your design file when prompted to Identify Location.

23. Window in close to the ground surface on the profile.

Note: The profile now shows two lines for the existing ground and two lines for the 
proposed. The existing ground is shown at the wall centerline and 1.5’ in front of 
the wall. The proposed ground is shown at the wall centerline and 1.0’ behind the 
wall. You can use profile offsets to set the bottom of wall elevations (e.g. if the toe 
of wall is 1.5 feet in front of the wall face, you can copy that offset line down by 
1.5' (or whatever the vertical exaggeration requires) to get the top of the footing. 
Dropping it 3 feet will provide the minimum bottom of footing).

24. <D> Close on the Profile dialog.
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25. Select Geometry > View Geometry > Active Vertical.

You may instead want to display and annotate the vertical alignment.

26. Select Geometry > View Geometry > Vertical Annotation.

27. Load the Other preference.
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28. <D> Apply.

29. Review the annotation on the profile. You may need to change the Text Scale Factor using 
Tools > Options > Factors. If you <D> Apply again, the original annotation is deleted 
and the new annotation is placed.

30. <D> Close when done.

31. Right-click on the SH52-H alignment in the Explorer part of the InRoads menu and choose 
Set Active.

32. Create a profile for this alignment using the same steps as shown above, except only toggle 
on the existing ground surface.

33. View the vertical annotation, using the Proposed preference.
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Note: When more than one profile exist in the MicroStation file, you can tell InRoads 
which one to use for annotation by selecting it from the drop-down list or by using 
the target button and selecting it graphically. 

The vertical alignment for SH52 does not currently show the location of the bridges. This can 
be accomplished using Event Points as shown below.

34. Verify SH52-H is still active.

35. Select Geometry > Horizontal Curve Set > Events.

36. Toggle on Add Vertical Event Points.

Important! Adding event points results in a modification to the *.alg file. In order to 
make this type of edit, you will need write access to the alignment file 
being used in the geometry project. This file is typically located in the 
Design group’s InRoads folder and often has restricted access. If direct 
access is not granted, someone fron the Design group will need to add the 
event points for you. Either way, communication with the Design group is 
critical. 
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37. <D> the Snap icon on the MicroStation Status bar and choose Intersection.

38. <D> the Target button in the Locate By field on the dialog.

39. Hold down your <Ctrl> and <Shift> keys on your keyboard and move your cursor to the 
intersection of the SH52 and Wall D-16-K alignment.

Note: <Ctrl> and <Shift> can be held down any time you want to use AccuSnap within 
an InRoads command. 
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40. When the two alignments highlight with a yellow X at the intersection, <D> to select the 
location.

The coordinates of the intersection are entered in the dialog.

41. <D> Apply to add the event point.
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42. Repeat this process for the location of the intersection of SH52 and Wall D-16-L.

43. <D> Close when you have both Event Points located.

44. View the vertical annotation for SH52, again using the Proposed preference.

Note: The last used preference remains active in a dialog until another one is selected or 
you close InRoads, so you should not need to load it this time. 
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The locations of the intersecting alignments are annotated on the profile as Event Points.

Next, you will create cross sections. 

45. For this example, set the Text Scale Factor to 40.

46. Choose Evaluation > Cross Section > Create Cross Section.
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47. Load the Stacked 20 per column preference.

48. Set the Offsets to -200 and 200.

49. Toggle on both surfaces.

50. <D> on the Include branch at left.
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51. Toggle on Components.

52. <D> on Controls > Plan Display.

53. Toggle on the Planimetric option in the Symbology branch.

Note: The planimetric option displays a MicroStation element showing where each cross 
section is cut.

54. <D> Apply.
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55. <D> in a clear area in the design file. Like the profile, you are identifying the lower left 
corner for the display, so make certain you are in an area that is clear above and to the right 
of your <D>.

56. Fit your MicroStation view and notice the planimetric lines. You can see that by default, 
cross sections are cut perpendicular to the active alignment. In a later section, you will 
learn to cut the cross sections on a skew.

57. Use MicroStation to delete the cross sections and the planimetric lines in the plan view.

58. <D> on Controls > Limits.

59. Toggle on Station.

60. Set the Start Station to 116+00.00.

61. Set the End Station to 111+50.00.

62. <D> Apply.
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63. <D> in a clear area in the design file.

64. Fit your MicroStation view and notice the planimetric lines. 

Note: Using the Station Limits allows you to cut sections for just a portion of the 
alignment.

You can zoom in and out of the cross sections to review them, or you can use a viewer that will 
automatically zoom into a selected cross section.
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65. Choose Evaluation > Cross Section > Cross Section Viewer.

The viewer allows you to view cross sections by set. If you have more than one set of 
sections in the file, you can use the drop-down to choose the set you want to view, or you 
can use the target and <D> inside one of the sections. If you are zoomed out far enough, 
you will see a box drawn around the set of sections currently shown in the Viewer.

66. <D> on any one of the sections in the list.

67. With only one MicroStation view open, the Viewer automatically uses it to zoom into the 
section selected. If you have more than one MicroStation view open, you are prompted to 
select the view with a <D>.

68. Change the Zoom factor to 1.0000 and choose another section.

69. <D> Run.

Just as before, with only one MicroStation view open, the Viewer automatically uses it to 
zoom into the sections, but this time it automatically scrolls through the entire set. If you 
have more than one MicroStation view open, you are prompted to select the view with a 
<D>.

Note: <Esc> on your keyboard stops the viewing process.

70. <D> Close on the Cross Section Viewer.

71. Window in to any one of the sections.
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Note: The lifts, curb and gutter, etc. are components, which were turned on before 
cutting sections. Design surfaces are made up of these components, as well as 
features and triangles.

72. Select Evaluation > Cross Section > Update Cross Section.

73. Set the Cross Section Set to SH52-H.

74. Set the Mode to Display Off.

75. Select the Components branch at left.

76. Highlight the 12345 SH52 surface.

77. Right-click in the component list and <D> Select All.

78. <D> Apply, then Close.

Note: The cross sections now show only the triangulated surface for SH52. Components 
may be turned on and off as desired using this procedure.
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79. Use MicroStation to Delete the cross section set and the planimetric lines.

Note: Sections can be cut along any alignment, not just a highway alignment.

80. Using what you have learned, cut 25’ sections along Wall-16-L that are 20’ wide on either 
side.

 

81. Review the sections.

82. Use MicroStation to Delete the cross section set and the planimetric lines.

Chapter Summary::

 Surfaces may be reviewed graphically by viewing the perimeter, triangles and/or contours 
among other surface displays.

 Horizontal alignments may be viewed graphically along with their stationing and 
annotation.

 Horizontal alignments may also be tracked as a review tool.

 Reports for horizontal alignment can be generated with the Review commands or with the 
XML Report command.

 With a horizontal alignment and surface, you can generate a profile and annotate a vertical 
alignment.

 With a horizontal alignment and surface, you can generate a set of cross sections to review 
the data.
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