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LAB 3 - Geometry Annotation

This lab demonstrates how annotate horizontal geometry, set and display alignment stationing, and use 
horizontal alignment tracking tools.

Chapter Objectives:

 Display horizontal alignments.

 Annotate horizontal alignments and cogo points.

 Reset stationing on an alignment.

 Display stationing.

 Add a station equation.

 Use Tracking and Horizontal Alignments Tracking.

The following files are used in this lab:

 C:\Projects\12345\Design\Drawings\Reference_Files\12345DES_Model.dgn

 C:\Projects\12345\Design\InRoads\12345DES_Geometry.alg

 C:\Projects\12345\Design\InRoads\12345 existing ground.dtm

Lab 3.1 - Geometry Display

Section Objectives:

 Set the proper scale factors.

 Open a saved view in MicroStation.

 Display alignments using the View and Annotation commands.

Options for displaying horizontal alignments are available when using the Horizontal 
Annotation dialog.

1. Select Tools > Global Scale Factors and set the scales to 100 for Text and Cell and 1 
for Line Style .

2. Using the MicroStation menus, select Utilities > Saved Views tools to open the saved 
views dialog.
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3. <D> on the name POB, <D> Apply for view 1, and <D> Close.

Below is an example of the saved view.
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4. Display alignment SH 86 from the Geometry Project 12345_Design by right-clicking <R> 
on the alignment name and selecting View from the fly-out menu.

The alignment display is based on the geometry style assigned to the alignment. This 
display method is suitable but does not allow the user any options or allow annotation of 
the geometry. The next steps illustrate how to customize the graphics display for geometry 
elements.
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5. Select Geometry > View Geometry > Horizontal Annotation.

6. Key in SH 86 in the Annotate field and Tab from the field.

7. Set options for the Display and Annotate sections of the dialog as shown in the above 
screen shot.

8. <D> the Apply button. This will write alignment SH 86 to the MicroStation Screen and 
annotate the alignment.
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Note how Bearing and Distance annotation is displayed along the tangents. If the 
alignment contains horizontal curves, curve data will be displayed.

9. Return to the View Horizontal Annotation dialog.
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10. In the Annotate area of the Main tab, Toggle on Points, <D> Apply

In addition to annotation for tangents and curves, notice that alignment vertices are also 
annotated.
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11. On the Main tab, click the Help button and review the descriptions for the various 
components that can be displayed.

12. Experiment displaying an alignment with Points and Elements turned on or off on both the 
Display tab and the Annotate tab.

13. Experiment displaying the various components available in the display portion of the 
dialog.

Section Summary:

 InRoads displayed graphics are governed by the Global Scale Factor in InRoads. THe 
MicroStation Annotation Scale has no affect on these elements.

 The view alignment commands (from the right click menu of from Geometry > View 
Geometry > Active Horizontal) only display the lines and arcs that make of the alignments 
path.

 Horizontal Annotation also displays the alignment’s path. It can display other geometry 
data as well.

Lab 3.2 - Selection of Geometry for display and/or Annotation

Section Objectives:

 Illustrate methods for defining horizontal alignment elements for display and/or 
annotation.
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1. Select Geometry > View Geometry > Horizontal Annotation.

2. <D> the Main tab.

3. Set the Apply Style to Assigned.

4. <D> in the Include field in the Horizontal Alignments area.  The Filter button becomes 
active.

5. <D> the Filter button.  The Geometry Selection Filter dialog will appear.
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Note: Available alignments are shown on the left, Selected (for display or annotation) 
alignments are shown on the right.  This makes it possible to select multiple 
alignments for display or annotation.

6. Move the alignments SH 86 and Side Road from the Available list to the Selected list by 
<D> the names in the Available list and then <D> the ADD button (or <D><D> on the 
names).

Note: The data in this dialog can be sorted by clicking <D> on the column headers. 
Multiple selections of alignments can be made through the use of the <CTRL> or 
<Shift> keys.
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7. When done identifying the desired alignments in the Filter dialog, <D> OK – the Selected 
geometry is populated in the Selected field

8. <D> Apply and the selected alignments will display in MicroStation.

9. Review the results in MicroStation.
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Section Summary:

 Alignments can be selected for annotation by key in, graphic selection using the  button, 
or by using the Filter options.

  The Display area is used to turn on or off the display of the geometry elements. 

 The Annotate area is used to turn on and off the text data associated with the geometry 
elements.

Lab 3.3 - Display or Annotation of Cogo Points

Section Objectives:

 Illustrate methods for defining cogo points for display and/or annotation.

Note: Whether you are annotating Points or Alignments, keep in mind that the element 

selection button can be used to graphically identify the geometry of interest. 
This is universally true in InRoads whenever the selection button is displayed.

10. <D> the Include field in the Cogo Points area to activate the Filter button

11. <D> the Filter button. The Geometry Selection Filter dialog will appear.
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12. Select points 1001-1005 & 1010 from the Available field and add them to the Selected 
field.

13. <D> the OK button. The points populate the Selected field.
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14. <D> the Apply button in the View Horizontal Annotation dialog.

15. Experiment displaying various Alignments and Points with the assorted settings.
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Note: Remember to toggle on Points in the Annotation tab if you need to see Cogo 
Point numbers, Northing, and Easting. Keep in mind annotation settings are 
derived from the Geometry Style Manager Type: Points for the assigned Geometry 
Style.

Section Summary:

 Cogo Points can be selected for annotation by key in, graphic selection using the  
button, or by using the Filter options.

  In the Display area, the Points toggle is used to turn on or off the display of the geometry 
elements.

 The Annotate area is used to turn on and off the text data associated with the geometry 
elements.

Lab 3.4 - Review Alignment Stationing

Section Objectives:

 Review the alignmet to determine its current stationing.

The default station at the beginning of a newly created horizontal or vertical alignment is 0+00. 
This value can be changed as shown later in this lab.

One of the easiest methods for determining assigned stationing values is through the alignment 
review commands.

1. Make 12345_Design the active geometry project by right-clicking on this geometry 
name and selecting Set Active from the fly-out menu.
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2. Right-click on the alignment SH 86 and select Review from the Fly-out menu.  The 
Review Horizontal Alignment dialog will appear.

Note: Fly-out menus can be access from either the workspace or feedback panes. Also 
note that selecting an alignment for review switches it to being the active 
alignment.

3. Investigate the stationing assigned to horizontal Alignment SH 86.

Initial station value is: _____________________________.

4. Review the Vertical alignment SH 86 V associated with horizontal alignment SH 86.

♦ Is the stationing for the horizontal and vertical alignments synchronized?

Section Summary:

 Use the Review command to find out information about the alignment, like stationing, 
without having to display it graphically.
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Lab 3.5 - Displaying Stationing

Section Objectives:

 Display stationing and alignment keypoints.

 Use the Symbology toggles to turn on and off various items.

1. Prior to displaying the stationing, display the lifework for the horizontal alignment  SH 86.

Right-click on the alignment name in the InRoads explorer window and select View from 
the fly-out menu.

2. Select Geometry > View Geometry > Stationing.  The View Stationing dialog 
will appear.

3. <D> the Preferences button.
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Note: The Preferences dialog is used to load preset settings for a particular tool.  In the 
View Stationing dialog the preference is setting the interval and symbology of the 
display graphics.

The following steps load the Preference Proposed–100 Ft Interval as the active symbology.

4. <D> Proposed-100 Ft Interval.

5. <D> Load then Close button.

6. In the Symbology portion of the dialog, select or de-select the alignment components for 
display. Loading the preference sets the default interval for major stations.
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7. <D> Apply to display the stationing.

The View Stationing dialog is populated with the predefined settings from the stored 
preferences. Notice the interval field and settings under the symbology section. The display 
toggles define what will display; the name column reflects the InRoads named symbology 
defining graphical attributes for displayed items.

There are several standard CDOT preferences to choose from, depending upon the type of 
alignment stationed and station interval. Choose the appropriate Preference and <D> 
Apply to see the stationing.

Keep in mind that text size is dependent on the active Global Scale Factor at time of 
display. If necessary, select Tools > Options [Factors] to change the value of the Global 
Scale factors.

8. Change the Global Scale Factor and redisplay stationing.

9. Experiment displaying stationing using various CDOT preferences until presets becomes 
familiar.
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10. Experiment with the various tabs and settings in the View Stationing dialog and 
investigate what changes are made when stationing is redisplayed.

Section Summary:

 The stationing Preferences are set to CDOT standards and should be used in most cases.

 Using the Pencil mode automatically deletes old stationing when new stationing is 
displayed.

Lab 3.6 - Defining Stationing

Section Objectives:

 Change the biginning station of an alignment.

Upon creation, alignments are defined with a beginning stationing of 0+00. Stationing can be 
redefined from any location along the alignment.  Additionally, station equations can be 
incorporated.
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1. Select Geometry > Horizontal Curve Set > Stationing.  By default, this dialog dis-
plays the beginning station value of the active alignment.

2. Select Synchronize Starting Stations in the Vertical and Superelevation Alignments 
section.

3. Set the beginning station of alignment SH 86 by keying in 125+25.36 and choosing 
Apply.

4. Verify the change has been applied by redisplaying the stationing using Geometry > 
View Geometry > Stationing and clicking Apply.  Also, check the beginning station 
value of any associated vertical alignments by using the review command.

Note: The options for Vertical Alignments should be considered carefully.  Do Not 
Update will leave the stationing of vertical application stations as is, 
Synchronize Starting Stations will update their stationing to match that of the 
horizontal and Maintain Station Difference will keep any difference (delta) in 
the current starting stations.

○ InRoads does not require a ‘+’ when keying in a station.  The plus sign will be 
added automatically.
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○ Any point along the alignment can be specified as the location for the input 
stationing value. The alignment location defined by either name or the northing 
and easting fields is the location the input stationing will propagate from.

5. Set the beginning station of alignment SH 86 by keying in 32062.24 and choosing 
Apply.

6. Verify the change has been applied by redisplaying the stationing.  Select Geometry > 
View Geometry > Stationing then click Apply.

Section Summary:

  When stationing is set for a particular point, the stationing for the remainder of the 
alignment (forwards and backwards).

 The reference to Superelevation in the Vertical and Superelevation Alignments area refers 
to geometry created in the 2004 edition of InRoads. It does not affect the superelevation 
contained in the Roadway Designer.
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Lab 3.7 - Station Equations

If there are inequalities in the alignment, station equations may be required. These equations 
can be either gap or overlap equations.

Section Objectives:

 Add a station equation to an existing alignment.

 Redisplay stationing to show the station equation.

1. From MicroStation, select Utilities > Saved Views.  Apply saved view Station Equa-
tion. Once applied, Close the Saved View dialog.
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At the PT of the curve a station equation is necessary to tie to previous work. The values 
are: 
Back   = 356+45.30
Ahead = 356+40.30

2. Select Geometry > Horizontal Curve Sets > Stationing.  The Stationing dialog 
will appear.

3. Verify SH 86 is the horizontal alignment.

4. At the bottom of the dialog, choose New. 

 

5. In the resulting box, set the Mode to By Station.

6. Enter the Back Station and the Ahead Station as shown below.

 

7. <D> Apply.
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8. <D> Cancel to close the Add Station Equation dialog. The station equation will be 
shown in the parent dialog.

9. <D> Close in the Stationing dialog.

10. Redisplay the stationing for alignment SH 86.
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Note: The ahead station must be prefixed with an equation name. The name must consist 
of at least one alpha character.

○ An alignment can contain multiple station equations.
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○ Annotation of stationing lying within the range of a station equation will be 
prefixed with the equation name. If the prefix is undesirable, toggle on Drop 
Station Equation Name in the View Stationing dialog and redisplay the 
stationing.
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Section Summary:

 Station equations are used to change the stationing from a given spot forward, along the 
alignment. Stationing prior to the equation retains its original stationing.

 The ahead station must have a prefix, containing atleast 1 letter, followed by the new 
station number.

Lab 3.8 - Horizontal Alignment Tracking

Two methods exist for receiving interactive information relative to a horizontal alignment. 
Both methods report on stationing, offset, elevation, etc.  One method reports the elevation of 
the active surface, the other reports the elevation of the active vertical alignment.

Section Objectives:

 Demonstrate the Tracking command.

 Demonstrate the Tracking Horizontal Alignments command

Horizontal Alignment & Surface Elevation Tracking

1. Recall Saved View Side Road.

In addition to reporting on station and offset information relative to the active alignment, 
the following method will report on information relative to the active surface.

2. Select File > Open and load the surface 12345SURV_Surface_Existing.dtm from the 
C:\Projects\12345\ROW_Survey\InRoads\DTM folder. 
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3. Select Tools > Tracking > Tracking to track both the active horizontal alignment and 
information relative to the active surface.

4. Select Activate to initialize the command. Slide the cursor along the alignment to 
interactively update the display in the Tracking dialog.  If a <D> (data point) is entered in 
the design file the information toggled on is displayed graphically.

Note: Select the Settings button in the Tracking dialog to examine the attributes 
assigned to annotation placed in the MicroStation design file.

Horizontal & Vertical Alignment Tracking

The second method tracks the station and offset relative to the active horizontal alignment 
along with the elevation of the active vertical alignment.  Station, Offset, and Elevation 
information is displayed in the message field of the InRoads interface. 
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1. Select Tools > Tracking > Horizontal Alignment to track the active horizontal align-
ment.

2. The results display in the status bar of the InRoads interface.

Note: The readout interactively reflects the location of the cursor relative to the active 
alignment. If a second horizontal alignment is selected with a data point, <D> the 
offset displayed will be relative to the two alignments perpendicular to the active 
alignment.

Section Summary:

 Use the Tracking command to get surface information in relation the the horizontal 
alignment.
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 The Tracking command can be used to display the information in its dialog box as 
MicroStation graphics. 

 The tracking Settings options are used to disable the graphic display of items in the 
Tracking  dialog box.

 Use the Horizontal Alignments tracking to get vertical alignment  information in relation 
the the horizontal alignment.

 Horizontal Alignments tracking can not be displayed graphically.

Chapter Summary:

 Alignments can be displayed using the View and View All Horizontals from the right click 
menu or from the main tool bar, or by using the horizontal alignment annotation command.

 Use the preferences to set up the Stationing dialog.  Items in the Stationing dialog box 
should only be changes for special circumstances.

 Use the Stationing options under the Horizontal Curve Set commands to change the 
stationing for the entire alignment.

 Use station Equations to change the stationing from a point on the alignment to the end.

 Tracking is used to gain station and offset information at the cursors location.

 Tracking also collects sufrace data, while Horizontal Alignment tracking gets vertical 
alignment data.
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