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Document Conventions 
There are several conventions that are used throughout this document to indicate 
actions to be taken or to highlight important information.  The conventions are as 
follows: 

 

Item     Meaning 

View Perimeter a command name or a file that you are to select 

Tools > Options a command path that you are to select – usually from the 
pull-down menus 

Key in entering data with the keyboard 

Document name style used when referring to another document 

Note:  text information about a command or process that you should 
pay particular attention to 

Emphasis an important word or phrase 

1. Numbered Steps actions that you are to perform as part of the lab activities 

<D> or Data press the data button on the mouse 

<R> or Reset press the reset button on the mouse 

<T> or Tentative press the tentative button on the mouse 
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1. Getting Started 

Introduction 
This course was developed to introduce the basics of using Bentley’s InRoads 
roadway design software package in the CDOT Design Process.  InRoads is a civil 
engineering design package that automates many of the tasks performed in the 
CDOT Process. It runs on top of a CAD platform, which in this case is Bentley’s 
MicroStation. 

InRoads is used throughout the process for developing and evaluating the design. 
The primary goals of the course are to use InRoads to generate all of the 
components of the design such as: plan/profile sheets, cross section sheets, 
quantities and a 3D model of the proposed roadway. Also covered is the 
development of a 3D model for a basic intersection. 

The document is designed for use in an instructor-led classroom environment, but 
will be useful for new users to refer back to as they begin applying the learned 
techniques to their projects.  However, it is not meant to be a software reference 
guide or to replace the on-line help available through InRoads. 

The lab activities are written to provide the students with step-by-step instructions 
for the main focus of the chapter, with additional challenge labs in many of the 
chapters for those who finish early or want to dig deeper into the topics. 

Prerequisites 
This course is designed for students that already have a working knowledge of 
MicroStation and a familiarity with civil engineering terms and concepts.  This is 
not a course on how to design, but rather on how to utilize InRoads in the design 
and modeling process. 
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CDOT CADD Resources 
There are many resources available to assist you when working on your CDOT 
CADD project. These resources can be found on the CDOT CADD & Engineering 
Innovation Web site. 

CDOT CADD & Engineering Innovation Web Site 
The CDOT CADD & Engineering Innovation web page is available at: 

http://internal/cadd/  It can also be found on the internal CDOT website: 
Organizations > Project Development > CADD and Engineering Innovation. 

The website (presently only available to CDOT) provides CDOT users with up 
to date information, tools, and resources related to CADD and the Colorado 
Engineering Software Transition (CEST) project.  

This website is a valuable resource for CADD users and includes links to: 

CADD Library -- provides links to manuals, newsletters, standard details, Tips 
and Tricks etc. 

CADD Manual -- documents standardized procedures for the exchange of 
information. The Manual also addresses software issues, tools, techniques, 
standards and procedures, etc. which will aid the user in the efficient production 
of CDOT plan sets. 

CDOT Workflows -- step-by-step CDOT-specific procedures for certain tasks 
that you may encounter when working in MicroStation or InRoads on a CDOT 
project. 

Issues Logs -- to determine the status of submitted requests. 

Requests and Support -- provides CADD help solutions where you can submit 
questions or requests, obtain InRoads, InRoads Survey and MicroStation 
support, and link to IT Services for support. 

Training -- sign up for training classes or review online computer-based training 
(CBT) for MicroStation, InRoads and InRoads Survey. 

 

Project design files 
The CDOT workflow requires that graphic and design data is created in multiple 
design files during the course of project development. These design files need 
standard, informative, and unique file names. 
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CDOT file naming convention 
Model files and Sheet files need standard, informative, and unique names to 
allow easy identification of the specialty group responsible for the file and the 
type of information contained within the file. All CDOT CADD drawings 
created should follow the CDOT standard naming convention so the data can be 
easily identified and shared by all users.  

The CDOT file naming convention contains the Job Project Code (JPC), a short 
standardized file name, and file extension.  

An example of a MicroStation design file would look like the following. 

12345DES_Model.dgn 

12345 indicating the CDOT Project Number, DES_Model indicates it is 
Roadway Design’s model file. DGN is the default extension for MicroStation 
design files. 

Note:  Working Files contain another identifier. This segment should be 
the initials of the designer or engineer who is working on the 
file.  
Example: CU12345DES_Model.dgn where CU are the initials of 
the designer or engineer (in this example, CU stands for “CDOT 
User”).  

For more information about the CDOT project directory structure, see the CDOT 
CADD Manual, Chapter Four – File Naming Convention. 
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Project File Structure 
All files related to this course are stored in the C:\Projects\12345\ folder, where 
12345 is the CDOT project code. Subfolders under the project contain the 
discipline-specific files. 

Project files follow a standardized scheme. This section describes the location of 
project files and the standard directory structure for each group within CDOT. 

   

 

For more information, including what files go where, search the CDOT CADD 
Manual for Group Sub-Directory Structure. 
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 Training files 
The training lab files for this course will be available after you complete the 
training.  Your computer will have a training files icon in CDOT Customization 
Group accessed from the Windows Start menu.  A link is also available in IT 
Services on the CADD & Engineering Innovation website.  The icon and link 
perform the same self extracting zip process to install the training files on your 
machine. 

It is highly recommended that you install the training files and continue practicing 
with MicroStation and InRoads by completing the lab exercises contained in this 
course guide, especially if you do not plan to start work on a MicroStation/InRoads 
project soon. 
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Files used by InRoads 
InRoads uses several different files to store parameters driving the design and 
display of InRoads graphics, as well as to store the design data. These files are 
loaded into memory during a design session and with some exceptions must be 
saved if they have been modified. The typical files used in a project are shown 
below. 

File Ext. Format Comes From * Contains Method of Saving 

Preferences 

(CDOT-
preferences.ini) 

.ini ASCII CDOT Standard M Units 

Precision Readout 

Command preferences 

** 

Styles 

(CDOT-
styles.ini) 

.ini ASCII CDOT Standard M Geometry Styles 

Controls symbology of 
alignments and cogo 
points. 

** 

Digital Terrain 
Models 

.dtm Binary Existing - from 
Survey 

Design - created 
by InRoads 

S Topographic 
information for ground 
surface. Used for 
contouring, profiles, 
cross section, etc. 

Must be saved before 
exiting. May use 
File>Save As>*.dtm 

Geometry 
Project 

.alg Binary Survey 

Copied and 
added to during 
design 

S Horizontal alignments 

Vertical alignments 

Superelevation  

Cogo points 

Must be saved before 
exiting. May use 
File>Save As>*.alg 

Typical 
Section Library 

.tml Binary CDOT 
Standard** 

Make copy for 
project use so 
you can edit 

M Templates 

Tables: Decision, 
Cut/Fill, Material 

TC (transition control) 
Names 

Must be saved before 
exiting. May use 
File>Save As>*.tml 

Roadway 
Library 

.rwl Binary Created for each 
project 

M Roadway Definitions 
(Station & Template 
setups, etc.) 

Must be saved before 
exiting. May use 
File>Save As>*.rwl 

Project  .rwk ASCII Created for each 
project 

S List of files used in 
project. 

The project file saves 
all the individual files 
using File>Save or 
Save As. NOTE: Files 
saved are only those 
listed in the .rwk. 

* M=Multiple Project Use, S=Single Project Use 

** CDOT configuration does not allow modification of standards, preferences or 
styles. 
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Starting InRoads 
If you are using a machine that has both MicroStation and AutoCAD loaded, or 
more than one version of MicroStation, you must tell InRoads which CAD platform 
to use before starting InRoads. 

Choose Start > All Programs > Bentley Civil Engineering > Select CAD Platform 
and select MicroStation V8, then choose OK. 

 

There are three main methods of starting InRoads: 

a. Choose Start > All Programs > Bentley Civil Engineering > Bentley InRoads and 
MicroStation will start and allow you to choose the design file, then InRoads will 
start. 

b. Choose the Desktop icon for InRoads if one is available on your machine. 
MicroStation will start and allow you to choose the design file, then InRoads will 
start. 

c. If you already have MicroStation open, you can choose the InRoads icon from the 
MicroStation main toolbar. 
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Project Defaults 
InRoads loads a preferences file and a styles file when it starts. You may create 
Project Defaults to have InRoads load your CDOT customized files automatically. 
If you do not, it will load the default files out of the InRoads product directory and 
you will have to load yours (CDOT-preferences.ini and a CDOT-styles.ini) 
through a project file (.rwk) or individually.  

The Project Defaults also set the path that InRoads will use to open or store data 
files that you load or save. These paths are not absolute; they are just the starting 
point to which InRoads defaults. 

Multiple Project Defaults may be created and stored on a machine, and you can 
switch between them when switching between projects.  

The Project Defaults are found on the InRoads menu under File > Project Defaults 
as shown below. (This figure shows a variable configured in the path so you do not 
need as many configurations.) 
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The InRoads Menu 
The InRoads menu consists of several parts as shown below, the Workspace and 
Menu bars can be undocked and placed at separate positions. The menu may be 
resized as needed and also minimized or contracted. 

 

 

 

 

 

 

             

 

 

 

 

 

 

 

 

 

             

 

 

Menu Bar 
This is the Primary menu system for 
InRoads commands. Toolbar menus are 
also available under Tools>Customize. 

Information window 
When an item is selected in the 
Workspace toolbar, this area 
displays information about the 
selection 

Workspace toolbar (InRoads Explorer) 
This toolbar has a tab for each of the 
data types that may be loaded into 
InRoads, where you can see what files 
are loaded and what they contain.  
There are several “right-click” options 
that can be used to load, save, delete, 
etc. 

Messages appear in the space at the bottom 
of the menu, as well as in the MicroStation 
prompt and message fields. 

Minimize
Maximize



Colorado Department of Transportation 

Page 10  Roadway Design Using InRoads 

InRoads Toolbars 
Most of the InRoads commands are located on toolbars as well as on the pulldown  
menus.  These toolbars as accessed through the Tools > Customize dialog.  
Toolbars can be turned on and off at will.  You can also create your own toolbars 
using the customize dialog. 

 

Initially, toolbars are docked on the InRoads menu, but may be pulled off of it and 
will remember their last location when they are closed and reopened. 
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InRoads Locks 
There are several locks that are used by InRoads in addition to the MicroStation 
locks that are available. These locks will be used throughout the course.  

The locks toolbar is shown below. 

Docked 

 

And Undocked 

                              

Filter Name – Lists the name of the Feature Filter that is currently active. It has 
no affect if the Feature Filter lock is off. If the Feature Filter lock is o n, it 
will limit dialog boxes to showing only the features that are within the filter. 
Feature Filters are stored in the CDOT-preferences.ini file and are accessed by 
using the drop-down arrow next to the name. 

Feature Filter lock – If on, activates the current filter. If off, has no affect and 
all surface features are shown in boxes that list features. Shown here in the off 
position. 

                                            

Style lock – The Style lock, if on, forces many of the Surface View commands 
to display the requested data (triangles, contours, etc.) without bringing up the 
dialog box.  The preference used is the one associated with the surface under 
Surface > Surface Properties. Style lock also forces the Cross Section 
Annotation command to use the named symbology associated with the feature 
for the annotation properties.  If off, the Style lock has no affect. Shown here in 
the off position. 
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Pen/Pencil (shown in Pencil) Delete Ink (shown off) Write lock (shown on) 

These three locks work together. 

Write lock – If Write lock is off, the displays will be temporary. Zooming in or 
out, updating the view, etc. will cause the graphics to disappear. 

If Write lock is on, there are two modes – Pen and Pencil.  

If the Pencil mode is selected, the graphics are updated whenever the same 
display command is selected again. For example, if you display the contours, 
then change to a different preference and display again, the old contours are 
deleted and the new contours are displayed.   

If Pen mode is selected there are two options. If Delete Ink is off, the graphics 
are not updated when the same display command is selected again.  Instead, 
another copy is placed in the design file.  If Delete Ink is on, the graphics are 
treated like Pencil mode and the old one removed before the new ones are 
placed. 

                               

Locate Features/Locate Graphics – There are several commands in InRoads 
that will work on either Features out of the DTM or on MicroStation graphical 
elements (Drape Surface, for example). These commands will “look” for 
features if this lock is toggled to Locate Features and for MicroStation 
elements if it is set to Locate Graphics. It is shown here in Locate Graphics 
mode. 

                               

Point Snap has three modes: Off   Point Snap  and Element Snap  

Off – No affect 

Point Snap – Some geometry commands (especially cogo commands) will lock 
onto the nearest geometry point’s coordinates when you select something 
graphically. This is useful when you need to identify a PC or PT, for example. 
Also, some DTM editing commands, such as Partial Delete Feature will lock 
onto the vertices or points that make up the feature. 

Element Snap – In geometry commands requiring a distance or a bearing, you 
can set the Element Snap and then identify an existing geometry element, such 
as part of an existing alignment and it will read the elements length or bearing 
(whichever is required). 
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Station lock – Locks you onto even stations in the event that the alignment you 
are using does not start on an even station. The station will be determined by the 
interval you are using. For example, if you are stationing an alignment at 100 ft. 
intervals, the displays will show even 100 ft. stations. This affects not only 
station displays but virtually everything that using a stationing interval, such as 
cross sections, profiles and modeling. 

                               

Report lock – Some commands will return information to you if this lock is on. 
For example, if you store a cogo point and the Report lock is on, a Results box 
will pop open showing the coordinate and point number of the new point.  The 
box can be moved out of the way, then it will keep a running list of messages, 
which can be saved to a text file if desired. 
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CDOT Design Process/InRoads Workflow 
The following diagram shows the CDOT Design Process and the chapter each item 
relates to in this book. 
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Lab 1 – Getting Started 
The CDOT training data set is used by several different classes, some of 
which require a model file that has already been setup. For this class, we 
need to start with a new model file, so you will first delete the current 
one, then create the new one. 

Start MicroStation 

1. Double-click the InRoads icon on your desktop (or use the Start menu). 

 

2. On the MicroStation Manager dialog, select the Project 12345, then 
highlight the file 12345DES_Model.dgn in the  
\Design\Drawings\Reference_Files folder. 
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3. Choose File > Delete. 

 

4. On the Alert box, choose OK. 

5. Choose File > New. 

6. Set the folder is \Design\Working 

7. Key in the name CU12345DES_Model.dgn  
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8. Choose OK to create the new file, then OK on the MicroStation Manager. 

This file is typically prefixed with your initials while you are working on 
it. When it is ready for other disciplines to reference, you will take your 
initial off and move it to the Reference_Files folder. 

9. Choose OK. 

The design file is saved into the Working folder, using the 
CU12345DES_Model.dgn name. You are automatically switched into 
this design file, and InRoads starts. 
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Review the different parts of the InRoads menu. 
 

 

 

 

 

             

 

 

 

 

 

 

 

 

             

Menu Bar 
This is the Primary menu system for 
InRoads commands. Toolbar menus are 
also available under Tools>Customize. 

Information window 
When an item is selected in the 
Workspace toolbar, this area 
displays information about the 
selection 

Workspace toolbar (InRoads Explorer) 
This toolbar has a tab for each of the 
data types that may be loaded into 
InRoads, where you can see what files 
are loaded and what they contain.  
There are several “right-click” options 
that can be used to load, save, delete, 
etc. 

Messages appear in the space at the bottom 
of the menu, as well as in the MicroStation 
prompt and message fields. 

Minimize
Maximize
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Project Defaults 
Project defaults define which preference and style files to open with each 
design session.  They also set the default folders for opening and saving 
your InRoads data files. If the machine you’re on has been used for a 
previous training class, you will not need to complete the first few 
steps. Skip to 5; if the configuration is in your list, start there. 

Create a new Project Default 

1. Choose File > Project Defaults. 

 

2. Choose Import. 
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3. Set the Look In folder to C:\Projects\12345\Project_Configuration. 

 

4. Highlight CDOT_Disciplines_V3_02.reg and choose Open. 

The .reg file contains project defaults that have already been configured 
for CDOT disciplines. In addition, they use variables in place of hard-
coding the folder structure so different projects can use the same 
configuration. 
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5. Click the drop-down next to the Configuration Name and choose  
CDOT Design Discipline. 

 

 

6. Apply, then Close the Options dialog – do NOT use the X in the upper 
right corner or the Project Defaults will not be activated. 

This will be the active configuration each time you enter InRoads unless 
you change it. 
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Check your .ini files. 

7. In the Explorer window, choose the Preferences tab in the left side of 
the window and make certain the correct .ini files are loaded.  If not, 
review your Project Defaults or ask for assistance. 
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Review design parameters for InRoads 
1. From the InRoads menu, select Tools > Options. 

2. Select the Units and Format tab. 

 

3. Review the parameters. 

4. Select the other tabs and review the CDOT default project parameters. 

5. Close the Preferences dialog. 

If changes are made to the preferences, then you must Apply to make the 
active in this design session.  They will be automatically reset when you 
next start InRoads. 

 

Open the locks toolbar. 
6. From the InRoads pull-down menu, select Tools > Locks > Toolbar. 

The Locks toolbar may already be open when you start InRoads. It can 
be docked on the Explorer window or floated on-screen.  

 

7. Review each lock by placing your cursor over the icon. 

8. Leave the Locks toolbar open for future use. 
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Challenge lab: Preview the InRoads Workflow 
You’ll be going through each of the following topics in detail during this 
course. If you finished the previous lab early, you may want to try your 
hand at a quick run-through similar to the demo your instructor just 
presented. 

 

Load InRoads data into memory 
1. From the InRoads toolbar, select File > Open. 

2. Set Files of type to Projects (*.rwk). 

3. Open 12345Preview.rwk from the \Miscellaneous folder and  

This loads the different types of previously created data files. These 
include the geometry project, the existing dtm, the template library and 
the roadway library.  

 

Review the existing surface data 
1. Right-click on 12345 existing ground under Surfaces in the left-hand 

portion of the InRoads menu (called the Explorer portion of the menu).  
You may have to expand the menu by dragging one of the edges. 

2. Choose Set Active. 

3. Right click again on exist and choose Properties. 

4. Review the surface information, then Close the Surface Properties 
dialog. 

5. Highlight 12345 existing ground and review the DTM data that make 
up the surface in the right-hand section of the Explorer window. 
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Review geometry data 
1. Click on the Geometry tab, then double-click on 12345Preview and 

review the geometry information in the right-hand side. 

2. Right-click on alignment SH86 in the geometry project 12345Preview. 

3. Select Review and scroll through the alignment data. 

4. Close the Review box when finished. 

5. Double-click on SH86 to see its vertical alignment, SH86 V. 

6. Review SH86 V. 

  

Review typical sections for this project 
1. Click on the Typical Sections tab. 

2. Double-click on Templates. 

3. Double-click on SH 86 1L-1L Rural. 

4. Double-click on D_SH 86 Finished-Grade. 

5. Click on Right Backbone. 

Review the right backbone segments for the finished grade surface in the 
right-hand side of the Explorer window. 

6. Review other template zones as desired. 

Note: You can also edit the typical section directly from the Explorer 
with a right mouse click. 

 

7. Use the same method in the previous step to review the decision table 
Plains_Z=12'@6:1 entries. 

Note: You can also edit the decision table directly from the Explorer 
with a right mouse click. 

8. Use the same method as above to review the station and template setups 
for the roadway definition SH 86 with dec table. 

Note: You can also edit the roadway definition directly from the 
Explorer with a right mouse click. 
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View contours 
1. Turn Write lock on. 

2. Set the mode to Pencil. 

3. Turn Style lock on. 

4. Select Surface > View Surface > Contours. 

The View Contours dialog box does not display since Style lock is on. 
The active preference is used to display the contours. 

 

View the proposed bypass alignment, SH 86. 
1. Select Geometry > View Geometry > Active Horizontal. 

Alternately, you can right-click on SH 86 from the Explorer window and 
select View. 

 

Station the SH 86 alignment 
1. Select Geometry > View Geometry > Stationing. 

2. Apply to use the default preference to station the alignment. 

3. Window in and take a look at the stationing. 

Remain in the View Stationing command. 

4. Under the Regular Stations tab, change the stationing preference to 
Parallel orientation with Center Center justification. 

5. Apply the command again – do not delete the original stationing. 

With Write lock on in Pencil mode, the old stationing is automatically 
deleted and the new stationing displays. 

6. Close the View Stationing dialog.  Since you did not save the 
preference, your changes will not be saved. 

 

Create a Profile of the existing ground  
1. Select Evaluation > Profile > Create Profile. 

Notice in the Symbology category, the 12345 existing ground surface 
is set to use a named symbology of Existing Ground. 

2. Keep the Profile command open. 

3. Choose Surface > Surface Properties. 
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4. Set the Surface to 12345 existing ground. 

5. Choose the Advanced tab  

Note the Profile Symbology and Cross Section Symbology are set to 
T_ Existing Ground.  This is where the symbology a surface will use on 
profiles and cross sections is assigned. 

6. Close the Surface Properties dialog. 

7. Choose Apply. 

8. You will be prompted to Identify Location.  <D> for the lower left corner 
of the profile in a clear area of your design file. 

9. Zoom in and review the profile information. 

View and annotate the proposed vertical alignment 
1. Select Geometry > View Geometry > Vertical Annotation. 

2. Select Apply and the vertical alignment is annotated in the profile 
window you just created.  

 

Review the typical sections for this project. 
1. Select Modeler > Define Typical Sections. 

2. Select the Template tab. 

3. Double-click on the SH 86 1L-1L Rural template. 

4. Use the Layer and Segment tabs to review the template. 

5. Use the Next button on the Segment tab to Review the template 
segments. 

6. Close the Edit Template dialog and repeat for template  
SH 86 2L-2L Rural. 

7. While still in the Define Typical Section dialog, review the decision 
table used to develop sideslopes for this project. 

8. Select the Decision Tables tab. 

9. Double-click on Variable Cut and Fill. 

10. Review the decision table entries. 

11. Close all dialogs when done 
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Review the roadway definitions  
1. Select Modeler > Define Roadway. 

2. Double-click on the roadway definition SH 86 with dec table. 

3. Review the transition entries, and notice the transition between 2 lane 
and 4 lane typicals.  Double-click on the first station.  Each entry has a 
dialog behind it that controls the transitioning and other criteria for 
modeling the roadway. 

4. Close all dialogs when done 

 

Model the road with the given data 
1. Select Modeler > Roadway Modeler. 

2. Review the default preference setup on the Advanced and Main tabs. 

3. Apply the command to model the road. 

4. Review the results of your Roadway Modeler run.  

 

Cut a set of cross sections 
Cut cross sections along SH 86 showing surfaces 12345 existing ground 
(existing ground), D_SH 86 Finished-Grade (finished grade of the 
proposed road) and the three additional layers, D_SH 86 Base-Course-
Top, D_SH 86 Subbase-Top and D_SH 86 Subgrade-Top 

1. Select Tools > Options > Factors and set the Text Scale Factor to 40. 
Apply, then Close the dialog box. 

2. Select Evaluation > Cross Sections > Create Cross Sections. 

3. Select Apply on the Cross Section dialog 

4. Place a <D> in a clear area of your file to define the location of the lower 
left corner of a cross section set. 

5. Select Close. 

6. Window in to see the information contained on the sections. 

7. Select Evaluation > Cross Sections > Cross Section Viewer. 

8. Set the Zoom Factor to 1 and the Time to 0.5, then choose Run. 

9. If you have more than one view open, you must <D> in the view to start 
the run. 
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Compute end area volumes 
1. Select Evaluation > Volumes > End Area Volumes. 

2. Set the Existing surface to 12345 existing ground and the Design 
surface to D_SH 86 Finished-Grade. 

3. Apply and view the results, then Close all dialog boxes. 

 

 

Visualize the new roadway 
1. Choose Tools > Application Add-Ins. 

2. Toggle on Drive Roadway and choose OK. 

3. Select Modeler > Drive Roadway. 

4. Highlight the Horizontal Alignment SH 86. 

5. Highlight the Vertical Alignment SH 86 V. 

6. Choose Run. 

If you have multiple windows open, you must <D> where you want to 
see the drive-through; if you only have one window open, it 
automatically uses it. 

7. Close the Drive Roadway dialog. 

During the rest of the course, you will be re-creating this roadway, 
learning the components and how they relate together to model the 
roadway. 

8. Select File > Exit on the MicroStation menu.  When prompted to save 
your changes, choose No to All. 
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2. Digital Terrain Models (DTMs)  
A digital terrain model (DTM) is a mathematical representation of topography that 
includes points and triangles and is often referred to as a surface. The triangles 
allow the DTM to provide elevation information at any location by interpolating the 
elevations of the three points making up the triangle in question. 

Using Delauney’s criteria, InRoads calculates the smallest triangles possible for a 
given set of point data. Delauney’s criteria states that any triangle formed may be 
circumscribed and no other point will fall within the circle. Linear features must 
sometimes violate Delauney’s criteria in order to hold a constant slope between 
points. In other words, linear features will not allow triangles to cross them. 

You may load as many DTMs as you need into memory when using InRoads. It is 
typical to have several DTMs loaded, since you will have an original and several 
design surfaces (such as a finished grade and one or more subgrades). At any given 
time, only one surface is active, meaning it will be the default when using any 
command requiring a surface. 

When a digital terrain model is saved to the hard drive, it takes on an extension  
of .dtm. 
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DTM Point Types 

Random 
 Normal topo shots 
 Often used for spot shots, local highs and lows 

Breakline 
 Used to represent linear features such as ditches, ridges, and edges of 

pavement, and named accordingly 
 No triangles cross breaklines — they take precedence over random 

points 
 Must have at least two points to form a breakline (lines, linestrings, 

curvestrings and complex chains are acceptable for import) 
 Can be densified or thinned 

Contour Points  
 Use when data comes from contours, e.g., digitized from aerial maps 
 Work much like breaklines with a constant elevation 
 Converts lines, linestrings, curvestrings and complex chains into DTM 

points 
 Can be densified or thinned 

Inferred breaklines 
 Only used with contour points 
 Generated by the software 
 Eliminate flat spots by forcing a slope on every triangle 
 Add overhead to your surface 

Interior  
 Used to model holes in your surface where there is unknown survey data 

or areas you do not want considered in the DTM 
 Requires at least three points to model a closed shape 
 No triangles are formed inside an interior boundary 
 You can have more than one interior boundary per surface, but they can 

not overlap 

Exterior  
 Define limits of triangulation 
 Requires at least three points to model a closed shape 
 There is only one exterior boundary per surface 
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Surface Triangulation 
In order for a surface to be used for contouring, modeling, etc., it must have been 
triangulated.  The original ground surface received from Survey will already be 
triangulated, however, if any changes or edits are made to a surface it will have to 
be triangulated again before the changes will show up in displays of the surface 
either in Plan, Profile or Cross Section. 

Surface > Triangulate Surface 

 

A surface may also be triangulated by right-clicking it in the InRoads Explorer 
menu and selecting Triangulate from the list of available commands. 
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Intelligent DTMs 
InRoads’ digital terrain models are intelligent models. By using Feature Names, 
Feature Styles and Named Symbologies as described below, the models will know 
what types of features can be displayed in which views as well as the symbology 
they will use to display. 

 

 

 

 

 

 

 

 

 

 

Feature Name 
Unique identifier for each 

feature in a DTM. 
Surface > Ftr > Ftr Prop. 

Feature Style 
Tells the feature what it 
can display and where. 

Tools > Feature Style Mgr 

Named Symbology 
Gives the feature its level 

and other graphical 
attributes. 

Tools > Symbology Mgr 
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Feature Names 
Everything in a DTM is a feature and every feature must have a unique name. 
Often, when creating new features, you will be asked to supply a Seed Name. 
This seed name is used as the base for a unique feature name. For example, if 
you use creek as the Seed Name, and you load more than one (with a level or 
selection set, for example) the second will be named creek1, third creek2, etc. 

A feature can be either triangulating, such as breaklines representing ditches, 
centerlines, etc. or it can be non-triangulating, such as utilities that are below or 
above the ground surface. These types of non-triangulating features can be 
shown on cross section, profiles and in plan view without affecting the 
triangulated network. 

Feature names are stored within the DTM. 

Feature Styles 
Feature Styles are assigned to features in the DTM. They control where and 
what the features is “allowed” to display, as well as assigning a named 
symbology. For example, when you assign a feature style to a feature, you are 
determining if it can be displayed in plan using lines, points and/or annotation; if 
it can be displayed in sections using points and/or annotation, etc. 

Feature Styles are stored in CDOT-Preferences.ini. 

Named Symbology 
Named Symbologies are just what they sound like — setups, such as color, 
weight, line style, font that can be saved by name. They even go one step farther 
allowing these setups to share a name while establishing different symbologies 
for plan, cross sections and profiles. This way, one entity that uses a named 
symbology can still display using different setups in plan vs. cross section vs. 
profile. Just about anywhere you assign symbology, you can use a named 
symbology instead. 

Named Symbologies are stored in CDOT-Preferences.ini. 
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Feature Selection Filters 
Feature Selection Filters allow a method of segregating features for use in other 
commands. For example, if you are working with the breaklines that form a ditch, 
you can use a selection filter containing just those breaklines, then turn on the 
Feature Filter Lock. Future commands that use features will show only those 
specified by the filter as being available. 

Feature Filters are stored in CDOT-Preferences.ini, and therefore cannot be created 
by users.  The CDOT configuration contains predefined filters. 
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Creating a DTM 
The existing ground DTM will be provided by Survey and proposed DTMs will be 
created by InRoads tools such as Roadway Modeler. However, there may be times 
when you may have to create or supplement one of these DTMs. If so, the data used 
to create the DTM may be in one of several formats. The most common formats are 
described below. 

ASCII (text) Files 
ASCII data can be loaded from several different formats. Using the File > 
Import > Surface > ASCII command, you can specify the format for your data. 
Some commonly used formats include: 

 x,y,z* 
 northing,easting,elevation* 
 station,offset,elevation (baseline alignment required)* 

 *Can have additional columns for “pen-up, pen-down” to define separate 
linear elements in one file, for feature names, features styles, etc. 
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Surface from graphics 
Graphical data is sometimes used to generate existing or proposed surfaces 
using File > Import > Surface > From Graphics. When using graphics, some 
key points are listed below. 

 Elevations may be taken from the element or from surface (if 
the surface has been triangulated already). 

 Elevations may be taken from text if you’re loading random 
points that are graphically displayed in the correct location, 
with text listing the elevations. 

 Linear features that contain curves can be densified using the 
chord height tolerance (set under 
Tools>Options>Tolerances). 

 Linear elements can be densified by setting a maximum 
segment length or a point density interval. 

 Points on linear elements can be thinned upon input using 
the Thin (and Tolerance) option. 
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Reviewing a Surface 
After a surface is created, you may review the data it contains using Surface 
Properties or Feature Properties. 

Surface > Surface Properties 

 

 

The Surface Properties dialog allows you to change the name, description or 
preference associated with the surface. By accessing the Advanced tab, you can 
also set the named symbology to be used when displaying the surface ground line in 
profiles and cross sections. The Advanced tab also allows the establishment of 
Offsets that can later be displayed when creating or updating a profile. 
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Surface > Feature > Feature Properties 

                       

 

 

 

The Feature Properties dialog allows you to change the name, description and 
style of an individual feature. You can also get a listing of all the points that make 
up the feature by highlighting the feature in the list (or using the target button to 
graphically identify it) and then choosing List Points. 
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Tracking the Surface 
The Tools > Tracking > Tracking command allows you to move your cursor and 
get a readout of the coordinate location and the interpolated elevation, as long as 
you are in a triangulated area. By toggling on the information you want, then 
choosing Apply, you can also Data point at any location and have the information 
written into the design file. 

 

Note that the station and offset are also available for tracking when a geometry 
project is loaded and has an active alignment. 
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Combining DTMs 

Merge Surfaces 
The Merge Surfaces command (Surface > Edit Surface > Merge Surfaces) is 
typically used to combine a design surface, such as a roadway with an existing 
ground surface. By turning off the option to Retain All Original Surface Points, 
everything from the original surface that falls inside the design surface’s 
perimeter is removed, the design surface added and the new surface triangulated. 

Other options include retaining any non-triangulating features and creating a 
breakline from the design surface’s edge (exterior). 

This command will not allow the destination surface to go outside of the exterior 
boundary contained in the original surface, so the original surface’s exterior 
would need to be removed if this command is used to combine adjacent 
surfaces. 

Note: It is a good idea to use a new surface name for the Destination 
surface. This ensures your original and design surfaces will 
remain intact. (Just type in a new name and is will be created 
upon execution of the command.) 
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Copy Portion of Surface 
The Copy Portion of Surface command (Surface > Edit Surface > Copy 
Portion of Surface) allows you to copy features from one surface into another 
surface. This can be used to combine two adjacent surfaces when the desire is to 
keep the features from both. Care must be taken not to use either exterior 
boundary in this case.  The recommended method is to copy one of the surfaces 
and remove the exterior using Surface > Edit Surface > Delete Features. Use 
this as the Destination surface, then do not select the exterior boundary feature 
when selecting the features from the Source surface to copy into the 
Destination. 
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Locks affecting Surface Displays 
Two locks affect surface displays. 

 

 

Style lock – If Style lock is on, the dialog box for the view command will not be 
displayed. Instead, the display will be executed using the active surface and the 
preference assigned to the surface in the Surface > Surface Properties dialog. 

 

 

Write lock – If Write lock is off, the displays will be temporary. Zooming in or out, 
updating the view, etc. will cause the graphics to disappear. 

If Write lock is on, there are two modes – Pen and Pencil.  

If the Pencil mode is selected (as shown here), the graphics are updated whenever 
the same display command is selected again. For example, if you display the 
contours, then change to a different preference and display again, the old contours 
are deleted and the new contours are displayed.   

If Pen mode is selected there are two options. If Delete Ink is off, the graphics are 
not updated when the same display command is selected again.  Instead, another 
copy is placed in the design file.  If Delete Ink is on, the graphics are treated like 
Pencil mode and the old one removed before the new ones are placed. 
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Viewing the DTM Perimeter 
The perimeter of a DTM is an outline of the current triangles, and therefore can 
only be displayed after a surface is triangulated. It should not be confused with an 
exterior boundary, which actually limits the triangulation. If there is an exterior 
boundary on the surface, the perimeter will be in the same location. 

Surface > View Surface > Perimeter 
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Viewing Contours 
The contours for a model may be displayed using the Surface > View Surface > 
Contours command. There are several preferences available in this command, 
depending upon the type of surface and contours you want to display. Select 
Preferences and choose the appropriate one for your application before choosing 
Apply. 

 

 

 

The CDOT preferences, as shown above, relate to the type of surface, existing or 
proposed, and to the interval for major and minor contours. The preferences also set 
the level for displaying the contours, which in turn sets the ByLevel symbology. 



 Chapter 2  Digital Terrain Models 

Roadway Design Using InRoads  Page 47 

Saving a Surface 
Surfaces can be saved using several methods including: 

 Choose File > Save > Surface 

The active surface is saved. 

 

 Right-click on the Surface in the Explorer menu and chose 
Save  

 

The surface you highlighted is saved. 

 

If the surface has never been saved, either of the above methods will bring up the 
Save > As box as shown below. 

 

 Choose File > Save As 
 Set the Files of Type to *.dtm 
 Choose the surface you want to save 
 Key in the file name (or use the default) 
 Choose Apply. 
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Note: Surfaces have both an internal name that appears in the dialog 
boxes in InRoads and a name on the hard drive that has a .dtm 
extension. It is recommended that these names be the same, and 
care should be taken to make certain you have chosen the correct 
surface name to match the file name you specify. Otherwise, you 
could accidentally save over a file on the hard drive with the 
wrong surface. 

The surface may also be saved as part of the project or .rwk file, which you will be 
using in your lab activities. 
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Lab 2 – Digital Terrain Models 
 

Start InRoads 
1. Double-click the InRoads icon from your desktop. 

 

2. Select the design file CU12345DES_Model.dgn from the 
\Design\Working folder. 

InRoads automatically starts with MicroStation, using the design file 
specified. 

Load the digital terrain model (DTM) provided by Survey 
1. Select File > Open From the InRoads menu. 

  

2. Set the Files of type to Surfaces (*.dtm). 

3. Navigate to the \ROW_Survey\InRoads\DTM folder. 
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4. Double-click 12345 existing ground.dtm or highlight it and select 
Open. 

 

5. Cancel the Open dialog box. 
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Review the DTM 
1. Select Surface > Surface Properties. 

This opens a review dialog where you can change the surface name, 
description, maximum triangle length and the preference associated with 
the surface.  You can also review the coordinate and elevation ranges for 
the different point types. 

 

2. In the Data Range category, review the coordinate range. 

3. Change the Point Type to Breakline and review the range again. 

You can review any of the point type’s ranges to look for discrepancies. 

4. Close the dialog when you are through reviewing the data. 

Display a perimeter 
1. Select Surface > Fit Surface. 

This sets the MicroStation view to show the entire surface, even though 
nothing from the surface has been displayed.  If you have more than one 
view open, you must <D> in the view you want to use after selecting the 
command. 

2. Turn on Write lock and set the mode to Pencil. 

3. Ensure Style lock is off, or the perimeter will be displayed without the 
dialog box appearing. 
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4. Select Surface > View Surface > Perimeter. 

 

5. Select Preferences, then highlight Existing and choose Load. 

 

6. Close the Preferences dialog, then Apply and Close the View 
Perimeter dialog. 

Use the MicroStation Fit command to fit the view if you do not see the 
perimeter. 

Your display should now show the perimeter of the existing surface. 
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Display Contours 
1. Select Surface > View Surface > Contours. 

 

Note that the existing ground surface is already listed in the dialog.  This 
is because the existing ground surface is your Active surface. 

2. Select Apply and the contours are displayed in your design file. If you do 
not see them, Fit the view. 
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3.  Select Preferences from the View Contours dialog. 

 

The CDOT standard preferences for contours are listed in the dialog.  As 
you can see, they correspond to different contours setups for both 
existing and proposed surface models. 

4. Highlight the Existing 100’ Mjr – 20’ Minor preference and choose Load. 

5. Close the Preferences dialog. 

 

Notice in the Symbology category, this preference is set up to display 
Majors, Minors and Labels. 

6. Select the Advanced tab and review the settings.  These are all 
controlled by the preference as well. 

7. Apply to generate the contours with the new preference. 

Note: Since you were in Pencil mode the first time you generated 
contours, this time the original display was deleted and replaced 
with the new display. 
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8. Select Preferences from the View Contours dialog and load the 
Existing 10’ Mjr – 2’ Minor preference. 

9. Apply to generate the contours with the new preference. 

10. Close the Contour dialog. 

Use Rotate View to look at the contours from different angles. 

11. Select the MicroStation Rotate View command and set the Method to 
Front. 

       

Note: If you have more than one view open, you will need to <D> in 
the view to execute the rotation. 

12. Fit the view and look for any spikes in the contours. 

 

13. Select Rotate View again and set the Method to Isometric. 
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14. Fit the view. 

 

15. Select Rotate View, set the Method to Dynamic and toggle on 
Dynamic Display. 

 

16. Snap ( <T>, then <D> or AccuSnap ) to one of the contours near the 
center of the surface, then move your cursor to review the surface from 
different angles. 
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17. If you are out of the Rotate View command, select it again. 

18. Set the Method to Top. 

19. Fit the view. 

20. Use MicroStation to delete the contour display.  The contours are a 
graphic group, so one delete will delete them all if Graphic Group lock 
is on. 

21. Use MicroStation to delete the perimeter display. 
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Display triangles 
1. Select Surface > View Surface > Triangles. 

 

2. Select Preferences. 

 

The CDOT standard preferences for triangles are listed in the dialog. 

3. Highlight Existing and choose Load. 

4. Close the Preferences dialog. 

5. Apply to view the triangles. 
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6. Use Rotate View to look at the triangles from different angles. 

7. Select MicroStation Utilities > Render > Phong to see a shaded view of 
the DTM. 
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8. Return to a top view when finished. 

9. Delete the triangle display. 

10. View the perimeter of the model. 
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Track the surface and display elevations 
1. Select Tools > Tracking > Tracking. 

 

2. Toggle off all options except Elevation, then choose Activate. 

3. Move your cursor around the view and note that the coordinates, 
elevations, etc. are ‘tracked’ in the dialog. 

 

4. Move your cursor outside the perimeter and notice that only the Northing 
and Easting coordinates are tracked when you’re outside the surface. 

5. <D> inside the perimeter to display the elevation at the cursor location. 

 

6. Try several locations, then Close the dialog. 

7. Use MicroStation to zoom in and review, then Delete the elevation 
displays. 
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Display the surface features 
1. Select Surface > View Surface > Features. 

  

2. Select None, then highlight the Edge of Water … features. 

 

3. Apply and Close the View Features dialog. 
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4. Zoom in to see some of the features. 

The features do not display as a graphic group, but as individual entities.  
As such, they must be deleted individually.  While a fence or a selection 
set could be used to make the task easier, you are going to use a new 
command, Update 3D/Plan Surface Display.  This command allows 
you to view or delete many of the surface displays from one dialog. 

5. Select Surface > Update 3D/Plan Surface Display. 

 

6. Set the Mode to Display Off. 

7. Select the 12345 existing ground surface. 

8. Toggle on Features. 

9. Next to the feature window, select All to highlight all the features. 

You do not have to find the Water features and highlight them 
individually, unless there are more features displayed and you only want 
to turn off the Water ones. 

10. Select Apply. 

11. Experiment with some of the other displays, turning them on and off as 
desired. 

12. When you are comfortable with this dialog, toggle all of the displays off 
and then Close the dialog. 
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Review features 
1. Select Surface > Feature > Feature Properties. 

            

2. This dialog allows you to change any of the properties of the feature.  
Note that one of these properties is the Exclude from Triangulation 
option. 

3. Highlight one of the Edge of Dirt Road features. 

 

4. Select List Points. 
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The Results dialog appears, listing the coordinates of each vertex of the 
feature, as well as the distance along the feature where the vertex occurs.  
This report can be printed, displayed in the design file, saved as a text 
file or appended to an existing text file. 

5. Close the Results box and the Feature Properties box. 

Attach the Survey file as a reference 
Survey provides several design files, using different scales, that can be 
referenced to your design.  This is why you turned off the previous 
feature displays, as these displays are contained in the design files from 
survey and were displayed previously for practice, since the same 
techniques are used for proposed models. 

1. Select File > Reference from the MicroStation menu. 
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2. Select Tools > Attach. 

3. Highlight 12345SURV_Topo.dgn from the 
ROW_Survey\Drawings\Reference_Files folder. 

 

4. Set the parameters as shown on the dialog and choose OK. 

By setting Coincident World on the dialog, you do not have to specify 
the name, description, model or view you want to reference.  These are 
set automatically and the Default model is referenced to the active design 
file model. 

5. Fit the view. 

6. Turn off the contour levels to better see the features. 
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1.  

 

 

 

 

7. Select File > Save Settings from the MicroStation menu. 

8. Select File > Compress > Design from the MicroStation menu. 
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Create a project file (rwk) 
When using InRoads, there are several data files that must be loaded into 
memory each time you start to work.  These files can be loaded in one 
step by creating a project file.  A project file is just a text file that lists the 
different data files you need to load.  It can be created with a text editor, 
or with the InRoads menu as you will do here. 

1. Select File > Save As from the InRoads menu and ensure the Files of 
Type is set to Projects (*.rwk) and the folder is 
C:\Projects\12345\Design\InRoads. 

 

2. Choose Options. 

 

3. On the Surfaces tab, toggle on Add for 12345 existing ground. 

Add will load the surface each time the project is loaded.  Update would 
save the surface, but since this surface is set you do not need to save it 
each time. 
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4. On the Preferences tab, toggle off CDOT-Preferences.ini. 

 

5. On the Styles tab, toggle off CDOT-Styles.ini. 

These files are automatically loaded with the project defaults, so you do 
not need to load them with the project.  If you do not use project defaults, 
then you can toggle these on. 

6. Choose OK. 

7. Back on the Save As dialog, key in the name 12345DES.rwk and choose 
Save. 

 



Colorado Department of Transportation 

Page 70  Roadway Design Using InRoads 

8. Right-click on the file when it appears in the dialog and choose Edit or 
Open With or Open and then choose Notepad. 

 

                           
Note:  If you do not have the option for Edit, Open or Open With 

options, Use Notepad to open the file from the 
C:\Projects\12345\Design\InRoads folder. 

9. Notice that the file is a text file that currently lists just the DTM.  If you 
do not see the file as shown here, try this section again or ask for 
assistance. 

10. Close the Notepad report and Cancel the Save As dialog box. 

Exit 
1. Exit MicroStation; do not save any changes to the surface.   

By now, you are aware that with each lab you will start MicroStation and 
InRoads again.  The temptation is to leave them open to save the step 
next time.  However, when you exit MicroStation and InRoads it clears 
the memory on your machine and your files will process faster, so you 
are encouraged to exit at the end of each lab. 
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3. Defining Horizontal Alignments 

The Geometry Project 
The geometry project is the data file that stores horizontal and vertical alignments, 
superelevation alignments (stations where the super transitions occur and the 
corresponding slopes) and cogo points (called the cogo buffer). 

There is a hierarchical relationship between the data stored in the geometry project, 
as illustrated below. 

 

 

 

 

 

 

 

 

 

 

 

You may load as many geometry projects into memory as you need at a given time. 
However, only one project is active at a time, with one Horizontal Alignment, one 
Vertical and one Superelevation active. The active Superelevation and Vertical 
must fall under the active Horizontal, and the active horizontal must fall under the 
active project. 

When the geometry project is saved to the hard drive, it takes on an extension  
of .alg. 
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Importing alignments 
If alignments are already defined graphically or in an electronic text file, they may 
be imported into InRoads without having to re-enter the data. 

From graphics 
Alignments that has already been drawn graphically may be imported using  
File > Import > Geometry > From Graphics. 

 

You can import Horizontal Alignments, Horizontal and Vertical Alignments, 
Cogo Points or Event Points. If the alignment has curves, it is typically best to 
toggle on Resolve Gaps and Nontangencies. If the alignment was drawn as a 
series of lines and/or arcs that have not been complexed, toggle on All Selected 
Elements Added to Single Alignment (you must first define a Fence or 
Selection Set of the elements, and the elements will import in the order of 
creation, even though they’re added to the same alignment). 

After specifying the Name (which defaults if you don’t supply one), the 
Description and the Style, choose Apply. If you have first created a Selection 
Set or defined a fence, you will be asked to Accept the contents. If you have not, 
you’ll be asked to identify the element. In either case, after accepting, an 
alignment or alignments will be added to the geometry project listed in the 
Target section. 
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From text files 
Text files may be imported from several formats, the easiest of which to create 
is an .ics file. (Interactive Coordinate geometry Subsystem) This file type was 
first used with a product of the same name many years ago, but is still in use 
with InRoads today. It is basically a list of cogo commands along with the input 
for those commands. 

If you have a text file of coordinates, you can create an .ics file by adding a 
Store command at the top and formatting the file similar to the one shown 
below. 

 

Choose File > Import > Geometry > ICS. Browse to find the file, then choose 
Apply.  

 

The cogo points will be added to the active geometry project. You may then use 
Geometry > Utilities > Create/Edit Alignment to join the points, forming an 
Alignment and Geometry > Horizontal Curve Sets > Define Curves to add curves 
to the alignment.  You can also accomplish these same tasks within the .ics file.  
See the Bentley Help topic Alpha Cogo. 
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Displaying Alignments 
There are several methods for displaying alignments in InRoads. The method you 
choose is based on the desired display. 

Whichever method you choose, a geometry style controls the level and therefore the 
symbology of the display. Geometry styles are associated with individual 
alignments when they are created. The CDOT standard styles have been pre-defined 
and are stored in the CDOT-styles.ini file, accessed through the Geometry > View 
Geometry > Geometry Style Manager dialog. Each style is really made up of 
one style in each of up to four categories: Points, Lines, Arcs, and Spirals. 

 

To display the active alignment, choose Geometry > View Geometry > Active 
Horizontal and the active alignment displays in the design file showing points and 
linework (no annotation is displayed). 
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To display any alignment, right-click on the alignment name in the Explorer menu 
and choose View. The chosen alignment displays in the design file showing points 
and linework (no annotation is displayed). 

 

To display the alignment and annotate it at the same time, choose Geometry > 
View Geometry > Horizontal Annotation. The alignment you want to annotate 
can be selected graphically by picking the target button first, it can be keyed in, or it 
can be selected from a list by clicking in the Annotate field and choosing Filter. 
Multiple alignments may be annotated at one time with this command, each will 
display using its associated style. 

The resulting display is a MicroStation graphic group. Therefore if you want to 
move the annotation (individual curve data, for example) you must first turn off the 
Graphic Group lock. 
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Copy Geometry 
Copy Geometry can be used to copy geometry from within the same geometry 
project, or from project to project. 
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Creating Alignments 
In order to create a new alignment, you must first have a geometry project loaded. 
If you need to create a new one, choose File > New > Geometry set the Type to 
Geometry Project and enter a Name and Description. 

 

Once the geometry project is loaded (and active), you may create a new alignment 
name. Select File > New > Geometry (if you have closed the dialog) and set the 
Type to Horizontal Alignment. Enter the Name, Description and select a Style. 

Apply after filling in the appropriate information, then you may proceed with either 
the Horizontal Curve Set or Horizontal Element tools to enter the alignment data. 
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Horizontal Curve Set commands 
The Horizontal Curve Set commands make up an easy way to create alignments. 
They consist of five primary commands described below, and may be access from a 
toolbar (shown) or from the pulldown under Geometry > Horizontal Curve Set. 

                 

 

 

 

 

 

Add PI – Add PI is used to create a PI that begins a new alignment, or to add a PI 
onto either end of an existing alignment. 

Insert PI – Insert PI is used to add a PI to an existing alignment between two 
existing PIs. 

Move PI – Move PI is used to change the location of an existing PI. 

Delete PI – Delete PI is used to remove a PI from an existing alignment. For 
removing more than one PI, you must choose and Accept each one individually. 
To remove all PIs associated with an alignment, but leave the alignment name, 
right-click on the alignment name in the Explorer menu and choose Empty. 

Define Curve 

Delete PI 

Move PI 

Insert PI 

Add PI 
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Define Curve – Define Curve is used to create a curve at a PI on an alignment, or 
to revise an existing curve on an alignment. The Previous and Next buttons are 
used to step through the alignment. The tangents forming the PI where the curve is 
to be defined are highlighted graphically.  

 

The Curve Calculator is used to generate curve data for different curves without 
having to accept the curve. This way, you can review the results before the curve is 
created. 
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The Design Calculator is used to compute or look up curve data to ensure your 
design criteria are met. 

 

Keyins 
In addition to the standard MicroStation keyins (like xy= and di=), there are 
keyins available only when InRoads is running.  Two of these are useful when 
creating alignments, but are available for other function as well. 

NE=northing,easting  (NE=935587.5418,1835192.1205) 

SO=station,offset  (SO=34500,-125)  stationing references active 
alignment 
SO=station,offset,elevation,alignment   
(SO=34500,-125,0,CL US 100) stationing references named alignment 
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Horizontal Elements  

 
The Horizontal Element tools allow you to create alignments without knowing the 
PI information.  They may be accessed from the toolbar shown above, or from the 
pulldown under Geometry > Horizontal Elements. 

There are several advantages to this method.  One of the greatest advantages of the 
horizontal element alignments is that they do not have to be continuous.  For 
example, you can create elements that have the most constraints, leaving gaps 
between them, and then join them together with unconstrained tangents and curves. 

Another advantage is the ease with which reverse and compound curves can be 
created, as well as curves greater than 180 degrees. 

When creating elements, you have three basic placement options for linear elements 
and the same three options for circular elements. These options are just for 
placement; once an element is placed and accepted, it is treated the same as any 
other element no matter the placement method. 

Fixed placement is used when you know exactly where the element is going to be 
located and you, in effect, lock it in place using a combination of coordinates, pass-
through points, bearings or radii. When using the fixed placement options, the 
resulting elements are not tangent or coincident with any existing elements. This 
placement option is used to place standalone elements. 

Floating placement is used to establish elements coincident and tangent to an 
existing element with a pass-through point and a radius (for curves) and with a 
pass-through point or a bearing for lines. They force the alignment to be coincident 
and tangent at the end where they join and will lengthen or shorten the element they 
are being attached to as necessary to meet the criteria specified. They will only 
ensure tangency and coincidence at the end where they are attached to an existing 
element. The floating placement options will not connect two existing elements. 

Free placement is used to connect two existing elements. It ensures coincidence 
and tangency at both ends where it connects to the existing elements. The existing 
elements may lengthen or shorten as necessary, but will not change locations. 

To create a horizontal element alignment, first give the alignment a name 
description and style, then use a combination of the fourteen commands to define 
the alignment. (The fifteenth command is for checking and correcting problems 
with the integrity of the alignment, described below.) 
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Check Integrity 
The Check Integrity command on the Horizontal Element toolbar allows you 
to check the coincidence and tangency of horizontal alignments.  The Element 
tools allow you to place the different components of the alignment in whatever 
order you wish, therefore it is not uncommon for the elements to be “out of 
order”.  This is one of the situations where Check Integrity can help, since you 
cannot only check the integrity, but make changes to the elements to correct 
integrity problems. 
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Cogo commands 
InRoads has a series of coordinate geometry commands built into the software. 
There is no need to exit and start another product in order to use them.  These 
commands provide an alternative method for creating horizontal alignments.  One 
of the main differences in creating the cogo alignments (sometimes referred to as 
figures) and other alignments is that cogo alignments require that the points be 
established first, then joined together to form the alignments. 

Once created, cogo points and alignments are, in most cases, interchangeable with 
other horizontal points and alignments. There are a few key differences, however: 

 Cogo points are always numbered as you go (beginning with the seed 
number established in Tools > Options > Geometry or with the next 
available number above the seed. 

 Cogo points can stand alone, such as when locating a fire hydrant or 
signs. 

There are several toolbars devoted to coordinate geometry described here.  These 
same commands may be found under the Geometry heading on the pulldown menu. 

Cogo Point commands 

 

Use the Cogo Points commands to create, edit or delete cogo points.  

Cogo Traverse commands 

 

 

The Traverse commands are used to input cogo points when you know an 
occupied point number or location and a distance and bearing to the point you’re 
locating (Direction Traverse). It may also be used when you know an occupied 
point or location, a backsight point or bearing and a distance and angle or 
deflection angle to the point you’re locating (Angle/Deflection Traverse). 
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Cogo Intersection commands 

 

 

The Intersection commands are used when you want to locate a new cogo point 
based on two known points, two known alignments or a combination of a known 
point and a known alignment along with and distances and or bearings between 
them and the desired point.  For example, you may know two cogo points and 
the bearings from each to the desired new point. 

Create/Edit Alignment by Cogo Points 

                 

Alignments are created from cogo points using the Create/Edit Alignment 
command.  It is not necessary to create the alignment name prior to using this 
command; it may be entered here, along with a Description and Style. The 
points you want to make up the alignment are listed as the Alignment 
Definition. Once you choose Apply, the alignment is created by chaining 
together the listed points. Dashes may be used when a range of consecutively 
numbered cogo points are selected. 

See the Bentley Help or InRoads Reference Guide for additional information on 
InRoads cogo. 
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Horizontal Event Points 
Horizontal Event points are points associated with an alignment that are not 
actually a part of the geometry of the alignment the way a PC, PT or PI are, for 
example.  They are used for points that need to be annotated with stations and 
offsets, for points where you need special sections cut or for points where you want 
to be certain Roadway Modeler drops a template. 

Select Geometry > Horizontal Curve Sets > Events. 

 

Event points may be added as either Station and Offset (so they move with the 
alignment if it moves) or as Northing and Easting (so they remain stationary if the 
alignment moves).  Whichever way they are stored, they can be initially defined by 
either coordinates or stations and offsets. 
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Setting the Beginning Station 
The default station at the beginning of a newly created alignment is 0+00. To 
change it, select Geometry > Horizontal Curve Sets > Stationing.  Set the 
beginning station of the active alignment by keying in the desired new station and 
choosing Apply.  The options for Vertical and Superelevation Alignments 
should be considered carefully.  Do Not Update will leave there stationing as is, 
Synchronize Starting Stations will update their stationing to match that of the 
horizontal and Maintain Station Difference will keep any difference in the current 
starting stations, such as when the vertical alignment does not start at the beginning 
of the horizontal. 

 

Note: InRoads does not require you to key in the ‘+’ when entering a 
station.  It will add the plus sign for you based on your 
preferences. 
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Equations 
If there are inequalities in your alignment, you may assign station equations. These 
equations can be either gap or overlap equations. To assign an equation, select 
Geometry > Horizontal Curve Sets > Stationing.  At the bottom of the dialog, 
choose New.  In the resulting box, enter the Back Station and the Ahead Station, 
with the ahead station prefixed with an equation name.  When choosing a name for 
the equation, remember that from this point in the alignment forward, stationing 
will be referred to by this name preceding the station so the shorter the name, the 
easier it will be for key-ins, etc. 

 

You can have multiple equations in one alignment if necessary. 



Colorado Department of Transportation 

 

Page 88  Roadway Design Using InRoads 

Displaying Stationing 
To display the stationing of an alignment in the design file, select Geometry > 
View Geometry > Stationing.  There are several standard CDOT preferences to 
choose from, depending upon the type of alignment you’re stationing as well as the 
station interval. Choose the appropriate preference, then Apply to see the 
stationing. 

 

The Station lock, if on, will force the display to even stations. 
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Tracking 
There are two methods of tracking a horizontal alignment. 

Tools > Tracking > Tracking – Tracks both the active horizontal alignment and the 
active surface.  After applying the command, data point a location in the design file 
and the requested information is displayed graphically.  The listed elevation is read 
from the surface at the cursor location, not at the alignment. 

 

Tools > Tracking > Horizontal Alignment – Tracks the horizontal alignment with a 
perpendicular line to your cursor. Gives a Station, Offset, Elevation readout in the 
message field, where the elevation is read from the active vertical alignment at the 
given station, not from the DTM. 

If a second horizontal alignment is selected, the offset will be between the two 
alignments, perpendicular to the first. 
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Saving an Alignment 
Alignments are not saved individually. Instead, they are saved when the geometry 
project is saved.  Since you are working on a copy of the geometry project that is 
loaded in memory, saving is a good idea whenever you make changes to your 
alignment, and mandatory before exiting – assuming you want to save your 
changes. 

Geometry projects can be saved using several methods including: 

Choose File > Save > Geometry Project 

The active geometry project is saved. 

 

Right-click on the Geometry Project in the Explorer menu and chose Save  

The geometry project you highlighted is saved. 
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If the geometry project has never been saved, either of the previous methods will 
bring up the Save > As box shown below. 

Choose File>Save As 

 

Set the Files of Type to (*.alg) 

Choose the geometry project you want to save (in the Active category) 

Key in the file name (or use the default) 

Choose Apply and the file is saved. 

 

Note: Geometry projects have both an internal name that appears in the 
dialog boxes in InRoads and a name on the hard drive that has an 
.alg extension. Care should be taken to make certain you have 
chosen the correct geometry project name to match the file name 
you specify. Otherwise, you could accidentally save over a file 
on the hard drive with the wrong geometry project. 

 

The geometry project may also be saved as part of the project file or 
.rwk, which you will be using in your lab activity. 
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Lab 3 – Defining Horizontal Alignments 
 

Starting InRoads 
1. Start InRoads using your desktop icon. 

2. Open CU12345DES_Model.dgn from the \Design\Working folder. 

Open your InRoads data file 
1. Select File > Open. 

 

2. Ensure the Files of Type option is set to Projects (*.rwk). 

3. Double-click on 12345DES.rwk. 

Double-clicking is the equivalent of highlighting the file and choosing 
Open. 

4. Cancel the dialog. 



Colorado Department of Transportation 

 

Page 94  Roadway Design Using InRoads 

Review geometry from Survey 
Survey provides a geometry project in addition to the DTM and design 
files.  You will first open and review the alignment from survey. 

Open geometry project from Survey 

1. Select File > Open. 

 

 Set the File of Type to Geometry Projects (*.alg). 
 Navigate to the folder ROW_Survey\InRoads\Geometry. 

2. Highlight 12345SURV_Geom.alg and select Open, then Cancel the 
dialog. 
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Display and review the existing geometry 

3. Select Geometry > View Geometry > Horizontal Annotation. 

 

 <D> in the Annotate field and select Filter. 

 

 Select All, then OK to add all of the alignments to the 
Selected field. 

Alternately, you could key in an asterisk in the Annotate field to select 
all of the alignments in the geometry project. 
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4. Select Apply to view the alignments (Window in, if necessary to see the 
annotation).  

 

5. Close the Horizontal Annotation dialog. 

6. Window to see the ROW annotated. 

You can toggle off the Reference Display (as shown here) if you like. 

 



 Chapter 3  Defining Horizontal Alignments 

 

Roadway Design Using InRoads  Page 97 

7. Use MicroStation to Move the curve data for one of the curves. 

Note: The curve data is graphic grouped not only together, but with all 
the other annotation. To move individual pieces, toggle of the Graphic 
Group lock. 

8. After you take a look at the ROW graphics, use MicroStation to Delete 
them all. You can use Undo if you prefer. Or, since they are the only 
graphics in this file, you can Edit > Select All to make a selection set, 
and then choose Delete on the MicroStation menu. 

9. Select Geometry > Review Horizontal to review the alignment data. 

10. Select the drop-down for Horizontal Alignment and notice you can 
review any of the available alignments. 

 

11. Close the Results dialog when you’re through reviewing the alignments. 



Colorado Department of Transportation 

 

Page 98  Roadway Design Using InRoads 

Create a new geometry project 
Create a new geometry project to hold your coordinate geometry and 
alignment information.  

1. Select File > New. 

 

2. Select the Geometry tab. 

3. For the Type, choose Geometry Project. 

 

 In the Name field, enter 12345DES  
 In the Description field, enter SH86 Design Geometry 

  



 Chapter 3  Defining Horizontal Alignments 

 

Roadway Design Using InRoads  Page 99 

4. Select Apply 

This creates the Geometry Project where all the new alignment data will 
be stored. At this point, it is held in RAM (Random Access Memory). 
When saved to the hard drive, the default extension will be .alg, just like 
the geometry project from survey. 

5. Close the New dialog box. 

Import an alignment into the new geometry project 
There are several methods of creating an alignment in InRoads, including 
keying in the coordinates for each PI. The method you will use first is to 
import the alignment from graphics. To save time, the alignment for this 
project has already been drawn in another file.  

1. Choose File > Open on the MicroStation menu. 

 

2. Highlight the file 12345DES_Align.dgn in the 
\Design\Drawings\Reference_Files folder. 

The file opens and you will see a graphic for the alignment. 
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3. Select File > Import > Geometry. 

4. Select the Graphics tab. 

 

5. In the Geometry category, 

 Set the Type to Horizontal Alignment. 
 For the Name, key in SH 86. 
 For the Description, key in SH 86 Centerline. 
 Set the Style to ALG_PRO. 

6. In the Target category, 

 Ensure the Geometry Project is 12345DES. 
 Make certain all other options are toggled off. 

7. Choose Apply. 

8. <D> (Identify) the graphical alignment when prompted and <D> again to 
accept it when it highlights. 

9. <R> and Close the dialog. 
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10. Look in the InRoads workspace bar menu and see that both your new and 
old geometry projects are loaded, and that the new alignment is listed in 
the 12345DES project. 

 

11. Right-click on the 12345DES project and choose Save. 

 

Since the project has never been saved, you are taken to the Save As 
dialog. 

 

12. Change the Save in folder to /Design/InRoads. 
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13. Choose Save, then Cancel the dialog. 

Return to your MicroStation working file. 

14. Choose File > Open on the MicroStation menu. 

 

15. Highlight the file CU12345DES_Model.dgn in the \Design\Working 
folder. 

16. Choose OK. 
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17. Make lock settings 

 Turn the Write lock on. 
 Toggle to Pencil mode. 

 

 

18. Right-click on the new alignment name and choose View.  
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Add a new POE to the end of the alignment. 
1. Window Area around the right end of the alignment 

2. Choose Tools > Customize. 

 

3. Toggle on the toolbar for Horizontal Curve Sets. 

4. Close the Customize dialog. 

5. The toolbar may be docked initially. You can use it docked, or float it to 
any location you choose. (It’s easiest to float the toolbar by ‘grabbing’ 
one of the vertical lines between buttons.) 
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6. Select Add PI. 

 

7.  You are prompted: Identify Alignment End;   

 <D> near the end of the alignment to tell InRoads which end 
you’re adding on to. 

 

The alignment starts tracking with your cursor. Don’t <D>, instead: 

 Key in ne=1553346.5,3293694.7 
              as the coordinate for the new POE alignment. 

 

A point is placed at the specified coordinates and you are prompted to 
identify the next point in the alignment. The tangent follows your cursor, 
so do not data point or a PI will be placed at the data point location.  

8. After the point is defined, <R> Reset twice out of the command. 

 

9. Fit your view 
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Define Curves 
1. Select the Define Curve command. 

 

 

The Horizontal Curve Set Editor dialog box is displayed. The first center 
PI is automatically selected for the curve. 

2. Ensure the Curve Set Type is set to SCS. 
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3. Choose Design Calc to open the Design Calculator. 

 <D> in the Table Name field and select Browse. 
 Navigate to the C:\Program Files\Workspace-

CDOT\Standards-Global\InRoads\Design Checks 
folder and choose the file Horizontal Design Checks.txt. 

 

 Choose Open. 
 Set the Method to Lookup Radius. 
 Set the Maximum e to 6.0 

 

Notice the minimum Radius is listed for various design speeds. 
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 Set the Method to Compute Radius. 
 Set the Speed to 60 
 Set the Maximum e to 0.06 
 Choose Compute. 

 

 

 Choose Cancel. 

The Design Checks can be very handy to lookup or compute the radius 
or design speed for curves on your alignment. If you choose OK when 
you have computed or highlighted a radius, that value is placed in the 
radius field. Here, we are going to key in the radii. 
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4. Key in 21120 for Radius 1. 

 

5. Choose Apply to add the curve to the alignment. 

6. Select Next to move to the next PI in the horizontal alignment. 
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7. Select Curve Calc to activate the Curve Calculator. 

 

 Set the Compute option to Simple Curve. 
 In the Curve column, set the Radius to 3000 and Lock the 

value. 
 Choose Compute. 

 

 Choose Results to generate a report of the computed curve 
data. You may save this to your hard drive if you would like. 
Note that it can also be printed directly from the results 
dialog. 
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 Close the Results dialog. 
 Choose OK on the Curve Calculator. 

The Curve Calculator is closed and the entered Radius is transferred to 
the appropriate fields in the Define Horizontal Curve Set dialog. 

 

8. Verify the curve is set as shown, then select Apply and the curve is 
added to the alignment and displayed in the design file. 

9. Choose Next to step along the alignment and input curve 3. 
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10. Set the Radius to 11000. 

11. Choose Apply. 

12. Choose Next to step along the alignment to curve 4. 

13. Set the Radius to 30000. 

14. Choose Apply. 

15. Continue stepping along the alignment set setting the other curves as 
follows: Be sure to Apply and choose Next between the curves. 

16. Curve 5  Radius = 30000. 

17. Curve 6 Radius = 1100. 

18. Curve 7 Radius = 2400. 

19. Curve 8 Radius = 15000. 

20. Curve 9 Radius = 5000. 

21. Curve 10 Radius = 3000. 

22. Curve 11 Radius to 1600. 

23. Curve 12 Radius to 15000. 
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24. After Applying Curve 12, choose First to return to the first curve, then 
step back through the curves using Next to verify their radii. 

25. Close the Define Horizontal Curve Set dialog box when done. 

 
The reference file display has been turned off in the picture so you can 
better see the alignment. 

 Save your geometry 
Save the geometry project that now includes the new horizontal 
alignment. 

1. Select File> Save > Geometry Project. 

Since the file has been saved before, you do not have to enter a name. 
When you choose Save > Geometry, the active geometry project is 
saved. 

  



Colorado Department of Transportation 

 

Page 114  Roadway Design Using InRoads 

Define the beginning station 
Set the beginning station of the new horizontal alignment.  

1. Select Geometry > Horizontal Curve Set > Stationing. 

 

2. Key in a Starting Station of 100+00.00  

3. Select Apply. 

Note:  You do not have to key in the “+” when you key in stationing in 
InRoads. Nor do you have to key in a leading or trailing “0”. 

4. Select Close to dismiss the dialog box. 

This defines the beginning station on the proposed alignment to 
correspond with the stationing on the existing alignment at the point 
where they coincide. 
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Add a Horizontal Event Point 
Add an event point for a culvert that crosses under the proposed 
roadway.  

1. Select the Geometry > Horizontal Curve Sets > Events command.  

 

 Set Define By to Single Station. 
 Set Add As to Northing & Easting. 
 In the Station field, key in 120+13. 
 The offset field should be 0.00. 

2.  Select Apply then Close. 

Save the changes to your alignment 
The alignment information has changed and should be saved to your hard 
drive. It is part of the geometry project. 

1. Select File > Save > Geometry Project. 

Note:  Using the Undo and Redo commands in MicroStation only affect 
the graphics – they do not change the InRoads data. 
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Station the alignment 
1. Make lock settings before proceeding. 

 Toggle on the Station and Write locks. 
 Set the Pen/Pencil mode to Pencil. 

  

 

2. Select Geometry > View Geometry >  Stationing.  

 

 Make certain the Horizontal Alignment is set to SH 86. 
 Select Preferences. 
 Highlight Proposed-100 Ft Interval and choose Load. 
 Close the Preferences dialog. 

3. Select Apply. 

The alignment is stationed at 100-foot intervals, the curve points, and the 
event points. Use MicroStation view commands to take a closer look at 
what was displayed. 
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4. Zoom in to the alignment and review the stationing display. 

5. Review each of the tabs on the View Stationing box to see the setup.  
Try displaying the stationing with other preferences. 

6. Select Close to close the Stationing dialog when you’re done. 

Review the alignment data 

Use General tracking 

1. Select Tools > Tracking > Tracking, then choose Activate. 

2. Move the cursor along the alignment and note that the Elevation, Slope 
and Aspect fields are populated as long as you’re in the area of the DTM. 

 

The information in the dialog box can be displayed into the design file by 
placing a <D> at the desired location. All of the annotation fields that are 
toggled on will be annotated in the design file. 

3. <D> in the file to see the annotation display. 

4. Close the Tracking dialog. 
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Use Alignment tracking 

5. Select Tools > Tracking > Horizontal Alignments. 

Move the cursor along the alignment and watch the data change in the 
InRoads command window. As the cursor moves, the station and offset 
from the active alignment is displayed.  

                          

 

As you move your cursor, you will see the line tracking between the 
proposed horizontal alignment and your cursor.  The offset listed is the 
perpendicular distance from the alignment to your cursor. 

6. Reset twice to exit the tracking mode 

Use the Review command 

7. Select Geometry > Review Horizontal. 

 
A window is displayed showing all the alignment data for the selected 
alignment. 

8. Scroll through the report to review the information it contains. 
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9. From the Review Horizontal Alignment window, select Save As. 

 

10. Set the folder to C:\Projects\12345\Design\InRoads and in the name 
field, key in SH 86 Horizontal.txt 

11. Select Save. 

12. Close the Review dialog box. 

An ASCII file has been created in the C:\Projects\12345\ 
Design\InRoads directory that can be reviewed and printed.  

Note:  If you have a default printer set in Windows, you can use the 
Print option on the Review dialog to print directly to your 
printer. 
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Move a horizontal PI 
Often in the process of defining an alignment or in making modifications 
to an alignment it is necessary to move a horizontal PI. InRoads provides 
several tools for accomplishing this task. You will use the Edit 
Horizontal Element command to extend the last tangent. 

1. Make lock settings. 

 Toggle Write lock on 
 Set the mode to Pencil 

 

 

Move the POE using Edit Horizontal Element. 

 

2. Window Area around the end of the alignment as shown. 
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3. Select Geometry > Horizontal Element > Edit Element.  

 

4. Select Last on the dialog to move to the last element in the alignment. 

Do not miss the step to choose Last or you will edit the wrong point ! 
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 At the top of the dialog, set the Define From option to Start. 

This holds the starting point of the element and allows you to edit the 
ending point. 

 In the Length field, change the entry to 500. 

 

5. Choose Apply. 

 

6. Close the Edit Horizontal Element dialog. 
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7. Using what you previously learned, view the stationing for the updated 
alignment. (Geometry > View Geometry)  

Since the stationing was originally placed in Pencil mode, it was deleted 
when the alignment was updated. 

 

8. Review the alignment again (Geometry > Review Horizontal).  

9. Compare the alignment to the Review dialogs shown below. Be certain 
to scroll to the bottom and check your alignment’s ending tangent length, 
which should now be 500 because of the change you just made. 
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10. If your alignment doesn’t match, you can:  

 Modify the ending tangent like you did above to set the length to 500, if 
the edit didn’t work, 

 Modify it using the Move PI command if a PI is in the wrong location, 
 Modify a curve using the Define Curve command if a curve is wrong, or 

if necessary,  
 Right-click the alignment in the Explorer portion of the menu and choose 

Empty, then start over with the alignment. 

 

11. If your alignment matches this printout, save your report again, over-
writing the one you saved earlier. 

Save your updated alignment 
1. Select File > Save > Geometry Project. 

This saves the active geometry project. 

Add the geometry project to your project (rwk) file 

2. Select File > Save As. 

 Set the Save as Type to Projects *.rwk. 
 Highlight 12345DES.rwk. 
 Choose Options. 

3. On the Geometry Projects tab, click on Add and Update for the  
12345DES geometry project. 

 

Add loads the file when the project is loaded and Update saves the file 
when the project is saved.  You do not need to load the Survey geometry 
project for future use, so you can leave it toggled off. 
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4. Choose OK. 

5. Choose Save on the Save As dialog. 

6. When prompted to overwrite the current .rwk, choose Yes. 

 

This adds the geometry project 12345DES.alg to the previously created 
12345DES.rwk file. 

7. Exit InRoads and MicroStation. 

If prompted, “Do you want to save changes to the Geometry Project 
12345DES.alg?” choose Yes.  This obviously means the geometry 
project was not saved with the project file.  Open InRoads and try saving 
your project again.  If you have trouble, ask for assistance. 

If prompted to save the survey geometry file, choose No. 

 

Challenge lab 
 

Create an alignment of your choosing using the Horizontal Element 
commands. 
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4. Creating Profiles and Vertical Alignments 

Creating Profiles 
A profile of the horizontal alignment showing the existing surface groundline is 
required before creating the design profile, known in InRoads as the vertical 
alignment.   

Select Evaluation > Profile > Create Profile.  

 

There are several CDOT preferences for the different vertical exaggerations. 
Choose the appropriate one under Preferences and Load it to establish the settings 
in the dialog. 

 

Multiple surfaces may be shown on one profile by selecting them in the 
Symbology category. You may also show features that cross the alignment and 
projected features on the profile.  These may be toggled on from the Features tab 
before creating the profile. 
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Updating Profiles 
If there are changes that need to be made to the profile after it is cut, such as turning 
on or off a surface or features, or updating surfaces or features that have been 
modified, you can update the profile.   

Select Evaluation > Profile > Update Profile. 
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Creating Vertical Alignments (Design Profiles) 
In order to create a new design profile or vertical alignment, you must first have a 
geometry project loaded, with a horizontal alignment active.  

Once the geometry project is loaded (and correct horizontal is active), you may 
create a new alignment name. Choose File > New > Geometry and set the Type to 
Vertical Alignment.  Enter the Name, Description and select a Style. 

   

Apply after filling in the appropriate information.  If you have already created a 
profile of the horizontal, then you may proceed with either the Vertical Curve Set 
or Vertical Element tools to enter the alignment data. 
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Vertical Curve Set Commands 
The Vertical Curve Set commands make up an easy way to create alignments. 
They consist of five primary commands described below. 

                      

 

 

 

 

 

Add Vertical PI – Add Vertical PI is used to create a PI that begins a new 
alignment, or to add a PI onto either end of an existing alignment. 

Insert Vertical PI – Insert Vertical PI is used to add a PI to an existing alignment 
between two existing PIs. 

Move Vertical PI – Move Vertical PI is used to change the location of an existing 
vertical PI. 

Delete Vertical PI – Delete Vertical PI is used to remove a PI from an existing 
alignment. For removing more than one PI, you must choose and accept each one 
individually. To remove all PIs associated with an alignment, but leave the 
alignment name, right-click on the alignment name in the Explorer menu and 
choose Empty. 

Define Vertical Curve – Define curve is used to create a curve at a PI on an 
alignment, or to revise an existing curve on an alignment. The Previous and Next 
buttons are used to step through the alignment. The tangents forming the PI where 
the curve is to be defined will be highlighted graphically. 

Define Curve 

Delete Vert. PI 

Move Vert. PI 

Insert Vert. PI 

Add Vert. PI 
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Dynamics – The Dynamics dialog allows you to set intervals for placement of the 
vertical PIs.  It locks your cursor into the desired station, elevation and/or grade 
intervals. 

 

The Design Calculator is used to compute or look up curve data to ensure your 
design criteria are met. 

 

Keyins – There are additional keyins that can be useful when creating a vertical 
alignment, including: 

SE=station,elevation  (SE=34500,8421) 

DG=distance,grade  (DG=1500,-2.5%  or  DG=1500,-.025) 
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Displaying Alignments 
There are several methods for displaying vertical alignments in InRoads. The 
method you choose is based on the desired display. 

If you choose one of the methods other than Vertical Annotation, a geometry style 
controls the level and therefore the symbology of the display. Geometry styles are 
associated with individual alignments when they are created. The CDOT standard 
styles have been pre-defined and are stored in the CDOT-styles.ini file, accessed 
through the Geometry > View Geometry > Geometry Style Manager dialog.  
(See Horizontal Alignment Annotation.)   

To display the active alignment, choose Geometry > View Geometry > Active 
Vertical and the active alignment will display on every profile (created from the 
vertical’s parent horizontal) in the design file showing points and linework (no 
annotation). 

To display any alignment, right-click on the alignment name in the Explorer menu 
and choose View. The chosen alignment will display on every profile (created from 
the vertical’s parent horizontal) in the design file showing points and linework (no 
annotation). 

To display the alignment and annotate it at the same time, choose Geometry > 
View Geometry > Vertical Annotation.  This command uses a preference to 
define the symbology of the vertical alignment and to define what and how the 
alignment is annotated.  There are several CDOT preferences available for different 
types of vertical alignments. 
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Tracking 
The Vertical Alignment can be tracked using one of two methods. 

Tools > Tracking > Horizontal Alignment – Tracks the horizontal alignment with a 
perpendicular line to your cursor.  It gives a Station, Offset, Elevation readout in the 
message field, where the elevation shown is that of the active vertical alignment at 
the given station. 

 

Tools > Tracking > Vertical Alignment – Tracks the vertical alignment on the 
profile grid with a vertical line to your cursor.  It gives a Station, vertical Offset, 
Elevation and vertical alignment Grade readout at the location of your cursor. 

 

If a second vertical alignment is selected, the offset is between the two alignments. 
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Saving an Alignment 
Alignments are not saved individually. Instead, they are saved when the geometry 
project is saved.  Since you are working on a copy of the geometry project that is 
loaded in memory, saving is a good idea whenever you make changes to your 
alignment, and mandatory before exiting – assuming you want to save your 
changes. 

Geometry projects can be saved using several methods including: 

Choose File > Save > Geometry Project 

The active geometry project is saved. 

 

Right-click on the Geometry Project in the Explorer menu and chose Save  

The geometry project you highlighted is saved. 
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If the geometry project has never been saved, either of the previous methods will 
bring up the Save > As box shown below. 

Choose File>Save As 

 

Set the Files of Type to (*.alg) 

Choose the geometry project you want to save (in the Active category) 

Key in the file name (or use the default) 

Choose Apply and the file is saved. 

 

Note: Geometry projects have both an internal name that appears in the 
dialog boxes in InRoads and a name on the hard drive that has an 
.alg extension. Care should be taken to make certain you have 
chosen the correct geometry project name to match the file name 
you specify. Otherwise, you could accidentally save over a file 
on the hard drive with the wrong geometry project. 

 

The geometry project may also be saved as part of the project file or 
.rwk, which you will be using in your lab activity. 
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Lab 4 – Creating Profiles and Vertical Alignments 
 

Starting InRoads 
1. Start InRoads and open CU12345DES_Model.dgn from the 

Design\Working folder. 

Open your InRoads data files 
1. Select File > Open. 

 

2. Ensure the Files of Type option is set to Projects (*.rwk). 

3. Double-click on 12345DES.rwk. 

Double-clicking is the equivalent of highlighting the file and choosing 
Open. 

4. Cancel the dialog. 
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Review Profile symbologies 
1. Select Tools > Symbology Manager. 

 

2. Choose T_Existing Ground from the list and select Edit. 

 

Notice that the Profile line is set to display on the level 
DES_PROFILE_Existing-Ground and to use By_Level symbology. 

3. Close the Symbology Manager dialogs. 
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4. Select Surface > Surface Properties. 

5. Set the Surface to 12345 existing ground. 

 

6. Select the Advanced tab. 

 

Note: The Profile Symbology is set to T_Existing Ground.  This 
means that when the profile is displayed, the ground line will use 
this named symbology, will be placed on the DES_PROFILE_ 
Existing-Ground level and will use By_Level color, weight and 
line style. 
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Create a multi-point profile 
Multi-point profiles display a profile of the existing ground surface 
between points defined graphically. 

1. Ensure Write lock is on. 

2. Set the Mode to Pencil. 

  

 

3. Select Evaluation > Profile > Create Profile. 

 

4. Choose Preferences and Load 5xVertical. 

 Toggle the Create option to Window and Data. 
 Key in a Set Name of Existing Road. 
 Select Multi-Point as the Source. 
 Under Symbology, toggle on 12345 existing ground in the 

list of surfaces. 
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5. Choose the Features tab. 

 Verify the both options are off. 

6. Choose the Controls tab. 

 

 Verify the Vertical Exaggeration is 5.0. 
 Verify the Horizontal Exaggeration is 1.0. 
 Note the Window Clearance Bottom is 50. The profile 

command uses the ground elevations to determine the 
elevation range of the profile, then adds enough to the low 
and high elevations to start and stop on an even interval. The 
Window Clearance is an opportunity to increase the size of 
the grid by adding ‘blank’ space at the top or bottom. This is 
especially helpful if you have vertical alignment data that 
will fall outside the elevation range of the existing topo. As 
you can see, the CDOT preference you loaded has a 
clearance at the bottom. If you need more room at the top, 
add a Top clearance. 
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7. Select Apply. 

 When prompted to Identify Point, place a <D> north of the 
beginning (POB) of the proposed alignment. 

 Place a second <D> south of the beginning (POB) of the 
proposed alignment. 

 <R> to stop selecting points. 

 

 

8. When prompted to Identify Location, place a <D> in a clear area above 
the alignment.  This will be the location of the lower left corner of the 
profile grid. 

 

 

<D> 

<D> 
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9. Close the Create Profile dialog. 

A profile is displayed that shows the ground surface between the first 
two data points. The third data point determined the location of the 
bottom left corner of the profile grid. 

The height of the profile is determined by the height of grid needed for 
the ground line, plus the 50 extra feet of bottom clearance (set by the 
preference and found on the Controls tab). 

10. Use the MicroStation window commands to take a closer look at the two-
point profile.  

11. When done, Fit your MicroStation view before continuing. 
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Create alignment profiles 
1. Ensure Station and Report locks are on. 

  

 

Create a profile for the active horizontal alignment 

2. Select Evaluation > Profile > Create Profile. 

 

3. Choose Preferences and load 2x Vertical. 

4. Set the following parameters in the Main tab if they don’t default: 

 Create:   Window and Data. 
 Set Name:   SH 86. 
 Source:   Alignment:  SH86. 
 Under Symbology, toggle on Surface 12345 existing 

ground. 
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5. Choose the Features tab. 

 Toggle off Crossing Features. 
 Toggle off Projected Features. 

6. Choose the Offsets tab. 

 

 Set the Surface to 12345 existing ground. 
 Highlight Offset 1 and choose Surface Properties. 
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7. On the Surface Properties’ Advanced tab,  

 

 Key in -24 for Offset 1 and choose the Symbology  
D_ SURFACE_1. 

 Key in 24 for Offset 2 and choose the Symbology  
D_ SURFACE _2. 

 Apply then Close the Surface Properties dialog. 

Note: D_ SURFACE _1 through 10 can be used to show additional 
surfaces on either cross sections or profiles. You can also use 
them here to show offset lines using different symbologies from 
the centerline. They each have different ByLevel symbologies 
that do not preview in the Surface Properties dialog box, but 
will display on the profile. 
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8. Back on the Offsets tab, toggle on Offsets 1 and 2. 
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9. Choose the Legend tab and toggle on Text and Box in the Symbology 
area. 

 

10. Look at the other tabs to see how the CDOT preferences are set up. 

11. Select Apply. 

 When prompted Identify Location, place a <D> in a clear 
area below the surface. 

The data point defines the lower left corner of the profile window. The 
profile is plotted showing the surface elevations along the active 
alignment SH86. 

 

12. Close the Profile dialog. 
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13. Use your MicroStation View commands to take a closer look at the 
profile.  

 

 

Note the centerline (green-dashed) offsets and the legend noting the 
different lines and symbologies. 
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Update your profile 
You have been requested to show culverts on your profile.  The utility 
information has been provided in your survey topo. 

1. Choose Tools > Options > Factors. 

2. Unlock the three factors. 

3. Set the Cell Scale Factor to 1. 

4. Choose Apply, then Close. 

5. Select Evaluation > Profile > Update Profile. 

6. Choose the Profile Set for last profile. 

 

 Set the Mode to Display On. 
 Set the Objects to Offsets and Features. 
 Under Surfaces highlight 12345 existing ground. 
 Under Crossing Features, highlight the features that start 

with T_Cul Corr Stl 24”  

7. Choose Apply. 

8. Window into the profile (near station 215+00) to see one of the 
crossings.
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Clean up your design file before plotting the final profile. 

1. Delete all the profile windows that are displayed in the design file. 

Note: Turn on Graphic Group lock and use MicroStation Delete. 

2. Select MicroStation File > Compress > Design to compress the design 
file. 
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Create a MicroStation design file for the final profile 

1. On the MicroStation menu, select File > New. 

 

 Key in CU12345DES_Prof.dgn and set the folder to 12345 \ 
Design\Working. 

 

2. Choose OK. 

You are now in the CU12345DES_Prof.dgn file, ready to create the final 
profile. 
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Create the final profile 
1. Select Evaluation > Profile > Create Profile. 

 

2. Choose Preferences and load 2x Vertical. 

This will reset all of your previous changes back to the CDOT defaults. 

3. Set or verify the following parameters in the Main tab: 

 Create: Window and Data. 
 Set Name:   SH 86. 
 Source:   Alignment  SH 86. 
 Under Symbology, toggle on 12345 existing ground. 
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4. On the Features tab, toggle on Crossing Features and select the 24” 
culverts you used before. 

 

5. Select Apply on the Profile dialog box. 

6. Place a <D> in the design file to plot the profile window. 

7. Close the profile dialog box. 

Since Write lock is on, the profile is now permanent in the design file.  

8. Use MicroStation view commands to take a closer look at your final 
profile, noting that the utilities are displayed. 
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Create a vertical alignment 

Create a slot in the active geometry project for your vertical alignment. 

1. Select File > New. 

2. Choose the Geometry tab. 

 

 Toggle the Type to Vertical Alignment and set the 
following: 

 Name:    SH 86 V 
 Description:   Proposed VA 
 Style:    ALG_PRO_Vert 
 Curve Definition:  Parabolic 

3. Select Apply then Close 
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4. Set up your MicroStation windows so the entire profile is visible in one 
window, then open another MicroStation window and Zoom in to the 
beginning of the profile as shown. 

        

 

Add PVIs to the Vertical Alignment 

5. Ensure Write lock is on. 

6. Set the mode to Pencil. 

7. Select Geometry > Vertical Curve Set > Add PI. 

 

8. Select Apply. 

9. For the first PVI, snap to the beginning of the ground line in the window 
where you are zoomed in. 

 



 Chapter 4  Creating Profiles and Vertical Alignments 

 

Roadway Design Using InRoads  Page 157 

10. In the MicroStation key in field, enter the following commands: (Be 
certain to use the % sign in your key-in.) 

 dg=2060,-3% 

 
 dg=1560,3.3%  

        

 
 se=14800,6570  

                                   

 
The dg= key-ins place additional vertical PIs at the specified distance 
and grade. The last one again places a vertical PI at the station and 
elevation specified. 

11. <R> twice to exit, then Close the Add Vertical PI command. 

12. Update the view. 
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The vertical alignment is displayed permanently in the design file since 
Write lock is on. Because Pencil mode is active, the tangents will 
automatically update when the curves are added. If you forgot to turn 
Write lock on and the vertical alignment disappears, re-display it by 
choosing Geometry > View Geometry > Active Vertical. 

Creating vertical curves 

13. Select Geometry > Vertical Curve Set > Define Curve. 

 

The Define Vertical Curve dialog box is automatically displayed ready 
to accept input for the first curve on the vertical alignment. To step to 
other curve sets, you can use Previous and Next, or First and Last. 

14. Under the Vertical Curve category,  

 Set Calculate By to Length of Curve. 
 Set the Length to 300. 
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15. Select Design Calc. 

 

 Click in the Table Name and Browse to the C:\Program 
Files\Workspace-CDOT\ Standards-Global \ InRoads\Design 
Checks folder and choose the file Vertical Design Checks.txt.   
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 Verify that the length of curve meets your design criteria. 

 

16. Choose Cancel when done.  You do not want to accept the minimum 
curve, just verify that yours meets the criteria. 

 

17. Select Apply 
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18. Select Next to move to the second intersection of tangents 

 

 Set Calculate By: to Length of Curve 
 Set the Length to 600 
 Select Design Calc. 
 Verify that the length of curve meets your design criteria. 

19. Choose Cancel when done. 

20. Select Apply. 

21. Close the Define Vertical Curve Set dialog. 
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Import final vertical alignment. 
The vertical alignment for this project actually has more than 20 PVIs 
and vertical curves. To save time, you will delete the vertical alignment 
you just started and import the vertical from an .ics file. 

1. Right-click on the vertical alignment in the explorer and choose Delete. 

 

Be sure you right-click on the vertical alignment! 

2. Choose Yes when asked to confirm the Delete. 
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3. Choose File > Import > Geometry. 

 

4. Choose the ICS tab. 

 

5. Browse to C:\Projects\12345\Miscellaneous. 

6. Set the Files of Type to All Files. 

7. Select SH86V.txt. 
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8. Choose Open. 

 

9. Choose Apply. 

 

Since Report lock is on, you get a Results box showing what was 
imported. 

10. Close the Import Geometry dialog. 
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11. The .ics import will not allow spaces in the alignment name, so you can 
add them as well as setting the description and Style using Geometry > 
Rename Geometry as shown. 
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Evaluate the alignment and create an ASCII report 
1. Select Geometry > Review Vertical. 

 

 Use the scroll bar on the right to view the vertical data. 
 Select Save As. 
 Ensure that the Save in folder is set to 

C:\Projects\12345\Design\InRoads. 
 Enter SH 86 Vertical.txt for the file name. 
 Select Save. 

2. Close the dialog box. 

This creates an ASCII report of the information shown in the dialog box. 
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Annotate the vertical alignment 
1. Update the view 

2. Ensure the Write lock is on. 

3. Set the Mode to Pencil. 

4. Select Geometry > View Geometry > Vertical Annotation. 

 

5. On the Main tab, 

 Select SH 86 and SH 86 V as the horizontal and vertical 
alignments. 

 Select the Profile Set SH 86. 

If you do not specify a name, profile sets are sequentially numbered as 
they are created using the alignment name.  If you created more than one 
profile, select the last one you created (SH 86_1 or SH 86_2, etc.). You 
can also select the profile set using the target button next to the set name 
and choosing the profile graphically. 

The tangents and curves are already displayed on the profile, however, 
since the original alignment was created in Pencil mode, it will be 
deleted and replaced when you Apply and Accept this display. 



Colorado Department of Transportation 

 

Page 168  Roadway Design Using InRoads 

6. Choose Preferences and load the Proposed preference. 

7. Select Apply to annotate, then Close to dismiss the dialog. 

The vertical alignment is displayed and each curve is annotated. 

8. Zoom in to see the curve information. 
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Annotate the profile 
Next, you will annotate your profile to show the existing and proposed 
elevations and the grades and distances for the tangents. 

1. Select Evaluation > Profile > Annotate Profile. 

 

 Set Profile Set to SH 86 (or the last one you created). 
 Set the Surface to 12345 existing ground. 

2. Select Apply. 

The existing and proposed elevation annotations are placed on the 
bottom axis of the profile.  
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Customize your annotation 

3. Go to the Selection tab and choose None. 

 

4. Toggle any displays you want to see by double-clicking them in the 
Available window. 

 



 Chapter 4  Creating Profiles and Vertical Alignments 

 

Roadway Design Using InRoads  Page 171 

5. Apply and note that since the original display was in Pencil mode, it is 
updated with the new display. 

Note that some of the information is not available yet (e.g. 
superelevation).  You’ll redisplay the profile annotation in a later lab, 
after these items are available. 

6. Select Close to dismiss the Profile Annotation dialog box. 

7. Use the MicroStation View commands to take a closer look at the profile 
annotation. 

Exit MicroStation 
1. Select File > Exit from the MicroStation menu. If prompted to save 

changes to surface 12345 existing ground, or Geometry Project 
12345DES choose Yes. 

 

Challenge lab 
Use Annotate Features on Profile to show stations and elevations for 
your utility features. 

 

This display is near station 215+00 
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5. Typical Sections 
Whether you work on roadways or retaining walls, templates provide the tools 
necessary for creating 3D models for your proposed designs.  Anything that can be 
defined by a typical cross section and horizontal and vertical alignments can be 
designed with templates and their counterparts for sideslopes, decision tables.  
Templates can be thought of as typical sections, but not just for roadways. 

The Library 
Templates are stored in a typical section library along with cut/fill tables, material 
tables, and decision tables.  CDOT has a standard typical section library that has 
been populated with several typical sections.  These typicals may be copied and 
modified as needed for a particular project or design situation. 

                                        

Only one typical section library can be open at a time, so all templates used to 
create one roadway must reside in the same library.  You can, however, copy 
typicals from library to library using Modeler > Copy Typical Sections. This 
command only affects libraries currently on the hard drive, so it should be used 
prior to loading. 
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Template Editor 
The template editor is your interface for creating new or modifying existing typical 
sections.  It is accessed by selecting Modeler > Define Typical Sections.  On the 
Templates tab, highlight the template you wish to modify and choose Edit.  You 
may also copy a template or create a new one from this tab. 

 

The Edit Template dialog is where you will add, modify or delete layers 
in the template, or select one of the other tabs for modifying the active 
layer.  Active layers show up in red and green, with green representing 
the active segment within the active layer.   

  

 

You will be using this interface to create and modify templates in the lab activities. 
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Template Zones 
A template consists of a left and right side, each containing a backbone, cut and fill. 
Each of these portions or zones of the template contains up to 255 segments, as 
long as the last fill section is negative and the last cut section is positive.  

Note: If you are strictly using tables for sideslope calculations, the 
templates itself does not have to have any cut and fill definitions. 

The hinge point is the point between the backbone and the cut and fill segments, 
and is the point the software uses to decide if, upon dropping the template, it needs 
to use the cut or the fill section.  This is also known as the POSS (Point Of Slope 
Selection).  If a decision table is specified for the particular template drop, it is used 
regardless of the hinge point location. 

Template Layers 
Multiple layers can be used in a single template to define finished grade, and 
several subgrades.  When Modeler is run, each layer in the template creates a 
separate DTM named the same as the layer name.  

In order for the template to transition properly, the layers must be built in the same 
order in every template, and identical names must be used for like layers in 
different templates.  

Note: The first template in the roadway definition must contain all 
layers used through the model. Subsequent templates cannot 
introduce new layers. 

Layers other than the main one do not project to intersection with the existing 
terrain. Instead, the subgrades project into either the main layer, or the layer 
processed just previous to the current one.  

Note: When editing a template, use Global edit to change the template 
segment and have all subsequent segments keep their slope and 
width, shifting closer or further from the center as necessary. 
Use Local edit to change a template segment and have the 
adjacent segment change slope and width to accommodate, while 
all other segments maintain their relationship to the center. 
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Transition Control 
Transition control names are names created in the template library and assigned to 
the end-point of template segments. They are used for several purposes: the TC 
name becomes the feature name and by assigning a feature style, it controls the 
placement and symbology of the resulting feature (known as transition control lines 
when displayed by Roadway Modeler), controlling template transitioning, 
reporting and independent control. If you do not assign a name to a point in the 
template, it will be name Uncontrolled. 

CDOT has standard TC names that are located in the seed typical section library.  
For any pre-defined templates, these names have already been assigned to the 
appropriate points on the templates. 

                                       

Transition control lines are features in the DTM created by Roadway Modeler.  
They represent the template points as they are transitioned longitudinally along the 
corridor.  They provide planimetrics of your design surface, such as edges of 
pavement, shoulder points and centerline. 

Controlling Template Transitioning 
Assigning identical TC names on adjacent templates forces those points on the two 
templates to be joined when the TC lines are drawn. Triangulation itself is affected, 
since the TC lines are breaklines in the model.  The like TC names must reside in 
the same zone of the template. 

Independent Control 
By assigning a unique TC name to a point on the template, you can control the 
point’s path. To do so, independent control is established for the point in question. 
Setting up and using independent control is discussed in a later chapter. 
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Saving a Typical Section 
Typical sections are not saved individually. Instead, they are saved when the typical 
section library is saved.  Since you are working on a copy of the library that is 
loaded in memory, saving is a good idea whenever you make changes, and 
mandatory before exiting – assuming you want to save your changes. 

Typical section libraries can be saved using several methods including: 

Choose File > Save > Typical Section Library 

The loaded typical section library is saved. 

 

Right-click on the Typical Section Library in the Explorer menu and chose Save  

The loaded typical section library is saved. 
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If the typical section library has never been saved, either of the above methods will 
bring up the Save > As dialog as shown below. 

Choose File > Save As 

 

Set the Files of Type to *.tml 

Key in the file name (or use the default) 

Choose Apply and the file is saved. 

 

Note: Typical section libraries have both an internal name that appears 
in the dialog boxes in InRoads and a name on the hard drive that 
has a .tml extension. 

 

The typical section library may also be saved as part of the project file or .rwk, 
which you will be using in your lab activity.  
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Lab 5 – Typical Sections 

Start InRoads 
1. Start InRoads and open CU12345DES_Model from the 

\Design\Working folder. 

Open your InRoads data files 
1. Select File > Open. 

 

2. Ensure the Files of Type option is set to Projects (*.rwk). 

3. Double-click on 12345DES.rwk. 

Double-clicking is the equivalent of highlighting the file and choosing 
Open. 
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Open the CDOT standard typical library and save a 
project copy 
The standard CDOT typical sections are found in the CDOT Workspace and 
called CDOT-Typical Sections.tml. Here, you will be using a copy of the 
standards that has been modified for the training exercises. 

1. Select File > Open if you’ve canceled the dialog. 

 Toggle the Files of type option to Typical Section Libraries 
(*.tml). 

 Navigate to the C:\Program Files\Workspace-
CDOT\Standards-Global\InRoads\Templates folder and 
Highlight the file CDOT-Typical Sections.tml and choose 
Open. 

 

2. Cancel the dialog. 
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3. Select File > Save As and toggle the Files of type option to Typical 
Section Libraries (*.tml). 

 

4. Navigate back to the C:\Projects\12345\Design\InRoads folder. 

 

5. In the File Name field, key in 12345DES.tml and select Save, then 
Cancel the dialog. 
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Reset the typical section library’s internal name 
Rename the internal InRoads name of your typical section library to match the 
hard drive name from the previous step. 

1. Select Modeler > Rename Typical Section Library. 

2. In the To Name field, key in 12345DES. 

3. Key in a Description of CDOT configuration to note where the 
template library originated. 

4. Select Apply, then Close the dialog. 
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Add the typical section library to your project file 
1. Select File > Save As. 

 Set the Save as type to Projects (*.rwk). 
 Highlight 12345DES.rwk. 

2. Choose Options. 

 On the Typical Section Library tab, click on Add and 
Update for the new library. 

 

Remember, Add loads the file when the project is loaded and Update 
saves the file when the project is saved. 

 Choose OK. 

3. Choose Save on the Save As dialog and overwrite the existing .rwk, 
then Cancel the dialog. 

This adds the typical section library 12345DES.tml to the previously 
created 12345DES.rwk file.  Now, anytime the project is loaded or saved, 
the typical section library will be also. 



Colorado Department of Transportation 

 

Page 184  Roadway Design Using InRoads 

Review the project library with CDOT standards 
1. Select Modeler > Define Typical Sections. 

 

Notice there are a few standard templates already created with CDOT 
standards. You can use these templates, copy and modify them for 
specific project purposes, or create new templates for your project.  

You will be creating new templates from scratch to better learn the 
Template Editor. 
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2. Select the Decision Table tab and note there are several decision tables 
created as well. You’ll be using the decision table later. 

 

3. Select the Transition Control tab and note there are several pre-defined 
TC names for use in your templates.  
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4. Click the Name heading to sort them as shown. 

 

These Transition Control (TC) names are the standard CDOT names and 
can be used on your templates to maintain consistency with the feature 
names resulting from using the template to model a roadway.   

Notice that they are assigned a feature style, which controls what and 
where the feature can be displayed.  The feature style is also assigned a 
named symbology that controls the graphical attributes of the displays.  
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Create a 4-lane rural template 
In general, you will start your template creation by copying an existing 
template and then modifying it to meet your criteria.  However, for the 
purposes of learning the template editor, you will create a 4-lane 
template, then copy and modify it to create a 2-lane template. 

1. Choose the Template tab. 

2. Choose New. 

 

 For the new Name, key in SH 86 2L-2L Rural 
 Description: 4 Lane Rural 10’ Shoulder 

The name indicates first the corridor the typical is created for, the 
number of lanes on either side of the centerline, then an indicator of the 
type of template – i.e Rural, Urban, Ramp, etc. 

3. Choose Apply, then Close. 
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4. While the new template is highlighted, choose Edit. 

 Type in D_SH 86 Finished-Grade for the layer Name 
and also for the Description. 

Hint: You can right-click to copy/paste. 

 Choose New. 

 

Note: The D prefix designates that this is a Design layer, which will 
later become Design surface after modeling. 
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Define the pavement segments on the right  

5. With the layer D_SH 86 Finished Grade highlighted, select the 
Segment tab. 

 Toggle on both Left Side and Right Side under View. 
 Set Zone to: Right Backbone. 
 Set Edit Mode to Add After. 

6. Under Input,  

 
 Enter the Slope: –2% 

You must either use the % sign or key in -0.02 

 Enter the Width:  12, then <Tab> on your keyboard. 

You do not need to key in any other values. Two values under input will 
allow all the others to be calculated. 

 Highlight RT_Laneline in the list of transition control names. 

Note: You can <D> on any column to sort the TCs. 
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7. Select New. 

The first segment is added to the template backbone and the display 
window updates. 

 

8. Highlight RT_Shoulder in the list of transition control names. 

9. Select New. 

 
The second segment is added to the template backbone with the same 
slope and width. 
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Define the shoulder segment on the right side. 

10. Under Input,  

 Enter the Slope:  –2% 
 Enter the Width:  10 
 Select the T.C. Name RT_Edge-of-Pavement. 

11. Select New. 

 

The third segment is added to the template backbone. 
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Create the left side from the right 
The portion of the template you have just created is the same for all the 
layers of the template. Therefore, we will finish the other side of the 
layer, then copy it to create the additional layers before coming back and 
completing it.  

Since this is a symmetrical template, you have two options for creating 
the other side.  First, you can repeat the steps above.  However, you can 
also mirror the template, which you will do here.  Since your TC names 
will be incorrect on the left side, you will Update them after the mirror. 

12. Choose the Mirror tab. 

 

 Set the Mirror option to Layer. 

This is inconsequential since the template has only one layer defined at 
this point. 

 Set the Direction to Right to Left. 
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13. Choose Apply, then OK to confirm the mirror. 

 

14. Back on the Segments tab, set the Zone to Left Backbone. 

 

 Make certain the segment closest to the centerline is 
highlighted (green).  Use Previous and Next to step between 
the segments if necessary. 

 Highlight LT_Laneline in the list of transition control names. 
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15. Choose Update. 

 Choose Next to move to the second pavement segment. 

 

 Highlight LT_ Shoulder in the list of transition control 
names. 

16. Choose Update. 

 Choose Next to move to the shoulder. 
 Highlight LT_Edge-of-Pavement in the list of transition 

control names. 

17. Choose Update. 
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Set the Superelevation Range and Pivot Points 
Since the entire paved width will later be superelevated, you can go 
ahead and assign Superelevation Points. 

18. Choose the Superelevation tab. 

 

19. In the Superelevation One category, choose Set Range. 
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20. Using your cursor, click on the diagram at the point where the shoulder 
segment ends on the left side, then again on the right side. 

 

A blue R1 will appear on the first point and a blue R2 will appear on the 
second point as shown in the diagram.  If you get any points in the wrong 
location, choose Clear and start over. If your points are red, you 
accidentally chose Superelevation Two instead of One. Clear the 
points and start over. 
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21. In the Superelevation One category, choose Set Pivot. 

22. Using your cursor, click on the diagram at the centerline. 

 

Notice there is also a Set Crown option.  While it will not hurt anything 
to set the crown point, there is no need when the Pivot point is set at the 
crown point of the template. 
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Create additional layers in the 4-lane template 
Now that the main part of the template backbone is created, you will 
copy it to create the additional layers. This saves much time in the 
creation of templates. At this point, you probably won’t know pavement 
depths, etc., but you will modify them later. 

1. Choose the Layer tab. 

 

2. Highlight D_SH 86 Finished-Grade. 

3. Type over the Name with D_SH 86 Base-Course-Top. 

4. Key in a Vertical Offset of – 4” 

Don’t forget the negative sign or the inches quote. 

5. Choose Copy. 
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6. Highlight D_SH 86 Finished-Grade. 

 

7. Type over the Name with D_SH 86 Subbase-Top. 

8. Key in a Vertical Offset of – 8” 

Don’t forget the negative sign or the inches quote. The vertical offset is 
from the vertical alignment, not the previous layer or the layer you are 
copying. 

9. Choose Copy. 
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10. Highlight D_SH 86 Finished-Grade. 

 

11. Type over the Name with D_SH 86 Subgrade-Top. 

12. Key in a Vertical Offset of – 12” 

Don’t forget the negative sign or the inches quote. 

13. Choose Copy. 
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Complete the finished grade layer 
You now have four layers in your template. Next, you’ll go back to the 
finished grade layer and add the Z-slopes and cut and fill. 

1. Highlight D_SH 86 Finished-Grade. 

2. Choose the Segment tab. 

 
 Verify that the Zone is Right Backbone, 

o The Edit Mode is Add After, 
o Choose Next until the last segment on the right is 

active (green) 
 Enter the H/V:  –6 

H/V is another method of specifying a slope. Be certain to enter it into 
the H/V field and not the Slope field. 

 Enter the Width:  8 
 Select the T.C. Name:  RT_POSS. 
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3. Select New. 

 
The fourth segment on the right is added to the template backbone and 
your template should look like the one above. 



 Chapter 5  Typical Sections 

 

Roadway Design Using InRoads  Page 203 

Define the sideslope segments 
The point at the end of the fourth segment, the point of sideslope 
selection, is the hinge point in the template.  From this point, you will 
establish the cut and fill slopes. Later, you will use decision tables for the 
sideslopes, but for preliminary runs, you’ll use cut and fill segments on 
the templates. 

4. Set the Zone to Right Fill. 

  

5. Under Input,  

 Enter the H/V:  –3 
 Enter the Width:  5 
 Select the T.C. Name:  RT_Toe-of-Fill. 
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6. Select New. 

 

The fill segment is added to the template. 
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7. Set the Zone to Right Cut. 

8. Under Input,  

  

 Enter the H/V:  3 
 Enter the Width:  5 
 Select the T.C. Name:  RT_Top-of-Cut. 
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9. Select New. 

 

The cut segment is added to the template. 
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Complete the left side finished grade layer 
You will now repeat the steps for the left side. 

10. Add the POSS Segment. 

 
 Verify that the Zone is Left Backbone, 

o The Edit Mode is Add After, 
o The last segment on the right is active (green) 

 Enter the H/V:  –6 
 Enter the Width:  8 
 Select the T.C. Name:  LT_POSS. 
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11. Select New. 

 
The fourth segment is added to the template backbone and your template 
should look like the one above. 
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Define the sideslope segments 
The point at the end of the fourth segment, the point of sideslope 
selection, is the hinge point in the template.  From this point, you will 
establish the cut and fill slopes. 

12. Set the Zone to Left Fill. 

  

13. Under Input,  

 Enter the H/V:  –3 
 Enter the Width:  5 
 Select the T.C. Name:  LT_Toe-of-Fill. 
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14. Select New. 

 

The fill segment is added to the template. 
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15. Set the Zone to Left Cut. 

16. Under Input,  

  

 Enter the H/V:  3 
 Enter the Width:  5 
 Select the T.C. Name:  LT_Top-of-Cut. 
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17. Select New. 

 

18. The cut segment is added to the template. 

19. Close the Edit Template dialog. 

20. Close the Define Typical Section dialog. 

Save the Typical Section Library 
1. Select File > Save > Typical Section Library. 
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Copy the four-lane template to create a two-lane 
1. Choose Modeler > Define Typical Section. 

2. Highlight the SH 86 2L-2L Rural template and choose Copy. 

 

 Change the To name to SH 86 1L–1L Rural 
 Change the description to 2-lane rural typical 10’ 

Shoulder 
 Choose Apply. 
 Close the Copy Template box. 

3. With the SH 86 1L-1L Rural template highlighted, choose Edit. 
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4. On the Layer tab, highlight D_SH 86 Finished-Grade. 

5. Choose the Segment tab. 

  

 With the first segment on the Right Backbone highlighted 
(the RT_Laneline segment), choose Delete.  

Remember, use <Previous and Next> to highlight the appropriate 
segment. 

 Repeat for the Left Backbone. 
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6. On the Layer tab, highlight D_SH 86 Base-Course-Top. 
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7. Choose the Segment tab. 

 

 With the first segment on the Right Backbone highlighted 
(the RT_Laneline segment), choose Delete. 

 Repeat for the Left Backbone. 

8. Repeat this process of deleting the two inside lanes on the other two 
layers. When done, you template should look like the one shown here. 
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9. Close all open template dialog boxes. 

10. Save the typical section library (File > Save > Typical Section Library). 

 

Test one of the templates 
In the next series of steps, you will test the template you just created by 
using it to model the roadway.  This will not be the final design, but just 
a test of the one template using Express Modeler.  Express Modeler 
does not allow the use of multiple templates, decision tables, or 
superelevation, but is a good, quick test. 

Create a model of the roadway using the 1L-1L template 
1. Ensure Write lock is on. 

2. Ensure Station lock is on. 

 

 

3. Select Modeler > Express Modeler. 

 

 Select SH 86 for the Horizontal. 
 Select SH 86 V for the Vertical. 
 Select SH 86 1L-1L Rural for the Template. 
 Select 12345 existing ground for the Surface. 
 Set the Interval to 25. 
 Toggle on Plot Transition Control Lines. 

Template SH 86 1L-1L Rural will be applied along the alignment every 25 
feet.   
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4. Select Apply. 

5. Close the Express Modeler dialog box. 

 

View the results 
1. Zoom in to see the features created by Modeler. 

View the contours for the finished surface created by Express Modeler. 

2. Ensure the Style lock is off. 
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3. Select Surface > View Surface > Contours. 

 

 Set the Surface to D_SH 86 Finished-Grade. 
 Select Preferences and load Proposed 10’ Mjr. – 2’ Minor. 

4. Select Apply. 

5. Use MicroStation View commands to take a closer look at the contours. 

6. Use MicroStation Delete Element command to delete the contour 
display. 

Remember that the contour display is a graphic group. 
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View the triangles for the finished surface created by Express Modeler. 

7. Select Surface > View Surface > Triangles. 

 

 Set the Surface to D_SH 86 Finished-Grade. 
 Choose Preferences and load the preference Proposed. 

8. Select Apply. 

9. Close the View Triangles box. 

10. Use MicroStation View commands to take a closer look at the triangles. 

11. Use MicroStation Delete Element command to delete the triangle 
display. 

The triangle display is also a graphic group. 
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Create a profile 

12. Select Evaluation > Profile > Create Profile to create multi-point 
profiles as you previously learned.  

 Load the preference 2x Vertical. 
 On the Main tab key in a set name SH 86 Multipoint 
 Set the source to Multipoint. Under the Symbology section, 

toggle on Display for 12345 existing ground and  
D_SH 86 Finished-Grade. 

 

13. Apply and be sure to cut the profile across your proposed road surface. 
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14. Use MicroStation View commands to take a closer look at the profile. 

15. Delete the profile when you’re finished reviewing it. 

 

 

Exit InRoads 
1. Exit MicroStation and InRoads by selecting File>Exit first from InRoads, 

then from the MicroStation command window. When prompted, do not 
save the surfaces just created; we will be modeling again in the next lab 
and will save the surfaces then. If you are prompted to save the typical 
section library, choose Yes. 

 

Challenge lab 
Model with SH 86 2L-2L Rural template and review the results as above 
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6. Preliminary Modeling and Sections 

Roadway Libraries 
Roadway libraries store station and template setups, called roadway definitions. 
Only one library can be loaded at any given time, but each library can contain 
multiple definitions.  In addition to setting which template is used where, the 
roadway definition establishes other modeling criteria like how the sideslopes are 
calculated, what the template interval is and how the transitioning between 
templates occurs.  Independent control is established in the roadway library as part 
of the roadway definition.  

Creating Roadway Definitions 
Roadway definitions are created from the main roadway library dialog, accessed by 
selecting Modeler > Define Roadway.  
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When the definitions are created, they are given a name and description. Before 
adding the actual entries, default setups can be established so they do not have to be 
repeated with every station and template in the definition. To set these defaults, 
choose the Defaults tab on the main Define Roadway dialog. 

 

Once the defaults are established, they are copied for each entry created in the 
roadway definition. When added or edited, any of entries’ default setups can be 
overridden. 
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Template Transitions 
Roadway definitions determine the transition lengths between two templates by the 
Use Transition Template toggle in the roadway entry. If it is toggled on, the 
transition will occur between the two stations listed for the template in each 
roadway entry. If the toggle is off, the transition will occur between the last drop of 
the first template and the first drop of the second template.  

                            

 

 

 

The example above shows the effect of the Transition Template toggle. In both 
diagrams, the template interval is 10; at station 12+00, the narrower template was 
dropped. At 12+50, the wider template was dropped. With Transition Template off, 
the transition occurred in the last 10 ft (left diagram). With Transition Template on, 
the transition occurred over the full 50 ft (right diagram). 

During the transitioning of templates, transition control lines are drawn by 
connecting like-named points on each template. These lines become breaklines in 
the DTM, and have a feature name that corresponds to their TC name. The 
transition control lines that are joined must be in the same zone of the template. In 
other words, TC lines cannot cross the centerline or hinges. 

 

12+50 

12+50 

12+00 

12+00 

Transition Template off Transition Template on 
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Saving a Roadway Definition 
Roadway definitions are not saved individually. Instead, they are saved when the 
roadway library is saved.  Since you are working on a copy of the library that is 
loaded in memory, saving is a good idea whenever you make changes, and 
mandatory before exiting – assuming you want to save your changes. 

Roadway libraries can be saved using several methods including: 

Choose File > Save > Roadway Library 

The loaded roadway library is saved. 

 

Right-click on the Roadway Library in the Explorer menu and chose Save  

The loaded roadway library is saved. 
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If the roadway library has never been saved, either of the above methods will bring 
up the Save > As box as shown below. 

Choose File>Save As 

 

Set the Files of Type to *.rwl 

Key in the file name (or use the default if it’s set) 

Choose Apply and the file is saved. 

 

Note: Roadway libraries have both an internal name that appears in the 
dialog boxes in InRoads and a name on the hard drive that has an 
.rwl extension. 

 

The roadway library may also be saved as part of the project file or .rwk, which you 
will be using in your lab activity. 
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Reports 
A report of Roadway Modeler conditions is accomplished from the Define 
Roadway dialog. Edit the roadway definition to report on, then choose Report.  

A report box is displayed on-screen, and can be saved by selecting Save As from 
the dialog. The report lists any Right-of-Way controls, Horizontal and Vertical 
Controls, and Stations and Templates setups. 



 Chapter 6  Preliminary Modeling and Sections 

 

Roadway Design Using InRoads  Page 229 

Roadway Modeler 
Roadway Modeler is the culmination of the process of defining a proposed 
corridor.  Prior to running Modeler, you must have an existing digital terrain model 
(DTM), proposed horizontal and vertical alignments, template(s) and a roadway 
definition.  Roadway Modeler combines these inputs to create a 3D proposed 
model of the corridor they define. 

Three locks affect results of Roadway Modeler: 

Write lock – Turn on if you are using any of the following options and want the 
graphics to be permanent MicroStation elements: display of TC lines or display of 
cut/fill features. 

Station lock – Turn on if you want the templates to fall on even stations, even if the 
alignment starts with an odd station. 

Report lock – Turn on if you want a report dialog to appear after Modeler is run 
listing resulting error messages (or blank if there are no errors).  If this lock is off, 
errors will result in abbreviated messages, and you will not get the empty box with 
every Modeler run that doesn’t generate an error. 

After ensuring that all data is available to complete the corridor (as listed 
previously), select the Roadway Modeler command from the Design Roadway 
toolbar.   

 

Several options are available when using Modeler and can be set under the various 
tabs. 
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On the Main tab: 
Cut and Fill Features —When toggled on, non-triangulated features are created 
in the DTM for cut and fill on either side of the road, using the Name and Style 
specified. If the surface is not emptied, then you have several options for what to 
do with duplicate names: Append makes one feature from this and any previous 
features with the same name; Replace replaces previous features of the same 
name; Rename changes the new feature’s name by adding an incrementing 
number to the end if another feature of the same name is encountered; Modify 
changes an existing feature of the same name. 

On the Advanced tab: 

 
Mode — Mode overrides the settings in the individual roadway definition 
entries, if desired. The options are As Defined (no overrides) or Backbone 
Only.  

Backbone only is useful when running checks on the corridor, such as testing 
superelevation. It prevents having to wait on the sideslope calculations at times 
when you are only interested in the backbone.  

Sides — Side overrides the settings in the individual roadway definition entries, 
if desired.  
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Superelevation — This toggle tells Roadway Modeler to look at the super 
application stations table to determine rotational values for accomplishing super. 
The options allow you to decide whether to apply super to only the main layer or 
all layers. 

Transition Control Lines — In order for a TC line to be displayed , this toggle 
must be on, and the 3D/Plan Display Line Segment toggle must be on in the 
feature style. 

Subgrade Intercept — This option sets the intersection point of the subgrade 
surfaces. The subgrade can either extend until it hits the First Layer, or extend 
until it hits the Previous Layer. If no intercepts are desired, toggle the option to 
None. 

Empty Design Surface — When toggled on, Modeler empties any data in the 
surfaces defined by the layer names on the template.  

Add Transverse Features – Toggle on and specify a Feature Style if you want 
features placed following every template drop, perpendicular to the alignment. 

Add Exterior Boundary — With Add Exterior Boundary turned on, the toe-of-
slope points are connected and added to the DTM as an exterior to form the 
limits of triangulation. 

Densify Curves Using Chord Height Tolerance — The chord height tolerance 
to segments curves in the horizontal alignment, densifying the template drops. 
The tolerance is set under Tools>Options>Tolerances. 

Use Elevation Interpolation in Unsuperelevated Backbone Areas — Segments 
being transitioned a great difference in width and slope do not form a smooth 
linear transition. Using this toggle, you can force the elevation transition to be 
linear, rather than the slope transition. 

Duplicate Feature Names —When Empty Design Surface is toggled off, you 
have several options for what to do with features that would cause duplicate 
names in the DTM: Append makes one feature from this and any previous 
features with the same name; Replace replaces previous features of the same 
name; Rename changes the new feature’s name by adding an incrementing 
number to the end if another feature of the same name is encountered; Modify 
changes an existing feature of the same name. 

Renaming at Template Drops — If you use the same TC names on both sides of 
your template, then the software will rename the features created from them to 
avoid duplicate names. The features on the left side will use the original name 
and on the right, they will be prefixed with Right_. If you do not want these 
prefixes, you can use this category to create your own prefixes and seed suffix. 
You may want to use this to prefix the corridor name onto the features. 
However, the Left and Right prefixes cannot be identical, so a space for 
example, must be used in one of the entries. 

Critical Sections — Choose the locations of your cross sections in addition to 
the even interval specified on the Main tab. 

Add Transverse Features – Toggle this option on when you want transverse as 
well as longitudinal features created when modeling. 
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On the Report tab 
Generate Binary Report —With this option toggled on, a binary file is created 
containing all of the data from the cross section command. It can later be 
formatted with the General Reports command.  

Generate Error Log  — Creates a text file containing any errors that occur 
during processing. 
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Layer Controls tab 
These options allow you to change the order in which the layers are processed, 
which layer will attach to the cut and fill, as well as specify rollover locks for 
superelevation per layer. 
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Saving Surfaces created by Roadway Modeler 
Since Roadway Modeler creates new surfaces from each of the layers of the 
template used, these surfaces must be saved to the hard drive using one of several 
methods including: 

Choose File > Save > Surface 

The active surface is saved. 

 

Right-click on the Surface in the Explorer menu and chose Save  

The surface you clicked on is saved. 
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If the surface has never been saved (as is the case when Modeler is run for the first 
time for a particular roadway), either of the above methods will bring up the Save > 
As box which is shown below. 

Choose File > Save As 

 

Set the Files of Type to *.dtm 

Choose the surface you want to save from the Active pulldown list 

Key in the file name (or use the default) 

Choose Apply. 

Note: Surfaces have both an internal name that appears in the dialog 
boxes in InRoads and a name on the hard drive that has a .dtm 
extension. Care should be taken to make certain you have chosen 
the correct surface name to match the file name you specify. 
Otherwise, you could accidentally save over a file on the hard 
drive with the wrong surface. 

This process must be repeated for each of the surfaces Roadway Modeler creates.  
(One for each layer in the templates used.) 

 

The surface may also be saved as part of the project or .rwk file, which you will be 
using in your lab activities. 
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Cutting Cross Sections 
Cross sections are created based on a horizontal alignment and DTM information. 
More than one DTM can be shown on a cross section, such as an existing and 
several design surfaces.  Select Evaluation > Cross Section > Create Cross 
Section. 

 

There are CDOT preferences for different width and scale cross sections. Each of 
the preferences other than the one named CDOT places the cross sections inside a 
CDOT border, placed as a cell.  All other parameters for cutting the cross sections 
are established by these preferences as well. 
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Lab 6 – Preliminary Modeling and Sections 

Start InRoads 
1. Start InRoads and open CU12345DES_Model.dgn from the 

Design\Working folder. 

Open your InRoads data files 
1. Select File > Open. 

 

2. Ensure the Files of Type option is set to Projects (*.rwk). 

3. Double-click on 12345DES.rwk. 

Double-clicking is the equivalent of highlighting the file and choosing 
Open. 

4. Cancel the dialog. 
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Create a roadway library 
1. Select File > New. 

 

2. Select the Roadway Library tab and: 

 Enter the Name:  12345DES 
 Enter the Description:  Definitions for SH 86 and 

SideRoad 

3. Select Apply. 

4. Select Close. 
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Establish the default settings for the roadway definitions. 

5. Select Modeler > Define Roadway. 

 

6. Select the Defaults tab. 

 

 Enter the Interval:  25 
 Set Alignment Side:  Both. 
 Set Method:  Template. 
 Toggle on Use Transition Templates. 
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Name the roadway definition in the Roadway Library. 

7. From the Define Roadway dialog box, Main tab, select New. 

 Enter the Name:  SH 86  
 Enter the Description:  110+00 to 366+60 

 

8. Select Apply, then Close. 
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Add station and templates entries to the new roadway definition. 

9. From the Define Roadway dialog box highlight the roadway definition,  
SH 86 just added. 

 

10. Select Edit. 
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11. Select New on the Edit Roadway Main tab. 

 

Note the default settings made previously are set in this dialog box. Note 
also that the station defaults to the beginning station of the active 
alignment. 

 The Interval should be 25. 
 The Alignment Side should be set to Both. 

12. Select the Template drop-down under the Both column. 

 Select SH 86 1L-1L Rural from the list. 

The Template field populates with the template name. 

 The Catch Point should be set to Template 

13. Select Apply. 

You have now added the first station/ template to the roadway definition. 
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14. Enter the Station:  338+75  

15. Set the Template to SH 86 1L-1L Rural. 

 

16. Select Apply. 

17. Continue adding the entries for the roadway definition in the Roadway 
Entry box.  If you make a mistake, close the dialog, highlight the 
erroneous entry in the Edit Roadway box and choose Edit.  When done 
correcting the mistake, choose Apply, and then Close the dialog.  
Choose New to continue adding new entries. 

 

 Station: 342+00   Template: SH 86 2L-2L Rural 
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18. At station 348+25, the design calls for two lanes on the left side of the 
alignment and one lane on the right. You can accomplish this by 
changing the Mode to Left and Right, then using the four-lane template 
on the Left and the two-lane template on the Right. 

 

 Enter the Station 348+25. 
 Set the Mode to Left and Right. 
 In the Left column, select SH 86 2L – 2L Rural. 
 Make certain the Catch Point is set to Template. 
 In the Right column, select SH 86 1L – 1L Rural. 
 Make certain the Catch Point is set to Template. 
 Choose Apply. 

19. Create an entry for 351+00. 

 

 Enter the Station 351+00 
 Choose Apply. 
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20. Create an entry for 353+00. 

 

 Enter the Station 353+00 
 Set the Mode to Both 
 In the Both column, select the Template SH 86 1L – 1L 

Rural. 
 Choose Apply. 

The next four entries define an abrupt transition from using templates for 
sideslopes to using no sideslopes (Backbone Only) through the bridge 
area. 

21. Create an entry for the last station to create a sideslope prior to the 
bridge. 

 

 Enter the Station 355+11.9 
 Select the Template SH 86 1L – 1L Rural. 
 Choose Apply. 
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22. Create an entry for the first station of the bridge area which is backbone 
only. 

 

 Enter the Station 355+12 
 Select the Template SH 86 1L – 1L Rural. 
 Select Backbone Only for the Catch Point. 
 Choose Apply. 

23. Create an entry for the last station of the bridge area which is backbone 
only. 

 

 Enter the Station 357+17 
 Choose Apply. 
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24. Create an entry for the first station on the other side of the bridge area 
which returns to normal cuts and fills. 

 

 Enter the Station 357+17.10 
 Select Template for the Catch Point. 
 Choose Apply 
 Choose Close 

25. Review your entries. When complete, the entries should look like the 
dialog below. 

You do not have to enter the ending station. The last entry will be used 
until the end of the model. 
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26. Select Close to dismiss the Roadway Entry box. 

27. Select Close to dismiss the Edit Roadway Table box. 

28. Close the Define Roadway box. 

Save the roadway library. 
1. Select File > Save As. 

 

 Ensure the Save in folder is set to Design\InRoads 
 Toggle the Save as Type field to: Roadway Libraries 

(*.rwl). 
 Verify the Name is:  12345DES.rwl 

2. Select Save 

The file 12345DES.rwl is saved to the hard disk. 

3. Select Cancel. 
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Add the roadway library to your project file 
1. Select File > Save As. 

 Set the Save as type to Projects *.rwk. 
 Click on 12345DES.rwk. 
 Choose Options. 
 On the Roadway Library tab, click on Add and Update for 

the new library. 

 

Remember, Add loads the file when the project is loaded and Update 
saves the file when the project is saved. 

2. Choose OK. 

3. Choose Save on the Save As dialog and overwrite the current .rwk. 

This adds the roadway library 12345DES.rwl to the previously created 
12345DES.rwk file.  Now, anytime the project is loaded or saved, the 
roadway library will be also. 
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Model the roadway 
1. Toggle Write, Report and Station locks on. 

2. Set the mode to Pencil. 

  

 

3. Using MicroStation, delete all TC lines (features in plan) and any other 
leftover surface displays from the previous Modeler run. 

 

4. Select Modeler > Roadway Modeler. 

 

Delete all of these 
lines, leaving the 
alignment and 
stationing. 
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Confirm and set additional design parameters.  

5. Select the Advanced tab. 

 

 Set the Mode to As Defined. 
 Toggle the Side to Left and Right. 
 Toggle off Superelevation. 
 Toggle on the Display Transition Control Lines for the First 

Layer. 
 Set the Subgrade Intercept to First Layer. 
 Toggle on Empty Design Surface. 
 Toggle on Add Exterior Boundary. 
 Key in a prefix of SH86 for Left and Center. 

The prefixes cannot be the same for Left and Right, so be sure you use 
the space in the Right prefix. 

 Key in a prefix of SH 86 for Right. 
 Ensure the Suffix Seed is 0. 
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6. Select the Report tab. 

 Toggle off Generate Binary Report. 

7. Select the Layer Controls tab. 

 

 Toggle on Use Layer Controls. 
 Toggle off Segment 1 under both Inside and Outside 

Rollover Locks categories. 
 Under Layers, 
 Highlight Finished Grade and make certain Model Layer is 

checked. 
 Also check Attach End Conditions. 
 Highlight each of the other listed layers (one at a time) and 

toggle off Model Layer. 

This sets the model to only process the D_SH 86 Finished-Grade layer 
from the template. 
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8. Back on the Main tab, make certain the: 

 

 Horizontal Alignment is set to SH 86. 
 Vertical is SH 86 V. 
 Highlight the Roadway Definition SH 86. 
 Under the Original Surface list, select 12345 existing 

ground. 
 Toggle off Create Cut and Fill Features. 

9. Select Apply. 

The templates are applied along the alignment as defined in the roadway 
definition.  A new surface is created for the D_SH 86 Finished-Grade 
layer in the templates. 

10. Select Close to dismiss the Roadway Modeler box. 
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Assign a named symbology to the surface 
Roadway Modeler automatically assigns named symbologies to the 
surfaces based on the surface name. Since you prefixed the alignment 
name to the front, these symbologies are not found in the configuration. 
You can change them to the desired symbology by selecting a new one 
on the Advanced tab of Surface>Surface Properties. 

1. Select Surface>Surface Properties. 

2. On the Advanced tab, 

 Set the Surface to D_SH 86 Finished-Grade 
 Set the Cross Section Symbology to D_Finished Grade 
 Set the Profile Symbology to D_Finished Grade 
 Apply, then Close the dialog. 
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Save the new surface 
1. Select File > Save As. 

  

 Set the Save As Type to Surfaces (*.dtm) 
 Set the Active surface to D_SH 86 Finished-Grade 
 Key in the file name:   

12345DES_SurfSH86FinGrade.dtm 
 Verify that the current Save in folder is Design\InRoads. 

2. Select Save. 

3. If prompted, ‘The file ... already exists.  Replace’, select Yes 
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Add the new surface to your project file 
1. Select File > Save As. 

 

 Set the Save as type to Projects *.rwk. 
 Click on 12345DES.rwk. 
 Choose Options. 
 On the Surfaces tab, click on Add and Update for the new 

surface. 

Remember, Add loads the file when the project is loaded and Update 
saves the file when the project is saved. 

2. Choose OK. 

3. Choose Save on the Save As dialog and overwrite the current .rwk. 

This adds the D_SH 86 Finished-Grade surface to the previously created 
12345DES.rwk file.  Now, anytime the project is loaded or saved, this 
surface will be also. 
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View the results of Roadway Modeler 
1. Zoom in or out as needed with MicroStation to visually review the 

display of the Transition Control (TC) lines. 

Note:  Zoom in on station 340+00 to see the transition from 2 lanes to 4 
lanes.  Zoom in on station 345+00 to see the transition from 4 
lanes to 3 lanes. 

 

You might want to try zooming with precision by picking the Window 
Area command and keying in: so=35100 <Enter> and so=35500 
<Enter>.  When prompted, pick the view you want and it will window 
between the two stations. 

 

Display the triangles for the proposed surface. 
1. Select Surface > View Surface > Triangles. 

 Set the Surface to D_SH 86 Finished-Grade. 

2. Select Apply then Close. 

3. Use the MicroStation View Control commands to take a closer look at 
the display. 

4. Use MicroStation Delete Element to delete the triangle display 
(Graphic Group lock on). 
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View contours for the proposed surface 
1. Select Surface > View Surface > Contours. 

 Set the Surface to D_SH 86 Finished-Grade. 
 Select Preferences and load Proposed 10’ Mjr. – 2’ Minor. 

2. Select Apply. 

 

3. Use MicroStation View commands to take a closer look at the contours. 

4. Use MicroStation Delete Element command to delete the contour 
display. 

Remember that the contour display is a graphic group. 
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Cut Cross Sections for the proposed roadway 
1. Make certain Write and Station locks are on, and that you are in Pencil 

mode. 

2. Select Tools > Options > Factors and key in a Text Scale Factor of 40 
then Apply.  By Applying but not saving the preference, the factor will 
revert back to 100 when you next start InRoads. 

 

3. Select Tools > Customize > Cross Section, then Close the Toolbars 
dialog. 

 

Up to this point, we have been using mainly the pull-down menus.  
Toolbars like this one are also available for selecting most commands. 
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4. On the Cross Section toolbar, select Create Cross Sections. 

 

 

5. Choose Preferences and load 40H 20V 160’ Wide. 

6. On the Main tab, 

 Set the Source to Alignment and select SH 86. 
 Toggle on Single Station. 
 Key in 114+50 . 
 Toggle on only 12345 existing ground and  

D_SH 86 Finished-Grade. 
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7. Apply and <D> for the lower left corner of the single cross section. 

8. Zoom in to the section. 

 

 

Note that the section appears inside a border. This is the default 
preference – next, you’ll load a preference that does not use a border so 
you can create a working or check set of sections.  Later, when you 
create the final sections, you’ll modify a border for this job and use it to 
cut section on sheets. 

9. Delete the cross section display with MicroStation when you are through 
reviewing. 
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10. On the Create Cross Section dialog. 

 Select Preferences. 
 Highlight the preference Stacked 20 per column and 

choose Load. 
 Close the Preferences dialog. 

 

11. Toggle off Single Station. 
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12. Select Apply. 

Before you complete the next step, remember that the location you 
identify is the lower left corner of the entire cross section set, so be 
certain to select a clear area in your file. 

If you place the cross sections in the wrong location, make sure Graphic 
Group lock is on, then Delete the set and re-create it.  Do not move the 
cross sections. 

13. Place a <D> in the design file to specify the lower left corner of the cross 
section plot. 

 

14. Select Close on the Cross Section dialog. 
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View the cross sections that are plotted in the design file. 
1. On the Cross Section toolbar, select the Cross Section Viewer 

command. 

 

 

 Set the Cross Section Set option to SH 86 (or the last section 
set in the list if you haven’t deleted all of your previous sets). 

 Set the Zoom Factor to 1.0. 
 Set the Time to 0.5 sec. 

2. Select Run. 

3. You can hit <ESC> on your keyboard to stop the run if you would like. 

4. You can choose individual sections to look at from the Viewer as well.  
If you have only one MicroStation view open, you can use your 
keyboard arrow keys to step between the sections. 

5. Close the Cross Section Viewer dialog when you are finished looking at 
the sections. 

6. Exit MicroStation. 
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7. Modeling with Superelevation and Transitions 

Superelevation 
Calculating the superelevation transitions requires that the horizontal alignment, 
vertical alignment and roadway definitions be set.  Superelevation points must also 
be defined in the template.  After that, there are three main steps to setting up 
superelevation. 

Calculate the rates 

Select Modeler > Superelevation > Rate Calculator.  There is a preference 
established for CDOT, but you will still need to Browse and select the appropriate 
superelevation table.  The tables are named according to the design criteria as 
shown below: 

08_65.sup 

08 = max super rate in table; 65 = design speed in mph. 

 

The CDOT superelevation tables are found in the folder C:\Program 
Files\Workspace-CDOT\Standards-Global\InRoads\Superelevation Tables. 
There are two subfolders – AASHTO 2001 and AASHTO 2004 – which contain 
their respective rate tables. 
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Create a superelevation alignment, which stores the stationing and rates for 
superelevation transitions. 

Select File > Geometry > New and specify a name and description for your 
superelevation alignment. 

 

Calculate or Build the Transitions. 

Select Modeler > Superelevation > Build Transitions. 

 

The CDOT standard Controls and Rollover Locks (which are turned off) are stored 
in the Preferences for the command. 
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Horizontal and Vertical (Independent) Control 
Independent control can greatly enhance the use of templates by allowing you 
to vary widths and slopes of backbone segments during Roadway Modeler 
runs without using a second template.  

Note: Independently controlled points in the template must be in the 
backbone of the template. 

Independent Control is setup and stored in the roadway library, with the 
individual roadway definitions. In order to define the controls, you must have 
the geometry file loaded with the alignment active that is to be used with 
Roadway Modeler, the template library loaded and the roadway library must 
also be loaded. The geometry file should also contain any alignments you plan 
to assign to different points on the template. 

There are two types of controls – horizontal and vertical. They can be used 
individually, or in combination. 

Use Horizontal controls when the independent control path is defined by a 
separate horizontal alignment or by stations and offsets from the mainline. 
Horizontal controls are used in conjunction with variable width template 
segments, typically for items such as lane widenings or turn lanes. 

Use Vertical controls when the separate path is defined by a separate vertical 
alignment, a vertical difference alignment, or by vertical offsets from the 
mainline vertical. 
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Workflow for H&V Controls 
There are four basic steps. 

1. Assign a unique TC name to the point on the template you 
want to control. 

2. Set the segment you want to vary in the template to 
Variable Slope, Variable Width or Variable Slope and 
Width. 

 

3. Make the horizontal alignment active that you’re going to 
use for Modeler. 

4. Establish the controls in the roadway definition. 
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Updating Existing Sections 
Cross sections retain their association with the surfaces and features they display 
and therefore you can update the sections when any new information is available. 
For example, you may realize that you need to add a utility line into the DTM.  
Rather than cutting a new set of sections to show the addition, select  
Evaluation > Cross Section > Update Cross Section.  From this dialog, you can 
either update the entire set of sections or a range of sections.  The update can 
involve refreshing items that have already been displayed on the sections, turning 
those items off, or turning on items not currently displayed. 

 

Always use this command to turn off features displayed from a design surface 
before running Roadway Modeler and creating the same surface.  Otherwise, the 
features will not be recognized by the new surface so you will not be able to turn 
them off or update them later. 
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Lab 7 –Modeling with Superelevation and Transitions 

Start InRoads 
1. Start InRoads and open CU12345DES_Model.dgn from the 

Design\Working folder. 

Open your InRoads data files 
1. Select File > Open. 

 

2. Ensure the Files of Type option is set to Projects (*.rwk). 

3. Double-click on 12345DES.rwk. 

Double-clicking is the equivalent of highlighting the file and choosing 
Open. 

4. Cancel the dialog. 



Colorado Department of Transportation 

 

Page 272  Roadway Design Using InRoads 

Create a superelevation alignment 
1. Make certain the active alignment is SH 86. 

 

2. Select File > New. 

3. Select the Geometry tab. 

 

 Set the Type field to Superelevation. 
 Enter the Name:  60 mph 
 Enter the Description:  Design option 1 

4. Select Apply then Close. 
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Calculate the superelevation rates 
Since you are have two design speeds for the alignment, you will 
calculate the rates for each separately. 

Set the superelevation rate parameters for 60 mph curves 
In this example, you’ll use a 6% maximum super and a design speed of 
60 mph.   

1. Select Modeler > Superelevation > Rate Calculator. 

 

 Set the Rate Calculation Method to   Table Method. 
 Click in the Rate Table field and delete the text. 
 Select Browse and choose 06_60.sup from the C:\Program 

Files\Workspace-CDOT\Standards-
Global\InRoads\Superelevation Tables\AASHTO 2004 
folder. 
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 Set Column from Rate Table to:  2-lane. 
 Enter the Preferred Max Super Rate:   5.5% 

This does not limit the super that can be used – it just warns you if this 
rate is exceeded by the table. 

 Toggle off Use Curve Limits. 
 Toggle on Round Rates to and select 0.123. 

Calculate rates 

2. On the Main tab, select All to toggle on all the curves in the Review/Edit 
area. 

3. Select Compute. 

 

 
Select OK when you get the Desirable Maximum Superelevation Rate 
Exceeded message. This message just warns you so you can check the 
curves to see if it’s what you want. 

The superelevation rates are calculated for the curves and displayed in 
the Review/Edit category.  

Notice the superelevation rate exceeded your preferred maximum rate.  
You can choose to accept this, override the calculation or redefine the 
curves and/or design speed.  For class purposes, choose OK. 

4. Select Close to dismiss the Superelevation Rate Calculator dialog box 
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Calculate the superelevation transitions 

Set the application station design parameters. 

1. Make certain Report lock is on. 

2. Select Modeler > Superelevation > Build Transitions. 
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3. From the Controls tab, 

 

 Review the standard CDOT superelevation controls. 

4. Choose the Default Rollover Locks tab. 

 

 Notice that CDOT’s superelevation criteria does not require 
rollover locks. 
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Calculate the application stations for the transitions 

5. Back on the Main tab, make certain the:  

 

 Horizontal Alignment is set to  SH 86. 
 Vertical Alignment is SH 86 V. 
 Superelevation is 60 mph. 
 Roadway Definition is SH 86. 
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6. Select Compute. 

 

The application stations are built and displayed in the Review / Edit 
Application Stations category. The Results window is also displayed 
because the Report lock is on.  This window shows super parameters and 
calculations.  The Save As command can be used to save this 
information into an ASCII file on disk. 

7. Review the Results box. 
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8. Choose Save As on the Results box.  

 Ensure the Save in folder is C:\Projects\12345\ 
Design\InRoads. 

 Key in the filename SH 86 super.txt and choose Save. 

9. Select Close on the Results dialog. 

10. Scroll through the application stations list and review the results. 

 

11. Select Save on the main dialog. 

12. Select OK. 

Save the application stations 
The superelevation rates and application stations have all been 
calculated.  Now save the results in the .alg on the disk. 

13. Select File > Save > Geometry Project. 
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Model the roadway 
1. Toggle Write lock on. 

2. Toggle Report lock on. 

3. Set the mode to Pencil. 

4. Toggle Station lock on. 

  

 

5. Delete all TC lines (features in plan) from the previous Modeler runs. 

6. Select Modeler > Roadway Modeler. 
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Confirm and set additional design parameters.  

7. Select the Advanced tab. 

 

 Toggle on Superelevation Apply to First Layer. 
 Other options should still be set as shown. 

8. Select the Layer Controls tab. 

 Toggle on Use Layer Controls. 
 Highlight Finished Grade and make certain Model Layer is 

checked  
 Toggle all Rollovers off. 
 Highlight each of the other listed layers (one at a time) and 

toggle off Model Layer and Rollovers 
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9. Back on the Main tab, make certain the: 

 

 Horizontal Alignment is set to SH 86. 
 Vertical is SH 86 V. 
 Highlight the Roadway Definition SH 86. 
 Under the Original Surface list, highlight only  

12345 existing ground. 
 Toggle off Create Cut and Fill Features. 

10. Select Apply. 

The templates are applied along the alignment as defined in the roadway 
definition and superelevation is applied as it was calculated.  A new 
surface is created for D_SH 86 Finished-Grade. Since Empty Design 
Surface was toggled on, the previously modeled surface is emptied and 
the new model with superelevation takes its place. 

11. Select Close to dismiss the Roadway Modeler box. 
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Save the new surface 
1. Right-click on D_SH 86 Finished-Grade in the Workspace (Explorer) 

portion of the InRoads menu and select Save. 

 

View the results of Roadway Modeler 
1. Zoom in or out as needed with MicroStation to visually review the 

display of the Transition Control (TC) lines. 

Display the triangles for the proposed surface. 

2. Select Surface > View Surface > Triangles. 

3. Set the Surface to D_SH 86 Finished-Grade. 

4. Select Apply then Close. 

5. Use the MicroStation View Control commands to take a closer look at 
the display.  (Try rotating a view to see the super.) 

6. Use MicroStation Delete Element to delete the triangle display (graphic 
group lock on). 

View contours for the proposed surface 

7. Select Surface > View Surface > Contours. 

8. Set the Surface to D_SH 86 Finished-Grade. 

9. Select Preferences and load Proposed 10’ Mjr. – 2’ Minor. 

10. Select Apply. 

11. Use MicroStation View commands to take a closer look at the contours. 

12. Use MicroStation Delete Element command to delete the contour 
display. 

13. Remember that the contour display is a graphic group. 
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Update the Cross Sections 
Since you already have a set of section for the roadway, you can just 
update them with the new surface instead of creating a whole new set. 

1. Make sure you’re in a top view, then Fit. 

2. Choose Evaluation > Cross Section > Update Cross Section. 

 

 Choose the Cross Section Set that contains your previously 
cut full set of section.  You can tell which one you select by 
the box that’s drawn around the set. 

 Set the Mode to Refresh. 

You can Refresh or toggle Off items that are currently displayed on the 
sections.  You can toggle On items that are not currently displayed. 

 Toggle on Surface in the Object category. 
 Highlight D_SH 86 Finished-Grade. 

3. Choose Apply. 

The surface displayed in the cross sections is replaced with the newly 
modeled surface. 
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4. On the Cross Section toolbar, select the Cross Section Viewer 
command. 

 

 

 Set the Cross Section Set option to the cross section set you 
just updated. 

 Set the Time to 0.5 sec. 
 Select Run. 

Watch for the sections through the curve to see the superelevation. 

5. Close the Cross Section Viewer dialog. 
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Using Independent Control 
In this section, you will add an independent control setup for creating a 
turn lane.   

Update the template for independent control 
In the template, you must have a unique TC name assigned to the point 
you want to control. 

1. Select Modeler > Define Typical Section. 

2. On the Templates tab, highlight SH 86 1L-1L Rural and choose Edit. 

3. Highlight the D_SH 86 Finished-Grade layer and choose the Segment 
tab. 

  

 Set the Zone to Right Backbone. 
 Choose Previous or Next as necessary to make the active 

segment (green) the right driving lane. 

Since we want this segment to widen for the turn lane, we must tell 
InRoads that the segment may vary in width, but hold the slope constant. 
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In this particular example, since we are only going to use Horizontal 
Control to widen one segment next the TC name you’re controlling, you 
could actually leave the Fixity set to Fixed and the lane would widen. 
However, it’s much safer to get in the habit of always changing the fixity 
of segment you want to vary. 

 

 Under Fixity, choose Variable Width. 
 Choose Update to confirm the change. 

Notice the TC name that is highlighted.  It should be RT_Shoulder.   

This is a unique name, since there should be only one RT_Shoulder on 
the template.  You can step back and forth to other segments to verify 
they have different names. 

4. Close the Edit Template dialog. 

5. Close the Define Typical Section dialog. 



Colorado Department of Transportation 

 

Page 288  Roadway Design Using InRoads 

Assign the controls in the roadway definition 
When you assign the controls in the roadway definition, the stationing it 
uses is based on the active alignment.  Since we’ll be using SH 86 to run 
Modeler, you must make it active before proceeding. 

6. Choose Geometry > Active Geometry. 

 

 Set the Type to Horizontal Alignment. 
 From the list at the bottom, select SH 86. 

7. Choose Apply. 

8. Close the Active Geometry dialog. 

Alternately, you can right-click the alignment in the InRoads Explorer 
menu and choose Set Active. 

9. Verify the active alignment by looking in the InRoads Explorer menu to 
ensure the red box is indicating SH 86. 
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10. Select Modeler > Define Roadway. 

11. Highlight SH 86 and choose Edit. 

12. On the Edit Roadway dialog, choose the Horizontal and Vertical 
Controls tab. 

 

 Set the Transition Control Name to RT_Shoulder. 
 Toggle on Use Horizontal Controls and Templates at 

Vertices. 
 Toggle off Use Vertical Controls. 
 Choose the Horizontal Alignment SH 86. 
 Key in a Start Station of 221+00 
 Key in a Stop Station of 222+50 
 Key in a Start Offset of 12.0 
 Key in a Stop Offset of 24.0 
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13. Choose New to add the independent control. 

 

This takes care of the taper to widen out for the turn lane. Next, you’ll 
add an entry to carry the widening for 300’ up to the intersection. 

 Leave the setting as they are, except: 
 Key in a Start Station of 222+50 
 Key in a Stop Station of 225+50 
 Key in a Start Offset of 24.0 
 Key in a Stop Offset of 24.0 

14. Choose New 

15. Close both of the open dialogs. 

Save the new setup 
Since we have modified both the typical section library and the roadway 
library, we can save them in one step by saving the project. 

16. Choose File > Save > Project. 
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Model the roadway 
1. Delete all TC lines (features in plan) from the previous Modeler runs. 

2. Select Modeler > Roadway Modeler. 

Confirm the design parameters.   
These should all still be set if you haven’t exited InRoads, but it’s always 
a good idea to double-check, especially the alignments and existing 
surface, since they reflect the actives. 

3. Select the Advanced tab. 

 

 Verify the settings you previously made. 
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4. Select the Layer Controls tab. 

 Toggle on Use Layer Controls. 
 Toggle off Segment 1 under both Inside and Outside 

Rollover Locks categories. 
 Under Layers, 
 Highlight Finished Grade and make certain Model Layer is 

checked. 
 Highlight each of the other listed layers (one at a time) and 

toggle off Model Layer. 

5. Back on the Main tab, make certain the: 

 

 Horizontal Alignment is set to SH 86. 
 Vertical is SH 86 V. 
 Highlight the Roadway Definition SH 86. 
 Under the Original Surface list, highlight only  

12345 existing ground. 
 Toggle off Create Cut and Fill Features. 
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6. Select Apply. 

The templates are applied along the alignment as defined in the roadway 
definition, superelevation is applied as it was calculated, and the 
independent control is applied as it was defined.  A new surface is 
created for D_SH 86 Finished-Grade. 

7. Select Close to dismiss the Roadway Modeler box. 

 

Save the new surface 
1. Right-click on D_SH 86 Finished-Grade in the Workspace (Explorer) 

portion of the InRoads menu. 

2. Select Save. 

 

View the results of Roadway Modeler 
1. Zoom in or out as needed with MicroStation to visually review the 

display of the Transition Control (TC) lines.  Be sure to look at the turn 
lane area to see how the model widens. 
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Display the triangles for the proposed surface. 
1. Select Surface > View Surface > Triangles. 

2. Set the Surface to D_SH 86 Finished-Grade. 

3. Select Apply then Close. 

4. Use the MicroStation View Control commands to take a closer look at 
the display.  (Try rotating a view to see the super.) 

5. Use MicroStation Delete Element to delete the triangle display (graphic 
group lock on). 

 

View contours for the proposed surface 
1. Select Surface > View Surface > Contours. 

2. Set the Surface to D_SH 86 Finished-Grade. 

3. Select Preferences and load Proposed 10’ Mjr. – 2’ Minor. 

4. Select Apply. 

5. Use MicroStation View commands to take a closer look at the contours. 

6. Use MicroStation Delete Element command to delete the contour 
display. 

Remember that the contour display is a graphic group. 
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Update the Cross Sections 
Since you already have a set of section for the roadway, you can just 
update them with the new surface instead of creating a whole new set. 

1. Make sure you’re in a top view, then Fit. 

2. Choose Evaluation > Cross Section > Update Cross Section. 

 Choose the Cross Section Set that contains your previously 
cut full set of section.  You can tell which one you select by 
the box that’s drawn around the set. 

 Set the Mode to Refresh. 

You can Refresh or toggle Off items that are currently displayed on the 
sections.  You can toggle On items that are not currently displayed. 

 Toggle on Surface in the Object category. 
 Highlight D_SH 86 Finished-Grade. 

3. Choose Apply. 

The surface displayed in the cross sections is replaced with the newly 
modeled surface. 

4. On the Cross Section toolbar, select the Cross Section Viewer 
command. 

 Set the Cross Section Set option to the cross section set you 
just updated. 

 Set the Time to 0.5 sec. 

5. Select Run. 

Watch for the sections through the curve to see the superelevation and 
through the turn lane are to see the widening. 

6. Select a cross section in the turn lane area to better see the widening 
without the viewer running. 

7. Close the Cross Section Viewer dialog. 

 



Colorado Department of Transportation 

 

Page 296  Roadway Design Using InRoads 

Drive the roadway 
1. Select Modeler > Drive Roadway. 

 Highlight the Horizontal Alignment SH 86. 
 Highlight the Vertical Alignment SH 86 V. 

2. Choose Run. 

If you have multiple windows open, you must <D> where you want to 
see the drive-through; if you only have one window open, it 
automatically uses it. 

3. Close the Drive Roadway dialog. 

4. Set your view back to Top. 

 

Exit 
1. Exit MicroStation.  If prompted to save the geometry project, choose Yes. 

 

Challenge lab 
Create right turn lane at the intersection for the East-bound lanes.  You 
may create an alignment or use Stations and Offsets from the CL. 
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8. Plan and Profile  

Concept 
The Plan and Profile Generator automates the process of putting together sheets.  
It uses MicroStation’s reference file utilities so that when done, you have a 
MicroStation sheet file with the border, plan view, associate profile view and any 
references to the plan attached and the view rotated to the proper angle. 

 

Select Drafting > Plan and Profile Generator.  There are CDOT preferences for 
this command: a CDOT default, one for Plan Sheets only, one for Profile Sheets 
only and one for Plan and Profile Sheets. 

 



Colorado Department of Transportation 

 

Page 298  Roadway Design Using InRoads 

The Plan and Profile Generator uses three main types of files: 

 Model Files, which are MicroStation design files containing your plan 
and profile along with any references to those files. 

 A Border File, which is a MicroStation file containing the CDOT border 
you wish to use for your sheets. The Border can be referenced in or used 
as a cell. 

 A Seed File, which is a MicroStation design file that will be copied to 
form the design files when sheets are created. 

Host files are created, which are actually the sheet files containing the plan, profile 
or plan and profiles along with a border.  Also created is a view definition file (.vdf) 
that stores all of the information about the sheets and can be retrieved later if you 
need to modify a sheet or sheets.  Without the .vdf file, you can still modify the 
sheets using MicroStation referencing commands. 
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Lab 8 – Plan and Profile  
The InRoads Plan and Profile Generator uses several different files to put 
together your Plan and Profile sheets. Here, you will create a border file 
to be used in each plan and profile. You will also create a profile design 
file, a seed file to be used for creating the individual sheets and a host file 
to use as the starting point for your sheets. 

Start InRoads 
1. Start InRoads and open CU12345DES_Model.dgn from the 

\Design\Working folder. 

2. Select File > Save As from the MicroStation menu 

3. Change the folder to Design\Drawings\Reference_Files 

4. Take the CU off the file name. 

5. Choose OK. 
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Open your InRoads data files 
1. Select File > Open. 

 

2. Ensure the Files of Type option is set to Projects (*.rwk). 

3. Double-click on 12345DES.rwk. 

Double-clicking is the equivalent of highlighting the file and choosing 
Open. 

4. Cancel the dialog. 

5. Make certain Write lock is on. 

6. Make certain Station lock is on. 
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Create a project specific border 
In order to use the Plan and Profile Generator, you need to have a border. 

You can use the following method to create a project-specific border cell. This 
method uses the CDOT menu to place the border, and then edit it for your 
situations. After it is edited, you will use it as a cell to replace the border in the 
copied plan sheets. 

Alternately, you can keep the Design borders and edit them individually. The 
method you choose should depend on the amount of edits you need to do to each 
and the number of sheets to edit. 

Create the border file 
Since you will use this border for multiple sheets, create one project border to 
avoid editing multiple borders later. 

1. From MicroStation, select File > New. 

 

2. Set the directory to \Design\Drawings. 

3. In the Name field, key in a drawing file name 
12345DES_PnPBdr.dgn 

4. In the New dialog box, select OK.  
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Use the CDOT Menu to create the border 
1. To start the CDOT Menu if it has been closed, select the CDOT icon on 

the Main tool palette. 

 

2. Select Settings and set Active Scale to 1 and Active Angle to 0.     

Note:  You will create the generic project border cell at a scale of 1  
(11 x 17 master units). You’ll actually scale the border, 
according to your plot scale, later when the cell is placed in the 
sheet file. 

3. Select Apply and Close in the Active Settings box. 

4. From the CDOT Menu Explorer, select Drafting, then select the 
Category Border.  From the Selection Window, pick Border (PnP 
11”x17”)  
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5. When prompted to enter cell origin, key in xy=0,0,0 

Note:  The lower left corner of the border must be located at the 0,0 
coordinate in the file since this will be the origin of the cell. 

 The sheet border cell is not anchored to your cursor but will be 
visible after you place it. 

You will place the bar scale and north arrow cell in each sheet. 

 

6. Fit your view. 
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7. Back on the CDOT Menu, set the Category to Border RE and select your 
RE’s Name.  

 

8. When prompted to enter cell origin of the Region Engineer cell, Zoom 
in as necessary on the bottom portion of the border and <T> to the 
location shown and then <D> to accept.   

 

9. Fit the view. 
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Edit the border text with project specific information 
1. Zoom in on the lower-right corner of the border as shown. 

 

2. Select the Edit Text command from the Text toolbar. 

3. <D> on the Project Number text. 

4. In the Text Editor, replace this with STA 086A-039. 

5. <D> anywhere to accept. 

6. <D> on the Code text. 

7. In the Text Editor, replace this with 12345 and <D> to accept. 

8. Edit the X’s beside Designer and replace with your initials. 

9. Edit the X’s beside Detailer and replace with your initials. 

 

10. Fit the view. 

11. Choose MicroStation Drop Element and select the border to drop 

The border must be dropped because you need to delete the profile grid. 
InRoads will generate it’s own grid for the profile. 

12. Delete the profile grid using MicroStation. 
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Make the border a cell 
1. Select Models from the Primary toolbar. 

 

2. In the Models dialog box, select Edit Model Properties. 

 

3. In the Model Properties box: 

 Toggle on Can be placed as cell 
 Change the Name to 12345 Plan Profile Border 
 Change the Description to PnP Border Cell 
 Leave all other options as shown. 

4. Select OK. 

5. Close the Models box. 

6. Save Settings (File > Save Settings). 
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Create a host seed file for the plan and profile sheets 
1. Select MicroStation File > New. 

2. Key in 12345DES_PnPHost.dgn. 

 

3. Choose OK. 

4. Select MicroStation Element > Cells. 

 

5. Select File > Attach. 
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6. Set the List Files of Type to MicroStation DGN Files. 

 

7. Ensure the directory is \Design\Drawings. 

8. Select 12345DES_PnPBdr.dgn and then select OK. 

 

9. Close the Cell Library dialog. 

10. Select File > Save Settings. 
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Prepare a profile design file 
1. Select MicroStation File > New. 

 

2. Navigate to the \Drawings\Reference_Files folder and key in 
12345DES_Prof.dgn. 

3. Choose OK. 

 

4. If you get a message that the file exists, choose OK to Overwrite. 
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Attach the border file as a cell library 
1. Select Element>Cells. 

 Select File>Attach. 
 Navigate to the \Design\Drawings folder and double-click 

12345DES_PnPBdr.dgn. 

 

This established the design file containing the border you previously 
placed and edited as a cell library, with the border as the only cell. 

  

2. Close the Cell Library dialog. 

3. Save Settings. 
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Set up the Plan and Profile Generator options 
1. Select Drafting>Plan and Profile Generator 

 

2. Choose Preference and load 100Scale P&P (2x Vert). 
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First, you will set up and review the different tabs. 
Many of the following parameters are set by the preference you loaded, but 
continue reviewing the tabs to enter additional data and to see what settings have 
been made for you. 

3. On the Plan Controls tab: 

 

Notice the Width Left and Right are set to –200 and 200.  This indicates 
the plan view will span 400 feet in total width. 

Notice the Overlap is set to 0, indicating there will be no overlap 
between the sheets. 

 Select the Model Files button. In the Open Model File 
dialog box, double-click on 12345DES_Model.dgn file from 
the \Design\ Drawings\Reference_Files folder. 

 If your profile file is not already listed, select the Model 
Files button again. In the Open Model File dialog box, 
double-click on 12345DES_Prof.dgn file from the 
\Design\Drawings\Reference_Files folder. 

 Toggle on Nested Attachments. 

With Nested Attachments, you will see not only the 
12345DES_Model.dgn graphics referenced to your plan, but also any 
files referenced to it.  In this case, it means your survey graphics file. 



 Chapter  8  Plan and Profile 

 

Roadway Design Using InRoads  Page 313 

4. On the Profile Controls tab: 

 

 Set Vertical Alignment to SH 86 V. 
 Toggle on the surface 12345 existing ground and toggle all 

other surfaces off. 
 Double-check that 12345 existing ground is highlighted. 

12345 existing ground must be highlighted and toggled on. Toggling it 
on is to have it shown on the profile. Highlighting it is to make certain 
the grid elevations encompass the entire surface. 
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5. On the Sheet Layout tab: 

 

 Verify that Sheet Number and Name are set to 1 
 In the Host File Content section, select Single Sheet Each. 

This will place each plan/profile sheet in a separate MicroStation design 
file, starting with PnP1.dgn, then incrementing by one (PnP2.dgn, 
PnP3.dgn, etc.). 

 Click inside the Host File field, and choose the … button to 
Browse. 

When the Save As dialog appears, navigate to the \Design\Drawings 
folder and key in a name of 12345DES_PnP01.dgn. Note that the 
files already exist for Plan and Profile sheets. Here, we’ll overwrite them 
with our new ones. 

 

 Choose Save. 
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 Click inside the Seed Host File field, and choose the … 
button to Browse. 

 Navigate to the \Design\Drawings folder, select the file 
12345DES_PnPHost.dgn and then select Open. 

 



Colorado Department of Transportation 

 

Page 316  Roadway Design Using InRoads 

6. On the View Layout tab, notice the location of the Plan and Profile.  
These values are measured from the lower left corner of the border with 
a starting coordinate of 0,0 and are listed in paper units, which in this 
case is inches. 
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7. On the Border and Title tab: 

 

 Notice the Cell option is toggled on. 
 Use the drop-down list to choose 12345 Plan Profile Border. 
 The Scale is set to 100. 

Your border will be scaled up 100 times around your graphics. 
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8. On the Symbols and Details tab: 

 

Note that a North arrow is automatically set.  It will be displayed 15 
inches over and 9.5 inches up from the lower left corner of the border. 
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9. On the Match Lines tab: 

 In the Symbology section, note the Plan Line, Plan Start 
Station and Plan Stop Station are already toggled on. 
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10. On the Main tab: 

 

 Set the Method to Plan Only. 
 Set the Plan Views to Use Station Limits. 

This will compute each plan view based on the station limits set on this 
tab. 

 Turn off Generate Sheets. 

This will allow you to set up the plan view first, then you can generate 
the sheets. 

 Set the Alignment to SH 86. 

The Start and Stop Station Limits should default to those of your 
alignment.  If they do not, use the drop-down under the Horizontal 
Alignment and actually <D> on the alignment name. 

The length is set by the preference at 1400 feet per sheet. 
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11. Apply and the Plan Views are generated. 

 Double-click on the first plan view in the list. 

 

Notice that its Stop Station is only 112+00, which is not the desired 1400 
feet. The Station lock has forced it to an even multiple of 1400, in this 
case 112+00. Next, you’ll turn off Station lock and recompute. 

 Close the Edit Plan View dialog. 
 Toggle off Station lock. 
 Apply again and choose Yes when prompted to overwrite the 

current plan views. 
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 Notice the first plan view is now 100+00 to 114+00. 
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12. Still on the Main tab. 

Now that the plan views are set the way you want, you can proceed with 
setting up and verifying other parameters on this tab. 

 

 Set the Method to Plan and Profile. 
 Set Plan View to Use Plan Views. 

This tells it to use the views as listed.  If you left it set to Use Station 
Limits, the edits to the plan views you just made would be wiped out. As 
it stands here, you would get the same results either way. If you had 
edited the stations manually, you would definitely want to Use Plan 
Views. 

 Toggle on Generate Sheets. 
 Toggle on VDF Information and Host Files. 

The VDF Information is found on the Sheet Index tab.  It lists each of 
the plan and profile sheets, their station range, plan rotation, etc.  

The Host Files are your actual plan and profile sheets. 
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Generate the plan and profile sheets 
Since profiles will be generated with the execution of this command, you are 
currently in a profile design 12345DES_Prof.dgn.  Double-check before 
continuing. 

1. In the Plan and Profile Generator dialog box, select Apply 

2. <D> anywhere in the design file (12345DES_Prof.dgn) to identify a 
location to plot the profile views. 

 

The profile views are plotted for each 1400’ of the proposed road and the 
plan and profile sheets are generated.  You should see them as they are 
composed.  In each sheet file the view is automatically rotated to 
horizontal, and the border and corresponding profile referenced. 
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View the plan and profile sheets 
Use the Plan/Profile Generator to view the sheet index and individual sheets. 

1. Select the Sheet Index tab on the Plan and Profile Generator box. 

 

 Highlight sheet number 1, then select Show Sheet. 

 

The 12345DES_PnP01.dgn file is automatically opened. 

 View other sheet files as desired. 
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Note:  The clipping boundary can be modified with MicroStation to 
show more of the design. After modifying it, choose Use 
Existing, then Show Sheet again and it will be ‘re-clipped’. 

2. Close the Plan and Profile Generator dialog box. 

3. When prompted “Save Current VDF file?“, choose Yes. Type in  
12345DES_PnP.vdf as the filename (do not choose a file from the list) 
and set the Save in folder to  
\ Design\Drawings and select Save. 
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Display proposed graphics 
1. Change the active design file back to the 12345DES_Prof.dgn file in the 

References folder. (File > Open in MicroStation) 

2. Display the proposed vertical alignment on the “mini” profile views 
created by the Plan and Profile Generator. 

 Select Geometry > View Geometry > Vertical 
Annotation. 

 Load the Proposed preference. 
 Choose Apply. 

 

Display Utilities on the profile 
Use the Update Profile command to view the culvert crossing information on 
the profiles.   
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Display the proposed contours for the new road surface 
1. Change the active design file to the 12345DES_Model.dgn file in the 

References folder. 

2. Make certain Style lock is off. 

3. Select Surface > View Surface > Contours. 

 Set Surface to D_SH 86 Finished-Grade. 
 Load the preference Proposed 10’ Mjr. 2’ Minor. 

4. Apply. 

5. Select Close. 
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Revisit the plan and profile sheets 
Use the Plan/Profile Generator to return to the sheet and view the updated 
graphics. 

1. Select Drafting > Plan and Profile Generator. 

2. Select the Sheet Index tab. 

 Select Sheet 1 from the list and select Show Sheet. 

The 12345DES_PnP01.dgn file is automatically opened.  

 

 

 View other sheets as desired 

3. To remove the clipping boundary, toggle off Constructions under 
MicroStation Settings > View Attributes. 

The clipping boundary does not plot, so turning it off is not necessary for 
plotting. 

4. Plot one of your plan and profile sheets. 

5. Exit MicroStation and InRoads.  If prompted to save geometry project, 
select No. 
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Challenge labs: 
1. Create an alternating set of plan and profile sheets for the same 

alignment. 

2. Change the clipping paths for one of your plans and plot the modified 
plan and profile sheet. 
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9. Final Modeling 
In the final modeling phase, you re-visit some familiar concepts.  Additional 
templates are included as needed, the template layers are adjusted as needed (with 
information from the Materials Engineer), and the Superelevation is reviewed and 
updated as needed.   

The main new concept that is introduced in this section is the use of decision tables 
for sideslope determination. 

Overview of Decision Tables 
Decision tables are made up of a series of records, each similar to a segment of a 
template, that defines a sideslope. A table can have more than one definition, and 
can have multiple targets — making it a very powerful tool in defining complex 
sideslopes.  

Template backbones are still used, but the decision tables take over at the hinge 
points to calculate sideslopes. The tables can also used with 3D graphical elements 
or features to calculate sideslopes, such as from ditch bottoms and ramps in gore 
areas.  This can be especially useful when creating models for intersections and 
interchanges. 

Decision tables are stored in the typical section library. CDOT has one default 
decision table stored in CDOT-Typical Sections.tml. When this file is copied into 
the project directory, the decision table may be copied and modified as needed. 
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Parts of a Table 
There are three main parts of a decision table. 

 

Records 
A record is a single line in a decision table made up of a starting TC name, an 
ending TC name, a slope and a width (along with other criteria discussed later). 
The TC names have several purposes, including: they become the feature names 
of the longitudinal breaklines resulting from running the table, and they also 
provide a method for the table to back-track to a previous location in the 
sideslope.  

Target Blocks 
A target block is a series of records that, together, seek one ‘hit’ of a target.  For 
example, you can create several records that make up cut and fill scenarios, but 
all seek the same existing ground surface, or target.  Within the target block, you 
can backtrack if one solution, such as a shallow fill slope, fails, and the next 
solution will be attempted.  

Processing occurs from the top down, evaluating each record in turn.  The target 
block continues processing until one segment meets the target.  Once a segment 
meets the target, the block is successful and no other records within that target 
block are evaluated.  Any records that were not lost to backtracking prior to 
hitting are placed along with the successful record. 

Note: A target block is successful and therefore stops if one of the 
records in the block meets its target. 

If no records in a target block meet the target, the block is unsuccessful and all 
records in the block are discarded.  If a record in the target block meets the 
target, the block is successful.  In either case, the table looks to see if any other 
target blocks exist in the group (see below).  If so, the next target block in line is 
processed (unless it is marked Attach After). 



 Chapter 9  Final Modeling 

 

Roadway Design Using InRoads  Page 333 

Groups 
One or more target blocks making up a mutually exclusive sideslope condition 
form a group.  Only one group in a decision table can be successful, since all 
processing stops when a group is successful.  

An example of mutually exclusive sideslopes broken into groups includes: 
testing with one group to see if a design surface is met, and with another group 
to see if the original ground surface is met, such as the case of a divided 
highway run at separate times. 

 Note: A group is successful ONLY if its last target block is successful. 
(Previous target blocks may also be successful.) 

Other previous target blocks may be successful also, but the last one must be. 
Once a group is successful, the processing ends at the current location.  

If the last target block in a group is unsuccessful, all previously successful 
records are discarded and the processing starts over again with the next group in 
the table.  If there are no more groups, the decision table fails and no sideslope is 
created at this location. 
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Building a Decision Table 
After creating several decision tables you will no doubt come up with your own 
methods for developing them.  Many times, existing tables are copied and modified 
to fit new conditions, saving time in the creation and testing process.  The following 
steps define a good path to follow when starting out with decision tables, and one 
that you can modify to fit your needs as your proficiency increases.  

The building of a decision table is an iterative process and may require trial and 
error.  When starting with the path outlined, keep in mind your initial division of 
target blocks and groups may need to be amended as additional variables are 
uncovered in the design process. 

1. The best method of starting a decision table is to sketch the desired sideslope 
results.  When completing the sketch or sketches, try to think of as many 
existing conditions as possible, and the sideslopes that will best fit the 
conditions.  Typically, you will need sideslopes for both cut and fill (at a 
minimum).  

2. The next step in building the table is to break the sideslope conditions into 
groups, or mutually exclusive designs.  In a very simple table only one group 
may be necessary, since both cut and fill can be addressed in the same group and 
the same target block.  

Note:  When breaking sideslopes into groups, keep in mind only one 
group is successful at any given location, so a group must 
contain a complete sideslope definition. 

3.  After determining the different groups required, each group must be broken 
into target blocks.  A target block is allowed only 1 “hit”, or interception with a 
target, so one must be developed for each instance a target is reached in a 
sideslope.  For example, you may have a fill slope extend to the existing ground 
(target 1), then continue and place a ditch at the toe of slope, coming back and 
intercepting the same existing ground again (target 2). 

4. With the preliminary work done, the next step involves creating the table.  
Since decision tables may be very complex, it’s always a good idea to test the 
table as you go.  Build one group (or even one target block) and display the table 
or test it on a small section of roadway where you know it should work.  This 
will help spot problems when it’s easier to determine the cause. 
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The Decision Table Interface 
Decision tables are stored in typical section libraries.  They are built record by 
record through a dialog interface, which can also be used to edit the table later. 
When developing each record, criteria are used to determine how the record will 
react under certain conditions.  

                                   

 

Each of the criteria is described below. 

New Target – The record starts a target block; new target is turned on once per 
target block, in the first record of the block. 

New Group – Indicates the beginning of a new sideslope definition. 

Target Type – What the target block is seeking; options are: DTM, Align Elevation 
(vertical alignment), Align XYZ (horizontal and vertical alignment), Align XY 
(horizontal alignment), Feature Elevation, Feature XY, Feature XYZ, and 
Elevation. 

Target – The name of the target being sought by the target block (e.g. the DTM 
name). 

Elevation Adjustment – An offset for the target; i.e., For a DTM, it has the effect of 
transforming the ground surface by the specified vertical offset. 

Start TC – Transition control name for feature name, symbology and backtracking. 

End TC – Transition control name for feature name and symbology. 
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Slope – Slope of the line defined by the record. 

Width – Horizontal distance the record will extend if no target is met. 

Seek Intersection – Indicates the record will stop if it meets the specified target. 

Attach After – The record is only used if the previous target block in the same 
group is successful. 

Construct Point – The point found at the end of the record will be used in the 
resulting DTM. 

Start Repeat Cycle – The record is the beginning of a repetitive series. 

 

It is beneficial to display the decision table during the building process to check the 
records for problems with slopes and connectivity. Display a decision table using 
Display from the main decision table dialog. 

Note: The display uses the attached color table and beginning with 
color 1, changes colors with each target block. Within the target 
block, if there is backtracking, each record displays with a 
different line style, beginning with line style 0. 

 



 Chapter 9  Final Modeling 

 

Roadway Design Using InRoads  Page 337 

Target Options 
One of the most powerful functions of a decision table is the ability to seek an 
intersection with targets other than DTMs.  With this benefit, you can accomplish 
the equivalent of independent control outside the backbone of your template, along 
with other equally complex sideslopes.  

The eight available targets are:  Surface, Fixed Elevation, Align Elevation 
(vertical alignment), Align XYZ (horizontal and vertical alignment), Align XY 
(horizontal alignment), Feature Elevation, Feature XYZ and Feature XY.  

 

The New Target option is toggled on whenever you are changing targets and/or 
when the previous target block has already hit its target.  For example, when 
creating berms at the top of cut, or toe-of-slope ditches, your initial DTM target 
may be the same as the DTM intercepted with the ditch or berm.  In instances 
where the additional target is only used if the previous one is successful, the Attach 
After Intersection option is also toggled on. 



Colorado Department of Transportation 

 

Page 338  Roadway Design Using InRoads 

Running a Decision Table with Roadway Modeler 
The most common use of decision tables is to define sideslopes along a roadway 
corridor.  This is done using Roadway Modeler, just like using template, cut/fill 
table or material table sideslopes.  

                                     

In the roadway definition, the Catch Point is set to Decision Table and a decision 
table selected from the drop-down list.  When the roadway is modeled, the decision 
table picks up at the hinge point with its calculations and the cut and fill portions of 
the template are ignored. 

In some situations, a different decision table is needed on each side of the roadway.  
For these times, the roadway definition mode is set to Left and Right and a different 
decision table listed for each.  You can also specify a decision table for one side and 
one of the other sideslope alternatives (cut/fill or material table, or template) for the 
other. 

The results of running decision tables with Roadway Modeler are twofold.  First, 
a DTM is created just like when the sideslopes are calculated with templates.  
Second, graphical elements are created longitudinally by connecting like TC points 
in the tables from template drop to template drop.  These longitudinal lines are 
actually the features that are part of the resulting DTM, and are named according to 
the TC names in the table, just as they are with the template. 

Note: In order to see the features created by Roadway Modeler, the 
TC name’s Feature Style must have the 3D Plan/Display 
toggled on and the Transition Control Lines Display option must 
be turned on in Roadway Modeler (on the Advanced tab). 
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Lab 9 – Final Modeling 

Start InRoads 
1. Start InRoads and open CU12345DES_Model.dgn from the 

\Design\Working folder. 

Open your InRoads data files 
1. Select File > Open. 

 

2. Ensure the Files of Type option is set to Projects (*.rwk). 

3. Double-click on 12345DES.rwk. 

Double-clicking is the equivalent of highlighting the file and choosing 
Open. 

4. Cancel the dialog. 
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Update your typicals 
In the next series of steps, you will update the 2 and 4-lane typicals you 
created earlier.  Since the templates were originally defined with multiple 
layers, you can adjust the layers for the desired pavement and subgrade 
depths. 

1. Select Modeler > Define Typical Sections. 

2. On the Templates tab, choose SH 86 1L-1L Rural and Edit. 

3. On the Layer tab,  

 Select D_SH 86 Base-Course-Top. 

You have learned that the Base Course Top needs to be a depth of 5”. 

 Key in a vertical offset of -5” and Tab on your keyboard. (If 
you use the ” it will automatically be converted to feet.) 

 Select Update to have the change take affect. 
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4. Also on the Layer tab,  

 Select D_SH 86 Subbase-Top 

You have learned that the Subbase-Top needs to be a depth of 7”. 

 Key in a vertical offset of -7” and Tab on your keyboard. (If 
you use the ” it will automatically be converted to feet.) 

Notice the depths you key in are from the vertical alignment – not from 
the previous layer. 

 Select Update to have the change take affect. 

 



Colorado Department of Transportation 

 

Page 342  Roadway Design Using InRoads 

5. Also on the Layer tab,  

 Select D_SH 86 Subgrade-Top 

You have learned that the Subgrade-Top needs to be a depth of 10”. 

 Key in a vertical offset of -10” and Tab on your keyboard. 
(If you use the ” it will automatically be converted to feet.) 

 Select Update to have the change take affect. 

 

6. Repeat these steps for the 4 lane template, SH 86 2L-2L Rural. 
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Model the roadway 
1. Ensure Write lock is on. 

2. Ensure Report lock is on. 

3. Set the mode to Pencil. 

4. Ensure Station lock is on. 

  

 

5. Delete all TC lines (features in plan) from the previous Modeler runs. 

6. Select Modeler > Roadway Modeler. 
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Confirm and set additional design parameters.  

7. Select the Advanced tab. 

 

 Verify the design parameters – be certain to set the 
Superelevation to All Layers. 

 Set the Subgrade Intercept to First Layer. 

8. Select the Layers tab. 

 Toggle off Use Layer Controls. 

Now that you have established the additional layers, you’ll model all. 
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9. Back on the Main tab, make certain the: 

 

 Horizontal Alignment is set to SH 86. 
 Vertical Alignment is SH 86 V. 
 Highlight the Roadway Definition SH 86 transition. 
 Under the Original Surface list, highlight only  

12345 existing ground. 
 Toggle off Create Cut and Fill Features. 

10. Select Apply. 

The templates are applied along the alignment as defined in the roadway 
definition and superelevation is applied as it was calculated.  This time, 
new surfaces are created for the Finished Grade, Base-Course-Top,  
Subbase Top and Subgrade Top. 

11. Select Close to dismiss the Roadway Modeler box. 

 



Colorado Department of Transportation 

 

Page 346  Roadway Design Using InRoads 

Save the new surfaces 
1. Right-click on D_SH 86 Finished-Grade in the Workspace (Explorer) 

portion of the InRoads menu. 

2. Select Save. 

3. Right-click on D_SH 86 Base-Course-Top in the Workspace (Explorer) 
portion of the InRoads menu. 

 

Since this surface has never been saved, the Save As dialog appears. 

  

4. DO NOT choose Save until you verify that the Active Surface is set to 
D_SH 86 Base-Course-Top and the file name is correct! (Remember to 
add the 12345 project code to the File name). 



 Chapter 9  Final Modeling 

 

Roadway Design Using InRoads  Page 347 

5. Repeat for the D_SH 86 Subbase-Top surface,  

 
 
and D_SH 86 Subgrade-Top 
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6. Choose File > Save As if you closed it. 

 Set the Save as type to Projects *.rwk. 
 Click on 12345DES.rwk. 
 Choose Options. 
 On the Surfaces tab, click on Add and Update for the three 

new surfaces (Base-Course-Top, Subbase-Top and 
Subgrade-Top). 

 

7. Choose OK 

8. Choose Save on the Save As dialog and overwrite the current .rwk. 
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Update the Cross Sections. 
Since you already have a set of section for the roadway, you can just 
update them with the new surfaces instead of creating a whole new set. 

1. Make sure you’re in a top view, then Fit. 

2. Choose Evaluation > Cross Section > Update Cross Section. 

Choose the Cross Section Set that contains your previously cut full set of 
section.  You can tell which one you select by the box that’s drawn 
around the set.  

You can Refresh or toggle Off items that are currently displayed on the 
sections.  You can toggle On items that are not currently displayed. 

 Set the Mode to Refresh. 
 Toggle on Surface in the Object category. 
 Highlight Finished Grade. 
 Choose Apply. 
 Set the Mode to Display On. 
 Toggle on Surface in the Object category. 
 Highlight Base-Course-Top, Subbase-Top  

and Subgrade-Top 

 

 Choose Apply. 

The new surfaces are displayed in the cross sections. 
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3. On the Cross Section toolbar, select the Cross Section Viewer 
command. 

 Set the Cross Section Sets option to the cross section set 
you just updated. 

 Set the Time to 0.5 sec. 

4. Select Run. 

Watch for the sections through the curve to see the subgrade surfaces 
superelevate. 

 

5. Close the Cross Section Viewer dialog. 
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Create a decision table 
There are often times when the simple cut and fill slopes created by 
using the template do not meet all of the necessary design criteria.  
Often, to meet the criteria, you must use a decision table.  There are 
several decision table in the CDOT standard typical section library that 
you can copy and modify.  However, to promote learning of the decision 
table concepts, you are going to create one from scratch. 

 

1. The following criteria must be met for your sideslopes: 

Cut Slopes 
Slope 6:1 where Cut is 5’ or less 

Slope 4:1 where Cut is 5’ to 10’ 

Slope 3:1 where Cut is 10’ to 15’ 

Slope 2:1 where Cut is over 15’ 

Fill Slopes 
Slope 6:1 where Fill is 5’ or less 

Slope 4:1 where Fill is 5’ to 10’ 

Slope 3:1 where Fill is 10’ to 15’ 

Slope 2:1 where Fill is over 15’ 

 

2. Sketch the decision table before proceeding. 
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Create a name for the decision table.  
1. On the Design Roadway toolbar, select Define Typical Sections. 

2. Select the Decision Tables tab. 

 

 Select New. 
 Enter the Name:  Variable Cut and Fill 
 Enter the Description: Variable slope in cut and fill 

3. Select Apply, then Close. 
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Define the cut slopes. 
1. Select Variable Cut and Fill from the available list. 

 

2. Select Edit. 
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Define the first record  

3. Select Add After. 

 

4. First, set the Target information: 

 Toggle on  New Target 
 Toggle on New Group 
 Toggle the Target Type to Surface 
 Toggle the Surface to 12345 existing ground 

5. Next, set the Segment Information: 

 Start TC Name:   POSS 
 End TC Name:   Top-of-Cut 
 Slope: 1:6  
 Width:  30  (which corresponds to a 5’ depth) 
 Toggle on: Construct Point and Seek Intersection 
 Toggle off: Attach After … and Start Repeat Cycle 

6. Choose Apply 
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Define the second record while in the Decision Table Record dialog 

 

7. First, set the Target information: 

 Toggle off  New Target 
 Toggle off New Group 

This segment is part of the same target block and therefore must not have 
either of these toggled on. 

8. Next, set the Segment Information: 

 Start TC Name:   POSS 
 End TC Name:   Top-of-Cut 
 Slope:   1:4  
 Width:   40  (which corresponds to a 10’ depth) 
 Toggle on: Construct Point and Seek Intersection 
 Toggle off: Attach After … and Start Repeat Cycle 

9. Choose Apply. 
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Define the third record 

 

10. First, set the Target information: 

 Toggle off  New Target 
 Toggle off New Group 

This segment is part of the same target block and therefore must not have 
either of these toggled on. 

11. Next, set the Segment Information: 

 Start TC Name:   POSS 
 End TC Name:   Top-of-Cut 
 Slope:   1:3  
 Width:  45  (which corresponds to a 15’ depth) 
 Toggle on: Construct Point and Seek Intersection 
 Toggle off: Attach After … and Start Repeat Cycle 

12. Choose Apply. 
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Define the fourth and final record in the cut group 
Be certain to use a large width, since the last record must be able to catch 
when all previous records have failed. 
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Define the first record in the fill group 

 

13. First, set the Target information: 

 Toggle on  New Target 
 Toggle on New Group 
 Toggle the Target Type to Surface 
 Toggle the Surface to 12345 existing ground 

14. Next, set the Segment Information: 

 Start TC Name:   POSS 
 End TC Name:    Toe-of-Fill 
 Slope:     -1:6  
 Width:   30  (which corresponds to a 5’ height) 
 Toggle on: Construct Point and Seek Intersection 
 Toggle off: Attach After … and Start Repeat Cycle 

15. Choose Apply. 
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Define the other fill records from the table 
Don’t forget, the fill slopes must be negative. 

 

16. Choose Close on the Edit Decision Table dialog. 

Note:  The cut and fill are in separate groups so they can easily be 
distinguished when editing or reviewing the table. However, they 
could also be in the same group as long as they are in the same 
target block. 

17. Close the Define Typical Section dialog. 

Save the decision table 
The decision table is stored in the typical section library. 

1. Choose File > Save > Typical Section Library. 
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Create a new roadway library entry 
You will copy the existing roadway definition file and then modify the 
copy to use the decision table created in the previous steps. 

1. Select Modeler > Define Roadway. 

2. Highlight the roadway definition SH 86. 

 

3. Select Copy. 

 

 In the To category, enter the Name:  SH 86 with dec 
table. 

 Enter the Description:  Variable slope dec tab. 
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4. Select Apply, then Close. 

 

Edit the copied roadway definition entry to use the decision table 

5. From the Define Roadway dialog box, 

 Highlight the new roadway definition, SH 86 with dec 
table. 

 Select Edit. 
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6. Select the first station in the list and select Edit. 

 Set the Catch Point to Decision Table. 
 In the Name field and select Variable Cut and Fill from the 

drop-down list. 

 

7. Select Apply. 

8. Select Next to move to the next station entry in the list. 

9. Continue for all the stations that have a Catch Point of Template, 
setting: 

 Catch Point to Decision Table and Name to Variable Cut 
and Fill – Apply after each, then choose Next. 

 WARNING: Don’t change the Catch Point for the 
sections that are Backbone Only! 

10. When complete, select Close to dismiss the Roadway Entry dialog box. 

11. Select Close to dismiss the Edit Roadway dialog box. 

12. Select Close to exit the Define Roadway box. 

 

Save the roadway definition 
1. Select File > Save > Roadway Library. 

2. The file 12345DES.rwl is saved to the hard drive. 
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Run Roadway Modeler 
Before processing Roadway Modeler again, clean up the design file 
and make your lock settings. 

1. Delete any contours from the previous Roadway Modeler run. 

2. Delete any Transition Control lines from the previous run. 

3. Ensure Write lock is on. 

4. Ensure Station lock is on. 

5. Select Roadway Modeler and choose the Report tab to set the report 
options. 

 Toggle on Generate Binary Report. 
 Select Browse, navigate to the \Design\InRoads and key in 

roadwaymodeler.bin. 
 Select Save. 
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6. Choose the Advanced tab and make certain Empty Design Surface is 
toggled on.   

7. Back on the Main tab, select the data to be used by Roadway Modeler.  

 

 Under the Roadway list select SH 86 with dec table. 
 Under the Original Surface list highlight only  

12345 existing ground. 

8. Select Apply. 

The templates are applied along the alignment using the decision table to 
determine the sideslopes. A new surface is created for each layer in the 
templates applied to the design. 

9. Select Close to dismiss the Roadway Modeler dialog box. 
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Save your new surfaces 
1. Save the finished grade surface created with Roadway Modeler to the 

hard disk. 

2. Select File > Save > Project. 

The surfaces are part of the project now, so they are saved and the old 
finished and subgrades are overwritten. The surfaces could also have 
been saved individually using the File > Save As command, or by right-
clicking them in the InRoads Explorer menu. 

 

View the results of Roadway Modeler 
1. Zoom in or out as needed with MicroStation to visually review the 

display of the Transition Control (TC) lines.   

 

Display the triangles for the proposed surface 
1. Select Surface > View Surface > Triangles. 

2. Set the Surface to D_ SH 86 Finished-Grade. 

3. Select Apply then Close. 

4. Use the MicroStation View Control commands to take a closer look at 
the display.  (Try rotating a view to see the variable slopes.) 

5. Use MicroStation Delete Element to delete the triangle display (graphic 
group lock on). 

 

View contours for the proposed surface 
1. Select Surface > View Surface > Contours. 

 Set the Surface to D_ SH 86 Finished-Grade. 
 Select Preferences and load Proposed 10’ Mjr. – 2’ Minor. 

2. Select Apply. 

3. Use MicroStation View commands to take a closer look at the contours. 

4. Use MicroStation Delete Element command to delete the contour 
display. 

Remember that the contour display is a graphic group. 
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Update the Cross Sections 
1. Using what you have previously learned, Update the sections with the 

new surface information. 

2. Run the Cross Section Viewer. 

Watch for the sections through the curve to see the superelevation and 
through the turn lane are to see the widening.  Also watch for the 
sideslopes to change as defined by the decision table. 

3. Close the Cross Section Viewer dialog. 

 

Drive the roadway 
1. Select Modeler > Drive Roadway. 

2. Highlight the Horizontal Alignment SH 86. 

3. Highlight the Vertical Alignment SH 86 V. 

4. Choose Run. 

5. Close the Drive Roadway dialog. 

6. Set your view back to Top. 

7. Exit MicroStation. 

Challenge labs: 
1. Use the Urban-4-Ln template to create SH 86 1L-1L Urban.  

 Copy your roadway definition 
 Transition to the Urban section between 353+54.99 and 

353+55.00 
 Keeping the bridge as backbone only, carry the Urban 

section through the end of the project. 

2. Create a decision table that uses a vertical alignment to define a ditch. 

3. Create another decision table of your choosing. 
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10. Final Sections 

Features on Sections 
Both triangulating features and non-triangulating features can be shown on the 
cross sections.  On the Features tab, toggle on Include Features and choose the 
features you want to show.  The feature’s style must allow Cross Section Point 
display. 

 

Features that are shown on cross sections are available for annotation and editing. 
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Annotating Cross Sections 
Several annotation options are available for cross sections.  Points can be annotated 
with offsets and elevations, Segments can be annotated with slopes, slope length 
and/or horizontal widths, and Features can be annotated with offset, elevations, and 
you choice of feature name, description or style. 
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Updating Existing Sections 
Cross sections retain their association with the surfaces and features they display 
and therefore you can update the sections when any new information is available. 
For example, you may realize that you need to add a utility line into the DTM.  
Rather than cutting a new set of sections to show the addition, select  
Evaluation > Cross Section > Update Cross Section.  From this dialog, you can 
either update the entire set of sections or a range of sections.  The update can 
involve refreshing items that have already been displayed on the sections, turning 
those items off, or turning on items not currently displayed. 

 

Always use this command to turn off features displayed from a design surface 
before running Roadway Modeler and creating the same surface.  Otherwise, the 
features will not be recognized by the new surface so you will not be able to turn 
them off or update them later. 
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Lab 10 – Final Sections 

Start InRoads 
1. Start InRoads and open CU12345DES_Model.dgn from the 

\Design\Working folder. 

Open your InRoads data files 
1. Select File > Open. 

 

2. Ensure the Files of Type option is set to Projects (*.rwk). 

3. Double-click on 12345DES.rwk. 

Double-clicking is the equivalent of highlighting the file and choosing 
Open. 

4. Cancel the dialog. 
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Create a new design file for your cross sections 
1. Select File > New. 

2. Navigate to the \Design\Drawings\Cross_Sections folder. 

3. Key in the Name 12345DES_XSec.dgn 

4. Choose OK. 

This creates the new design file and automatically opens it for you. 

Prepare a cross section border 
There is a generic border in your cell library.  In the next series of steps, you 
will import that cell as a model into your cross section design file and modify it 
with project-specific information. 

1. On the MicroStation menu, select File > Models. 

2. On the Models dialog, select Import Models. 

 

 

 Change the List Files of Type to All Files (*.*). 
 Navigate to the C:\Program Files\Workspace-

CDOT\Standards-Global\MicroStation\Cell folder. 
 Choose General.cell and then select OK. 
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 On the Select Models dialog, choose SHEET_Design-Sheet 
then OK. 

 

The cell is imported into your active design file, 12345DES_XSec.dgn 
and shows up in your Models dialog. 

 

 Right-click on SHEET_Design-Sheet and change the name to 
SHEET_12345DES_XSec. 

3. Close the Models dialog. 
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4. Window into the title block and use MicroStation Edit Text to change 
any of the generic information you want. 

 

5. Use the CDOT Menu to add the Resident Engineer’s cell to the border 
like you learned in the previous Plan and Profile chapter. 

 

Hint: Set the Scale to 1 before Applying. 
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6. Return to the CDOT  Default Model using the View Groups in the lower 
left of your screen. 

This is very important! If you do not have the View Groups in the lower 
left of your screen, ask your instructor for assistance! 

 

 

 

 

 

Verify you are in the CDOT Default model by checking the top left of 
the View window. It should look like the one pictured above. 
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Attach the design file as a cell library 
Since any design file can be used as a library, you will now attach the file you 
just placed and customized the border cell in as a cell library itself. This allows 
you to use the customized cell as the border for your cross sections. 

1. On the MicroStation menu, select Element > Cells. 

 

2. Toggle off Display All Cells in Path. 

3. Select File > Attach and navigate to the C:\Projects\12345\ 
Design\Drawings\Cross_Sections folder. 

4. Change the Files of Type to MicroStation DGN Files (*.dgn). 
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5. Choose 12345DES_XSec.dgn and OK. 

 

Your design file is now attached as a cell library, allowing you to place the 
modified border as a cell when creating cross sections in the next series of steps. 
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Cut Cross Sections 
1. Make certain Write and Station locks are on, and that you are in Pencil 

mode. 

2. Choose Tools > Options > Factors and set the Text Scale Factor to 40, 
then Apply. 

3. If you have closed your Cross Section toolbar, then select Tools > 
Customize > Cross Section, then Close the Toolbars dialog. 

4. On the Cross Section toolbar, select Create Cross Sections. 

 

 

5. Choose Preferences and load 40H 20V 240’ Wide. 

 



 Chapter 10  Final Sections 

 

Roadway Design Using InRoads  Page 379 

6. On the Main tab, 

 Set the Source to Alignment and select SH 86. 

7. On the Controls tab, 

 Notice the Vertical Exaggeration is 2. 

8. On the Spacing tab, 

 Set the Cell Name to SHEET_12345DES_XSec. 

 

9. On the Report tab, 

 Turn on Generate Binary Report 
 Click in the Name field and Browse.   
 Set the folder to \12345\Design\InRoads 
 Key in section.bin and Save. 
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10. Apply and <D> for the lower left corner of the first cross section. 

 

11. Zoom in to the section set. 

Notice that the sections are placed inside sheets and the cell you 
modified is used as the border.   

12. Fit your MicroStation view and make certain you have only one set of 
cross sections. 

View the cross sections that are plotted in the design file 
1. On the Cross Section toolbar, select the Cross Section Viewer 

command. 

The Cross Section Sets option should list only one set of sections. 

 

2. Set the Time to 0.5 sec. 

3. Select Run. 

 You can stop the viewer by pressing the <ESC> key on your 
keyboard. 

4. Close the Cross Section Viewer dialog. 

5. On the MicroStation menu, select File > Save Settings. 
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Annotate sections 
1. Window in to the 131+00 cross section. Hint: Use the Cross Section 

Viewer. 

Using the following command, you can annotate all of your sections with 
the desired information at one time.  However, you will first annotate one 
section to ensure you are satisfied with the results before annotating the 
complete set. 

2. Ensure the Write lock is on. 

3. Ensure you are in Pencil mode. 

4. Ensure the Style lock is off. 

If the Style lock is on, it will control the symbology of the annotation 
when annotating features, forcing them to use the Named Symbology 
assigned to each features.  With it off, you will be able to control the 
symbology directly from the Annotate Cross Section dialog. 

5. Select Annotate Cross Sections. 
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 Select Preferences and Load the Existing Gnd CL only 
preference. 

 Set the Surface to 12345 existing ground. 
 Toggle on Points. 
 Toggle on Single in the Sections area. 

6. Apply, then <D> on the cross section in your view. 

 

Notice only the CL elevation is annotated.   

7. Select Preferences and Load the CDOT preference. 

 Set the Surface to 12345 existing ground. 
 Toggle on Points. 
 Toggle on Single in the Sections area. 

8. Apply, then <D> on the cross section in your view. 

 

Notice the CL elevation is deleted (if you are still set to 12345 existing 
ground as the surface) and all points on the existing ground are 
annotated.  The original annotation is deleted because it was placed in 
Pencil mode.  If you wanted to keep it and annotate all other point, you 
could have switched to Pen mode first, then if desired, back to Pencil for 
subsequent annotations. 
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9. Set the Surface to D_SH 86 Finished-Grade. 

10. Apply, then <D> on the cross section. 

 

Notice the Finished Grade annotation is added to the existing annotation.  
Since you are annotating two different surfaces, it does not erase the first 
display, even though it was created in Pencil mode. 

11. Delete the annotation. 

Since the annotation is just graphical, you can use MicroStation delete 
(with Graphic Group lock On) or you can use the MicroStation Undo 
command. 

12. Select the Points tab. 

 

 This tab controls the annotation when you are in Point mode.  
Experiment with the different options and re-annotate to see 
the results. 
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13. Delete the annotation when you are done. 

14. Select the Main tab. 

 

 Toggle off Points and toggle on Segments. 

15. Apply, then <D> on the cross section. 

 

Notice that the segments are annotated with the slope.  This annotation is 
controlled by the Segments tab. 
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16. Select the Segments tab and experiment with some of the options. 

 

17. Delete the annotation when you are done. 

18. Close the Annotate dialog. 
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Using features with cross section annotation 
The display of features on the cross sections can greatly enhance the ability to 
annotate sections. 

1. Select Update Cross Section. 

 

 

 Set the Mode to Display On. 
 Toggle on the Object Feature. 
  Highlight the Surface D_SH 86 Finished-Grade. 
 Select All. 
 Hold your <CTRL> key down and select the Exterior 

Boundary to ‘un-highlight’ it. 
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2. Apply, then Close. 

 

The cross section set is updated with location cells for each of the 
features in the proposed Finished Grade DTM. 
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3. Select Annotate Cross Section. 

 Set the Surface to SH 86 Finished-Grade. 
 Toggle off Segments and toggle on Features. 

Note that all of the features you just displayed on the cross sections now 
show up in the Features area. 

 Select All next to the Feature list. 
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4.  Select the Features tab. 

 

 Toggle on Offset and Elevation. 
 Toggle off Property. 

5. Apply and <D> on the cross section. 

 

6. Review the annotation, then use MicroStation to delete it (do not delete 
the location cells (names) – just the offset and elevation annotation). 
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7. Select the Main tab. 

 Highlight just the edges of pavement. 

8. Apply and <D> on the cross section. 

 

Note that this time, only the edges of pavement are annotated.  
Annotating features allows you to control which points are annotated and 
only annotate those you need, rather than all. 

Features also allow you to annotate just the segments you want.  For 
example, if you only need to annotate the sideslope segments, you can. 
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9. Select the Main tab. 

 

 Toggle off Features and on Segments 
 Highlight the features for the backbone as shown. 

(Centerline, LT_Laneline, LT_Edge-of-Pavement, 
RT_Laneline, RT_Edge-of-Pavement) 

10. Apply and <D> on the cross section. 
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11. Select the Tolerances tab. 

 Change the Slope setting to 0.01%. 

This will annotate adjacent slopes that are identical only once.  

12. Apply and <D> on the cross section. 

Notice that the adjacent segments are annotated once. 

 

13. Close the Annotate Cross Section dialog. 
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Cutting skewed sections 
1. Return to your working design file 12345DES_Model.dgn. 

2. Draw a few lines that cross the roadway similar to those shown. 
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3. Make a selection set out of the MicroStation lines by using the Element 
Selection tool, holding down your <CTRL> key and choosing each of the 
elements.  Make certain you do not get additional lines. 

 

4. Select Evaluation > Cross Section > Create Cross Section. 

 Choose Preference and load the Stacked 20 per column 
preference. 

 On the Custom tab, choose Add Graphics. 

 

This adds the graphic lines from the selection set as locations to cut 
sections. 

5. Select Export. 

6. Key in a name of 12345DES_SkewSec.xsc 

This will save the skewed cross section setup to an ASCII file that can be 
Imported later to re-create the section set without the original 
MicroStation lines.  Do not close the Create Cross Section dialog yet. 

7. Choose Apply and <D> for the location of the lower left corner of the 
cross section set. 

8. Close the Cross Section dialog. 
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Notice this cross section’s sideslopes do not appear correct – it has a 
break in the slope.  This is because the cross sections were cut based on 
triangles and therefore show the slope of individual triangles.  You may 
or may not see this in any of your skewed sections. If you do, you can 
remedy this problem by using only the features to create the sections.  
This option can be used on all cross section sets, not just these skewed 
sections.  Just remember, the cross sections will no longer reflect exactly 
what the DTM triangles define. 
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9. Select Surface > Surface Properties. 

 

 Set the Surface to D_SH 86 Finished-Grade. 
 On the Advanced tab, toggle on Use Feature Only. 

10. Apply. 

11. You may want to repeat for each of the proposed surfaces. 

You typically do not want to turn this on for existing surfaces! 
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12. Update the surfaces on your skewed cross sections and review the 
results. 

 

Challenge labs 
1. Plot one of your cross section sheets if a plotter is available. 

2. Show the utility lines on the cross sections and annotate them. 

3. Create additional custom sets of sections. 
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11. Visualizing the Project in 3D 

Drive Roadway 
The Drive Roadway command is an Application Add-in with InRoads.  After 
toggling it on under Tools > Application Add-ins, it becomes an option on the 
Roadway Modeler pulldown and toolbar. 

 

Drive Roadway has two primary functions.  First it can be used to draw a 3D 
linestring along the alignment (using the Display option).  This display can be used 
with MicroStation Fly-through or other rendering software to define a camera path 
for creating a movie.  The vertices on the linestring represent camera positions to 
achieve the desired frames per second and travel speed. 

Second, the Drive Roadway can be used as a visualization tool itself (using the 
Run option).  It does not provide a rendered image, but a wireframe ride down the 
road.  (The exception is if the view is set to display a rendered image and triangles 
or shapes are displayed.  However, the drive is not a smooth, movie-like image such 
as you would get from a MicroStation Fly-through.)  The more frames per second 
and the slower the speed, the smoother the resulting image during the drive, but the 
more likely your hardware will not be able to display it adequately.  
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Rotated Views 
MicroStation 3D allows a view to be rotate to any position, which can be used to 
evaluate the design model.  Select the View Rotation command at the bottom of the 
MicroStation view.  If you snap to a point before beginning the rotation, that point 
will stay centered in the view.   

If there are triangles displayed, the view may be rendered using one of the 
MicroStation rendering commands.  To create more realistic rendered images, you 
can assign materials to the triangles (or shapes, see Visualization tool section), 
assign lighting characteristics, and even match the model to a photo of the site.  See 
the rendering section of MicroStation Help for additional information. 
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InRoads Visualization 
The Visualization command in InRoads – also an Application Add-in – simplifies 
the rendering process by creating color-coded shapes for the design model based on 
the features.  Since the shapes are colored based on the symbology assigned to the 
feature styles, you may need to modify the colors in order to get the desired look for 
the model. 
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Lab 11 – Visualizing the Project in 3D 

Start InRoads 
1. Start InRoads and open CU12345DES_Model.dgn from the 

\Design\Working folder.    

Open your InRoads data files 
1. Select File > Open. 

 

2. Ensure the Files of Type option is set to Projects (*.rwk). 

3. Double-click on 12345DES.rwk. 

Double-clicking is the equivalent of highlighting the file and choosing 
Open. 

4. Cancel the dialog. 
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Create a new design file for your visualization displays 
1. Select File > New on the MicroStation menu. 

 

 Navigate to the \ Design\Working folder. 
 Key in a name of CU12345DES_Vis.dgn. 

2. Choose OK. 

3. View the triangles for D_SH 86 Finished-Grade. 
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Rotate the View  
1. Select the MicroStation View Rotation command and rotate the view.  

Hint:  It is easier if you start from an ISO view, and remember, if you 
snap to a point after picking the command, that is the point you’ll be 
rotating about. 

 

You can also use Change View Perspective. 

 

 

2. When you’ve rotated to a view you are satisfied with, choose Utilities > 
Render > Phong on the MicroStation menu, then <D> in the view. 
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3. If the rendering appears too dark, choose Settings > Rendering > 
Global Lighting. 

 

 Toggle on Solar and choose the drop-down arrow next to the 
toggle. 

 Toggle off the Solar Direction Vector lock. 
 Choose Map under Location and click on a location on the 

map. 
 Set the time you would like. 

4. Close the Global Lighting dialog and Render the view again. 

Note: If you would like to see more definition of the roadway, you can 
display the features with the exception of the exterior. If you 
display the exterior, since it is a closed shape, it will be rendered 
as a whole. 
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5. Select Settings > Rendering > View Attributes. 

 

 Set the Display to Pong Shading. 
 Toggle on Graphics Acceleration. 

6. Choose Apply. 

7. Choose View Rotation again and this time make sure Dynamic Display 
is on. 

8. Snap to a point in the road, then move your cursor to rotate the view.  
When you accept the rotation, it will be shaded. 

Drive the Roadway 
1. Use Modeler > Drive Roadway to see the rendered image as you drive. 

Hint: If you don’t have Drive Roadway on your menu, toggle it on first with  
Tools > Application Add-ins. 

2. Experiment with different vertical offsets to see the difference in the 
Drive Roadway command. 

3. Delete the triangle display. 
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Display the surface with InRoads Visualization  
1. This command uses the surfaces features to create a color-coded display 

of the roadway.  The segments from the template are color-coded based 
on the color of the feature.  Using the CDOT standard preference (.ini) 
file, this results in a purple, red and yellow roadway.   

2. Use Surface > View Surface > Features to view the features (except 
the Exterior Boundary). 

3. Choose Tools > Application Add-ins and ensure Visualization is 
toggled on. 

4. Select Surface > View Surface > Visualization. 

 

 Choose the Surface D_SH 86 Finished-Grade. 
 Choose the Alignment SH 86. 
 Key in an interval of 50. 
 Toggle on Station Limits and set the Start to 175+00 and 

the Stop to 275+00. 
 Highlight all of the features except Exterior Boundary. 

5. Choose Apply. 

6. When the processing is done, Drive Roadway again to see its new 
colors. 

Challenge lab 
1. Use the perimeter of the proposed finished grade as an interior on a copy 

of the existing surface.  Then display triangles for the existing, visualize 
the finished grade and render the combination.  You can also drive the 
roadway with this display. 
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12. Generating Project Quantities 
The surfaces generated by Roadway Modeler (or other design methods – see the 
intersection modeling chapter) are used to calculate volumes. There are four 
methods of volume calculations in InRoads: Triangle, Triangle by Station, Grid, 
and End-area, with the latter being the standard for CDOT highway design and the 
other methods being used where conditions warrant, or as checks. 

 

Triangle 
The Triangle volume command compares two surfaces, listed as original and design 
surfaces.  The Cut and Fill Factors are applied to the totals of cut and fill and the 
results consist of overall cut, overall fill and cumulative volumes. 

 

Grid 
The Grid volume command compares the two surfaces, listed as original and 
design, based on an interval specified.  The accuracy of the grid volume is 
dependent upon the size of the Grid Interval. 
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End Area 
The CDOT standard for computing volumes is the End Area method.  Prior to using 
the End Area Volume command, a set of cross sections containing at least two 
surfaces must be created in the active design file. If additional surfaces are shown 
on the sections, they can be used for volume calculations as well.  Select 
Evaluation > Volumes > End Area to access the command (or choose it from the 
toolbar). 

Main tab 

                                        

On the Main tab, choose the set of sections to use for volumes, and specify the 
Original and Design Surfaces by choosing them from the list of surfaces on the 
drop-down.  

Note: The Subgrade Surface defined in the dialog is the surface used 
to determine the depth of cut and height of fill. In effect, the 
volume accounts for cutting down to the subgrade in cut 
situations and filling up to the subgrade in fill situations.  

If Cut and Fill Volume Factors are applied to the entire corridor, they are 
entered on the main dialog. If not, see Adjustments. 

When the volumes are calculated, the MicroStation elements forming the cross 
section surfaces are used to determine the area of cut and fill on each section. 
The areas are outlined with MicroStation shapes if the Objects are toggled on 
under Symbology. If so, you also have the choice of annotating these areas on 
the sections.  

In addition, when the areas are used to calculate the volumes, they can be used 
in the standard end-area method, or they can be corrected for curvature — 
whichever is toggled under Method. 

Under Reports, you have two options. The Binary option creates a binary file 
with all the data from the volume calculations. This data can be formatted into 
one of a number of reports using the Tools > Reports > General command.  
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The ASCII report file is not as flexible as the binary file, since the format is hard-
coded, but you get an immediate report. 

Several other options are available. They are found under the different tabs at 
the top of the main end-area dialog, and described in the following sections. 

Layer Volumes tab 
                                       

 

The Layer Volumes tab is used to specify additional surfaces for volume 
calculations.  

Listed are the Bottom Layer, Top Layer, Cut and Fill Factors and Closure. The 
closure options allows you to determine how the two surfaces are to be joined 
together.  

 Vertical Drop projects a vertical from the end points of the 
narrower surface to the other surface in the set.  

 Connect Ends connects the ends of the two surfaces using a 
straight line. 

 Design Surface connects the two ends of the surfaces by 
joining them along the layer defined in the dialog as the 
Design Surface. 
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Adjustments tab 

                                       

The Adjustments tab is used to define various adjustments made to the volume 
computations. These options are listed below: 

Added Quantities — This option is used for adding quantities that are calculated 
from other sources into the end-area volume report. For example, you may have 
a volume from a side road or drive that needs to be shown in the overall end-
area report. 

The volume of added quantities is averaged over the range specified. 

Volume Exceptions — Volume exceptions are used to define areas where no cut 
and fill is calculated. A good example would be a bridge area.  

In order to use this command, cross sections must be cut at the station where the 
first zero volume is desired, and at the station for the last zero volume. 

 Note: Add event points to the alignment at each station where you 
want to cut a section. 

Forced Balance — The forced balance option allows you to specify stations at 
which the volumes must balance.  

How does it balance? It determines a factor that must be applied to each 
station’s volume of cut or fill (your choice) in order for the volume to balance at 
the requested station. It is then an iterative process of changing either templates 
or alignments to reduce the factors necessary to balance. 

Cut / Fill Factors — If you need to specify different cut and fill factors along 
the alignment rather than using the same one for the entire length, select this 
option and specify the different factors needed along with the ranges to which 
they apply. 

Stripping — Calculates the quantities for stripping material under a design. 
Specify the depth of stripping and the station where the stripping begins.  
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This amount of stripping remains in effect until the next entry in the table is 
reached or until the end of the alignment if no other entries are included in the 
table.  

Note: The volumes in the Results box do not reflect stripping 
quantities. These quantities are only available from generating a 
report after the volumes are calculated. 

Annotation tab 
                                      

 

The area of cut and fill on each section is annotated, along with the volume 
between the current and previous stations and the cumulative volume. In this 
option, specify the location and symbology of the information to be placed on 
the sections upon triangulation. 
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Advanced tab 

                                        

The Advanced tab is used for two things: First, you can specify Moisture 
Density Control surface(s). These MDC surfaces are additional layers on your 
template used only in cut. 

Second, you can specify Alternate Lane information. This is for divided 
highways where you have a separate subgrade on the other side of the median. 
(Use one side’s subgrade on the main dialog, the other one here.) This is used to 
define overall cut/fill volumes. 

 

 

When all of the desired options are selected, both on the main dialog and under 
Setup, execute the volume command by choosing Apply. Volumes are calculated 
according the surfaces shown on the cross sections and the criteria specified in the 
options.  

If specified, report files are created and the cross sections are annotated.  
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Triangle by Station 
An extension of the Triangle volume command, Triangle by Station computes the 
volumes in the same manner – comparing triangles to triangles – however, it does 
so in between stations at a specified interval.  This results in an optional report that 
is similar to an end-area report listing volumes by station and a cumulative volume 
up to each station. 

  

  

In order to get the station by station report, you must generate a binary file and then 
apply a format using Tools > Reports. 
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Lab 12 – Generating Project Quantities 

Start InRoads 
1. Start InRoads and open 12345DES_XSec.dgn from the 

\Design\Drawings\Cross_Sections folder. 

Open your InRoads data files 
1. Select File > Open. 

 

2. Ensure the Files of Type option is set to Projects (*.rwk). 

3. Double-click on 12345DES.rwk. 

4. Cancel the dialog. 

Volume Comparison 

Grid 

50’ C: F: N: 

10’ C: F: N: 

5’ C: F: N: 

Triangle 

 C: F: N: 

End Area without subgrade considered 

 C: F: N: 

End Area with subgrade considered 

 C: F: N: 
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Make Lock Settings 
1. Toggle Write lock on 

2. Toggle Station lock on 

3. Set the mode to Pencil 

Calculating Grid Volumes 
Calculate the volume between the existing surface and the proposed surface 
using the grid volume method. 

1. Select Tool > Customize > Volume, then Close the Customize dialog. 

2. Select the Grid Volume command. 

  

 

 Set the Original Surface to:  12345 existing ground. 
 Set the Design Surface to:  D_SH 86 Finished-Grade. 
 Enter the Grid Interval:  50 and Tab to accept. 
 Leave the Cut Factor and Fill Factor set to 1.0. 

3. Select Apply. 

 

4. Record the results in the table provided. (You may not get the exact 
numbers shown.) 
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5. Enter the Grid Interval:  10 and Tab to accept. 

6. Select Apply. 

7. Record the results in the table provided. 

8. Enter the Grid Interval:  5 and Tab to accept. 

9. Select Apply. 

10. Record the results in the table provided. 

11. Select Close to dismiss the Grid Volume command. 

Calculating Triangle Volumes 
Calculate the volume between the existing surface and the proposed surface 
using the triangle volume method. 

1. From the Volumes toolbar select the Triangle Volume. 

  

 

 

 Set the Mode to Entire Surface. 
 Set the Original Surface to:  12345 existing ground. 
 Set the Design Surface to:  D_SH 86 Finished-Grade. 
 Leave the Cut Factor and Fill Factor set to 1.0. 

2. Select Apply. 

This method will take longer to process than the grid method. 

3. Record the results in the table provided. 

4. Select Close to dismiss the Triangle Volume command. 
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Calculating End-Area Volumes 
Calculate the volume between the existing surface and the proposed surface 
using the end-area volume method. With the first run, you will not take the 
subgrade into account. 

End Area w/o subgrade 
The sections are annotated with end areas during this process, so start by 
changing the Scale factor to 40. 

1. From the Volumes toolbar, select the End-Area Volume command. 
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2. Define the cross sections and surfaces to be used for the volume 
calculations. 

 Select the final section set from the Cross Section Set list. 

This should be a full set of cross sections generated along the alignment. 
A box is drawn around the set to show which one you’ve picked. 

 Set the Original Surface to 12345 existing ground. 
 Set the Design Surface to D_SH 86 Finished-Grade. 
 Set Units to Cubic Yards. 
 Leave the Cut Factor and Fill Volume Factors set to 1.0. 

3. Select Apply. 

 

Results appear in a separate dialog box. 

4. Record the results in the table provided, then Close the Results dialog. 
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End Area w/subgrade considered 
Calculate the volume between the existing surface and the proposed 
surface including the subgrade-top surface using the end-area volume 
method and generate an ASCII report and binary file to be formatted into 
an ASCII report in a later exercise.  You will also calculate the additional 
material volumes. 

5. In the End Area Volume dialog. 

 

 Toggle on Subgrade Surface and set to  
D_SH 86 Subgrade-Top. 

 Toggle on ASCII Report. 
 Browse, set the folder to InRoads and enter a File Name of 

12345DES_EndVol.txt. 
 Toggle on Binary Report. 
 Browse and enter a File Name of  

12345DES_Endvol.bin. 
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6. To calculate additional sublayer volumes, select the Layer Volumes tab. 

 

 Set the Top layer to D_SH 86 Finished-Grade. 
 Set the Bottom layer to D_SH 86 Base-Course-Top. 
 Set the Closure to Vertical Drop. 
 Select Add. 
 Set the Top layer to D_SH 86 Base-Course Top. 
 Set the Bottom layer to D_SH 86 Subbase-Top. 
 Set the Closure to Design Surface. 
 Select Add.  
 Set the Top layer to D_SH 86 Subbase-Top. 
 Set the Bottom layer to D_SH 86 Subgrade-Top. 
 Set the Closure to Design Surface. 
 Select Add. 

7. Review the other tabs and make any changes you would like. 
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8. Select Apply on the End-Area Volume dialog box 

 

9. Record the results in the table provided 

10. Close the Results box 

11. Select Close to dismiss the End-Area Volume command 

Note the difference in the volumes as the Subgrade-Top is removed from fill 
volumes and added to the cut volumes. 

In the next chapter, we will look at the reports just created. They will show a 
station by station list of the overall volumes as well as the Base-Course, Subbase 
and Subgrade materials. 

12. Window in to your cross sections and review the shapes that were 
created when you calculated volumes. 

13. Exit MicroStation and InRoads. 

 

 



 Chapter 13  Creating Reports 

 

Roadway Design Using InRoads  Page 425 

13.  Creating Reports 

Automatic 
There are several reports in InRoads that can be generated automatically, with 
the user having no (or very little) choice on the format of those reports.  Some 
examples are shown below.  

The results from these reports can be: Saved to the hard drive by selecting Save 
As and specifying a name;  Appended to an existing text file by selecting 
Append and choosing the file; Displayed in the design file by selecting Display 
and identifying a location; or Printed by selecting Print. 

Alignments 
The quickest and easiest method of generating an alignment report is to use one 
of the Review commands.  This can be accomplished by right-clicking the 
alignment in the Explorer menu and selecting Review, or by choosing it from 
the pulldown menu or from the toolbar. 
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Surfaces 
Select Surface > Surface Properties and choose the surface you desire.  Then 
select Report. 
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You can report on individual features by selecting Surface > Feature > Feature 
Properties, identifying the feature in question (by highlighting or using the 
target button to choose it graphically) and selecting List Points. 
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Profiles 
On the Create Profile dialog, there is a Report tab that allows you to specify 
two different types of text reports as shown below.  If toggled on, when you 
create the profile, these report files are automatically generated. 

 



 Chapter 13  Creating Reports 

 

Roadway Design Using InRoads  Page 429 

Cross Sections 
On the Create Cross Sections dialog, there is a Report tab that allows you to 
specify three different reports, two of which are ASCII (text) and one of which 
is a binary file. 
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DBAccess Reports 
DBAccess reports comprise a method of formatting binary files into ASCII (text) 
files.  These binary files consist of the geometry project (.alg), and files created 
from Roadway Modeler, Cross Sections, and End-Area Volumes (.bin).  
DBAccess libraries delivered with InRoads contain a series of pre-determined 
formats for these reports.   

DBAccess reports are being replaced by the XML reports described in the next 
section, however there are some reports that are not yet available in the XML 
command, such as End Area Volume reports. 

Select Tools > Reports and then you can choose between the Geometry tab for 
reports from the active geometry project and the General tab for reports from 
binary files created with one of the aforementioned commands.  

For General Reports, you must first specify the DBAccess library containing the 
format you desire.  These libraries are categorized by the type of report (rwy.dba 
for Roadway Modeler reports, vol.dba for Volume reports, etc.).  Within each, 
specify the Report template.  The Binary File must be entered (by using Browse or 
keying it in) and the method of output specified. 
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For Geometry Reports, the DBAccess library is chosen by default, and you are just 
required to choose the Report Type and Report (format), then enter the criteria for 
the data on which you want to report.  Different options become available 
depending upon which report you choose.  Again, the method of output must be 
specified. 

 

 



Colorado Department of Transportation 

 

Page 432  Roadway Design Using InRoads 

XML Reports 
XML reports are on their way to replacing the DBAccess reports.  Their concept 
is similar, but they pull the information directly from your data files rather than 
from binary files you must create.  They also allow the mixing of data types – 
for example, you can report on stations and offset from an alignment to a surface 
feature. 

Another advantage of the XML reports is their use of a style sheet (.xsl) file to 
format the report.  The programming of the format is very familiar to HTML, so 
if you’re familiar with HTML programming, you can create your own style 
sheets or modify the predefined ones. 

 

Select Tools > XML Reports. (If the XML Reports command is not available on 
your pulldown menu in InRoads, first toggle XML Reports on in Tools > 
Application Add-ins.)  Choose the tab associated with the type of report you 
wish to create, and specify the criteria on which to report.   
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Select Save As and specify a name for the .xml file that will be created.  The 
Tools > View XML Reports command is automatically executed, and a default 
format chosen for your report.  Other formats may be chosen from the list along 
the left of the screen. 

 



Colorado Department of Transportation 

 

Page 434  Roadway Design Using InRoads 



 Chapter 13  Creating Reports 

 

Roadway Design Using InRoads  Page 435 

Lab 13 – Creating Reports 

Start InRoads 
1. Start InRoads and open 12345DES_Model.dgn from the 

\Design\Drawings\Reference_Files folder.    

Open your InRoads data files 
1. Select File > Open. 

 

2. Ensure the Files of Type option is set to Projects (*.rwk). 

3. Double-click on 12345DES.rwk. 

Double-clicking is the equivalent of highlighting the file and choosing 
Open. 

4. Cancel the dialog. 

Make lock settings. 
1. Toggle Write lock off. 

2. Toggle Report lock off. 

3. Toggle Station lock on.  
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Creating a new profile and report 
Create a new profile that contains the existing and proposed surfaces.  

1. Select Evaluation > Profile > Create Profile. 

 

 On the Main tab, set the source to Alignment and choose  
SH 86. 

 Select the surfaces 12345 existing ground and  
D_SH 86 Finished-Grade. 

2. Select the Report tab. 
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 Toggle on Generate Station, Elevation, Offset Report . 
 Browse to the Design\InRoads folder and key in the File 

Name: 12345DES_Prof.rpt. 
 Set Report At:  Major Ticks. 
 Toggle on Generate Station, Elevation Report. 
 Browse to the Design\InRoads and key in the File Name: 

12345DES_Prof.se. 
 Toggle on Show Connectivity. 

3. Select Apply. 

4. Place a <D> in the design file to define the lower left corner of the profile 
plot. 

5. Select Close to dismiss the profile command. 

Since we don’t really need another profile display, you turned Write lock 
off before using this command.  Therefore, you can Update the view and 
the profile display disappears, but the report file stays on your hard drive.  

6. Open the 12345DES_Prof.rpt file with Notepad. (It should be in your 
Design\InRoads folder.) 

 

The elevations are only shown to the nearest tenth of a foot.  The 
elevation precision is controlled by the precision for elevations in Tools > 
Options. 

7. Close the report. 
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8. Open the profile.se file with Notepad. 

 

The profile.se file is displayed in a window that can be scrolled through. 
The elevations are also shown to the nearest tenth of a foot.  

This file can be used to plot a profile by reading in the ASCII data. 

9. Close the report. 
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Create an ASCII cross section report 
Take the binary report file created, cross.bin, and apply a format template to it to 
create an ASCII cross section report file. 

1. Select Tools > Reports. 

2. Select the General tab. 

 

 Click in the Report Library field and select Browse. 
 Select xsec.dba from the \Program 

Files\Bentley\Civil\data folder. 
 Select Open. 
 From the Report drop-down list, Select X_SECT_MULTI. 
 Click in the Binary Input field and select Browse. 
 Select  12345DES_XSec.bin from the C:\Projects\12345\ 

Design\InRoads folder and Open. 
 Toggle on Text to Screen 
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3. Select Apply 

The ASCII report is displayed to the screen in a window that can be 
scrolled through, and an ASCII file can be saved to the disk. 

 

4. Review the report and close the window when complete. 

5. Close the dialog box. 
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Create an end-area volume report 
Two report files were created when the end-area volumes were calculated – 
12345DES_EndVol.txt and 12345DES_EndVol.bin.  Review the ASCII 
12345DES_EndVol.txt file. 

1. In Notepad, open 
C:\Projects\12345\Design\InRoads\12345DES_EndVol.txt. 

2. Review the information contained in the report. 

3. Close Notepad. 

Create another ASCII report for end-area volumes, this time using the 
12345DES_EndVol.bin file that was created when the volumes were computed. 

4. Select Tools > Reports. 

5. Select the General tab. 

 Click in the Report Library field and select Browse. 
 Select vol.dba from the Program 

Files\Bentley\Civil\data folder. 
 Select Open. 
 From the Report drop-down list, select 

BASIC_END_AREA_80. 
 Click in the Binary Input field and select Browse. 
 Select 12345DES_EndVol.bin from the 

C:\Projects\12345\ Design\InRoads directory and 
Open. 

 Toggle on Text to Screen. 
 Toggle off Text to File. 

6. Select Apply 

The ASCII report is displayed to the screen in a window that can be 
scrolled through. 

7. Review the report and close the window when done. 

8. Select Close to dismiss the dialog box.  
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Creating an alignment report 
Using the data stored in the binary geometry project file, 12345DES.alg, create 
an alignment report. 

1. On the Reports dialog, select the Geometry tab. 

 

 Set the Report Type:  Horizontal Alignment. 
 Click in the Report Library field and choose Browse. 
 Select geo.dba from the  

Program Files\Bentley\Civil\data folder. 
 Select Open. 
 From the Report drop-down list, select HORIZ_ALIGN_B_80. 
 Under Output, toggle on Text to Screen. 
 Toggle off Text to File. 
 Pick the Target Button next to the Report On field and click 

on your horizontal alignment. 
 Set the Interval to 25. 
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2. Select Apply. 

 

The ASCII report is displayed to the screen. 

3. Review the report and close the window when done. 

4. Select Close to dismiss the Reports box. 
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Creating an XML report 
1. Choose Tools > Application Add-ins. 

 Toggle on XML Reports if it isn’t already on. 

 

 Choose  OK. 
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2. Choose Tools > XML Reports. 

 Select the Station Offset tab. 
 Set the From Horizontal Alignment to SH 86. 
 Toggle on Station Base. 
 Under the Features category: 
 Set the Surface to D_ SH 86 Finished-Grade. 
 Highlight the cut and fill features. Hint: You can sort by 

Style to make it easier to find them. 
 Toggle on Interval and key in 25 
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3. Choose Save and key in the name 12345DES_SH86_CF.xml 

 

The report browser will start automatically. If it doesn’t for some reason 
or you want to look at this same report later, choose Tools > View XML 
Reports. 
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4. On the Report Browser, select the style sheet TransverseFeature.xsl. 

 

5. Choose Tools > Format Options from the browser. 

 

You can change any of the formats or precisions shown and it will 
automatically change the report. 

6. Choose Close. 

If you would like, save the file by choosing File > Save As. It can be 
saved as an HTML file, or you can copy and paste the data into another 
text editor. 
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7. Exit the browser and Close the Report dialog. 

8. Exit MicroStation and InRoads. If prompted ‘Do you wish to save 
changes to geometry project 12345DES?’  Select No.  

Optional Activities 
1. Print one of your reports if a printer is available. 

2. Experiment with any other report options you would like. 
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14. Intersection Modeling 

Overview 
It is not unusual, when you are working with InRoads, to run across situations that 
don’t fit neatly into the roadway modeling mold – situations where a template and 
alignments or even templates, tables and alignments don’t give you the flexibility 
you need. For example, intersections and interchanges – something you run into all 
the time in highway design.  

One of the best ways to accomplish these tasks is to model the features. You can 
think of it as developing the breaklines that would be collected if the site were 
surveyed after being built. This is accomplished using a variety of techniques, 
including some commands that you have already used in class and some new 
commands introduced here. 

We’ll start by running Roadway Modeler for each of the roadways, then use 
several different Design Surface and Edit Surface tools to combine the two surface 
created by Modeler and the develop the returns.  These same techniques are 
employed in many situations, such as interchanges and pedestrian refuges.  
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Lab 14 – Intersection Modeling 

Start InRoads 
1. Start InRoads using your desktop icon. 

2. From the MicroStation Manager, select File > New. 

 Set the folder to \Design\Working and key in the name 
CU12345DES_SH86-SR_Intersect.dgn file. 

 

3. Select OK to create and OK again to open the file. 
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Open your InRoads data files 
1. Select File > Open. 

2. Toggle the Files of Type option to Projects (*.rwk). 

3. Double-click on 12345DES.rwk. 

4. Cancel the Open dialog. 

Set your InRoads locks 
1. On the locks toolbar, ensure that Write lock is on in Pencil mode and 

toggle Locate Graphics to Locate Features and Report lock is on. 

  

 

 



 Chapter 14  Intersection Modeling 

 

Roadway Design Using InRoads  Page 453 

Model the Roadways 

The first portion of modeling an intersection involves modeling the 
roadways.  In the next series of steps, you will model both roadways, but 
rename the surfaces so you will have each roadway as a separate model. 

Model SH 86 

1. Select Modeler > Roadway Modeler. 

   

 On the Main tab, select the SH 86 with dec table. 
 Choose SH 86 as the Horizontal Alignment. 
 Select the 12345 existing ground as the original surface 
 Set the Begin Station to:  220+00 
 Set the End Station to:  230+00 
 While you would normally model the entire roadway, you 

will limit the model here, making a smaller intersection 
surface to speed the process. 

 Toggle on Create Cut and Fill Features and set them as 
shown. This creates a continuous feature for the left and 
right toes, which will later be used in making an exterior 
boundary. 

 Set the Advanced tab as shown. 
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2. Apply. 

 

Save the Surfaces 

3. Select File > Save > Project. 
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Model the side road 

Import the horizontal alignment 
The side road alignment has already been defined in an input file, which 
you will load in the next series of steps. 

1. Select File > Import > Geometry. 

2. Choose the ICS tab. 

3. Browse and choose the SideRoad.ics file from the 
C:\Projects\12345\Miscellaneous folder. 

 

 Choose Preview if you would like to see the contents of the 
ics file. 
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 Choose Apply to import the alignment. 

 

4. The Results box appears and lists the points and alignment just created. 

5. Close the Results box. 

6. Fit your view. 

 

Since Auto Plot is used in the text file, the graphic displays for the 
alignment as it’s created. 
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7. Make the new alignment active. 

 

 Right-click on the SideRoad alignment in the Geometry 
portion of the Explorer menu. (Select the Geometry tab at 
the bottom if it is not the active tab.) 

 Choose Set Active. 

8. Verify that the side road alignment is active by checking that the red box 
is to the left of the name SideRoad. 
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9. Back on the Import dialog, (If you closed it before, choose File > Import 
> Geometry and select the ICS tab.) 

 Browse again and choose sideroadV.ics from the 
C:\Projects\12345\Miscellaneous folder. 

 

10. Choose Apply to import the vertical alignment. 

 The Results box will appear again with the vertical 
alignment information. 

 

 Close the Results box and the Import Geometry dialog. 
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11. Verify that the vertical alignment was imported by looking at the 
Explorer portion of the InRoads menu. By using the + sign next to the 
geometry project and the horizontal alignment, you can ‘drill’ down to 
see the horizontal and vertical alignments. 

 

12. Choose File > Save > Geometry Project to save the geometry project 
with the new alignments. 



Colorado Department of Transportation 

 

Page 460  Roadway Design Using InRoads 

Copy and modify a typical section to use for the approach road 
Instead of creating a new typical section, for the approach road you will 
use a copy of the 2-lane typical you created previously. 

1. Select Modeler > Define Typical Section. 

 

2. Highlight SH 86 1L-1L Rural and select Copy. 

 

3. Change the name as shown and choose Apply. 
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With the SR 1L – 1L Rural  typical highlighted, select Edit. 

4. Change each of the layer names from D_SH 86 to D_SR  by highlighting 
the layer, keying in the new name and selecting Update. 

 

5. Highlight the Finished Grade and select the Segment tab 
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6. Set the Zone to Left Backbone. 

7. Set the Edit Mode to Global. 

8. Use Previous> or <Next to make the shoulder segment active (green). 

9. Change the Width to 6 and tab. 
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10. Repeat for the Right side and for each layer. 

 

11. Save the typical section library. 
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Create a roadway definition 

Before modeling, you must have a roadway definition for the Side Road.  
For this example, you will use the new two-lane template and the same 
variable slope decision table. 

12. Choose Modeler > Define Roadway. 

13. Choose New. 

 

 Enter the Name and Description as shown. 
 Choose Apply. 
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14. Highlight the new roadway definition and choose Edit. 

 

 

15. Choose New and enter the information shown. 

 

 Select Apply to create the Entry. 
 Close the Roadway Entry dialog. 
 Close the Edit Roadway dialog. 
 Close the Define Roadway dialog. 
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16. Select Modeler > Roadway Modeler. 

 On the Main tab,  
 Choose SideRoad as the Horizontal Alignment and 

SideRoadV as the Vertical. 
 Highlight the Roadway Definition SR with dec tab. 
 Select the 12345 existing ground as the original surface. 
 Toggle off the Station Limits. 
 Toggle on Create Cut and Fill Features and set them as 

shown. This creates a continuous feature for the left and 
right toes, which will later be used in making an exterior 
boundary. 

 On the Advanced tab, toggle off Superelevation. 
 Change the Left, Center and Right Prefix as shown to 

designate side road features in the new surfaces. Be sure to 
make the right and left prefixes unique by putting a space 
after the “S” in the right prefix. 
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17. Apply. 

 

Save the Surface 

18. Select File > Save As. 

 

 Set the Active Surface to D_SR Finished-Grade. 
 Set the File name to 12345DES_SurfSRFinGrade.dtm 
 Choose Save. 
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 Continue and save the D_SR Base Course Top, Subbase, 
and Subgrade surfaces using the naming convention shown. 

 

 Cancel the Save As dialog. 
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Add the new surfaces to your project file 

19. Choose File > Save As. 

 Set the Save as type to Projects *.rwk. 
 Click on 12345DES.rwk. 
 Choose Options. 
 On the Surfaces tab, click on Add and Update for the new 

Side Road surfaces. 

 

20. Choose OK 

21. Choose Save on the Save As dialog and overwrite the current .rwk. 
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Combine the two models 
After completing the two individual models, next you’ll combine the 
features from each to create a third surface.  Each of the current models 
has an exterior, which is the only feature that you do not want from 
either model. 

1. Select Surface > Edit Surface > Copy Portion of Surface. 

 

 Set the Source Surface to D_SH 86 Finished-Grade  
 Key in D_SH 86 SR Inter  for the Destination Surface. 

The new surface does not have to be created ahead of time – it is created 
when you select Apply below. 

 Hold down your <CTRL> key and pick the feature Name 
Exterior Boundary to un-highlight it in the Feature list. 

 Set the Duplicate Names to Rename. 

2. Choose Apply. Do not choose Apply more than once, or it will copy the 
features again. 
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3. Set the Source Surface to D_Side Road Finished-Grade and repeat the 
previous process, being certain not to include the Exterior from this 
surface, either. 

 

4. Select File > Save As. 

 

 Set the Active Surface to D_SH 86 SR Inter. 
 Key in the File name   

12345DES_SH86-SR_Intersect.dtm 
 Choose Save. 
 Cancel the Save As dialog. 
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Display the features 
Since the features currently shown in your file are not from the new 
surface intersection, you should display the new ones. 

1. Make the intersection surface active. 

2. Using MicroStation, delete all of the features (TC lines) that currently 
exist in your design file. (You can delete everything in the file using a 
fence or selection set. 

3. Select Surface > Update 3D/Plan Surface Display. 

 

 Set the Mode to Display On. 
 Highlight the intersection surface. 
 Toggle on Features. 
 Select All 
 Choose Apply 
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Model the returns 
1. Ensure that Write lock is on in Pencil Mode. 

2. Ensure that Locate Feature/Locate Graphics is set to Locate 
Features. 

 

3. Select Surface > Design Surface > Fillet Features. 

 Set the dialog as shown. Use the target button to graphically 
choose the shoulder features. 
 

 

Apply and move your cursor to see the options for filleting the two features. 

 When the fillet is in the quadrant you want, <D> to accept it. 
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4. Change the Radius, reference features, feature name and feature style as 
shown.   

 Remember to use the target button to graphically choose the 
EOP features on the SH 86 and Side Road. 

 

5. Apply and Accept with a <D> to fillet the edges. 
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6. Change the Radius, reference features, feature name and feature style as 
shown.   

 

7. Apply and Accept with a <D> to fillet the POSS. 

 



Colorado Department of Transportation 

 

Page 476  Roadway Design Using InRoads 

8. Repeat the process in the NE quadrant for the NE_Shoulder, 
NE_Edge-of-Pavement and NE_POSS. Don’t forget to use SE as the 
prefix for the feature name. 
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Save the Intersection Surface 
1. Save the intersection surface by right-clicking it in the Explorer menu 

and selecting Save. You will need to choose the Surfaces tab first. 

 

 

After choosing Save, the message will appear as shown above, letting 
you know the surface has been saved to the hard drive. 

You can save your surface using this method at any time. 
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2. Repeat the process in the other two quadrants, using Radii of 50 for the 
Shoulder, 42 for the Edge and 34 for the POSS. 

3. During the process, if you create a feature incorrectly, you can delete the 
feature using Surface > Edit Surface > Delete Feature. Warning: 
MicroStation Delete does NOT remove the feature from the surface! 

 

 

4. Save the Surface again. 
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Create sideslopes for the returns 
In the next series of steps, you will use your decision table to create the 
sideslopes around the returns.  In scenarios where a more complex 
template was used for the roadways, such as curb and gutter sections, 
you can create a decision table that includes all of the features from the 
first fillet out instead of only the sideslopes. 

1. Select Surface > Design Surface > Apply Decision Table. 

 

 Choose D_SH 86 SR Inter as the Design Surface. 
 Set the Direction to Left. 
 Toggle on Interval and key in 10. 
 Toggle off Stroke Tolerance. 
 Select the Decision Table Variable Cut and Fill. 
 Delete anything that is currently in the Final Intersection 

Feature Name field. 
 Toggle on Remove Loops. 
 Toggle on Generate Graphics Only. 

2. Apply and identify the new POSS feature as the Primary and the 
Reference Features. 

 <R> to run the decision table along the entire feature. 
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3. Visually check the graphics to make certain they are on the correct side 
of the return (i.e. on the outside).  If so, toggle off Generate Graphics 
Only, Triangulate Surface and Add Primary Feature to Surface, then 
run the command again to generate the features. 
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4. If the graphics appeared on the wrong side, delete the toe of slope 
graphic with MicroStation, change the Direction to Left and try again. 

 

5. Repeat this process for the other returns. 

 

6. Save the intersection surface.  
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Clean up the decision table features 
When a decision table is run on returns such as these, it is not uncommon 
for the resulting features to have ‘jags’ in them.  Using the Generate 
Longitudinal Feature command, you will smooth out these jagged 
features by modifying them with a set interval, which will ignore the 
vertices causing the problems. 
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1. This will be easier to see if you turn Line Styles off under Settings > 
View Attributes on the MicroStation menu, then select All. 
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2. Select Surface > Design Surface > Generate Longitudinal Feature. 

    

 
 Set the dialog as shown. 

3. Apply and follow the prompts to identify the sideslope feature as the 
primary feature, again as the reference feature and then <R> to modify 
the entire element. Review the changes to the feature. 

4. If the feature is acceptable, repeat for the other decision table features.  If 
not, Apply the command again to further smooth the feature. 
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5. Save the intersection surface.  

 

Break the SH 86 toe features 
The toe features created by Roadway Modeler consist of one continuous 
feature for both cut and fill on each side of the roadways. In order to join these 
features into one exterior boundary later, you will break the toe features so they 
can later be joined all the way around the combined surface. 

1. Select Surface > Edit Surface > Break Feature. 

2. <D> on the SH 86 R_toe feature to identify it. 

Note: There are two features at the toe – one for the RT_Top-of-Cut 
and one for the R_toe. It is important that you choose the R_toe 
feature as the correct feature to break. When you identify the 
feature, read your prompts to determine which feature you’ve 
selected.  
 

 
 

If you select the Top-of-Cut feature first, then <R> to select the 
R_toe feature.  

3. <D> to Accept the R_toe feature. You can now track the feature with 
your cursor. 
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4. <D> in the middle of the intersection to break the feature. 

 

 

5. Repeat for the other side of SH 86. 

6. Repeat for each side of the Side Road. 

Partial Delete the features 
In these steps, you will delete the portion of the features that run through 
the intersection. 

1. Select Surface > Edit Surface > Partial Delete. 

 <D> on the right shoulder from SH 86. When it highlights, 
Accept with another <D> as shown: 

 

<D>, Then <D> 
to Accept 

<D> in this vicinity to 
break the R_toe 

feature 
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 To identify the Starting Point, <T> on the end of the fillet, then <D> to 
Accept as shown: (Be sure to get the very end of the fillet – the fillet will 
highlight when you <T> on it.  If you don’t get it on the first <T>, you can 
continue to <T> and until you do.) 

 

 To identify the Ending Point, <T> on the end of the opposite fillet, then 
<D> to Accept as shown: 

 

<T>, Then <D> 
to Accept 

<T>, Then <D> 
to Accept 
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Note the feature is deleted through the middle of the intersection. 

 

 

2. Repeat for each of the other features in the intersection.  Remember that 
there are two features at each toe – one for the  
Top-of-Cut or Toe-of-Fill and one for the toe. 
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3. Partial Delete the Centerline of the Side road. 

 

 
4. Save the intersection surface. 



Colorado Department of Transportation 

 

Page 490  Roadway Design Using InRoads 

Create an exterior boundary 
1. Select Surface > Edit Surface > Join Features. 

 Identify and accept the features around the perimeter of the 
intersection surface in turn. Be certain to identify the new 
toes of slope created inside the returns when you come to 
them as you proceed around the perimeter. 
You MUST identify and accept each feature individually. 
(i.e. you CANNOT accept a feature at the same time you 
identify the next one.)   

When you are identifying the features, be certain to choose the L_toe and 
R_toe features along the roadways and the cut features for the returns. If 
the wrong one is chosen, <R> and it will select the other one. 

You do not have to close the feature; it will be closed automatically 
when you change it to an Exterior point type in the next step. 
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Change the feature to an exterior 
1. Select Surface > Feature > Feature Properties. 

 

 
 Highlight the feature that you just created by joining feature 

around the perimeter. (The name will depend upon which 
feature you started with when combining them.) 

Note:  The new feature takes on the name of the feature you started 
your join command with, so it may not be the same as the dialog 
shown. Use the target button to graphically identify the feature if 
you’re not sure of the name. 

 Change the Name to Exterior. 
 Toggle off Exclude from Triangulation. 

2. Choose Apply. 



Colorado Department of Transportation 

 

Page 492  Roadway Design Using InRoads 

3. Click on the Style heading to sort by Style 

 

4. Scroll down and find the D_Toe-of-Fill and D_Top-of-Cut features. 

5. Highlight all of them, and toggle on Exclude from Triangulation. 

6. Choose Apply. 

Since you changed the non-triangulating Toe lines to triangulate, you no 
longer need these in the triangulation. 
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7. Save the intersection surface.  

8. Triangulate the surface using Surface > Triangulate Surface. 

 
 

9. Using what you have learned throughout the class, review the surface 
using displays, rotating the view, etc. 

 

 

 

10. Save the intersection surface.  

11. Exit MicroStation and InRoads. 
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