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Document Conventions 
There are several conventions that are used throughout this document to indicate 
actions to be taken or to highlight important information.  The conventions are as 
follows: 

 

Item     Meaning 

View Perimeter a command name or a file that you are to select 

Tools > Options a command path that you are to select – usually from the 
pull-down menus 

Key in entering data with the keyboard 

Document name style used when referring to another document 

Note:  text information about a command or process that you should 
pay particular attention to 

Emphasis an important word or phrase 

1. Numbered Steps actions that you are to perform as part of the lab activities 

<D> or Data press the data button on the mouse 

<R> or Reset press the reset button on the mouse 

<T> or Tentative press the tentative button on the mouse 
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Section 1 — Getting Started with MicroStation 
In this section, you will learn the basics of working in a MicroStation design file. 
This includes opening and navigating in a design file, working with Levels and 
understanding 3D design file basics. 

Once you have mastered basic MicroStation principles in Section 1, you will learn 
how CDOT specifically uses MicroStation in Section 2. Here you will learn the 
CDOT MicroStation workflow and apply this workflow to create model file 
graphics, compose sheet files, annotate and dimension sheets, and plot the sheets. 

1. Design File Basics 

Mouse mechanics 
There are three types of mouse “points” you can execute in MicroStation.  These 
points correspond to the different buttons on the mouse.  The default settings are: 

Mouse points 

 

Data point   <D> — used to select tools, pull down menus, etc., identify 
coordinate locations, place and manipulate elements, or confirm actions before 
they take place.  The left button is the default data button.  Used when prompted 
to Accept. 

Tentative point:  <T> — used to temporarily locate a point in space or an 
element.  The middle button (or wheel) is the default tentative button. 

Note: to execute a tentative point on a two button mouse, 
simultaneously click the right and left buttons. 

Reset:  <R> — releases the current operation or rejects a highlighted element. 
The right button is the default reset button.  Used when prompted to Reject. 

Using the mouse 
Click — tap the mouse button once. 

Double click — tap the mouse button twice quickly. 

Snap — locate an existing point on an element by using a <T> , then <D> to 
accept. 

Reset   <R>  

Tentative   <T>  Data   <D>  
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Wheel mouse settings 
MicroStation V8 supports wheel mice.  You can set your middle wheel to 
perform several different view control options including Zoom In/out, pan 
radial, pan with zoom, etc. Select Workspace > Preferences > Mouse to 
configure the wheel on your mouse. 
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Starting MicroStation 
To start MicroStation on the Windows platform: 

 From the Windows Start Button, select  
Start > All Programs > MicroStation > MicroStation. 

or 

 Double-click on the MicroStation V8 icon located in the MicroStation 
product directory  
(usually c:\Program Files > Bentley > Program > MicroStation) or on 
your desktop. 

 

MicroStation will start and the MicroStation Manager dialog box will appear on 
your screen. 
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The MicroStation Manager 
The MicroStation Manager is your file management interface to MicroStation. 

 

By default, a MicroStation design file has an extension of .dgn.  “Design file” is a 
generic term used to describe all MicroStation files, regardless of their use – design, 
drafting, etc.  In addition to MicroStation V8 DGN files, you can also open 
previous version MicroStation files and AutoCAD files (.dwg or .dxf).  This is 
designated under List Files of Type drop-down. 

Use the File pull-down menu to create new MicroStation design files, open existing 
files or copy, rename or delete existing files.  You can also compress a file, which 
permanently removes the deleted elements and reduces the file size.  You can 
quickly access the last 10 files opened. 

Use the Directory pull-down menu to create or copy existing directories (folders). 

In the Workspace category, select 

User:   Your login name 

Project:  Your project name – this is the same as your JPC number 

Interface:  CDOT for the customized CDOT Groups menu and special CDOT 
interface settings. 

For Training purposes your workspace settings will be: 

User:  CDOT User 

Project:  12345 (the JPC for this class) 

Interface:  CDOT 
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Note: A more detailed discussion of the CDOT Workspace, which is 
set with the Project and Interface options, will take place in 
Chapter 4. 

Opening a MicroStation Design File 
To open a MicroStation design file: 

 Set Drives to the drive containing your file. 

 

 Navigate to the correct directory. 

 

Set List of File Types to MicroStation All files (*.*) (or to the type of file you 
wish to open.) 

 Click to highlight the file. 

 

Click OK. 

Note: MicroStation design files have a default extension of .dgn, but 
can have any extension. 
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The CDOT Default MicroStation Interface 
 

 

Standard      Attributes     Primary 
Toolbars (docked)

AccuDraw (docked) 

Tool Settings 
Main Toolbar Menu 

Pull down Menus 

View controls 

View Toggles 
Snaps Toolbar 

Scroll Bars 

Select Tool/Prompts 
Information/ 
Messages 

Snap Mode 
Locks 

Active Level 
Selection set 

Fence mode 

Design change indicator 
Workmode 

Digital rights 

CDOT Groups Menus 

Key-in Browser 

File name 
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The different parts of the MicroStation screen are: 

Pull down menus 

                                
 Pull down menus are used to access MicroStation toolbars, settings and 

dialog boxes. 
 An arrow next to a pull-down command indicates sub-menu options. 
 … Indicates a dialog box to open. 

CDOT Groups Menus 
The CDOT Group Menus contain custom menus specific to CDOT disciplines.  

 

There are two options from the Group Menus pull-down: Bridge and CDOT 
Menus.  
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The Bridge Menu provides custom settings for the Bridge Specialty Group. 

 

The CDOT Menus option provides automation tools and custom programs for 
general drafting and all other specialty groups. 

 

 

If you close the CDOT Menu and wish to re-open it, select the CDOT icon from 
the Main toolbar. 

 

The CDOT Menu is discussed in detail in Chapter 4. 
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Toolbars 

   

 MicroStation’s tools for creating and manipulating your design elements 
are organized into logical groupings called toolbars. 

 Each tool is represented by an icon on its toolbar. 
 Toolbars can be opened, closed and moved around the screen like dialog 

boxes, views and the command window. 
 Toolbars can be “docked”  

 

 

 

 Or “floated” within the drawing workspace. 

 

 

 
 

 Most toolbars can be accessed from the menu or from the Main toolbar. 

Docked 

Floating 
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 The Main toolbar opens automatically when you start MicroStation.  If 
you close the Main toolbar and want to re-open it, select Tools > Main > 
Main from the command window.  

 The Main toolbar is where you access other toolbars where most of your 
drawing tools exist. 

 To open a toolbar from Main, select one of the tool icons and drag the 
cursor away from Main while pressing the data button on the mouse 
(float the toolbar). 

Delete Element 

Start InRoads 

The Main toolbar 

CDOT Groups Menu and version 
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Tool Settings 

     

 Many tools have parameters or settings associated with them, which are 
shown in the Tool Settings dialog box.  Each time you select a new 
drawing tool, the optional settings will appear in the Tool Settings box. 

The Primary toolbar 

 

 The Primary toolbar contains commonly used MicroStation tools 
discussed later. 

 This is one toolbar you’ll frequently use, so you will probably want to 
open and dock it. 

 Select Tools > Primary to toggle on the Primary toolbar. 

The Key-in Browser box 

 

 Many MicroStation commands can be accomplished by keying in the 
command text (e.g. Place Line). 

 Key-ins can also be used to input data (e.g. xy=<x,y,z> to locate a 
coordinate). 

Note:  key-ins are not case sensitive. 

 This is another toolbar you’ll frequently use.  Select Utilities > Key-in to 
open, then dock the box. 

 When you’re ready to key in a command, set the focus in the Key-in box 
by data pointing in it or use the <Esc> key. 

 After you key in the command, use the <Enter> or <Tab> key to activate 
the command. 
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Views 

 

 The area where graphics are placed is called a view. 
 Up to eight view windows can be opened. 
 Open and close views from Window > Views or the Views dialog box. 
 You can set different view perspectives (top, front, rotated, etc.) 
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Opening views 

 

A view or view window is the area in which you place graphics and view your 
design.  Up to eight view windows can be opened at one time.  You can open 
and close views from the Window > Views pull-down menu.   

 

You can also select Window > Views > Dialog to open the View Groups 
toolbar where you can quickly turn views on or off. 

  

 You can use the control buttons in the upper right-hand corner to 
maximize, minimize or close a view. 

View Groups toolbar 
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Status Bar 

 

The Status Bar is MicroStation’s command center composed of the following 
areas (left to right): 

 Select Tool – displays the name of the active drawing tool. 
 Prompt – displays the next user operation needed by MicroStation. 

 
 

 

 

 

 

 

 Information and messages – displays current element parameter 
settings, error messages, etc.  A data point <D> in this area activates the 
Message Center. 

 

 

 

 Snap mode – displays the active snap mode used in conjunction with a 
tentative point or AccuSnap. 

 Locks – displays a list of locks that you can quickly toggle on/off. 
 Active level – displays the current level on which graphics are placed.  A 

data point <D> in this area activates the Level Manager. 

 

 

 

 

 

 

 

 

Select Tool 

Prompt 

Active level 

Locks 

Snap mode 
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 Selection set – displays number of elements in the current selection set.  
A data point <D> in this area activates selection set commands. 

 Fence mode – displays the active fence mode setting.  A data point <D> 
in this area allows you to change the active fence mode. 

 Workmode – a data point <D> in this area displays the current 
Workmode – DGN (or V8), V7, or DWG. 

 

 Design change indicator – a floppy icon indicates the file has been 
graphically modified. 

 Digital rights – displays if the file is protected for digital rights (user 
access control). 

 

 

 

 

 

 

 

 

 

 

Many of these concepts will be covered in later sections. 

Selection set 

Fence mode 

Design change indicator 

Workmode 

Digital rights 
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Show/Hide toolbar options 
You can select which tools you want to include on any toolbar.  This helps 
streamline your toolbars for the way you work and lets you customize your 
MicroStation setup. 

 

To show/hide tools, right click on any toolbar and toggle the tools on/off as 
desired.  The changes are stored in your MicroStation Workspace. 

Controlling the mouse 

 

By default, the left mouse button is the Data button, the right is the Reset and 
the middle is the Tentative.   

Note: The middle button may be the scroll wheel on some mice. If so, 
press the wheel to execute a tentative point.  

You can change these button assignments by selecting Workspace > Button 
Assignments. 

View Control toolbar 
The View Control toolbar located in the lower-left corner of each view allows 
you to adjust what you see in that view and to maneuver around in the view.  
The horizontal and vertical scroll bars also help you move around in the view.  
To use the View Control toolbar and scroll bars, turn on the option Scroll bars 
on View Windows under Workspace > Preferences > View Windows. 

 

View Control toolbar 
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Use the following View Control tools as follows: 

 Update View — to update a view (refresh or redraw). 

 

 Zoom In — to increase the magnification of a view by Zoom factor. 

 

 Zoom Out — to decrease the magnification of a view by Zoom factor 

 

 Window Area — to increase the magnification of a view by drawing a 
“box” around the area you want to see close up. 

 

 Fit View — to show all displayable elements in a view. 

 

 Rotate View — to rotate the view (top, front, etc.) 

 

 Pan View — to move around in the view (up, down, right, left, etc.) 

 
 View Previous — to step back through view operations. 

 

 View Next — to step ahead through view operations. 

 

 Change View Perspective – to change the view’s perspective angle 

 
 Set View Display Mode – to set how 3D graphics will render. 

 

 Navigate Camera – to interactively “fly” through a design (3D). 
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You can set your middle wheel to perform several different view control options 
including Zoom In/out, pan radial, pan with zoom, etc.  These options are set 
under Workspace > Preferences > Mouse. 

 

Setting Views for dual monitors 
The default CDOT MicroStation workspace is set up to recognize dual monitor 
machines. However, in case these settings are changed, follow the steps below 
to reset this feature. 

 Start MicroStation. 
 Select Workspace > Preferences > Operation and toggle on Open 

Two Application Windows. 

 

 Select File > Save Settings. 
 Exit, then restart MicroStation. 
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When MicroStation starts this time, it will open two different windows.   

 

You can drag one window to the other monitor.  (Click on the title bar and drag 
the window– don’t stretch it).  When you maximize the window, it will fill the 
screen, but stay on the monitor where you placed it rather than trying to span the 
monitors.  In MicroStation, Views 1-4 open in application window 1, while 
Views 5-8 open in application window 2. 

You can drag most MicroStation windows from one monitor to the other, but 
there are some that will not allow dragging.  If you run into one, pick the 
Bentley logo in the upper left corner and choose Change Screen to move the 
dialog or menu to the other screen. 

 

Training Directory Structure 
All of the files for this class are located in the C:\Projects\12345 directory. 
This directory structure, as well as the file names used, conforms to the CDOT 
standards. More information on the CDOT directory structure and file naming 
convention is found in Chapter 4 – Creating a CDOT Project. 

 
 

How To Get Help 
There are many resources available to assist you when working on your CDOT 
CADD project. These resources can be found on the CDOT CADD & Engineering 
Innovation Web site. See Chapter 4, CADD Resources for detailed information 
on each of these options. 

CDOT CADD & Engineering Innovation Web Site 
The CDOT CADD & Engineering Innovation web page is available at: 

http://internal/cadd/  It can also be found on the internal CDOT website: 
Organizations > Project Development > CADD and Engineering Innovation. 
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The website (presently only available to CDOT) provides CDOT users with up 
to date information, tools, and resources related to CADD and the Colorado 
Engineering Software Transition (CEST) project.  

This website is a valuable resource for CADD users and includes: 

CADD Library  
The CADD Library page provides links to manuals, newsletters, standard details, 
etc. One extremely useful link is to the Tips and Tricks section for MicroStation 
and InRoads. This information changes daily, so check back often. 

CADD Manual 
The CDOT Computer Aided Design and Drafting (CADD) Manual outlines 
CDOT’s use of Bentley’s MicroStation and InRoads software. It can be accessed 
several different ways including: 

 From the CDOT internal CADD web site home page link; 
 From the CDOT Design and Construction Project Support Page (external 

web site); 
 From the CDOT Menu (Help > CADD Manual). 

CDOT Workflows 
There are several standardized MicroStation and InRoads workflows that CDOT 
has developed to assist you. In addition to accessing the workflows from the 
CDOT CADD Web site Home page link CDOT Work Flow, you can also access 
workflows: 

 From the Windows Start menu  
(Start > All Programs > _CDOT_CADD_Information > Workflows); 

 From the CDOT Menu (Help > Workflows). 

Issues Logs  
Check the issues log to determine the status of submitted requests. 

Requests & Support 
This page provides CADD help solutions where you can help, submit questions 
and requests, and obtain InRoads, InRoads Survey and MicroStation support.  

There is also a link to IT Services for hardware support, “how to” instructions, 
installation, training files, and dual monitor and work space setup. 

Training 
Use this link to sign up for training classes.  You can also review online 
computer-based training (CBT) for MicroStation, InRoads and InRoads Survey. 
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Lab 1 – Getting Started 

Objectives 
After completing this exercise you will know how to: 

 Start MicroStation. 
 Open a MicroStation design file. 
 Use the MicroStation mouse buttons. 
 Navigate the MicroStation interface. 
 Use the View Control commands. 
 Assign view controls to the mouse wheel. 
 Float and dock toolbars. 
 Show and hide tools on toolbars. 
 Access the MicroStation Key-in box. 

Starting MicroStation 
 To start MicroStation: 

1. Select Start >All Programs > MicroStation > MicroStation   

or  
 
Double-click on the MicroStation V8 icon located on your desktop or in 
the MicroStation product directory  
(usually C:\Program Files > Bentley > Program > MicroStation). 

 

MicroStation will start and the MicroStation Manager dialog box will 
appear on your screen.  
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The MicroStation Manager Dialog Box 
The MicroStation Manager is your file management interface in MicroStation. It 
allows you to create, rename, delete and open files as well as set workspace 
parameters. The MicroStation workspace is made up of three components: Users, 
Project and Interface. Setting these components allow you to customize the 
MicroStation interface. 

Note: Do not press <Enter> after you key data in a dialog box unless 
you are ready to apply the settings.  Use the <Tab> key or your 
mouse cursor to move from one field to the next to choose or 
enter your setup options before you Apply or OK the command. 

Opening files 
1. In the lower portion on the dialog box, set  

 User:   CDOT User 
 Project:  12345 
 Interface:  CDOT 

Note: The Project option automatically sets the directory to 
C:\Projects\12345. You’ll lean more about the project 
configuration file (PCF) in chapter 4. 

2. In the MicroStation Manager, navigate to 
\Design\Drawings\Reference_Files folder. 

3. Highlight 12345DES_Model.dgn as the design file to open. 

A thumbnail preview of the file is shown. 

4. Select OK to open the design file. 

This is a design model file of CDOT project SH 86, which will serve as 
the example project for this class as well as other CDOT training classes. 

 

Note: The CDOT Menu opens automatically. You’ll use this menu 
later. For now, minimize or close the CDOT menu. 

1 

2 3 

4 
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Working with the Mouse 
While in MicroStation, your mouse operations include: 

<D> Data  (usually the left button) for selecting tools, highlighting fields, 
moving dialog boxes, confirming actions, etc. 

<R> Reset  (usually the right button) for terminating commands, rejecting 
actions, etc. 

<T> Tentative (usually the middle button or scroll wheel) for snapping to 
existing elements at exact locations.  

Access Pull-Down Menus 
Use pull-down menus to select settings and non-drawing commands from the 
application window.  You can either post a menu (display it until you select a 
function from the menu) or open the menu and select a command all in one step. 

Post a pull-down menu from the command window 
1. Point your cursor to File in the application window and select it by 

clicking the data point once <D>. 

 The pull-down menu appears. 

 

 Menu names followed by ... indicate a dialog box will open 
when you select the item. 

 Names with an arrow to the right indicate there is a sub-
menu associated with the item. 

 You can also use the keyboard to select a command from a 
menu. 
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2. Use the up and down arrow keys on your keyboard to move up and down 
an item list or move your cursor. 

 Text to the right of an item indicates the hot key or shortcut 
to use to activate the command (e.g., Ctrl+N means to hold 
down the Ctrl key and type N). 

 Underlined letters indicate a shortcut key to choose an item 
from a menu. 

3. Move your cursor to Element to show the element pull-down menu.  

 

Open a Settings Box 
1. Select Settings > Locks  > Toggles to open the Locks settings box. 

 

Note: A settings box, like the Locks box, does not have any command 
buttons (OK, Close, etc.).  Settings boxes can be left open while 
working in MicroStation. 
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2. Close the Locks settings box by selecting the X in the upper right hand 
corner. 

 

Control Views 

Turn on additional views 
1. From the View Toggles box (lower left of the screen), toggle on 

views 2, 3 and 4.  <D>. 

 

Note: By default, views 1-4 open in screen 1, views 5-8 open in screen 
2. To move a view to a different screen, select the “B” control 
menu and choose Change Screen. 
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2. Select Window > Tile to arrange the views. 

 

Fit View 1 
1. From the View Control toolbar in View 1, select Fit View. 
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All of the plan view graphics appear in the view. 

 

Rotate all views to top 
1. From the View Control toolbar in View 2 select Rotate View. 

 

2. In the Rotate View tool settings box, set Method to Top.  

 

3. <D> in View 2 to change it to a top view (verify the view name is Top). 

 

4. Fit view 2. 
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5. Repeat the above steps to rotate views 3 and 4 to a Top view and Fit the 
views. 

 

Zoom In within a view 
1. From the View Control toolbar in View 2, select Zoom In. 

 

2. Place your cursor (the X cross-hair) in the center of the intersection and 
place a data point <D>. 
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The view is updated to Zoom In twice as close.  The center of the view is 
the data point you identified. 

 

3. Continue placing data points until you’ve zoomed in to the intersection 
as shown. 

 

4. Reset <R> out of the Zoom In command. 
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Turn off the raster files 
The model file has aerial photos attached. These raster images can be 
turned off while working in the file. 

Note: You will learn more about raster management in Chapter 4. 

1. Select File > Raster Manager. 

 

2. Double-click the 09a.tif file. 

3. On the Display/Print tab, toggle off all View (1-8) and select OK. 

 

4. Repeat for 10a.tif. 

5. Close the Raster Manager box. 



 Design File Basics 

 

CDOT MicroStation Essentials  Page 31 

Zoom out in a view 
1. From the View Control toolbar in View 2, select Zoom Out. 

 

The view is updated to zoom out twice as far. 

2. Again in View 2, <D> in the center of the intersection to zoom out again 
until you can see the entire intersection cross road.  
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Use the Window Area command 
1. From the View Control toolbar in View 3, select Window Area.    

 

2. <D> above and to the left of the beginning of the project. 

3. <D> again below and to the right of the first point as shown (this will 
draw a box around what you want to show close-up). 

 

The view is updated to show the alignment at the beginning of the 
project. 

 

<D> here for point 1 

<D> here for point 2 
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4. While still in the Window Area command, move your cursor over to 
View 4 and <D> above and to the left of the alignment end as shown. 

5. <D> again below and to the right of the alignment end. 

 

The view is updated to show the end of the project. 

 

<D> here for point 1 

<D> here for point 2 
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Your views should look similar to the illustration below. 

 

Fit views 
1. From View 2, select Fit View. 

All of the graphics in View 2 are displayed in the view. The Fit View 
command is a handy way to see all graphics on levels that are on. 

2. With the Fit command active, <D> in views 3 and 4 to select these views 
to fit.  
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Close some views 
1. Toggle off views 2, 3 and 4 on the View Toggles box. 

 

Note:  You can also click the X icon in the view’s upper right corner to 
close it or you can double-click on the B icon (the control menu 
icon) in the upper left corner of a view. 

Click once on the B icon and choose Change Screen to move 
the view to the other monitor. 
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Make view one fill the screen 
1. Select the Maximize button in the upper right corner of View 1. 

2. Fit View 1. 

 

Mouse Wheel Settings 
Note:  If you do not have a mouse with a wheel, go to the next section 

titled Try Out Tool Boxes. 

Use the wheel on the mouse to Zoom In/Out 
1. Position your cursor over the center of the intersection. 

2. Roll the wheel up; this zooms in on your graphics. 

3. Roll the wheel back; this zooms out. 

Note: If you <T> on a location before rolling the wheel, that location 
will center in the view when the wheel is rolled. 
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Change the wheel settings 
1. Select Workspace > Preferences > Mouse. 

2. Set the Wheel to Pan Left/Right. 

 

3. Select OK to accept the changes and close the dialog box. 

4. Move your mouse wheel back and forth to pan in the view. 

Notes: You can also Pan by selecting this command on the View 
Control toolbar.  Specify a “from” and “to” point to move in the 
view.  Toggle on Dynamic Display to see the graphics. 

     
 
You can also Pan by pressing <Shift> on the keyboard while holding 
down the data button <D>. Then, drag your cursor in the direction you 
wish to move. 

5. Practice panning with the Pan tool. 

6. Practice panning using <Shift>+<D>. 

Note: After you start panning, you can release the <Shift> key. 
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7. Set your wheel for the view control option you prefer (Workspace > 
Preferences > Mouse). 

 

Pan the project site 
1. Window in to the beginning of the project as shown. 
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2. Use panning to review the SH 86 project site.  

 Start at the POB (STA 100+00) and pan to the right along 
SH 86. 

 Pan across the intersection (between STA 220+00 and 
230+00). 

 

 Continuing panning to the right through the transition from 
rural 2-lane to urban 2-lane with curb and sidewalk (around 
STA 353+00). 
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 Stop at the POE. 

 

Try Out Tool Boxes 

Pull a tool bar from the main palette 
1. Select the Place SmartLine icon from the Main tool palette to display 

the Linear Elements tool bar. 

2. Hold down the data button <D> and drag your cursor to the right until the 
tool bar comes loose from the main toolbar. 

 

Hold down the data <D> button and drag 
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3. Select the Place SmartLine command. 

 

 The Tool Settings box shows this command’s settings options. 

4. Select the Place Line command from the Linear Elements toolbar and 
notice the changes in the Tool Settings box. 

 

 Tool Settings updates for each tool selected. 

5. Close the Linear Elements toolbar by clicking the x in the upper right 
corner. 

Float and Dock Toolbars 

 Float the Primary toolbar 

1. Position your cursor over the edge of the Primary Tools toolbar at the top 
of the application window. 

2. Hold down the data button and drag the toolbar until it “floats” in the 
view. 

                           

Drag 
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3. Repeat for the Standard toolbar.  

 

Toggle the Primary Tools toolbox off/on 

4. Select Tools > Primary. 

The Primary Tools toolbox is turned off. 

5. Select Tools > Primary again to toggle it back on.  

6. Dock the Primary Tools and Standard toolbars back to the upper right 
corner of the application window by dragging the title bar with the data 
button. 

 

Note:  Any toolbar can be docked on the perimeter (top, bottom, left or 
right sides) of MicroStation’s application window.  
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Show/Hide Tools 
1. Drag the Linear Elements toolbar from the Main toolbar.   

2. Right-click anywhere on the Linear Elements toolbar.  In the list of 
tools, toggle off Place SmartLine. 

 

 The SmartLine tool is removed from the toolbar. 

 

3. Right-click <R> again and turn Place SmartLine back on. 

4. Right-click <R> and choose List. 

 

5. Toggle off the last four tools. 

 

6. Choose OK. 
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The toolbar is updated to show these tools hidden. 

 

7. Right-click <R> and select Show All. 

 

All tools are now shown on the toolbar.  

 

8. Close the Linear Elements toolbar (click the X in the upper right 
corner) 

Note: Use this procedure to customize any toolbar to show just the 
tools you want. 

Using the Key-In Box 

 Open and dock the key-in box 

1. Verify the Key-in box is opened and dock. 

 

Note: If the Key-In box is not open, select Utilities > Key-in to open it.  

Key in box docked 
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2. Float the Key-in box from the top of the screen. 

 

3. Expand it by grabbing the bottom of the box and dragging down.  

 

Key-ins can be selected from the list, but are typically just typed directly 
into the box. 

4. Grab the title bar of the key-in box and drag it to the blank space at the 
top of the application window. 

 

The Key-in box docks beside the other tool bars in the application 
window. 

Note: You can also dock the Key-in box at the bottom of the screen if 
you prefer. 
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Save settings  
Save settings in the file so the views will look the same when you next 
open the design file. 

1. Fit View 1. 

2. In the Key-in box you just docked, place a data point to set the focus in 
this box (you will get a blinking cursor). 

Note:  You can also press <Esc> on the keyboard to set the focus in the 
Key-in box. 

3. Key in File (short for File design), then press <Enter> on the keyboard. 

 

Note: You always press <Enter> or <Tab> after key-ins in the Key-in 
box. 

Keep the Key-in box docked.  It is where you will key in all 
MicroStation commands. 

Note: To Save Settings, you could also select File > Save Settings. 
Most commands can be accomplished with either key-ins or by 
selecting from the menu or toolbars. 

By saving settings, the next time you enter this design file, it will be 
exactly as you left it. 

4. Choose File > Exit to exit MicroStation and your design file. 

Note: You can change your MicroStation user preferences to always 
save setting upon exiting the file. Select Workspace > 
Preferences > Operation and toggle on Save Settings on Exit. 
Just remember that if you’re working in another user’s file, 
you’ll change their settings. 
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2. Levels 
Levels help you separate graphics in the design file and for plotting.  By placing 
your graphics on different levels, you can easily control what graphics to display by 
turning the appropriate levels on or off.  Levels are synonymous with layers in 
AutoCAD. 

By using a standard level structure defined in your CADD standards, you can create 
a logical design file.  Everyone in the organization knows exactly what graphics are 
on what level by referring to the CADD standards.  This improves the CADD 
workflow efficiency. 

Levels are named and numbered and you can then turn levels on or off by name or 
number.  There is no limit to the number of levels you have in a design file. 

The level on which you place graphics is known as the active level.  When you set a 
level active, it is automatically turned on. 
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Using the Level Display box 
Access Level Display from Settings > Level > Display or from the Primary 
toolbar. 

 

 

 

The Level Display is used primarily to turn levels on and off in the views 
selected.  You also have the option to turn levels on or off by selecting an 
element (right-click <R> on a level or click the Change Level button). 
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There are three display modes: 

 View Display – turns levels on/off in the chosen view(s). 
 Global Display – turns levels on/off in all views. 
 Global Freeze – elements in selected view(s) are not displayed, cannot 

be plotted and graphics cannot be placed on a frozen level. 

Note: you can also turn levels on or off with the following key-ins: 
 on=<level name or number >  
 of=<level name or number > . 

Note:  <D> and drag across levels in Level Display to select multiple 
consecutive levels or use <Ctrl> to select non-consecutive levels.  
Right-click <R> on any level name to quickly turn all levels 
off/on. 
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Saved views 
Once you have defined a view’s parameters (area of display, levels, etc.), you 
can save the view for recall later.  For example, you can Zoom In on an 
intersection, turn on all necessary levels and then save the view.  Then, no 
matter where you are in the design file, or what levels you’ve turned on or off,  
you can always return to the intersection saved view with the appropriate levels 
turned on. 

To save a view, either: 

 Select View Save/Recall from the view’s control menu  

 

 Or, use the sv=<view name,description > key-in (e.g. 
sv=intersection). 

You can later recall the save view from the View Save/Recall dialog 
box or use the key-in vi=<view name > . 
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Working with Level Libraries 
So, where do the levels come from? Levels are obtained from a level library. A 
level library is a master template of levels, which is attached to your active 
design file. Libraries can be separated by type (Bridge, Roadway Design, 
Survey, etc.) and then you can attach multiple level libraries to an active file. 

CDOT Level Libraries 
CDOT level libraries are attached as a file type DGNLIB.  A DGNLIB file is the 
same format as a DGN file (they can be opened just like a DGN file in 
MicroStation) but with a .dgnlib extension.  Typically there are no graphics in 
a DGNLIB file – just level setups.  DGNLIB files can also be used to store text 
styles and dimension styles (discussed later). 

The following CDOT level libraries (DGNLIB files) are currently available: 

1. Alignments 
2. Bridge 
3. Construction 
4. Drafting 
5. General 
6. GIS 
7. Hydraulics 
8. Landscape and Environmental 
9. Materials and Geotechnical 
10. Roadway Design 
11. ROW 
12. Survey 
13. Topo 
14. Traffic 
15. Utilities 

For more information on level libraries, see Chapter 4 – CADD Overview, The 
CDOT Level Structure. 
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CDOT Select Group Environment 
The CDOT discipline-specific DGNLIBs are automatically attached via the 
CDOT Select Group Environment program.  When attached, levels from the 
library are available for use in the active design file.  When graphics are placed 
on a level from the library, the level is copied from the library into the active 
design file.  

Access the Select Group program from the _CDOT_CADD_Information 
program group on your computer’s Windows Start menu (Start > All Programs 
> _CDOT_CADD_Information > Select Group Environment). This program 
provides you two options: Bridge and xxMulti-Discipline. The Bridge option 
will attach only those libraries necessary for the Bridge specialty group. All 
other groups will choose the xxMulti-Discipline option, which attaches all level 
libraries so you can work across disciplines. 

Level libraries selected via the CDOT Select Group Environment will be 
automatically attached to any design file opened with MicroStation after running 
the program. You only have to run the utility again if you need to switch groups.   
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Using the Level Manager 
The Level Manager is used to set level properties (name, description, number, 
display, plot, symbologies, etc.) and is located next to Level Display on the 
Primary toolbar.  

 

You can also access Level Manager from Settings > Level > Manager or from 
the Primary toolbar.  

 

 

 
Levels with library name

shown in brackets
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The Level Manager shows a list of all levels attached and the library the level 
is in. Additional information can be displayed by right-clicking in the column 
headings and turning columns on/off – information like the level number, 
description, and its ByLevel Symbology. 

 

ByLevel symbology 
ByLevel symbology is the color, line style and line weight assigned to a level.  
When you place graphics on that level, the elements take on the level’s 
symbology.  The combination of naming levels and using ByLevel symbology is 
a good way to ensure CADD standards are maintained.   

Note: CDOT has established ByLevel symbology for all its standard 
levels to conform to CDOT CADD standards. The ByLevel 
symbology is stored with the level in the level library.  You 
should not change the ByLevel Symbology. 

You can review a level’s ByLevel symbology by turning on the appropriate 
columns in the Level Manager. 
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You can also obtain level properties by selecting Level>Properties from the Level 
Manager. 

 

The Attributes toolbar is where you can set the Active Level (the level on 
which you will place graphics), which in turn sets the ByLevel symbology for 
the graphics.  After making your selection, the Attributes toolbar shows you a 
preview of the ByLevel symbology for that level.  Hold your cursor over the 
symbology preview for a description of active color, style and weight. 

Note: Unless you have specific reasons or permissions not to, you 
should always use ByLevel symbologies when creating elements 

 

Note: The CDOT menu, which is discussed in Chapter 5, automates the 
process of setting the proper level and ByLevel symbology for 
drawing elements.
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The Attributes toolbar provides other useful information.  In 
addition to showing the active level, it also shows if the level is 
turned on/off (global setting – all views), if it is locked (graphics 
on the level can not be deleted or modified), and the ByLevel 
color. 

  

 

 

 

 

 

 

 

Global Display 
Locked level 

ByLevel color 
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Setting symbology overrides 
The Level Manager is also where you set level Symbology Overrides.  You 
can set a different symbology for each level.  For example, you may want to 
“dither out” (to show faintly, typically using a gray color) graphics on a specific 
level before plotting by setting color, style and weight to 0.   

Note: If you need to override the ByLevel symbology of an element for 
a special plot, for example, you should do so by setting the 
Symbology Overrides.  Do not change the ByLevel symbology. 

Set Symbology Overrides under Level > Properties 

  

After setting symbology overrides (or if the ByLevel symbology has been 
changed), an asterisk appears beside the level to let you know that has been 
changed from the library standards. To synchronize the level back to the library 
standards, select Update Levels from Library.  

 



Colorado Department of Transportation 

Page 58  CDOT MicroStation Essentials 

View Attributes and Symbology Overrides 
The View Attributes box (Settings > View Attributes) is where you tell 
MicroStation what you want to see (or not see) in a view.  For example, you can 
turn all text in the view on or off.  You can also turn off line weights 
(thicknesses) or line styles (solid, dashed, etc.) to show all graphics the same.  If 
you have set Symbology Overrides in the Level Manager, you have to turn on 
Level Symbology in View Attributes before the override takes affect. 

Symbology Overrides only affect how graphics are displayed (the element 
attributes are not changed, just temporarily overridden), whereas ByLevel 
symbology actually sets or changes the element’s attributes. 

  

Note: More information on how to set up shaded color and grayscale 
printing is available in Chapter 10. 

Working with Level Filters 
Level filters are named groups of levels that can be turned on or off as a group 
(e.g. all road design levels, all survey levels, all topo levels). You can filter on 
many criteria (name, number, etc.) to create the groups. 

CDOT filters 
Several pre-defined CDOT filters are available for your use.  These filters are 
obtained from the various discipline-specific CDOT level libraries attached via 
the Select Group Environment program.  The filters have been defined based 
on logical groups of levels that you normally work with (e.g. Cross Section, 
Profiles, Surface for the Design group, Existing, Easements, Ownership for 
the ROW group.)  
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Setting filters 
Use Level Display to turn the filters on or off.  Set the Show option to Filters, 
and then select the filter from the list. This turns the entire group of levels 
on/off. 

  

When working with levels, it is often easier to work with just a subset to quickly 
find a level to set active or turn on/off. In this case, you can “filter down” your 
levels by setting the Show Option to Levels and then changing the List Filter 
option from (none) to the desired filter.  

   
 List Filter set to none 

(All Levels) 
List Filter set to Roadway Design Surface 
(A subset showing only design surface 
levels) 

List Filter 

Show option 
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Filters can also be set on the Attributes toolbar when setting the active level. 

    

  

Setting the active level 
The active level is the level on which you will place graphics, using the level’s 
ByLevel symbology. There are many ways to set the active level including: 

 Double-clicking <D><D> the level in Level Display 
 Double-clicking <D><D> the level in Level Manager 
 Right-click <R> in the Level Manager and choose Set Active 
 Using the lv=<name or number > key-in or 
 Selecting the level from the Attributes toolbar. 

The active level appears green in the Level Display and Level Manager 
boxes. 
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Lab 2 – Levels 

Objectives 
After completing this exercise you will know how to: 

 Attach the appropriate levels by using the Select Group program. 
 Use Level Display to turn levels on/off. 
 Use keyins to turn levels on/off. 
 Set the active level for placing graphics. 
 Use shortcuts for turning all levels on/off. 
 Turn levels off by graphically selecting an element. 
 Turn different levels on/off in different views. 
 Customize the Level Display and Level Manager boxes. 
 Sort levels. 
 Save a view for later recall. 
 Access CDOT standard level filters. 
 Use level filters to manage levels and turn groups of level on/off. 

Starting MicroStation 
1. From your desktop’s Start Menu, choose Start > All Programs > 

_CDOT_CADD_Information > Select Group Environment. 

 

2. In the Select Group Environment box, select xxMulti-Discipline, and 
then select OK. 

 

Note: This will allow you access to all discipline’s levels. Refer to 
Section 2, The CDOT MicroStation Workflow -- Chapter 4 for 
more information on the Select Group Environment Utility. 
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3. Start MicroStation and open the design file 12345DES_Model.dgn from 
the c:\Projects\12345\Design\Drawings\Reference_Files folder. 

 

View 1 is a plan view of the entire project that you set up in the last lab. 

4. Minimize or Close the CDOT Menu. 

5. Open View 5 from the View Toggles toolbar (lower left). 

 

6. Fit View 5. 

Note: If you want to move View 5 to the left screen, select the 
Change Screen option from the view’s control menu (the “B”). 
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7. In View 1, Window Area around the intersection as shown.  
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Working with levels 

Sorting Levels 
1. Select Settings > Level > Display (or, from the Primary toolbar select 

Level Display). 

 

The Level Display box opens.  It is used to turn levels on and off. 

2. In the top left corner on the Level Display box, toggle off all of the View 
Indexes. 

 

With all view indexes off, there are no levels available to turn on/off (the 
levels are grayed-out). 

3. Turn on View Index 1 and leave all other view indexes off. 

 

View Index
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4. <D> on the column heading Name to sort by name, then <D> on Used to 
bring the used levels to the top of the list. 

 

5. Scroll through the list of levels. 

The levels which are used (those with graphics placed on them) appear in 
bold text. All other un-used levels are from the attached libraries. 

6. <D> on the column heading Number to sort by level number. 

 

Note that levels are grouped by number. For example, all Roadway 
Design levels are 14000 series; all Right-of-Way levels are 15000 series, 
etc. 

<D> here to sort by Name 
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7. <D> on the column heading Name to sort the levels alphabetically by 
name and scroll through the level list. (If you toggle the Name column, 
you will sort A – Z, then Z – A).  Toggle Name until you sort A – Z. 

 

Note: All MicroStation levels are assigned both names and numbers. 

8. Right-click in any column heading (Name, Number, etc.) and toggle off 
the column Logical. 

 

You can customize the look of the Level Display box by turning on/off 
information columns. 

Right-click on any column 
heading to turn columns 

on or off 
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Turn levels on/off using Level Display  
1. With the levels now sorted by name, <D> on the column heading Used 

until all used levels are brought to the top of the list. This now sorts all 
used levels alphabetically. 

Note: You may have to click Used twice to get all used levels to the 
top. 

 

2. Scroll up to the top of the list to see the used levels. 

Note: Sorting by Used is a handy way to quickly find a level that you 
want to turn on/off. 

Window Area around the same intersection location in View 5 as in 
View 1. 

 

Look for the “dot” in t
Used column when 
sorting Used levels  
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3. In Level Display, toggle off View Index 1 and toggle on View Index 5 
and scroll through the level list. 

 

4. <D> on the level ALG_PROPOSED_Hor-Alignment-Text to turn it off.  

 

Note: Levels with a black background are on, levels with a white 
background are off. 

Note: Level displays are view dependent – you can have different 
levels on/off in different views.  

5. In View 5, hold down the data button and drag to turn off all ALG levels 
except the ALG_PROPOSED_Hor-Alignment level as shown. 
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The intersection text is now off in View 5 but on in View 1. 

 

6. Turn off View Index 5 and turn View Index 1 back on. 

 

7. Hold down the data button and drag across all DES_ levels to turn them 
off in View 1. 
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Only alignment levels are now on in View 1. 

 

8. Turn off the levels ALG_PROPOSED_Hor-Alignment-Text and 
ALG_PROPOSED_Hor-Alignment-Sta-Major in View 1. 
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9. Turn on View Index 5 so that both View Index 1 and 5 are now on. 

 

 

Some levels are now shown with a medium-gray background. When 
multiple view indexes are on, a medium-gray background means that the 
level is on in at least one of the views, but not in all selected views. A 
light-gray background means the levels are off in all selected views. 

10. Turn on the levels ALG_PROPOSED_Hor-Alignment-Text and 
ALG_PROPOSED_Hor-Alignment-Sta-Major. 
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Note that the levels are turned on in both views 1 and 5. 

 

11. Turn off View Index 5. 

12. Close View 5. 
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Turn levels on/off By Element 
1. The station and alignment text levels are currently on. Right-click 

anywhere inside the Level Display box and select Off By Element. 

 

2. <D> on the red alignment curve text as shown. 
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The level ALG_PROPOSED_Hor-Alignment-Text is turned off by 
graphically picking an element on that level. 

3. Turn off the Level DRAFT_LC-Center_WT-3. 
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4. Right-click again anywhere in the Level Display box and select All 
Except Element. 

 

5. <D> on the SH 86 (mainline) red-centerline. 
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6. Fit View 1. 

 

All elements except the centerlines are turned off in the view.  The Off 
By Element and All Except Element are handy options to turn levels 
on/off without knowing the level names or number. 

Note: You can also use the Change Level command, with the Level 
option set to Display Only or Display Off, to accomplish the 
same task.   
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7. Turn on all of the alignment levels (data point <D> and drag across all 
ALG levels. 

 

8. Window in to the intersection as shown. 
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Save a view 
1. <D> in the Key-in box to set the focus. 

2. Key in sv=intersect,intersection alignments and press <Enter>. 

Note: Always press <Enter> or <Tab> after key-ins. 

3. <D> in View 1 to select it as the view to save. 

4. Verify you saved the view.  Select Utilities > Saved Views. 

 

Note:  The Saved Views dialog box opens and the saved view shows in 
the list.  The Saved Views dialog is used to manage your saved 
views (create and delete views, edit view names and 
descriptions, and recall saved views). 

5. Close the Saved Views dialog box. 

You will recall this saved view later. 

Turn all levels on/off 
1. Right-click again in Level Display and select All On. 

 

All levels are turned on in View 1. 
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2. Fit View 1. 

3. Right-click in the level display box and select All Off to turn all levels 
off in View 1. 

 

Note:  You can also turn all levels on or off with the key-ins on=all 
and of=all. 

4. Turn all levels back on in View 1. 

5. Window in to the end of the project as shown. 
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Recall the saved view 
1. In the Key-in box, key in vi=intersect. 

Don’t forget to <Tab> or <Enter> after key-ins. 

2. <D> in View 1. 

 

The saved view of the alignment and stationing is recalled in View 1.  
The appropriate levels from the saved view are turned on/off. 

3. From the View Control toolbar, select View Previous. 

 

The previous view of the beginning of the project is recalled. Notice that 
all levels are turned back on from this previous view. 

 

4. Select View Next. 

 

This recalls the intersection view again with the design levels turned off. 
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Use key-ins to turn level on/off 
1. Key in on=all, then <Tab> or <Enter>. 

2. <D> in View 1 to turn all level back on in this view. 

 

Note: Levels are view-dependent.  When using keyins, you must select 
the view with a data point to tell MicroStation which view to 
turn levels on or off. 

3. Key in of=des* 

4. <D> in View 1 to select View 1 

 

All DES_ levels are turned off in view 1. You can use wildcards with 
keyins to turn a group of levels on or off. 
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Set the active level 
1. In the Level Display box, double-click on the level 

ALG_PROPOSED_Hor_Alignment to set it active. 

 

The background color changes to green. 

Notes:  You can also use the lv= key-in to set the active level. 
 
The active level is also reflected in the Attributes toolbar at the 
top of the screen. 
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2. Turn all levels off in View 1. 

All levels are turned off except the alignment centerline because it is the 
active level.  

 

Note: The active level is always displayed provided the option Display 
Active Level in All Views is toggled on in  
Workspace > Preferences > Operation. If this option is turned 
off, you can also turn the active level on/off. 

3. Key in lv=14051, to change the active level to the Toe-of-Fill level. 

 

This level is automatically turned on in the view and now shows with a 
green background in the Level Display box. 

4. Close the Level Display box. 

Toe-of-fill 
lines 

Active toe-of-fill level 

Centerline 
Alignments 
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Working with the Level Manager 
The Level Manager shows all of the level libraries that are attached to your design 
file, level names, numbers, descriptions, etc. The Level Manager also displays 
each level’s ByLevel symbology – the color, line style and weight assigned to that 
level, which conforms to CDOT’s CADD standards. Other information like if the 
level is used, frozen, available for plotting, etc. is also shown in the Level 
Manager. 

1. Open the Level Manager.  Select Settings > Level > Manager or on 
the Primary toolbar select Level Manager. 

 

2. Sort the Level Manager on Used to bring all the used levels to the top 
of the list (you may need to scroll over to the right to see the column 
Used). 

 

Level Libraries 
Level libraries are master templates of levels. The discipline-specific 
level libraries (Roadway Design, ROW, Alignments, etc.) are attached to 
your design file via the Select Group Environment utility program that 
you ran before starting MicroStation. The Select Group program has 
two options: Bridge and xxMulti-Discipline. All groups except Bridge 
should choose xxMulti-Discipline to attach all level libraries. The Bridge 
option just attaches level libraries needed for the Bridge group.  

When a level is set active and graphics are placed on this level, the level 
is copied from the library file to the active design file. 

Used levels that are copied to the design file appear bold in the Level 
Manager. All unused levels are in the library. 
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1. Scroll through the list of levels. 

All levels have a logical level naming convention according to their 
library (e.g. all roadway design levels start with DES, all alignment levels 
with ALG, topo levels with TOPO). 

The library name is shown in brackets after the level name. 

 

 

 

Change the look of the Level Manager box 
1. Right-click in any column heading (Name, Number, etc.) and select 

List. 

2. Toggle off Number, Description, Logical, Global Display, Global 
Freeze, Lock, Plot and Elements and select OK. 

 

Level library name 
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3. Sort on Used to bring all the used levels to the top of the list. 

 

The Level Manager box updates to reflect the changes. 

4. Close the Level Manager box. 

ByLevel Symbology 
ByLevel symbology ensures that CDOT CADD standards are met by placing 
graphics ByLevel (the color, line style and weight assigned to that level in the 
level library).   

Note: When placing graphics using the CDOT Group Menus, the 
correct level, along with it’s ByLevel symbology is automatically 
set for you (see Chapter 5). 

Analyze an element 

1. Select the drop-down arrow on the Key in box to recall the vi=intersect 
keyin, Enter the keyin and then <D> in view 1 to recall the alignment 
saved view. 
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2. From the Primary toolbar, select Element Information. 

 

3. <D> on the horizontal alignment centerline graphic. 

Element Information shows that the alignment was placed on 
ALG_PROPOSED_Hor_Alignment level and placed with ByLevel 
Symbology.  

 

4. Cancel out of the Element Information box. 

5. Open the Level Manager box. 

6. Find the ALG_PROPOSED_Hor_Alignment level and note the ByLevel 
Symbology is set up in the Level Manager. 
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Review Pop-up information 

7. Hold your cursor over the centerline of SH 86 (the mainline alignment). 

 

MicroStation’s “pop-up” information tells you the type of graphic (line) 
and the level on which it is placed (ALG_PROPOSED_Hor_Alignment.) 
Pop-up information is a quick way to determine what level graphics are 
on. 
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Level Filters 
Level Filters are groups of levels created in the Level Manager by filtering on 
virtually any level criteria (name, number, color, etc.) and then naming the filter. 
These level groups can then be turned on/off using the filter. 

Review the filters 

1. In the left pane of the Level Manager box, click on Filters. 

2. Click on the column name Filter to sort alphabetically by filter name. 

 

3. Turn on the Number column. 
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There are several standard CDOT filters, which are based on name and 
number.  The CDOT standard level naming and numbering convention 
enables the efficient use of level filters. 

 

Note: Level filters are stored in level libraries (note the library name in 
brackets beside the filter). 

4. In the left pane of the Level Manager, Click the + symbol next to the 
Filters to expand the list. 

5. Click the + symbol next to the Roadway Design to expand this list. 
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6. Click on Roadway to review the levels that make up this filter (all 
design levels with Roadway in the name). 

 

 

Note that this filter contains both used levels in the active file and unused 
levels in the library. 

7. Click on Guardrail to review all design levels with Guardrail in the 
name. 

 

 

Note  This filter does not have any used levels in the active design file. 
All levels are from the library. 

8. Right-click in any column heading and turn on the Number column.  
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9. Click on the upper level Roadway Design filter to and review levels. 

 

 

Note that this filter is not filtered on name, but instead contains all levels 
in the Roadway Design level number range (14000 – 14999).  This 
includes all “children” filter levels like Guardrail and Roadway. 

Use level filters to turn levels on/off 
The level filters are stored in the level libraries, accessed via the Level 
Manager. However, to actually use the filters, you need to use Level Display. 

10. Close the Level Manager. 

11. Open the Level Display box from the Primary toolbar. 

 

12. Set the active level to Default by double-clicking it in the Level 
Display box. 

13. Turn off all levels. 
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14. Change the Show option from Levels to Filters.  

 

15. Sort the Level filters alphabetically in ascending order. 

16. Toggle on the Alignments filter. 
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Only the alignment levels (centerline and stationing levels) are turned on. 
Choosing the filter turns on all levels in the filter. 

 

Note: If you toggle the filter off, it turns all levels on by default. 
However, selecting the filter again resets the filter and turns on 
only the filter levels. 

Use level filters to select a group of levels to work with 

17. With the Alignments filter selected, change the Show option back to 
Levels. 
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18. Change the List Filter from (none) to Alignments > Proposed. 

 

The list of hundreds of levels is filtered down to only a few (the levels 
contained in the Proposed Alignments filter). 

19. Turn off the ALG_Proposed_Hor-Alignment-Text and 
ALG_Proposed_Hor-Cardinals levels. 

 

Note: Use Level Filters to improve your MicroStation efficiency when 
searching for levels. Setting the List Filter is an efficient way to 
work with levels. Instead of scrolling through hundreds of levels 
to find a level to turn on, off or set active, the filter breaks the 
levels down into a logical and manageable group.   
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20. Set the List Filter back to (none) to show all levels in the Level Display 
list. 

 

21. Close the Level Display box. 

22. Fit View 1. 

23. Save your settings (File > Save Settings). 

24. Exit MicroStation. 
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3. Working in a CDOT 3D Design Model 
This chapter covers the difference between working in 2D and 3D model and the 
3D concepts you need before moving on to InRoads or other 3D applications. 

2D vs. 3D  

2D design plane 
In MicroStation, you can create either 2D or 3D models within a design file.  In a 
2D model, the working area is known as the design plane.  A 2D design plane is 
similar to drawing on a sheet of paper.  You have an X (horizontal) and Y (vertical) 
axis and all graphics placed in the 2D file are “flat”. 

 

 

 

 

 

 

 

 

You can rotate the 2D design plane about its perpendicular axis (the Z axis 
coming out of the screen). 

2D Design Plane 

X 
Y 
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3D design cube 
In a 3D model, your work area is called the design cube.  You’re working in a 
volume of space with 3 axes — X, Y and Z.  When you place elements, you can 
place them not only in the correct horizontal (X, Y) location, but also in the 
correct vertical (depth or Z) location to create a true 3D model of your design. 

In the design cube, different view orientations can be set.  These include: Top, 
Bottom, Front, Back, Right, Left, Isometric, and Rotated. 

 

Think of a view as a camera location that’s taking a snapshot of your design.  
When you rotate a view, you’re not rotating graphics.  Instead, you’re rotating 
the camera position (or the orientation) of how you’re looking at the graphics. 

Each “face” of the design cube is a standard view (Top, Front, etc.)  In addition 
you can set an isometric view and you can rotate any view about the X, Y or Z-
axis.  For most civil drafting and design work, the top view is synonymous with 
the plan view and the front view is synonymous with the elevation view. 

Set view orientations by using either: 

 The Rotate View command on the View Controls toolbar, or 

   

 The vi= <view name > key-in (e.g. vi=top). 
 The rv= <x,y,z> keyin to rotate a view about the x, y and /or z axis (e.g. 

rv=,,-30 rotates a view 30 degrees clockwise about the z axis). 
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Using Active Depth 
When working in a 3D design model and placing graphics in a view, at what depth 
are the graphics being placed?  They are placed at the active depth.  The active 
depth is a plane, parallel to your view screen, on which you’re placing elements.  
For example, if you are creating a topo map and manually drawing the 5000-foot 
contour in the top view, you first set the active depth for the top view to 5000, and 
then draw the contour. 

 

To set a view’s active depth: 

 Key in az=<depth>. 
 <D> to select the view of interest. 

The active depth is view dependent.  Therefore, you must tell MicroStation 
which view you’re setting the active depth in by data pointing in the view. 

Note:  For most civil work, you’ll set an active depth in the top (plan) 
view.  The active depth is then the elevation at which you’re 
placing graphics.  If you switch to a Front view, you’ll see the 
elements at the different elevations. 

Active depth is synonymous with the term active z. 

To check a view’s current active depth: 

 Key in az=$. 
 <D> in the view of interest. 

The current active depth is displayed in the message field 

 

Note: Use the delta key-in dz=<depth> to move the active depth by 
the delta <depth> amount, then <D> in the view.  Multiple data 
points change the depth each time. 

Active depth 
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Using Display Depth 
Display depth is the depth range or the “slice” of the design cube in which elements 
are visible.  You set the display depth by specifying an upper and lower depth 
(elevation) range for the view. 

 

To set a view’s display depth: 

 Key in dp=<lower depth, upper depth>. 
 <D> in the view of interest. 

Note:  Like active depth, display depth is also view dependent.  So you 
have to tell MicroStation which view you’re setting the display 
depth range for by data pointing in the view (the top view in 
most cases). This allows you to have different display depths in 
different views. 

Active depth 

Upper depth limit 
(clipping plane) 

Lower depth limit 
(clipping plane) 
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Display Depth tips: 

 Display depth limits are also known as the view’s clipping planes. 
 A view’s active depth is always within its display depth range (i.e. you 

can not set an active depth outside the display depth). 
 Use the key-in dd=<delta lower depth, delta upper depth> to 

expand the display depth by the delta amount.  This moves the display 
depth as specified from its current location. 

 The Fit command automatically changes a view’s display depth (expands 
or shrinks to fit elements currently turned on in the view). 

Note:  If you can’t see graphics in a 3D model, they may just be outside 
your display depth.  Fit your view as a quick check. 

 The current active and display depth settings are saved when you save 
settings (File > Save Settings).  This determines the default depth when 
you open a design file. 

To check a view’s display depth: 

 Key in dp=$. 
 <D> in the view of interest. 

The view’s current display depth is displayed in the message field. 

 

 

CDOT 3D Seed File Defaults 
The CDOT default settings for active and display depth are set in the CDOT 3D 
seed files for each specialty group. 

Active Depth 
The CDOT default setting for active depth is 0. 

Display Depth 
The CDOT default setting for display depth is -1000, 15000. 
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Lab 3 – 3D View Control 

Objectives 
After completing this exercise you will know how to: 

 Check the elevation of an element. 
 Rotate a view using the rv= keyin. 
 Rotate a view using the 3-point method. 
 Rotate a view by element. 
 Rotate to a standard view (Top, Front, etc.) . 
 Check and set the Active Depth. 
 Check and set the Display Depth. 

Starting MicroStation 
1. Start MicroStation and open the design file 12345DES_Model.dgnfrom 

the C:\Projects\12345\ Design\Drawings\Reference_Files folder. 

You will use this CDOT project, which has proposed graphics placed at 
the correct elevations, to practice with the concept of 3D view controls.  

2. Look in the top title bar of the MicroStation window and note that this is 
a 3D file. 
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3. Fit View 1 

 

The design file shows only the proposed alignments because only the 
ALG levels were turned on when settings were last saved. 

Checking element elevations 
You can quickly check the coordinates of any point (including the Z coordinate in a 
3D file) by placing a tentative point. 

1. Key in vi=intersect to recall the alignment saved view. 

Note: Always press <Enter> or <Tab> after keyins. 

2. <D> anywhere in View 1 to recall the saved view. 

 

The design file has some graphics, like the horizontal alignment, placed 
at elevation 0. Other graphics, like contours generated by InRoads, are 
placed at an elevation range of approximately 6600 ft. 
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3. On the Attributes toolbar, set the filter to Alignments-Proposed and 
then set the active level to ALG_PPROPOSED_Hor-Alignment. 

   

4. Place a Tentative point <T> on the North-South cross-road alignment just 
south of the intersection.  

Note: The Tentative button in the CDOT workspace is set to the 
middle button on the mouse. If you want to change it, select 
Workspace > Button Assignments. 

 

The tentative point jumps to the closest keypoint on the element. You 
will see a large cross-hair at the keypoint.  You’ll learn more about 
keypoint and other snap modes in later chapters. 

A tentative point is a temporary location that displays the coordinates for 
the point in the Message Field (bottom of screen). 

 

Note that the centerline alignment graphic in the top view (plan view) 
has a Z value of 0. Therefore it has an elevation of 0. 

Tentative snap 
location 
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5. Open Level Display and set the level Filter to None to show all levels.  
Sort by Name and then Used levels.  Turn on the levels 
DES_ROADWAY_Toe-of-Fill and DES_ROADWY_Top-of-Cut.   

 

6. <T> on one of the cut or fill lines and note its elevation (Z coordinate). 

 

 

7. <T> on a few other top or toe lines and note the elevations. 

The graphics should be placed at a depth of approximately 6620 ft. or 
within a close range. 

Tentative snap on a 
cut or fill line
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8. In Level Display, click on the + symbol next to the file 
12345SurveyTopo100Scale.dgn to expand the list of reference files.  

 

9. Highlight the reference 100Scale2_10,12345SURV_Contour100.dgn 
and turn on levels TOPO_TERRAIN_Contours-Major and 
TOPO_TERRAIN_Contours-Minor. 

 

Note: The contour file is a reference to the design model file. You’ll 
learn more about references in Chapter 4. 
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10. Window in on some of the contours to the right of the intersection so that 
you can easily read the labels. 

11. <T> on some of the major contour graphics and note the elevations. 

 

 

The major contours are placed at 10 ft. intervals. 

12. <T> on some of the minor contour graphics and note the elevations. 

 

 

The minor contours are placed at 2 ft. intervals. 

<T> on a major 
contour 
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13. In Level Display, turn off the existing major and minor contour levels as 
shown. 

 

14. In Level Display, highlight the 12345DES_Model.dgn file to work with 
the master file levels again and turn all levels on. 

  

 



Colorado Department of Transportation 

Page 110  CDOT MicroStation Essentials 

Rotating a 3D Standard View 
1. From the View Control toolbar, select Rotate View. 

   

2. In the Tool Settings box, set Method to Front. 

3. Fit View 1. 

 

The view is rotated from Top (plan view) to Front (elevation view). Note 
that some graphics, (like the red horizontal alignments you checked 
earlier), are displayed at elevation 0 below the proposed graphics (edges 
of oil, cut/fill lines, etc.), which are displayed at the correct elevation 
(6620 ft. range). 

Note: Rotating to the Front view is a handy way to visually check your 
file for survey busts or bad elevations which may “spike” down 
to 0. 

Proposed graphics 
at correct elevation 

(6620 ft. range) 

Alignment graphics 
at 0 elevation 

Front view 
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4. Select the Rotate View command again and set the Method to Top. 

   

 

This returns the view to a plan view and its original un-rotated settings. 

5. Key in vi=front. 

6. <D> to select the view. 

 

The view is rotated back to an elevation view.  You can use the vi= keyin 
to rotate to standard views (top, front, isometric, etc.) as well as to recall 
saved views. 
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7. Key in vi=iso. 

8. <D> to select the view. 

9. Fit the view. 

 

This gives another 3D perspective of the design file graphics. 

10. Select the Rotate View command again, set the Method to Dynamic 
and toggle on Dynamic Display. 

 

11. <D> near the intersection in the view to identify it for rotation, then move 
your cursor in a counter-clockwise motion. 

As you move your cursor the view dynamically rotates.  The Dynamic 
Display option allows you to see the rotation in real time. 
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12. Zoom in on the intersection and continue experimenting with the 
Dynamic rotation option until you’re comfortable with the tool. 

 

Hint: If you <T> on a location (like the intersection center) after 
selecting the Dynamic method, you will rotate about the 
tentative point. 

Check the Active Display Settings 

Check the Current Active Depth 
1. Rotate the view back to Top. 

2. Fit the view. 

3. In the MicroStation Key-in box, key in az=$ to check the active depth. 

Note: The dollar symbol ($) is used to request current settings. You can 
also use a question mark (?). 

MicroStation prompts: Select View. 

4. <D> anywhere in View 1 (top view). 

Note: Active and Display depths are view dependent (i.e. you set these 
in each view).  Therefore, you have to tell MicroStation which 
view you want to check the Active Depth in by data pointing in 
the view. 
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5. Check the Message field. 

 

MicroStation returns the current active depth setting (yours may be 
different than shown). This means if any graphics are placed in the 
design file’s top view without giving them an elevation, they will go in at 
this elevation or depth. 

Since the depth axis of the top view (plan view in a 3D file) is the Z axis, 
this means graphics will be placed at this elevation. 

6. Key in az=0. 

7. <D> to select the view. 

8. Key in az=$. 

9. <D> to select the view. 

 

You have now set the active depth to 0.  Any new graphics placed in the 
file will be placed at an elevation of 0, unless you snap to an element at 
another elevation. 

Check Current Display Depth Settings 
1. Window in around the intersection. 

 

2. Key in dp=$, then press <Enter>. 

3. <D> in View 1. 
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4. Check the Message for the current display depth settings. 

 

The current display depth in the top view is set very large (yours may 
vary from that shown).  Therefore, you are able to see all the graphics in 
the top view since they fall in the depth (elevation) range. 

5. Key in dp=6000,7000. 

6. <D> anywhere in View 1 and look at your graphics. 

 

The graphics placed at this elevation range (shoulder, edge-of-oil, cut/fill 
lines, etc.) now appear in the view.  All of the graphics placed at 
elevation 0, like the red proposed horizontal alignment, stationing and 
alignment text, are not displayed. 
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7. Key in dp= –10,100. 

8. <D> anywhere in View 1 and look at your graphics. 

 

Only the elements placed in this elevation range (e.g. the proposed 
horizontal alignment and text placed at 0) appear in the view.  All other 
graphics are outside of this elevation range and are not displayed. 

9. Fit View 1. 

All of the graphics appear in the view. 

10. Key in dp=$. 

11. <D> anywhere in View 1 and check the Message field. 

 

The display depth range is automatically expanded after using the Fit 
command to show all of the elements in the view. 
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Turn On Raster Images 
1. Select File > Raster Manager. 

2. Double-click on the 09a.tif file. 

3. On the Display/Print tab, toggle on View 1 and select OK. 

 

4. Repeat for 10a.tif. 

5. Close the Raster Manager box. 

6. Fit View 1. 

The raster images are now on for a future lab. 

7. Select File > Save Settings. 

This saves all settings changes, including open views, levels turned 
on/off, active and display depth settings, etc.  The next time you enter 
this design file, it will appear just as you left it. 

8. Exit MicroStation. 
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Section 2 – The CDOT MicroStation Workflow 
Now that you are comfortable working in a MicroStation design file, you are ready 
to learn how CDOT specifically uses MicroStation in the project process. This 
section concentrates on how CDOT creates model file graphics by utilizing the 
CDOT Menu. It also covers the sheet file creation process. Once your sheets are 
created, you will learn how to annotate, dimension and plot the sheets. 

4. Creating a CDOT Project 
This chapter is a general overview of the entire CDOT workflow to complete a 
CADD project using MicroStation. You will learn how to set up a CDOT project 
and create your design model file and reference other discipline’s files. 

CADD Workflows  

Model files vs. Sheet files 
To understand how CDOT uses MicroStation for design and drafting, you first 
need to understand the difference between Model files and Sheet files. Model 
files contain the design graphics. These are the working files for your design. 
Each group has at least one Model file, but can have multiple model files for 
different types of graphics. For example, the Roadway Design group can have a 
model file for plan graphics and another model file for profile graphics. The 
Traffic group may have separate model files for signs, signals and lighting. 

Model Files 

Design/Specialty Group
Plan graphics

Profile graphics
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Sheet files are the files that will be plotted for the creation of a plan set. Sheet 
files reference model file graphics. A reference is just a MicroStation file 
attached to your active file (the file you have opened). You can reference 
multiple model files to create a sheet file. For example, a Bridge general layout 
sheet may reference the existing survey/topo model, the proposed roadway 
design model and the proposed bridge model to show all of the needed 
information on the sheet. A Plan Profile sheet (shown below) references the 
proposed roadway design model and the profile model.  

Sheet files typically do not contain design graphics since they are referenced in 
from the model files. You can’t modify the model file reference graphics in a 
sheet file; they are there for information only. The sheet files, however, do 
contain the border and associated information (bar scale, north arrow, etc.) along 
with text and dimensions, which can be modified since these elements are 
placed directly in the sheet. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

For more information on References, see the section Referencing Others Work 
in this chapter. 

Model Files 

Sheet File 

REFERENCE 

Border, Bar Scale, North Arrow and RE info. 
placed directly in the sheet file 
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Model File Workflow for Survey/ROW  
To create existing model files, the Survey/ROW group uses MicroStation and 
InRoads Survey to reduce the electronic fieldbook data and create model files 
for ROW, survey planimetrics and existing topographics. These existing model 
files can then be referenced by Design and specialty groups as a base for 
creating the proposed model files. 
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Model File Workflow Roadway Design  
To create proposed design model files, the Roadway Design group references 
the existing survey/topo and ROW models to begin the design. MicroStation and 
InRoads are then used to create the proposed graphics in various model files – 
plan, profile, intersection, etc. (See Chapters 5 - 8 for more information on 
creating your design.) Occasionally, other specialty group model files are 
needed by Design, so these model files may be referenced as well. 
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Model File Workflow for Specialty Groups 
Each specialty group references the Roadway Design group’s proposed model 
file to begin their design. MicroStation and other specialty programs are used to 
create the graphics in separate model file(s) for each group. (See Chapters 5 – 8 
for more information on creating your designs.) When the specialty group 
references Design’s model file, they can choose to reference the existing model 
file(s) from the Survey/ROW group as well.  This way, both existing and 
proposed graphics can be displayed in the specialty group’s model file, if 
needed. 
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Sheet File Workflow for Roadway Design 
To create sheets (specifically plan or plan/profile sheets in this example), the 
Design group creates a new MicroStation design file for each sheet. Then, the 
proposed model file is referenced into the sheet file. Since the proposed model 
also has the existing model file referenced, the survey graphics can be displayed 
in the sheet. The sheet file view is rotated, if needed, so graphics appear 
horizontal. Then, only the portion of graphics needed for the sheet is “clipped” 
out from the reference. The border, north arrow, bar scale and resident engineer 
information is then placed directly in the sheet file via the CDOT Menu (see 
Chapter 5). Many generic sheet files also contain a border, which can be edited. 
The sheet can be annotated with MicroStation text and the reference graphics 
dimensioned, if required. Unlike reference graphics, text and dimensions are 
placed directly in the sheet file and, therefore, can be edited in the sheet. 

Other sheets like detail, title, general notes, etc. have specific requirements, but 
use the same general premise of referencing the model file(s) to the sheet file. 
Typical Section sheets are an exception to the rule, since graphics are created 
directly in the sheet file using the CDOT Typical Section Program. See Chapter 
9 for more information on creating sheets. 
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Sheet File Workflow for Specialty Groups 
Specialty groups create a separate MicroStation design file for each sheet, and 
then reference their own model file(s) into the sheet file. Since this model file 
can also have Roadway Design and ROW/Survey’s model files referenced, these 
graphics can be displayed in the sheet. The sheet file view is rotated, if needed, 
so graphics appear horizontal. Then, only the portion of graphics needed for the 
sheet is “clipped” out from the reference. The border, north arrow, bar scale and 
resident engineer information is then placed directly in the sheet file via the 
CDOT Menu (see Chapter 5). Many generic sheet files also contain a border, 
which can be edited. The sheet can be annotated with MicroStation text and the 
reference graphics dimensioned, if required. Unlike reference graphics, text and 
dimensions are placed directly in the sheet file and, therefore, can be edited in 
the sheet. 

Other sheets like detail, tab, and note sheets have specific requirements. See 
Chapter 9 for more information on creating sheets. 
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CDOT CADD Resources 
There are many resources available to assist you when working on your CDOT 
CADD project. These resources can be found on the CDOT CADD & Engineering 
Innovation Web site. 

CDOT CADD & Engineering Innovation Web Site 
The CDOT CADD & Engineering Innovation web page is available at: 

http://internal/cadd/  It can also be found on the internal CDOT website: 
Organizations > Project Development > CADD and Engineering Innovation. 

The website (presently only available to CDOT) provides CDOT users with up 
to date information, tools, and resources related to CADD and the Colorado 
Engineering Software Transition (CEST) project.  
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This website is a valuable resource for CADD users and includes: 

CADD Library  
The CADD Library page provides links to manuals, newsletters, standard details, 
etc. One extremely useful link is to the Tips and Tricks section for MicroStation 
and InRoads. This information changes daily, so check back often. 
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CADD Manual 
The CDOT Computer Aided Design and Drafting (CADD) Manual outlines 
CDOT’s use of Bentley’s MicroStation and InRoads software. It documents 
standardized procedures for the exchange of information between CDOT 
regions, specialty groups, and consultants working on CDOT projects. The 
Manual also addresses software issues, tools, techniques, standards and 
procedures, etc. which will aid the user in the efficient production of CDOT plan 
sets. 

The CDOT CADD Manual and the associated electronic files contained in the 
CDOT configuration are used in the generation of electronic plans by both 
CDOT internal designers and the consulting firms doing business with CDOT. 
The electronic version of the Manual provides hyperlinks to each chapter as well 
as context sensitive index and search functions. You can also print chapters or 
the entire manual. 

The CDOT CADD Manual can be accessed several different ways including: 

 From the CDOT internal CADD web site home page link; 
 From the CDOT Design and Construction Project Support Page (external 

web site); 
 From the CDOT Menu (Help > CADD Manual). 
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CDOT Workflows 
There are several standardized MicroStation and InRoads workflows that CDOT 
has developed to assist you. These workflows are step-by-step CDOT-specific 
procedures for certain tasks that you may encounter when working in 
MicroStation or InRoads on a CDOT project. Many of these workflows are 
referenced throughout the course. 

In addition to accessing the workflows from the CDOT CADD Web site Home 
page link CDOT Work Flow, you can also access workflows: 

 From the Windows Start menu  
(Start > All Programs > _CDOT_CADD_Information > Workflows); 

 From the CDOT Menu (Help > Workflows). 

New workflows are typically added with CDOT configuration updates, so check 
back often. 
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Issues Logs  
Check the issues log to determine the status of submitted requests. 

Requests & Support 
This page provides CADD help solutions where you can: 

 Learn how to get help; 
 Submit a questions; 
 Submit a request (e.g. request a new MicroStation level or InRoads 

preference), as well as  
 Obtain InRoads, InRoads Survey and MicroStation support.  

There is also a link to IT Services for hardware support, “how to” instructions, 
installation, training files, and dual monitor and work space setup. 

 

 

Training 
Use this link to sign up for training classes.  You can also review online 
computer-based training (CBT) for MicroStation, InRoads and InRoads Survey. 
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Single Source Project Data 
The use of MicroStation references is a powerful tool that allows all users on a 
project to share graphical data files from a single source. You should always access 
graphics files from a central location (either on a project server or from a Project 
Manager’s machine). This eliminates the need to copy graphics files to multiple 
machines when several users are working on a project. Copying graphics files 
out of their project location is bad practice and should be avoided. 

Instead, you can use MicroStation to reference files you need from other groups, 
and multiple users can reference the same file. The “owner” of the file can continue 
working on it while those referencing the file can see the updates. This way, the file 
remains in a central location and you’re assured that you’re working with the latest 
version of that file. 

 

 

 

 

Project 
Manager’s 

computer or 
network drive 

ROW/Survey 

Design 

Bridge 

Utilities 

Single-source 
Project 

Directory 

Hydraulics 

Landscape/Env. 

Traffic/ITS 
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Project set-up  
The Project Manager (PM) is responsible for setting up a new project. To take full 
advantage of single source data, the project directory is created on either a network 
sever or on the PM’s personal computer. All users working on a project would then 
need to map the PM’s machine in order to access the project directory. 

The Create Project Directory Utility 
To create the project directory, the Project Manager runs the Create Project 
Directory utility. The utility is found on the Windows Start Menu (Start > All 
Programs > _CDOT_CADD_Information > Create Project Directory 
Structure). 

 

The PM enters the Job Project Code (JPC) and runs the utility. This creates the 
project directory and associated blank and auto-populated files, along with the 
Project Configuration File (PCF).  

The project can either reside on the Project Manager’s computer or on a network 
drive. If it’s on the PM’s machine, make sure this drive is shared to others 
working on the project. To create the project on a network drive, select the 
Browse button (…) next to Destination and then select Open. 

 
You can now set the path to any mapped network drive. 
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For more information see the CDOT CADD Manual, Chapter Three —
Project Directory Structure, section 3.1 – Project Creation Utility. 
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The PCF file 
The Project Configuration File, created by the utility, defines a specific directory 
that MicroStation defaults to when opening up a DGN file or referencing model 
files. PCF files are extremely useful when multiple users are accessing the same 
project directory across the network, or when DGN files are moved from one 
directory to another. 

Working in a server environment 
If multiple users are accessing the same project directory, the PCF file will need 
to be distributed to everyone on the team accessing the project directory. Each 
member of the team should have their own copy of the PCF file and it should be 
saved to the same location, C:\Program Files\Workspace-CDOT\Standards-
Local\Projects. The PCF is also useful for managing references. If a reference 
file is moved, you should never have to reattach it. You can use the PCF to 
manage the reference locations. 

When team members are sharing the project manager’s machine, the PCF file 
will need to be edited. See the Workflow CDOT PCF Management for more 
information. 
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The CDOT Project Directory Structure 
The Project Creation utility creates the project directory structure on the server or 
PM’s computer. All CDOT projects should follow this structure to ensure the 
accurate sharing of information between groups within the Department as well as 
outside consultants. The CDOT Project Directory’s top level designates the project 
code. Below this folder is a set of standardized sub-directories for each CDOT 
specialty group. Under each specialty group folder is a sub-directory structure 
unique to that specialty group. 

For more information about the CDOT project directory structure, see the CDOT 
CADD Manual, Chapter Three – Project Directory Structure, section 3.2 
– Project Directory Structure.  
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Training Project Directory 
For this training class, you will create a project directory structure with an 
example Job Project Code (JPC) of 12345 shown below. The Roadway Design 
group’s sub-folder is shown expanded to show an example of a group’s sub-
folder structure. 

 

Training files 
The training lab files for CDOT CADD courses can be accessed from the 
Windows Start Menu. Select Start > All Programs > 
_CDOT_CADD_Information > Training Files > Insert Training Files on my 
Computer. A link is also available on the Training page of the CDOT CADD 
web site.  

It is highly recommended that you that you install the training files and continue 
practicing with MicroStation by completing the lab exercises contained in this 
course guide, especially if you do not plan to start work on a MicroStation 
project soon. 
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CDOT file naming convention 
Model files and Sheet files need standard, informative, and unique names to 
allow easy identification of the specialty group responsible for the file and the 
type of information contained within the file. All CDOT CADD drawings 
created should follow this naming convention so the data can be easily identified 
and shared by all users.  

The CDOT file naming convention contains the Job Project Code (JPC), a 
specialty group identifier, short standardized file name, an optional annotation 
scale identifier, an optional description, and file extension.  

 

An example of a MicroStation design file would look like the following: 

12345DES_Model100US285.dgn 

12345 indicating the CDOT Project Number, DES indicates it is Roadway 
Design’s model file and 100 indicating it uses a 1”=100’ annotation scale, 
US285 is a description identifying the highway this model depicts. . DGN is the 
default extension for MicroStation design files. 

Note:  A seventh segment is used on Working Files. This segment 
should be the initials of the designer or engineer who is working 
on the file.  
Example: CU12345DES_Model100.dgn where CU, are the 
initials of the designer or engineer (in this example, CU stands 
for “CDOT User”).  

For more information about the CDOT project directory structure, see the CDOT 
CADD Manual, Chapter Four – File Naming Convention. 
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Auto-populated files 
In addition to creating the project directory structure, the Project Creation Utility 
also creates several auto-populated drawing files that have the CDOT standard 
file names already assigned (the # symbol is used for the counter). When 
creating a new file, one option is to open the appropriated auto-populated file in 
MicroStation, select File > Save As and then rename the file. 

The diagrams below shows an example of auto-populated files automatically 
created for the Roadway Design group. 
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What files go where? 
As you’ve learned there are two main types of CADD files for a CDOT project: 
Model files, which contain graphics for referencing into sheets and Sheet 
files, which generally contain either references to model files or non-design 
related items such as general notes, special symbols, quantities, sheet borders, 
etc. 

Working Model files 
Working files (or sketch files) are model files containing graphical data created 
during the design workflow.  These files should be placed in the "Working" 
folder in each group’s sub-folder. The file name should include the designer's 
initials. These files are not to be considered final design files, and 
should not be referenced to sheet files or other reference model 
files. An example of a working file would be: 
//12345/Design/Working/CU_12345Des_Model100.dgn 

 

Reference Model files 
The most up-to-date model files which are available to other groups for 
referencing (files that only have the most current non-sketch or working 
information in them) should be placed in the group’s Drawing > 
Reference_Files folder. The designer’s or engineer’s initials should be removed 
after moving this file. 
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Sheet Files 
Sheet files are typically stored in a group’s Drawings folder as shown.  

 

Plot files 
When sheet files are plotted to PDF, the plot files are placed in the project’s 
Plot_Sets folder. Sub folders for AD, FIR, FOR and ROW are available. 
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For more information, see the CDOT CADD Manual, Chapter Three – 
Project Directory Structure, section 3.2.2 – Group Sub-Directory 
Structure. 

 

 

See also: 

 CDOT CADD Manual, Chapter Four – File Naming Convention, 
section 4.2 File Types. 

 CDOT Directory Structure Workflow. 
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The CDOT Workspace 
The CDOT Workspace is a custom environment designed to facilitate CADD 
productivity and direct the user to CDOT-specific standards, workflows and 
processes. The CDOT Workspace is a complex set of configuration files, 
MicroStation and InRoads resource files, workflow documents, and many other 
customized tools, all designed to work together to increase productivity and 
efficiency, and allow for a standardized project plan set output. Some of the items 
in the workspace include: 

 Seed files (starter files that contain MicroStation settings for creating 
new files). 

 Cell libraries (standard details, symbols, notes, etc.) 
 DGN libraries (standard level structures, text styles and dimension 

styles). 
 Line style resource files (custom line styles). 
 Font resource files (special fonts). 
 Plot drivers (for plotter configuration and PDFs). 
 Pen tables (for special plotting preferences for certain graphics). 
 InRoads preference files (for controlling InRoads graphical displays). 
 InRoads templates (for standard typical sections). 
 CDOT configuration files (to set the correct MicroStation resource files 

and other standard files located on the user's computer). 
 Workflow documents (CDOT standardized procedures for specific 

MicroStation and InRoads tasks). 
 CDOT Group Menus (access to tools and applications which provides a 

simple, efficient method of applying CDOT’s CADD standards to every 
project). 

The installation of the Workspace will be controlled and maintained by the 
Information Technologies (IT) Department. You can manually update the 
workspace at any time by selecting the  
Start > All Programs > CDOT_CADD_Information > Update MicroStation-
InRoads Standards.   

The CDOT workspace and configuration files are located on each user’s computer 
in the C:\Program Files\Workspace-CDOT folder. 
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The Select Group Environment Utility Revisited 
You have seen how the Select Group Environment utility automatically 
attaches the correct level libraries needed for working on a CDOT project. 
However, this utility also provides CDOT users additional MicroStation 
resources unique to their group (group-specific cells, seed files, linestyles, levels 
and symbology, etc.) The utility must be run prior to starting MicroStation in 
order to set up tools specific to that user's group. 

There are two group options: Bridge and xxMulti-Discipline.  The multi-
discipline environment enables MicroStation to have all the cell libraries, level 
libraries and filters, available at anytime without having to load these items 
individually.  The Bridge option loads just the specific files needed for the 
Bridge group.  

The Select Group Environment Utility can be run from the user's computer 
through the Start button (Start > All Programs > _CDOT_CADD_Information > 
Select Group Environment. You MUST exit MicroStation prior to running this 
utility.  

 

For more information on the Select Group Environment, see the CDOT CADD 
Manual, Appendix F – Select Group Environment Utility. 

For more information on the CDOT Workspace in general, see the CDOT CADD 
Manual, Chapter Two – CDOT Workspace. 
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Configuration releases 
The IT Department is responsible for updating your computer when the CDOT 
workspace and configuration is updated. For a detailed description on what’s in 
the new configuration release, see the CDOT Configuration ReadMe workflow. 

 

You can also access this workflow and others (in PDF format) from the CDOT 
workspace in the CDOT Notes sub-folder. 
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The CDOT Level Structure 
Thirteen Specialty Group Design File Level Libraries (DGNLIBs) are available for 
use within CDOT.  The levels libraries are attached to your MicroStation design file 
via the Select Group Environment utility and provide the CDOT approved 
standard discipline levels you can use when placing graphics. You can not create, 
edit or delete levels within the CDOT Workspace – you must use the levels 
provided in the DGNLIBs. Likewise, you can not modify the level's symbology, 
thereby maintaining “ByLevel” status for standardization purposes. ByLevel 
symbology is used by default for all level libraries and is the required standard for 
plan set creation.  CDOT has adopted an “existing vs. proposed” leveling scheme, 
whereas with the use of pen tables, all existing design data will plot gray scale.  
Level duplication across disciplines has been avoided wherever possible. 

Level libraries (DBNLIBs) are stored in the CDOT workspace (C:\Program Files 
\Workspace-CDOT\Standards-Global\MicroStation\DGNlib). 
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For more information about the CDOT level structure and a list of all discipline 
level libraries, see the CADD Manual, Chapter 5 – Drafting Standards, section 5.3 – 
Design File Level Libraries. You can link to a specific group to review its standard 
level structure. 
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Level naming convention 
The standard CDOT level naming convention shown below is used to allow for 
easy filtering of levels in MicroStation’s Level Display or Level Manager.  

 

Levels and configuration releases 
When a new configuration is released, it is not unusual for the CDOT Standards 
and Configuration committee to add, change or delete levels from the level 
libraries.  If you’re working on a project, you will need to update the used levels 
in a design file to the new configuration standards. Each new configuration 
release includes a comma separated variable (CSV) file that maps old levels to 
new levels. You will need to apply this level mapping to all existing files that 
you wish to update to the new configuration. Refer to the CDOT Level Update 
workflow for more information. 
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Creating a new CDOT Model file 
When you’re ready to create a new model file to begin your work, you have two 
options: 

 Create the new file from an auto-populated file or 
 Create the new file from a seed file 

Creating a model file from an auto-populated file 
Auto-populated files are created by the Project Creation utility. The model files 
are created in the group’s \Drawing\Reference_Files folder. You can rename 
these files and save them to the project’s \Design\Working folder to create 
your new model file. 

Creating Model files from seed files 
A seed file is a “starter” file.  It has all CDOT standard settings for each 
specialty group. Seed files are either 2D or 3D, so make sure you choose 3D 
when creating model files. 

See the CDOT CADD Manual, Chapter Five – Drafting Standards, 
section 5.2 – Seed files for more information. 

 

CDOT default settings 
When a new file is created from a seed file or auto-populated file, there are 
several settings already established that conform to the CDOT standards. Two 
important settings include Working Units and Coordinate Readout. 
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Working Units 
The working units in either a 2D or 3D file determine the measurement system 
for the design file.  Working units are defined as: 

 Master Units:Sub Units or  
 MU:SU. 

You set a design file’s working units for any desired measurement system.  For 
typical Imperial units (English), you could set Master Unit to feet and Sub Units 
to inches.  The working units would then be expressed as 1:12.  If you set 
Master Units to Feet and Sub Units to tenths of a foot, your units would be 
expressed as 1:10.  

CDOT standard Working Units 
CDOT standard working units are 1:12 and express as: 

 Master Units = Survey Feet (’) 
 Sub Units = Survey Inches (”) 

There are two types of unit definitions for imperial feet – survey and 
international.  These have a slightly different conversion factor from metric.  
CDOT uses the survey foot definition. 

The working units settings are found under Settings > Design File > Working 
Units. 

 

Entering data 
When you enter data for lengths, distances, etc. you use the format for working 
units: MU:SU.  You can enter data in just master units, just sub units, or both. For 
example, if your working units are 1:12 (feet and inches), and you want to place 
a line with a length of 1 foot 1 ½ inches, you could enter the length as: 

 1.125 
 1: 1 1/2 
 :13 1/2 

Note:  You can use either fractions or decimals when entering data. 
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Coordinate Readout 
Use Settings > Design File > Coordinate Readout to determine how 
MicroStation values are displayed.  This is helpful, for example, when you 
measure graphics.  

 

You can set your linear values to readout in master units, sub units or both. 
Angles can readout in either degrees-minutes-seconds (DD MM SS) or decimal 
degrees (DD.DDDD) with up to 8 decimal place accuracy. 

The CDOT standard coordinate and angle readouts are shown above.  These 
settings are copied over from the seed file. 

Referencing others work 
A Reference is a file that is attached to your active file, so that you can see the 
file’s graphics.  Reference graphics are not actually in your active file, but serve as 
background data.  You cannot modify reference graphics from the active file.  You 
can, however, copy graphics from the reference model to the active model and then 
modify them, if desired.  Using references is a good way to copy a large number of 
graphics from model to model. 

The proper use of MicroStation References is critical to achieving two key 
components of the CDOT MicroStation workflow: 

1. Maintaining a single source for project data. 

2. Sharing graphical data between specialty groups. 

References allow multiple users to work on different parts of a project at the same 
time.  Multiple users can access the same reference from a central location (e.g. 
project directory on the PM’s computer). Specialty groups can interact throughout 
the design process by referencing other discipline-specific model files. The data 
exchange between disciplines is “real time” when using MicroStation References.  

References are useful in the plan set creation phase.  You can “build” the sheets by 
referencing in the individual model files (survey/topo, design, utilities, etc.) Each 
discipline’s Master Model file can reference other discipline’s model files, as 
needed. The Master Model file can then be referenced into a newly created sheet 
file (see The CDOT MicroStation Workflow section in this chapter). You can also 
reference in details and show these at a different scale on the same sheet. 
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Attaching References 
To attach references, select References from the Primary toolbar. In the 
References dialog box, select Tools > Attach.  

 

Different reference file attachment methods are available to help control 
reference manipulations and displays. These include: 

 No nesting 
 Live nesting 
 Copy attachments   

Nested References 
References can be attached nested — meaning you can attach a reference’s 
reference. 
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The Nested Depth option determines how many reference levels deep you can 
attach.  In the example below, if the reference BridgeModel is attached to 
BridgePlanSheet01 with No Nesting, only the Bridge Model graphics are 
attached. If the nested depth is set to 1, you would attach BridgeModel01 and 
DesignModel01. If the nested depth is set to 2, you would attach 
BridgeModel01, DesignModel01, Survey/Topo and UtilityModel01. 

12345BRDG_Plan01.dgn 
(Sheet File) 

12345BRDG_Model.dgn 

12345DES_Model.dgn 

12345SURV_Topo.dgn 12345UTIL_Model.dgn 

Model Files 

Nested depth =1 

Nested depth =2 
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The Live Nesting option allows you to dynamically update a reference’s sub-
references after the reference is attached.  You can change your Live Nested 
Depth and your references will automatically update without having to detach 
and reattach the reference. 

The Copy Attachment Option 
The Copy Attachment option allows you to dynamically make all nested 
references upper-level references. This way, you can manipulate and control 
each reference display individually, if needed. You can switch between nested 
references and the copy attachment at any time. 

 

Working with Raster Attachments  
When you attach a reference, you have the option to Display Raster 
References. If the reference has a raster image attached (e.g. aerial photo), you 
can choose to attach the raster with the reference. You can toggle the raster 
reference on/off from the Reference dialog box. 

 

For more information on working with raster references, see the CDOT Raster 
Manager workflow. 

Reference Levels 
You can control each reference’s levels just like the master file levels. The Level 
Display box shows a list of all attached references to the Master file. Select the 
reference and then turn the reference level on/off. 
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Lab 4 – Creating the Project and Design Model 
In this lab, you’ll create a new 12345 project using the Create Project Utility. 
Then, you’ll create a new Roadway Design model from an auto-populated file 
(generated by the Create Project Utility program) and by creating one from a CDOT 
3D seed file. Once created, you’ll reference other discipline’s work in order to start 
the design.  

In subsequent labs, you’ll use a similar process to create other discipline model files 
(Bridge, Landscape & Environmental, Traffic, etc.). 

Objectives 
After completing this exercise you will know how to: 

 Create a new project and project configuration file (PCF) using the 
Create Project Directory Structure program. 

 Re-assign a project number via the PCF. 
 Create a new design model using a CDOT seed file. 
 Create a new design model using an auto-populated model file. 
 Attach a reference. 
 Turn reference displays on/off. 
 Turn reference levels on/off. 

Create a Sample 99999 project 
In this example, you are starting your project before a project number has been 
assigned. You will temporarily assign the project number 99999. Later in this lab, 
you will learn how to change this project number by updating MicroStation’s 
project configuration file. 

1. From the Windows Start Menu, select Start > All Programs > 
_CDOT_CADD_Information > Create Project Directory Structure. 

2. Verify that the Project Template location is set to C:\Program Files > 
Workspace-CDOT > Project Template. 

3. Set Destination to C:\Projects. 

4. Key in 99999 for the Project Code. 

 

Note: The project number must be a 5-digit numeric code. 

5. Toggle on Create Project Configuration File. 

6. Select Apply. 
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The project directory structure is created in the C:\Projects folder and 
the Project Configuration File (PCF) file is created. 

7. Close the Create Project Directory box. 

8. Use My Computer or Windows Explorer to navigate to the 
C:\Projects\99999 folder to review your project directory structure. 
Note that several generic CDOT files (e.g. 99999Des_Model.dgn) have 
automatically been created. 

 

9. Use My Computer or Windows Explorer to navigate to C:\Program 
Files > Workspace-CDOT > Standards-Local > Projects. 

 

10. Double-click on the 99999.pcf file to open it in Notepad. 
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The PCF defines a specific directory that MicroStation defaults to when 
opening up a DGN file or referencing model files. It makes setting paths 
much easier in MicroStation.  

If your project was installed on a project manager’s machine, you could 
edit this file to specify the location. See the CDOT PCF Management 
workflow for more information. 

11. Close the Notepad file. If prompted to save changes, select No. 

12. Close My Computer or Windows Explorer. 

You will later edit the 99999 project and update it with an actual project 
number. For now, you will continue working in the example 12345 
project. 

Select Group Environment 
Run the Select Group Environment Utility to determine which CDOT 
level libraries will be attached and available for use. 

1. From your desktop’s Start Menu, choose Start > All Programs > 
_CDOT_CADD_Information > Select Group Environment. In the 
Select Group Environment box, select xxMulti-Discipline, and then 
select OK. 

 

Any MicroStation design file that is now opened will have all level 
libraries (general and all disciplines) automatically attached. 

Note: You only have to run this program once.  The only time you 
have to re-run it is if you wish to switch groups on the same 
machine. 
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Start MicroStation 
1. Start MicroStation by double-clicking the desktop shortcut or by 

selecting Start > All Programs > MicroStation > MicroStation. 

Set the Workspace components 
2. In the lower portion on the dialog box, set:  

 User:  CDOT User 

This sets user preferences and users customized options like custom 
toolbars. 

 Project: 12345 

Note: Be sure to re-set this option because it will default to you upper 
level project directory. 

This Project component of the workspace should already be set by the 
PCF file created by running the Create Project Utility. It sets the proper 
path for opening, saving and attaching files. 

 Interface: CDOT 

This loads custom menus and tools at the organizational level. The 
CDOT interface will load, among other things, the CDOT Groups Menu. 
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Create a new Design Model File 
There are two ways you can create a new file: Using a seed file or from a CDOT 
auto-populated model file. You’ll practice both in this session. 

Creating a new design file using a CDOT seed file 
1. From the MicroStation Manager dialog box, select File > New. 

2. In the Seed File section, choose the Select button. 

 

3. Highlight the seed file 3D-Seed_CDOT.dgn and choose OK. 

 

Note: The seed file will copy over all of CDOT’s default MicroStation 
settings when creating the new file. 

4. Set the Directory to \Design\Working.   

5. Set List Files of Type to MicroStation DGN Files (*.dgn ). 
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6. Key in the name CU12345DES_Model02.dgn. 

 

7. In the New box, select OK to create the new file. 

 

The file is created from the seed file and placed in the Working folder. 
When creating a new working model file, you’ll prefix it with your 
initials (you’ll use CU for CDOT USER for this class). 

The working folder is for files that you are using for your design process 
prior to the design being finished. Once complete, you will move the 
files to the Reference_Files folder and take the CU off of the file name. 

8. In the MicroStation Manager box, choose OK to open the file. 
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9. The blank file opens with all of the standard settings from the CDOT 
seed file. 

 

Check settings 
1. Select Settings > Design File > Working Units. These are the CDOT 

standard units copied from the seed file. 
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2. In the DGN File Settings box, Coordinate Readout. These CDOT 
settings were also copied from the seed file. 

 

3. Cancel the dialog box. 

4. Choose File > Close to return to the MicroStation Manager. 

5. From the MicroStation Manager choose File > Delete and choose OK 
from the Alert box to delete the file you just created. 
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Create a new file by copying an auto-populated model file 
1. In the MicroStation Manager, navigate to the 

\Design\Drawings\Reference_Files folder. 

2. Select 12345DES_Model##.dgn and choose OK to open the file. 

Note: Make sure you select the file with the ## suffix. 

 

3. After opening the file, select File > Save As, navigate to the 
\Design\Working folder key in the name CU12345DES_Model02.dgn 
and select OK. 

 

The file is copied to the new name into the working folder.  
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Check settings 
1. Select Settings > Design File > Working Units.  

 

These are the CDOT standard units, which are the same as the seed file 
units. 

2. In the DGN File Settings box, select Coordinate Readout.  

 

These CDOT settings are also consistent with the seed file. 

Note: The auto-populated file provides the same settings as a seed file. 
You can create a new file either way with the same results. 
However, by copying a CDOT auto-populated file, the name is 
automatically set to the CDOT standard, you only have to 
change the counter. 
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Attach the Survey/Topo reference 
After creating your initial design model, you can attach other groups’ work that 
you’ll need to start your design. In this case, attach the existing survey and 
topographic information. 

1. Select File > Reference. 

Note: You can also choose References from the Primary toolbar. 

 

2. On the References dialog, select Tools > Attach. 

3. Your current Directory should be C:\Projects\12345 (obtained from 
your PCF file). Use the Directory pull down to select the 
C:\Projects\12345\ROW_Survey\Drawings\Reference_Files folder. 

 

Note: The Reference directory list is read from the PCF. 
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4. Select 12345SURV_Topo100.dgn from the list of files. 

 

5. Set Attachment Method to Interactive and select OK. 

The Interactive method allows you to supply additional reference settings 
in the next dialog box.  

6. In the Reference Attachment settings box, key in a Logical Name of 
Survey/Topo and set: 

 Orientation to Coincident World (to align Master file and 
Reference file global origins) 

 Scale to 1:1 (to bring in graphics full scale) 
 Nested Attachments to No Nesting 
 Display Raster Reference on 

7. Select OK. 
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8. Fit the view. 

 

The Survey/Topo reference is attached to the design model master file. 
The graphics come in at their true coordinates (Coincident-World) and 
the actual size (1:1 scale). 

9. Window in on the Survey graphics at the beginning of the project. 

 

10. In the Reference dialog, make sure Show Hierarchy is turned on and 
highlight the Survey/Topo reference on the right-side. 
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11. Toggle the Display option off. 

 

12. Fit the view. 

With the reference display turned off, there are no graphics to display, 
since the design model is currently empty. 

13. Toggle the Display option back on. 

14. Fit the view. 

The design file is now ready to placed proposed graphics with survey and 
topo graphics referenced for information purposes. 

Turn survey levels on/off 
1. Window around the intersection near the center of the project. 

 

Window here
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2. Zoom in as shown. 

 

3. Hover over one of the barbed wire fence lines. 

 

Basic element information “pops up” at your cursor location. 
MicroStation tells you that the element is on level 
TOPO_FENCE_Barbed-Wire and located in the Survey/Topo reference.  

Barbed wire fence 

Barbed wire fence 
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4. Open Level Display from the Primary toolbar. 

5. Highlight the master file CU12345DesignModel02.dgn. 

6. Sort on Used levels. 

 

Note that there are no used levels in the master file since there are no 
graphics in the design model file. 

7. Highlight the Survey/Topo reference underneath the master file 

8. Sort on Name, then sort on Used. 

 

Note that the reference has several used levels. 
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9. Turn off the level TOPO_FENCE_Barbed-Wire. 

 

10. Right click in the list of levels and select Off By Element. 

11. <D> on one of the green breaklines to turn off the level 
TOPO_TERRAIN_Break-Lines. 

 

Breaklines 
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12. Update the view. 

 

 

13. Turn other Survey levels on/off as desired. 

Note: You have control over all reference levels just like levels in the 
master file. 

14. Turn all Survey levels back on. 

15. From the MicroStation Main toolbar, select Delete Element. 
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16. <D> on the barbed wire fence. 

 

The command is now not available because the barbed wire fence is in 
the reference file, not the active file. You can not delete or modify 
reference graphics. 

17. In the Reference dialog, turn off Snap for the Survey/Topo reference. 

 

18. Try to tentative snap on some of the Survey graphics. 

With Snap turned off, you can’t tentative to the graphics in the reference 
file. 

19. In the Reference dialog, and turn off Locate for the SurveyTopo 
reference. 
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20. On the Main toolbar, choose the Element Selection tool and hold your 
cursor over some of the survey graphics. 

  

With Locate off, you can’t located reference elements for information, 
measuring, copying, etc. 

21. In Level Display, turn Snap and Locate back on for the Survey/Topo 
reference. 

22. Hold your cursor over some of the reference graphics. 

 

 

 

You can now locate the graphics. 
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23. <T> on some reference graphics. 

 

You can now snap to the reference graphics for coordinate information. 

Note: It’s often helpful to turn Snap off in a reference in dense areas 
where you don’t want to snap to reference graphics. It’s useful to 
turn Locate off for a reference if you’re copying master file 
graphics and you don’t want to accidentally copy the reference 
graphics. 

Live Nesting 
1. Window around the intersection as shown. 
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2. In the Reference dialog, change No Nesting to Live Nesting and set the 
Depth to 1. Expand the Hierarchy list to show all nested references. 

 

The Survey fieldbook data files, which are referenced to the 
Survey/Topo model, are now displayed in the file. 

3. Review the graphics. 

 

The Nested graphics, including the existing contours are now shown in 
the file. 
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4. On the left side of the Reference dialog, highlight the Survey/Topo 
reference. On the right-hand side of the References box, highlight the 
Contour (Surface data) nested reference and toggle off the Display. 

  

 

The display of just the nested contour graphics is turned off. 

 

5. Turn the Contour reference Display back on. 
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6. On the left side of the Reference dialog, highlight the Design Model 
master file. On the right-hand side of the References box, highlight the 
Survey/Topo reference and toggle off the Display. 

 

 
All graphics in the file are turned off.  

Note: With a nested reference, when you turn off the display of the 
upper level reference, all nested references are turned off too. 

7. Turn the Survey/Topo reference display back on. 

 

8. Open the Level Display box and expand the Target Tree list. 
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9. Select the Contour nested reference and toggle off the minor contour 
level. 

 

 

 
You have control over all nested reference levels via Level Display. 

10. Turn the minor contours back on and Close the Level Display box. 

You will work more with nested references and the Copy Attachment 
options in later labs. 
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11. Choose File > Close to return to the MicroStation Manager. 

 

12. From the MicroStation Manager choose File > Delete and choose OK 
from the Alert box to delete the 12345DES_Model02 file that you just 
created in the Working folder. 

Note: In this class, you’ll work with the previously created Design 
Model file 12345DES_Model.dgn in the Refereence_Files 
folder. 

13. Cancel the MicroStation Manager box. 
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Update project 99999 
You have now been assigned a project code of 54321 for the previously 
created 99999 project. Update the PCF to reflect this change. 

1. Using My Computer or Windows Explorer, navigate to the CDOT 
workspace (C:\Program Files\Workspace-CDOT\Standards-
Local\Projects). 

2. Double-click on 99999.pcf  to open it with Notepad. 

 

3. On the second line under Project Directory, edit it as follows: 

MS_DEF=C:/Projects/54321/ 
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4. Select File > Save As, name the file 54321.pcf. and select Save. 

 

Note: By updating the MS_DEF path, all reference paths are updated 
as well. 

5. Close the 54321.pcf file in Notepad. 

6. Delete the 99999.pcf file from the C:\Program Files\Workspace-
CDOT\Standards-Local\Projects folder. 
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7. Using My Computer or Explorer, navigate to the C:\Projects\99999 
folder. 

 

8. Rename the folder C:\Projects\54321. 
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9. Start MicroStation and select the Project drop-down 

 

Note that 99999 is no longer available and has been replaced by 54321. 

10. Set Project to 54321. 

 

The project directory structure is selected. 

Note: All files prefixed with 99999, would need to be renamed with the 
prefix 54321 on the hard drive. 

11. Cancel the MicroStation Manager. 
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5. Creating Your Design Graphics 
In this Chapter you will learn how to use the CDOT Menu to set standards and 
place simple graphics. You will also learn how to use precision drawing techniques 
to locate your graphics.  

The CDOT Menu 
The customized CDOT menu provides access to tools and applications intended 
to provide the user a simple, efficient method to apply CDOT’s CADD 
standards to every project.  These menus direct MicroStation to place elements 
on discipline-defined levels for drawing consistency.  

Note: Since the CDOT Menu automatically selects the correct level for 
element placement across disciplines, you must have selected the 
xxxMulti-Discipline group from the Select Group Environment 
program. 

Opening the menu 
After starting MicroStation, select the CDOT icon from MicroStation’s Main 
toolbar to open the CDOT Menu. You can hover over the icon to verify the 
CDOT configuration release. 
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Notes: You can also open the CDOT Menu from the Group Menus 
toolbar. Select Group Menus > CDOT Menu.  The CDOT 
Group Menus automatically opens when you start MicroStation. 
There are two group options: Bridge (and CDOT Menus (for all 
other groups). The Bridge menu is discussed later in this chapter. 

 

Parts of the menu 
 

 

Drop-down menus 

Explorer

Status Window 

Main Menu 
Help 

Filters 

Item 
Category

Active angle and 
scale settings
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Drop-down menus 
Use the drop-down menus to make the following selections: 

Group Display 

Toggle on your Group to display Explorer menu selections for placing graphics. 
Some groups, like Drafting and Traffic ITS have “children” options that can be 
expanded with the “+” symbol in the Explorer menu tree. Drafting is a generic 
group (i.e. it’s used by all groups) for placing general text, dimensions, borders, 
etc. There is an option on this menu to select/deselect all groups. 

 

Add On’s 

The Add On’s menu allows you to launch custom add-on programs like 
AutoTrack, SignCAD, Typical Section Program as wall as other MDL  and 
automation tools for working with graphics like the Breakline tool and the 
ModZ tool, covered later in this class. 

For more information on Add On’s, see the CDOT CADD Manual, Chapter 
Two – CDOT Workspace, section 2.5 Customized MicroStation Menu 
and follow the links Review Discipline Specific Group Menus – All about 
Add On’s pull-down. 

 

Note: 
The Add On’s 
menu has been 
replaced with the 
CDOT Tools 
menu in the 
3.02.02 release. 
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Options 

This menu allows you to have the CDOT Menu appear on top of any Windows 
Application, or have it reside behind other programs. 

Help 

This pull-down provides convenient links to the CDOT CADD web site Home 
page, the CDOT CADD Manual, Support Requests and Workflows. 

Explorer 
The Explorer Window is used to navigate through the tree structure of group 
options. 

Status Window 
The Status Window is used to select either Existing or Proposed 
categories/items for a particular group. Category options change based on the 
Existing or Proposed status. 

Category 
Group categories for graphic placement. 

Item 
Items are the specific graphical elements that can be placed in the design file. 
When an item is selected, the CDOT Menu automatically selects the proper 
drawing tool and selects the appropriate level for placement (along with that 
level’s ByLevel symbology). 

Filters 
Filters are used to filter types of items. There are five filters: Lines, Text, Cells, 
Patterns and All. Selecting a filer shows you only those types of elements in the 
selection window. 

Main Menu Help 
Discipline specific help topics using the CDOT menu. 

Settings 
Allows you to set the Active Angle and Active Scale before placing text, cell 
and pattern items. 
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Placing Graphics 

The CDOT Drafting Menu 

Linework tools 
The CDOT Drafting > Linework group provides a convenient way to place basic 
elements from one location. From here you can place SmartLines, Shapes, 
Circles, Arcs and Hatch areas. 

SmartLines are  used to place a chain of connected line segments and arc 
segments as individual elements or as a single line string or shape. 

 

 
Selecting the Line Weight, Line Style and Plot Color filters sets the appropriate 
level. Each item in Linework these categories goes on a unique Drafting level.  
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MicroStation Drawing Tools 
You can also access basic drawing tools from the MicroStation Main toolbar. 
See the MicroStation online User and Reference Guide for more information. 

Important!  Read your prompts for proper use of these drawing tools! 

  

                      

Tool Settings 
Each time you select a new drawing tool, the optional settings will appear in the 
Tool Settings box. 

 

 

 

 

 

Linear Elements toolbar 
• Lines 
• SmartLines 
• Multi-lines 

Polygons toolbar 
• Blocks (rectangles) 
• Shapes 
• Orthogonal shapes 
• Polygons 

Ellipse toolbar 
• Circles 
• Ellipses 

 

Arcs toolbar 
• Arcs 
• Arc modifications 

Tool Settings for the  
Place SmartLine tool 
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Snap Lock 
Snap lock determines if your tentative point snaps are forced onto nearby 
elements.  If Snap lock is on and you place a tentative point on or near an 
element, your cursor locks onto that element at the location specified by the snap 
mode. 

Snap Modes 
The active snap mode determines how you will snap onto an element.  Several 
different snap modes are available and can be accessed from the Status bar. 

 

You can also access snap modes from the Snap Mode button bar. 

 

Executing snaps 
You can execute a snap two ways: 

 Using a tentative point, or 
 Using AccuSnap. 

To snap to an element using a tentative point: 

 Select the drawing tool (Place Line, Place Block, etc.) 
 Set the Snap mode (if not currently active). 
 <T> on the element. 

A large cross hair appears at the snap mode location and the element 
highlights.  MicroStation displays the X,Y,Z coordinates of the <T> 
location in the Message field. 
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 <D> to accept the tentative. 

Snaps can be a one-time setting.  Once you’ve executed the snap, the snap mode 
returns to the default setting.  One-time overrides of the default snap mode are 
accomplished by: 

 Choosing a snap mode from the Status Bar 
 Selecting Settings > Snaps or 
 By single clicking on snap on the Button Bar. 

You can change the default snap mode by: 

 Selecting a new mode in the Full Locks dialog box or 
 Double clicking the snap mode on the Button Bar. 

Tentative point <T>  
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Using AccuSnap 
AccuSnap is a feature that streamlines your snaps.  Instead of tentative snapping to 
an element, you can AccuSnap to it.  In addition, AccuSnap can give you basic 
element information (element type and level). 

Turning AccuSnap on/off 
You can also toggle AccuSnap on/off from the Snaps Button Bar. 

  

To snap to an element using AccuSnap: 
 Select a drawing tool. 
 Select a Snap mode. 
 Move your cursor across the element. 

AccuSnap identifies the element type and its level with Pop-up 
information.  An icon representing the current snap mode is displayed 
along with a tentative hint – a light dashed cross hair at the closet snap 
point according to the selected snap mode. 

 

 

 

 

 

 

 Move your cursor closer to the tentative hint. 

The cursor changes to a bold X and the element highlights to indicate 
you’re locked on to the snap point. 

 

 

 <D> to select this location. 

A Tentative point is not necessary to define the temporary snap location. 

Tentative hint 

Active snap icon 
Cursor location 

Pop-up info. 

AccuSnap locked location 
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Note: AccuSnap sometimes does not work correctly with Depth lock 
on. Therefore, if you’re snapping to elements with Depth lock 
on, be sure to turn AccuSnap off and use a Tentative snap <T> 
instead.  This ensures that you’ll pick up the active depth instead 
of the element’s depth. 

Multi-Snaps 
MicroStation includes three Multi-Snap modes.  Multi-snaps are an ordered list 
of snaps. When you choose a multi-snap with AccuSnap on, MicroStation 
processes the multiple snaps according to your cursor location. 

Using Multi-Snaps 

 From the Snaps button bar or from the Status bar, select a Multi-Snap 
(Multi-snap1, Multi-snap2 or Multi-snap3). 

  

 Move your cursor over the element until AccuSnap locates the first 
multi-snap option. 

 Continue moving your cursor until the next snap option highlights. 
 When you have locked on the correct snap point, <D> to accept. 

Editing Multi-Snaps 

 Select Settings > Snaps > Multi-snaps (or select Multi-snaps from the 
Snaps button on the Status bar). 

 Select a multi-snap (1, 2 or 3). 

 

Note: You can also right-click on the Multi-snap icon and select 
Properties. 

 Toggle on the snaps you want to include in the multi-snap. 
 Toggle off snaps you don’t want. 
 Close the Multi-snaps box. 
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Precision keyins  
Precision key-ins allow you to precisely locate elements in your design file 
based on its coordinate system.  You can locate data points at exact coordinates, 
at a delta distance from your current location, or at a distance and direction from 
the current location. 

xy=key-in 
Use the xy= key-in to specify a point’s exact x, y and z coordinates.  The syntax 
for this key-in is: xy=<x,y,z>. 

To place an element at the active depth, leave off the z value. 

dx=key-in 
Use the dx= key-in to specify an x distance, y distance and z distance from the 
current point or from a tentative point.  This key-in is sometimes referred to as 
the “delta” key-in, since it locates a point at a delta distance from the current 
location.  The syntax for this key-in is: dx=<dx,dy,dz>. 

You can leave out variables in the key-in.  For example, if you only want to 
locate 100 feet (assuming your master units are feet) in the y direction from the 
current location, key in dx=,100.  To draw planar elements at the active depth 
in a 3D file, leave off the z value. 

The dx= key-in behaves the same regardless of the view in which you’re 
working.  It uses the view axis, meaning it always assigns the x axis to 
horizontal and the y axis to vertical in any view (top, front, right, etc.) 

dl=key-in 
The dl= key-in is also a “delta” key-in and works in a similar fashion to the dx= 
key-in.  It also locates a point at an x distance, y distance and z distance from the 
current point or from a tentative point.  The syntax for this key-in is 
dl=<dx,dy,dz>. 

The difference between the dl= and the dx= key-ins is dl=  uses the model axis 
in a 3D file.  Instead of assigning every view’s x-axis to horizontal and y-axis to 
vertical, it uses the design cube’s true coordinate system. For example, a front 
view’s horizontal axis is the x-axis and the vertical axis is the z-axis. 

The dl= key-in behaves differently based on the view in which you’re working. 
In a top view of a 3D file, there is no difference between the dx= and the dl= 
key-ins. 
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di=key-in 
Use the di= key-in to specify a distance and direction along the view axis from 
the current point. The syntax for this key-in is: di=<distance,direction>  
Like the dx= key-in, this key-in also uses the view axis. 

You can specify the direction in either DMS (degrees, minutes, seconds) or DD 
(decimal degrees). This key-in also works in any angle mode (conventional, 

azimuth or bearing).  For DMS, use ^ for degrees, ’ for minutes and ” seconds. 
For example, di=10,n37^19’30.27”e would place a point 10 feet at the 
specified bearing angle. 

Note:  When using the dx=, dl= or di= key-ins, you can place multiple 
points by using the pipe symbol (above the \ on a standard 
keyboard). For example if you’re in the Place Line command 
and key in dx=10|3, this would place three lines, 10 feet long 
each, in the x direction. 

AccuDraw 
AccuDraw is a precision drawing tool that streamlines the placement of data 
points.  It basically combines the techniques of precision keyins with axis lock-
type features into one command to help you place, modify or manipulate 
elements. 

AccuDraw is context sensitive.  Its behavior changes depending on which 
drawing tool you’ve selected.  AccuDraw will evaluate your current position, 
the previous data point, the drawing tools needs, etc. to help you place your next 
data point.  

Starting AccuDraw 
In the CDOT workspace, AccuDraw automatically loads when you open a 
design file.  If you don’t want to use AccuDraw, you can toggle it off by 
selecting the Toggle AccuDraw button from the Primary toolbar. 

 



 Creating Your Design Graphics 

 

CDOT MicroStation Essentials  Page 197 

The AccuDraw Compass 
When you start AccuDraw, one of the first things you notice is the AccuDraw 
compass. The compass shows your origin location (current drawing location) 
and defines your drawing plane.  There are two different drawing plane modes 
and, therefore, two different compasses: rectangular and polar.  

                    

 

The rectangular mode allows you to enter coordinates or delta distances, relative 
to the origin point, in an X,Y,Z coordinate system (like an XY=, DX= or DL= 
keyin).  The polar mode allows you to enter distances and angles relative to an 
origin point (like a DI= keyin).  

The AccuDraw Window 
The AccuDraw window is where you enter your X,Y,Z or Distance and Angle 
values. You can also lock the drawing axes. The window changes according to 
your compass mode. 

               

 

Note: To toggle the compass (rectangular and polar mode), set the 
focus into the AccuDraw window and press <Spacebar>. 

You can dock the AccuDraw window at the top or bottom of the MicroStation 
window, or you can float the window into the view. 

AccuDraw locks 
You’ve seen how to lock your X,Y or Distance, Angle entries you enter in the 
AccuDraw window using the <Enter> key.  You can also lock “dynamically” in 
AccuDraw.  Dynamic entries are X,Y or Distance, Angle values entered 
automatically as you drag your cursor.  Use the following keyboard shortcuts to 
lock dynamic entries: 

 <X> – to lock x-axis entries in rectangular mode. 
 <Y> – to lock y-axis entries in rectangular mode. 
 <D> – to lock distance entries in polar mode. 
 <A> – to lock angle entries in polar mode. 

Rectangular mode Polar mode

Rectangular mode Polar mode
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Smart Lock 
Use AccuDraw’s Smart Lock feature to lock your cursor in one direction only 
(your pointer location).  For example, if you’re working in Rectangular 
compass mode and you only want to move in the Y direction, lock your cursor 
on the Y axis, move your cursor up or down and then press < Enter>.  You can 
now only move in the Y direction only.  Smart Lock in Polar mode will lock 
your cursor to the closest 90 degree axis. 

 

Smart Lock summary:  

 In Rectangular coordinates, locks X to 0 if the pointer is on the drawing 
plane y-axis or Y to 0 if the pointer is on the x-axis. 

 In Polar coordinates, locks Angle to 0°, 90°, -90°, or 180° if the pointer 
is on a drawing plane axis or otherwise locks Distance to its last entered 
value. 

Rotating the AccuDraw compass 
There may be times when you do not want the AccuDraw compass to rotate with 
the element being placed.  Instead, you want the compass to maintain its 
conventional drawing plan mode of X-axis horizontal and Y-axis vertical.  In 
this case, press V on the keyboard to rotate the compass back to the “view” 
plane. 

Note: When using AccuDraw with the SmartLine tool, there is a 
SmartLine placement Setting (select the drop-down arrow) 
called Rotate AccuDraw to Segments.  Toggle this option off 
if you always want the AccuDraw compass to maintain its 
conventional drawing plane mode of X-axis horizontal and Y-
axis vertical. 
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The AccuDraw keyboard shortcut V will always rotate the compass to the view 
in which you’re placing elements.  Therefore, in a 3D file, pressing V in a front 
view, rotates the AccuDraw compass so that the X-axis is horizontal in the front 
view; whereas pressing V in a top view rotates the compass so that the X-axis is 
horizontal in the top view, etc.  Or, you can quickly rotate the compass to a 
particular view by pressing the appropriate keyboard shortcut below: 

 T – top view 
 F – front view 
 S – side view 

                  

 

                      

 

                   

 

Using these keyboard shortcuts simplifies drawing in 3D.  For civil design 
applications, however, most of the time you will be drawing in a top (plan) 
view. 

Another handy rotation option is Quick Rotate (keyboard shortcut <R> <Q>). 
This temporarily rotates the compass dynamically as you move your cursor.  
This is handy to rotate the AccuDraw compass to match the angle of an existing 
element to place off of that element or when placing cells or text. 

Compass 
rotated to Top 

Compass 
rotated to Front 

Compass 
rotated to Top 

Compass 
rotated to Front 

Compass 
rotated to Top 

Compass 
rotated to Front 

Top View 

Front View 

Side View 

Compass 
rotated to Side 
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Moving the AccuDraw Origin to your cursor location 
When you tentative snap to an existing element, press O on the keyboard to 
move the AccuDraw origin temporarily to the tentative location.  You can then 
locate the AccuDraw compass off of this tentative point by entering values in 
the AccuDraw window.  If you accept the tentative with a data point, you 
compass “sticks” in this location. 

Shortcut snap modes  
AccuDraw provides a shortcut alternative for selecting a few snap modes.  
Instead of selecting the snap mode from the status bar or the Snaps button bar, 
you can use on of the following keyboard shortcuts: 

 <N> — Nearest 
 <C> — Center 
 <I> — Intersect 

In addition, you can press <K> to set the keypoint snap division when using 
AccuDraw. 

 

 

Deleting elements 

To delete an element: 
 Choose the Delete Element command from the Main toolbar. 

  

 Move your cursor over the element (it will highlight). 

Note:  The element highlights if Identify Elements Automatically is 
on in AccuSnap Settings (discussed later in this chapter).  If 
this option is not on, <D> or snap to identify the element. 

 <D> to accept the deletion. 

Note: Choose Element Select or another tool to get out of the Delete 
command. 



 Creating Your Design Graphics 

 

CDOT MicroStation Essentials  Page 201 

Using the Undo and Redo commands 
When you delete an element, it is moved to the Undo buffer, so MicroStation 
actually remembers everything that is placed in the design file, even after it’s gone.  
You can retrieve a deleted element using the Undo command (Edit > Undo).  The 
Redo command (Edit > Redo) negates the last Undo command. 

The Undo and Redo commands not only work on deleted elements, but on most 
graphics commands.  For example, you can place a line, use Undo to remove the 
line, then use Redo to re-place the line. 

The Undo buffer is virtually unlimited in size (it’s only limited by the operating 
system file size limit). 

The Undo and Redo commands can also be accessed from the Standard toolbar 
(Tools > Standard). 

  

Note:  Compressing the design file (File > Compress Design), or 
exiting the design file clears the Undo buffer. 

Compressing the design file 
Select File > Compress > Design to permanently remove deleted elements from 
the Undo Buffer.  This will make your design file smaller and more efficient.  
However, you will lose your Undo history for the design file session. 
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Element Information 
Use the Element Information command from the Primary toolbar to analyze an 
element for general and detailed information.   

 

Select the command, then <D> on an element to get general information on the 
element’s attributes and its properties (solid, snappable, etc.) You can change any 
information on the General tab to update the element.  The Details tab contains 
information on the element’s geometry, including coordinates, size, etc.  
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Lab 5A– Drawing Basics using the CDOT Menu 
In this lab you will learn how to access the CDOT Menu and become familiar with 
its different components and operation. You will use the CDOT Menu to set 
standards (level, color, line style, line weight), automatically select drawing tools 
and then place basic elements (lines, circles, arcs, etc.). 

Objectives 
After completing this exercise you will know how to: 

 Access the CDOT Menu 
 Access the CDOT Bridge Menu 
 Use the CDOT Menu to set element attributes. 
 Use the CDOT Menu to place basic elements (lines, arcs, circles, shapes, 

etc.) 
 Use the Delete command. 
 Use the Undo and Redo functions. 
 Change the element highlight color. 

Create a Miscellaneous Details file 
Create this file to practice placing graphics using the CDOT Menu, as well as to 
draw a few miscellaneous details that later can be placed on a sheet. 

1. Start MicroStation from your desktop shortcut or from the Start Menu. 

2. In the MicroStation Manager, select File > New. 

3. Verify the Seed File is set to 3D-Seed_CDOT.dgn. 

  

4. Set the Directory to \Design\Working. 
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5. Key in a file name CU12345DES_MiscDetails01.dgn. 

Note: CU stands for “CDOT User” the initials you’ll use for training 
purposes. 

6. Select OK. 

 

7. With the CU12345DES_MiscDetails01.dgn file highlighted in the 
MicroStation Manager, select OK to open it. 

Check Seed File Settings 
1. Select Settings > Design File > Working Units and review the CDOT 

defaults. 
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2. In the DGN File Settings box, s0elect Coordinate Readout and review 
the CDOT defaults. 

 

3. Cancel the dialog box. 

4. Key in dp=$ to check the display depth. 

5. <D> anywhere in the view to select it. 

6. Review the CDOT defaults in the message field. 

 

7. Key in az=$ to check the active depth. 

8. <D> anywhere in the view to select it. 

9. Review the CDOT defaults in the message field. 
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Open the CDOT Menu 
1. On the Main toolbar, select the CDOT icon. 

 

Note: On the CDOT Group Menus toolbar, select Group Menus > 
CDOT Menus. 

The CDOT Menu V03.02 opens. 

 

2. On the CDOT Menu, select Group Displays > Drafting (if not already 
toggled on). 

 

3. Review some of the categories and items available for general drafting. 
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4. On the CDOT Menu, select Group Displays > Design. 

 

5. Review some of the categories and items available for the Roadway 
Design Group. 

6. On the CDOT Menu, open other groups of interest (Hydraulics, Traffic, 
Utilities, etc.) and review the available categories and items. 
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7. On the CDOT Group Menus toolbar, select Group Menus > Bridge. 

 

The CDOT Group Menus updates to show the options for Bridge. 

 

Note: The Bridge Menu is a different interface from the other Groups, 
which are located within the CDOT Menus. 

8. Select the Bridge pull-down menu and review the categories and items 
available in the Bridge Menu. 

 

Note: All other pull-downs from the Bridge Menu (Group Menus, 
General, Drafting, etc.) will open the CDOT Menu V03.02. 
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Place practice graphics with the CDOT Menu 

Place Lines 
1. On the CDOT Menu, select Group Display > Deselect All to turn off all 

groups. 

 

2. Select Group Display > Drafting. 

3. In the CDOT Menu Explorer, select Drafting to show the Drafting 
Categories. 
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4. Select the Linework category. 

This category is used for general drafting work that is placed on standard 
drafting level.  The Filters are used to organize the different linework 
Items.  

5. Set the Filter to WT, for line weight  

6. Select the Item Weight 3. 

 

The filter determines the appropriate drafting level for the SmartLine.  
The Smartline command is the default for this menu.  All other drafting 
commands should be either be picked from the Main tool bar or entered 
as a key-in. 

 

7. Data point in View 1 to enter vertices for the SmartLine. 

 

8. <R> when finished. 

Note: Always <R> when you are finished drawing an element. The 
active drawing tool (in this case SmartLine) remains active so 
that you can place another line without having to re-select the 
item from the menu. 
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9. The seed file settings have line weights turned off to provide a better on 
screen display. To see the line weights, select  
Settings > View Attributes, turn Line Weights on and select Apply. 

 

 

10. Set the Filter to LC, for linestyle. 

11. Select the Item Dashed (Thick) 
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12. Place another SmartLine and note the change in line style and the active 
level on which it is placed.  

 

 

13. <R> when done. 

14. Set the Filter to CO, for Color. 

15. Select the Item Plot Orange. 

 

16. Place another SmartLine and note the change in both line style and color 
and the active level on which it is placed.  
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Place Circles 
1. In the CDOT Menu, set the Category, Filter and Item to establish 

whatever level and symbology you like. 

2. From the Main tool palette, select the Circle icon. 

 

3. In the Tool Settings box, set Fill Type to None. 

 

4. Follow your prompts and <D> to identify the center of the circle, then 
<D> to place a point on the circle. 

 

5. <R> when done. 
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6. In the Tool Settings box, toggle on Diameter and key in a  
value of 5. 

 

Note: Important! Don’t forget to tab after keying in the value. 
Otherwise, your entry will not be accepted. This is true for all 
fields in MicroStation dialog boxes. 

7. <D> to identify the center of the 5 ft. diameter circle. 

 

8. <R> when done. 

9. Practice placing circles with other diameter or radius values. 

10. In the Tool Settings box, set Method to Edge and toggle off the 
Diameter or Radius constraint. 

 

11. Follow your prompts and <D> to place a circle by specifying three edge 
points. <R> when done. 
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12. In the Tool Settings box, set the Method to Diameter and follow your 
prompts to place a circle with two points for the diameter. <R> when 
done. 

 

 

Place Arcs and Shapes 
1. In the CDOT Menu, set the Category, Filter and Item to establish the 

correct level and symbology. 

2. From the Main tool palette, select the Arc icon. 
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3. In the Tool Settings box, set the Method to Center. 

 

4. Follow the prompts and <D> anywhere to place the first arc endpoint. 

5. <D> to define the arc center. 

6. <D> to define the second endpoint. 

 

7. <R> when done. 

8. In the Tools Settings box, set the Method to Edge. 

 

9. Follow the prompts to place an arc by 3 points. 
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10. Repeat the above step, but place the arc in the opposite direction. 

 

11. Using either the Center or Edge methods, constrain the radius and place 
another arc. 

 

 

Arc by Center with a constrained 
radius of 1.0 
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12. Try setting other constrains and place additional arcs. 

13. <R> when done. 

14. In the Main tool bar, set the select the Place Shape icon. 

 

15. <D> to place vertices for an unconstrained shape. 
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16. For the last data point (to close the shape), select Close Element. 

 

17. In the Tool Settings box, set Fill Type to Opaque and place another 
shape. 

 
    

18. Set Fill Type back to None.  

19. On the Polygons toolbar, select Place Block. 

 

20. <D> for the first corner of the block. 

21. <D> for the opposite corner. 
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22.  Place a few more blocks until you’re comfortable with the command. 

 

Delete and Undo 

Delete an element 
1. Fit View 1. 

2. From the Main toolbar, select Delete Element.  
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3. Move your cursor over the orange line until it highlights. 

 

Notice the highlight color is light blue. 

4. <D> to delete. 
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Note: Choose Element Select or choose another tool to get out of the 
Delete command. 

 

Undo and Redo the deletion 
1.  From the Standard toolbar, select Undo. 

 

 The line reappears. 

2.  Select Redo. 

 

 The line is deleted again. 

Notes:  You can also choose Edit > Undo to reverse the previous action 
and get a description of what you are undoing. 
 
In addition to the Delete command, the Undo/Redo commands 
work for most MicroStation drawing tools. 
 
If you have coincident elements, <R> until the element you want 
to delete highlights, then <D> to delete. 

Change the Element Highlight Color 
1. Select Settings > Design File > Color. 

2. Set Element Highlight Color to Yellow.  

 

3. Select OK. 
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4. Choose Delete Element from the Main toolbar. 

5. Move your cursor over an element until it highlights. 

6. Notice the highlight color is now yellow. 

7. <D> to delete the element. 

The Delete Element command remains active and you can continue 
deleting elements. 

8. Set the highlight to a color you prefer. 

Delete all 
1. Select Edit > Select All to put all elements you’ve drawn in a 

MicroStation selection set (you’ll learn more about selection sets later). 

2. Choose Delete from the Main toolbar. 

All elements selected are deleted. 

3. Do not exit MicroStation. Continue to the next lab. 
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 Lab 5B – Draw the Median Island Nose Section 
In this lab, you’ll draw the nose section shown below using AccuDraw and 
precision keyins. 

 

1. From the bottom of the MicroStation screen, drag the AccuDraw 
Window and float it in the view. 

 

Note: If AccuDraw is not on, toggle it on from the Primary toolbar.  

 

If your compass is set to Polar mode, switch it to Rectangular mode by 
pressing <spacebar> on the keyboard. 

                 

 Rectangular Compass Polar Compass 
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Draw the concrete gutter pan section 
1. On the CDOT Menu, set the Explorer to Drafting, the Category to 

Linework, the Filter to WT and select Item Weight 1. 

2. Key in xy=1000,1000 to define the starting coordinate for drawing the 
section (the upper left corner). 

Note: If you can’t see the line’s endpoint and it is “rubber banding” 
into the view, Zoom Out and then reset once <R> back into the 
Place Line command.  If you zoom with your mouse wheel, you 
don’t have to reset. 

3. Set your cursor to slope down and to the right to establish the direction. 

 

4. Use the AccuDraw’s rectangular compass to place median’s 8 ft. gutter 
pan at a 1:12 slope. Key in 8 for X and 8/12 for Y. (The Y value updates 
to -0.667). Make sure your cursor is set to slope down before entering the 
values. 

Note: Remember, do not move your cursor into the AccuDraw window 
to key in your values; you may lose your positive/negative axis 
orientation.  The focus (blinking cursor) is already set for you in 
the X field – just start typing!  Then, <Tab> or arrow down to the 
next field. 

   

 

5. <D> to place the point. 

6. Zoom in, if necessary, to see the line 

 

Note that the compass rotates to the segment.  You actually want to place 
the next line from the horizontal axis, so you need to rotate the compass 
so that X is horizontal. 
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7. Press V on the keyboard to rotate the compass to the view. The X-axis 
(red tic mark) should now be horizontal. 

 

8. Position your cursor up and to the right to establish the direction of the 
next segment. 

9. Key in 2 for X and 2/12 for Y. (The Y value updates to 0.167 to establish 
the slope on the next line). 

 

10. <D> to place the point. 

11. Press V on the keyboard to rotate the compass to the view. 

 

12. Lock your cursor on the –Y axis and key in .5 in the Y field for the next 
segment. <D> to place the point..  

Note: You don’t have to key in the negative, AccuDraw knows the 
direction from your cursor location. 

 

13. Press V on the keyboard to rotate the compass back to the view. 

14. Lock your cursor on the –X axis and key in 10 in the X field. <D> to 
place the point. 

 



Colorado Department of Transportation 

Page 228  CDOT MicroStation Essentials 

15. Hover over the starting point of the median section. When you see the 
bold X, <D> to AccuSnap to the point to complete. 

 

Draw the median cover 
1. Fit the view. 

 

2. Select the Place Block command. 

3. AccuSnap on the upper-left corner of the median. 

 

4. Place your cursor down and to the left to establish the direction. 

5. Using AccuDraw’s rectangular window, place a 2 ft. X 4 in. block as 
shown. Key in 2 for X and :4 for Y (don’t forget the colon in front of the 
4 to specify inches.) <D> to place the point. 

6. <R> when done. 
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Draw the pavement section 
1. While still in the Place Block command, AccuSnap on the upper-right 

corner of the concrete section. 

2. Using AccuDraw, place a 3.5 ft X 6” block as shown. 

 

 

3. In the Place Block Tool Settings, toggle Fill Type to Opaque. 

4. Use AccuDraw to place two 1.5 ft X 3 in. and one 6 in. X 3 in. filled 
blocks to create the pattern as shown. 

 

 

5. Set Fill Type back to None. 

Draw the subgrade section 
1. Select the Place SmartLine tool. 

 

2. AccuSnap on the lower-right corner of the asphalt to start the subgrade. 

 

3. Use the information above to place the SmartLine using AccuDraw. 
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4. To practice drawing these lines again using precision keyins, Delete the 
two lines you just placed to start over. 

 
 

5. Re-draw the two lines using the dx= precision keyin (delta keyin). 

 AccuSnap to the starting point. 
 Key in dx=,-:6 for the first line. 
 Key in dx=-15.5 for the second line. 

Note: Don’t forget the negative signs. You could also key in .5 instead 
of :6 and 15:6 instead of 15.5. 

6. Again, Delete the two lines you just place to start over. 

7. Re-draw the two lines using the di= precision keyin (distance, direction 
keyin). 

 AccuSnap to the starting point. 
 Key in di=:6,-90 for the first line. 
 Key in di=15.5,180 for the second line. 
 AccuSnap to the location shown to finish. 

Note: You don’t need the negative signs because of the direction. 

 

8. Fit the view. 

You’ve now used MicroStation’s two main techniques for precision 
placement – precision keyins and AccuDraw.  By using each method, 
you can compare the two methods and determine which you prefer. 

You’ll practice more with precision keyins and AccuDraw in later labs. 

9. Save Settings (File > Save Settings). 

10. Exit MicroStation. 

 

Starting Point
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6. Manipulating and Modifying Design Graphics 

Using Manipulate tools 
Now that you know how to place basic elements and control their placement using 
various locks and snap modes, you’re ready to learn how to manipulate and modify 
the elements you’ve placed. 

The Manipulate toolbar commands allow you to manipulate the entire element 
(copy, move, rotate, scale, etc.).  Follow your prompts closely to properly execute 
the commands.   

 

Some of the more commonly used commands include: 

Copy 
Copies an element from one location to another. 

     

Move 
Moves an element from one location to another. 
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Move Parallel 
Moves or copies an element parallel to the original element using one of three 
modes. 

 Miter — extends or shortens the segments while maintaining the angle of 
their connections 

 Round — fills the gap with a rounded arc between the two moved 
elements or 

 Original — the resulting element is the same type as the original 
element. 

     

The Miter and Round modes also help eliminate “loops” that sometimes form in 
interior corners of the offset element using the Original mode. 

If you specify a distance, you only need to data point the direction. 

With Use Active Attributes on, the parallel element takes on the active level, 
color, style and weight. 

Scale 
Resizes an element based on one of two methods: 

 Active scale or 
 3 points. 

      

If you like, you can create a copy or copies of the scaled element. 

Under Show Extended, you can toggle on About Element Center, which, 
when used with the Active Scale method, allows you to scale about the 
element’s center with just one data point. 

The lock icon allows you to 
type in a value once and 
have it apply to all locked 
fields.  If the lock is ‘open’, 
you can enter individual 
values in the different 
fields. 
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Rotate 
Rotates an element using one of three methods: 

 Active Angle 
 2 Points or 
 3 Points. 

     

Like the Scale command, you can toggle on About Element Center under 
Show Extended, which allows you to always rotate about the element’s center. 

Mirror 
Mirrors an element using one of three methods: 

 Horizontal — about horizontal axis 
 Vertical — about vertical axis or 
 Line — about line defined by two data points. 

     

Align Edges 
Aligns the edge of one element with the edge of another element using one of 
the following alignment options: Top, Bottom, Left, Right, Horizontal Center, 
Vertical Center, Both Centers 
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Construct Array 
Copies elements multiple times in an array of two types: 

 Rectangular 
 Polar 

 

 

Using the Modify tools 
The Modify toolbar commands allow you to modify a piece or part of an 
element (trim, extend, partial delete), instead of manipulating it as a whole. 
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Modify 
Modifies the geometry of an element.  This tool works differently on different 
types of elements.  For example, you can: 

 Move a vertex or segment of a line, linestring or shape 
 Scale a block or circular arc or 
 Change a circle’s radius. 

 

Partial Delete 
Deletes part of an element.  The element can be closed, or you can delete an 
interior portion of line, linestring, curve or arc. 

 

Extend 
Extend or shorten a line or linestring. 

 

If Distance is off, enter a data point to define the new endpoint (i.e. 
dynamically extend or shorten the line or linestring). 

Note:  Toggle on From End to extend/shorten from the nearest endpoint 
that you identify. If off, the line is extended/shortened relative to 
the origin point, no matter where you identify the line. 

Extend Two Elements to Intersection 
Extends two lines, linestrings, or arcs to their intersection.  If the lines or 
elements currently intersect, it will shorten the elements to their intersection 
point. 
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Extend Element to Intersection 
Extends one line, linestring or arc to intersect with another element (which does 
not have to be another line, linestring or arc).  If the original element already 
intersects or overlaps the second element, it is shortened to the intersection 
point. 

 

Trim 
Trims an element at its intersection with a specified cutting element.  You can 
trim multiple elements and you can have more that one cutting element. 

 

When identifying elements to trim, always data point on the portion of the 
element that you want trimmed. 

You can place two cutting elements in a selection set before executing the 
command and trim elements between them.  However, a more effective way of 
accomplishing this is to use the IntelliTrim command. 

IntelliTrim 
Trims, extends or cuts multiple elements in one operation using two different 
modes: 

 Quick Mode — allows you to draw a line through multiple elements to 
trim (or extend) to one cutting (or extension) element. 

 Advanced Mode — allows you to select multiple cutting elements.  You 
can trim or extend elements between or outside of the cutting elements.    

 
To extend elements, set the Operation to Extend and follow the same steps to 
define an extension element and then draw a line through the elements to extend. 

The Operation Cut will break elements in two pieces at the cutting element. 
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Insert Vertex 
Inserts a vertex on a line, linestring or shape.  It is also used to attach a line 
segment onto the end of a line or linestring. 

 

Delete Vertex 
Deletes a vertex on a line, linestring or shape. 

 

Fillet 
Constructs a circular fillet (an arc) of a specified radius between to elements or 
two sides of a linestring or shape.  You can truncate one side, both sides or 
neither side of the original element. 

 

Note:  To fillet between 3D elements, they must be co-planar. 

Chamfer 
Constructs a chamfer between to lines or two sides of a linestring or shape. 

 

Note:  To chamfer between 3D elements, they must be co-planar. 
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Drawing graphics in 3D  
When drawing graphics in a 3D file, you can either draw planar graphics at a 
particular elevation, or you can draw 3D graphics (endpoints at different 
elevations). 

Active Depth 
To draw planar graphics at a particular depth in a 3D file, set the active depth to 
the desired depth <az=depth>, and then place the graphics. The active depth 
would be the elevation you want to place the graphics if you’re drawing in the 
top view.  For example, if you want to draw the 5000 ft. contour, set az=5000, 
than draw the contour. All data points will be placed at a Z value of 5000. 
Unless you snap or AccuSnap to existing elements. See below. 

Depth lock 
When placing new graphics by snapping on to existing elements, you’ll pick up 
the elements’ elevation if Depth lock if turned off. Depth lock locks all of your 
data points onto the view’s active depth plane.  Therefore, if you want to place 
planar elements, but you’re snapping on to elements at different elevations, set 
the active depth to the desired elevation <az=depth>, and then turn Depth lock 
on. 

 

Depth lock and AccuSnaps 
Depth lock behaves inconsistently with AccuSnap. Therefore, if you want to 
place element with Depth lock on, turn AccuSnap off and Tentative snap to the 
elements. 
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Using the CDOT Menu ModZ Add On 
Another way to set the elevation of an element in the top view of a 3D file is to 
move it (after it is placed) in the Z direction only.  This is useful if you want to 
planarize elements to a specified elevation.  The ModZ program is located on 
the CDOT Menus.  Select Add On’s > ModZ Load. 

 

You can specify the elevation to planarize a single element, elements within a 
fence or all elements in the design file. 

Custom Line styles 
Custom line styles are used to represent various types of graphics in the CDOT 
MicroStation configuration. Custom line styles, unlike standard line styles, can be 
scaled. The line style scale should match the plot scale of the sheet file in which 
they will be referenced. 

Setting the Scale 
You should set the line style scale before placing the custom line style. The line 
style scale is set under Element > Line Style > Custom. In the default CDOT 
workspace, the custom line style scale is set to 100. You only need to change the 
custom line style scale if you will eventually reference this file into a sheet with 
a different scale. 

 

Note: Custom line styles are assigned to levels via ByLevel symbology. 
The line style is automatically selected with the level is set 
active. 
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Changing the scale 
If you have placed a line style at the wrong scale, you can change the scale with 
the keyin Change Linestyle Scale ## (where ## = the scale), and then select 
the element to change. 

Changing Direction 
Some custom line styles are directional and depend on the direction they are 
drawn (e.g. Type 3 guardrail). If you place a custom line style in the wrong 
direction, key in Change Direction, and then select the element. 

For more information on custom line styles, see the CDOT CADD Manual, 
Chapter Five – Drafting Standards, Section 5.7 – Line Styles and 
follow the CDOT Line Styles links. 
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Changing Levels and ByLevel Symbology  
If you place an element on the wrong level, and thereby place it with the wrong 
ByLevel symbology, you can change that element to the correct level. Once 
changed, the graphics will take on the new level’s ByLevel symbology (as long as 
the element was originally placed ByLevel). 

Using Element Information 
You can change the level of an element using the Element Information 
command. Be sure to Apply the change when done. 

 

 

Using the Change Element Attributes tool 
The Change Element Attributes command on the Change Attributes toolbar 
also allows you to change an element’s level.  
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There are two options: 

 Change 

With this option, set the level you want to change to, then select the element. 

 Match/Change 

With this option, you can change an element to a level by matching another 
element’s level. First select the element to match, then select the element to 
change. 

 

Note: Be careful! If Use Active Attributes is turned on, the level you 
set in the Change option, or the level you match in the 
Match/Change option, will become the active level. If you 
do not want to change your active level, turn this option off. 
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The CDOT Misc. Toolbar 

  

The CDOT Miscellaneous Tools toolbar (Add On’s > Launch Miscellaneous 
Tools from the CDOT Menu) contains three useful tools: 

Change Active Symbology ByLevel 
If you accidentally change the active color, line style or line weight in the 
Change Element Attributes command, you can re-set the actives back to 
ByLevel symbology with the Change Active Symbology ByLevel command. 

  

Change All Elements to ByLevel Symbology 
If graphics have been placed with symbology other than ByLevel symbology, 
use the Change All Elements to ByLevel Symbology command. This is 
especially useful before plotting to ensure all graphics conform to CDOT 
standards. 

  

Shift Linestyles 
Sometimes custom line styles need to be shifted to meet in corners of to avoid 
interference with other graphics. Use the Shift Linestyle tool to accomplish this. 

 

Change Element Direction 
The display of some custom line styles is dependent on the direction the line was 
drawn.  Use the Change Element Direction tool to reverse the line so that the 
style is displayed as desired. 
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Tags 
MicroStation tags are a special way attaching information to elements drawn in 
the design file. For example, survey graphics contain tag information like 
feature name, the InRoads preference and description. 

Use the Review Tags command on the Tags toolbar to obtain tag information on 
an element. 
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Lab 6A – Place Guardrail lines  
In this exercise, you’ll place guardrail lines in the design model file and then 
work with the custom line styles.  

Objectives 
After completing this exercise you will know how to: 

 Use the CDOT Menu to place custom lines styles. 
 Change the direction of a directional line style. 
 Set the scale for a custom line style. 
 Change the scale of a custom line style. 
 Change the level on which an element was placed 
 Update graphics to ByLevel Symbology. 

Open the Design model file 
1. From the MicroStation Manager, open the 12345DES_Model.dgn file 

from the \Design\Drawings\Reference_Files folder 

Note that the aerial photo raster images are attached. 

2. Select File > Raster Manager. 

3. Double-click on the raster files 09a.tif and 10a.tif and turn off their 
display in View 1. 

 

4. Select Settings > View Attributes, toggle off Line Styles and the select 
Apply to apply this setting to view 1. 
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Draw the Guardrail 
Next, you’ll follow the steps below to place guardrail along the fill area 
approaching the intersection. 

Create the guardrail trace lines 
Create temporary lines using the Parallel Copy command. 

1. Window in to the area to the left of the intersection around station range 
212+00 – 215+00 as shown. 

 

2. Pull the Manipulate toolbar off the Main toolbar. 

3. Select the Move Parallel tool off the Manipulate toolbar. 

4. In the Tool Settings box: 

 Toggle on Distance and key in 2. 
 Toggle on Make Copy. 

 

5. <D> on the red Edge of Oil line on the upper (North) side of the road. 
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6. Move your cursor up to establish the direction for the parallel copy. 

7. <D> to copy the Edge of Oil line. 

 

8. Repeat the above steps to create a guardrail trace line for the lower 
(South) side of the road. Be sure to parallel copy the Edge of Oil line. 

 

Red edge of oil line

Parallel copy 2 ft. on the 
outside

Parallel copy 2 ft. on the 
outside 

Red edge of oil line
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Trim the trace line for the extent of the guardrail 
1. On the CDOT Menu, select Drafting > Linework. 

2. Set the Line Weight category to 1. 

Note: This should automatically select the Place SmartLine tool. 

3. On the Status bar, turn off Depth lock.  

Note: Make sure that Depth lock does not have a check mark beside of 
it to ensure that it is off. 

 

4. On the Status bar, set the active snap mode to Perp. 

 

5. <D> on the guardrail trace line you just copied. 

As you move your cursor, note how you can only place perpendicular to 
the trace line. 
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6. AccuSnap on the endpoint of the Toe of Fill line as shown to draw the 
perpendicular line. 

 

This will serve as the cutting element for the trace line. The guardrail 
starts at the beginning of the toe of fill line. 

7. <R> when done. 

8. Repeat the above steps to create a trim line for the other side of the road 
and be sure to AccuSnap to the end of the toe of fill line. 

 

9. Pull the Modify toolbar off the Main toolbar. 

Snap to end of toe line 

Perpendicular trim lines 
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10. Select the Trim command. 

 

11. Follow your prompts and <D> on the perpendicular line as the cutting 
element. 

12. <D> on the trace line to the left of the cutting element as the portion to 
trim. 

 

13. <D> to accept.  

 

14. Update your view, if necessary. 

Cutting element 
Portion to trim 
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15. Repeat to trim the lower side as shown. 

 

16. Delete the blue perpendicular trim lines. 

Check the Depth lock 
1. <T> on the left end of the upper trace line. 

 
Note that the trace lines were copied at the same elevation as the edge of 
oil lines. When you place the guardrail lines, you want to place them at 
an elevation of 0. 

Note: If you want the guardrail lines to pick up the correct elevations 
of the roadway surface, you can drape them with InRoads. 

2. Key in az=0 

3. <D> anywhere in the view to set the active depth. 

 

Note that the active depth is set to the CDOT default of 0. 

4. Select the Locks button from the Status bar. 

5. Turn Depth lock on. 
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With Depth lock turned on, you will place elements at the active depth 
instead of picking up the elevation of elements you snap on. 

6. Toggle AccuSnap off. 

 

Note: It’s always a good habit to turn AccuSnap off when using 
Depth lock. 

Place the guardrail lines 
1. On the CDOT Menu, select Group Display > Design. 

2. Set the Category to Guardrail and select the item Type 3 left. 

 

Note: This automatically sets the active level to 
DES_GUARDRAIL_Type-3_Left with all ByLevel settings (color, 
style and weight), and automatically selects the Place 
SmartLine command. Note that the ByLevel style is a directional 
custom line style called GUARDRAIL_Left_Proposed. 
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3. <T> on the left endpoint of the upper trace line as shown. 

 

Check the message field. Note that with Depth lock on, you’re placing 
the line at a Z value of 0 instead of the elevation of the line’s endpoint. 

4. <D> to accept. 

5. Pan or Zoom to locate the other endpoint of the trace line near the 
intersection. 

Note: Remember when using View Controls in the middle of a drawing 
command, reset <R> once to get back to the command. 

<T> here to start guardrail line 
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6. Snap (<T>, then <D>) on the right endpoint as shown. 

 

7. <R> when done. 

<T> here to end guardrail line
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8. Select Settings > View Attributes and toggle on Line Styles and then 
select Apply to apply this setting to view 1. 

 

 

 

Note: Custom line styles are scaled before they are placed. The 
guardrail line is placed at the default line style scale of 100.  The 
line style scale corresponds to the plot scale (1:100). This setting, 
which comes from the CDOT seed file, is found under Element 
> Element > Line Styles > Custom. 



Colorado Department of Transportation 

Page 256  CDOT MicroStation Essentials 

9. Change the Line Style scale factor. Select Element > Line Style > 
Custom and set the Scale Factor to 50. 

 

10. On the CDOT Menu, select the Guardrail Type-3 Right. 

The active level updates to DES_GURARDRAIL_Type-3_Right. 

11. Snap on the right endpoint of the lower trace line as shown. 

12. Snap on the left endpoint as shown. 

 

 

13. <R> when done. 

Note: You are drawing this line right to left to illustrate a point. 

Snap here for the first point 

Snap here for the second point 
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Note that this guardrail line is smaller than the first. That’s because you 
set the active scale to 50 before placing the line. It is ½ the size of the 
first line placed at the default 100 scale.  

Note also that the guardrail line is placed in the wrong direction (the 
posts should be on the outside). Some custom line styles, like these, 
depend on the direction they are drawn. You drew this line right to left, 
so it is going in the wrong direction. You can correct this with the 
Change Direction command or through the CDOT Misc. Toolbar using 
the Change Element Direction icon. 

14. Turn Depth lock off. 

15. Turn AccuSnap back on. 

 

Change the custom line style direction 
1. Key in Change Direction. 

2. <D> on the guardrail line you just placed. 

An arrow is displayed on the line indicating the direction it was placed. 

50-scale guardrail placed in 
wrong direction. 
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3. <D> to change the direction. 

 

The posts now appear on the correct side. 

Change the custom line style scale 
You actually drew the guardrail at the wrong scale. Instead of deleting and re-
drawing the guardrail, you can change it to the correct scale of 100. 

1. Key in change linestyle scale 100 <Enter>, then <D> on the 
guardrail line to change it. 

 

Note: You can select multiple lines and scale them by using the 
PowerSelector (see Chapter 8). 

Guardrail after Change 
Direction command 

Guardrail after changing 
linestyle scale factor 
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2. Select Element > Line Styles > Custom and set the line style Factor 
back to 100. 

Delete the trace lines 
1. Select Delete from the Main toolbar. 

2. Hover over on the trace line with your mouse. 

Note: Watch for the trace line (not the guardrail line) to highlight. If 
you see the guardrail posts highlighted, <R> until the trace line 
highlights (watch for pop-up information to show the line on 
level DES_ROADWAY_Edge-of-Road-Oil).  

 
 
When using the Delete command, use the reset button to select 
coincident elements. 

3. With the correct line highlighted, <D> to accept.  

Use the Element information to change levels 
1. Select Element > Information or select this command from the Primary 

toolbar. 

 

2. <D> on the upper Type 3 guardrail lines you’ve just placed. 

3. Read the basic element information in the Message field. 
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Note: This is the same as the pop-up information provided when you 
“hover” over an element with your cursor. 

4. On the General tab of the Element Information box, review the element 
attributes and properties. 

5. Set the Level to DES_GUARDRAIL_Type_7. 

 

6. In the Element Information box, select Apply. 

The element is moved to the DES_GUARDRAIL_Type_7 level and the 
graphics update. 

 
Note: Element Information is one way to change element attributes or 

properties if the element was originally placed incorrectly. 

7. Select the Element Information command again and change the Level 
back to DES_GUARDRAIL_Type-3_Left and Apply. 

Guardrail changed to Type 7 
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8. Select the Details tab to review the element geometry. 

 

 

Note that the element was placed at the CDOT default active depth of 0 
in the 3D file.  

9. Cancel the Element Information dialog box when done. 

Turn rasters back on 
1. Fit the view. 

2. Select File > Raster Manager and turn both raster files back on in  
View 1. 

 

3. Fit your view if you don’t see the raster images. 

4. Select File > Save Settings. 

5. Continue on to Lab 6B. 
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Lab 6B – Create 3D Utility Graphics 
In this example, you’ll create a Utility model file, work with references, and 
then place proposed 3D utility lines using the CDOT Menu and the parallel copy 
tool. You’ll also modify the graphics as necessary. 

Objectives 
After completing this exercise you will know how to: 

 Work with nested references 
 Use the Copy Attachment option for references 
 Use the Locate setting for references 
 Use the CDOT Menu to place custom line styles (Utility lines). 
 Place elements in 3D using Depth Lock 
 Manipulate elements using the Parallel Copy tool. 
 Modify elements using the Trim tool. 

Create the Utility model file 
1. Select File > Close to close the 12345DES_Model file. 

2. In the MicroStation Manager Workspace section, re-set Project to 
12345. 

3. Set the directory to \Utilities\Drawings\Reference Files. 

 

4. Open the file 12345UTIL_Model.dgn  

The blank Utility model file opens. 

5. Select File > Save As... 

6. Set the Directory to \Utilities\Working. 
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7. Change the file name to CU12345UTIL_Model.dgn and select OK. 

 

The new file is created in the Working folder. 

Attach references 
1. Select References from the Primary toolbar. 

 

2. From the References dialog box, select Tools > Attach and select the 
12345DES_Model.dgn file from the \Design\Drawings\Reference 
Files folder. 

 

3. Set the Attachment Method to Interactive and select OK. 
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4. In the Attachment Settings box, keyin a logical name of Design and a 
Description of Design Model Plan. Make sure Display Raster 
Reference is on. Set the other options as shown and select OK. 

 

5. Fit the view. 

The Design reference graphics, along with the raster photos, appear in 
the Utility model file. 

 

 

Raster Images 
Since Display Raster References was turned on when attaching the 
reference, the aerial photos were attached with the design model file 
(they were turned on in the Design Model file from the last lab). You can 
quickly turn them off from the Reference dialog instead of opening the 
Raster Manager. 



Colorado Department of Transportation 

Page 266  CDOT MicroStation Essentials 

1. In the References box, highlight the Design reference and toggle 
Display Raster References off. 

 

 

Work with references 
1. Window in on the Intersection. 

 

2. On the Reference dialog, change No Nesting to Live Nesting and set 
Depth to 1. 
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3. On the left, select the upper-level Design reference. On the right, select 
the Survey/Topo nested reference and make sure that Display is toggled 
on. 

 

 

4. In the Level Display box, make sure the Show Target Tree button is on 
and select the Survey/Topo Reference. Turn on all reference levels. 

 

The nested Survey/Topo graphics are displayed. 

 

Show Target 
Tree
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5. Back in the Reference dialog box, on the left side, select the upper-level 
Utility master file. On the right side, select the Design reference on the 
right and toggle off Display. 

Both Design and Survey/Topo are turned off since Survey/Topo is 
nested. 

6. Turn the display of the Design reference back on. 

What if you wanted to turn off Design graphics and leave the 
Survey/Topo graphics on? Currently, as nested references, you can’t do 
this. However, in the next section you will accomplish this using Copy 
Attachment. 

Use the Copy Attachment option 
Many times, especially in Model files, you want all your references to be 
upper level references (as opposed to nested references) so that you can 
turn on/off the individual reference displays. In order to accomplish this, 
you would either have to reference all the nested files one by one, or you 
can use the Copy Attachment option. 

1. With the Design reference selected on the right, change the Live Nested 
option to Copy Attachment. 

 

 

Note that now, on the left-hand side of the References box, both the 
Design and the Survey/Topo references are upper level references. The 
nested Survey/Topo reference was copied in as a direct attachment. 
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2. Select Level Display again and turn on all Survey/Topo reference 
levels. 

 

3. On the right-hand side of the References box, select the Design 
reference and toggle the Display off. 
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With both references as upper-level, direct attachments, you can now 
individually turn each reference on/off. The Design reference is turned 
off while the Survey/Topo graphics remain on. 

Note: As a rule of thumb for Model files, you can reference nested to 
avoid having to attach multiple times. Then, once the nested 
references are attached, use the Copy Attachment option to 
make all nested references direct attachments. For Sheet files 
(see Chapter 9), you can typically use nested attachments. 

4. Turn the Design reference display back on. 
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Drawing in 3D (using Depth lock) 
In the next series of steps, you’ll practice placing utility graphics from the 
CDOT Menu with and without Depth lock. Depth lock determines the 
elevation that graphics are placed in a 3D file. 

Place overhead electrical lines 
1. Key in az=0, then <D> in the view to check your active depth. 

The active depth is the CDOT default of 0 for the Utility model file. 

Select the Locks button on the status bar and verify that Depth lock is 
turned off. 

 

With Depth lock turned off, you will pick up the elevation of elements 
you snap to in a 3D file. 

2. Zoom in on the south side of the intersection cross road. 
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3. Follow the steps below to place a proposed overhead electrical line that 
connects to the two power poles on the east side of the road. 

 On the CDOT Menu, select Group Displays > Utilities. 
 Highlight the Utilities group and set Status to Proposed. 
 Select the Electric category. 
 Set Filters to All. 
 Select the Overhead Line item. 

 

Note that the active level is automatically set to 
UTIL_ELECTRICAL_Overhead and the Place SmartLine command is 
selected. 
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4. AccuSnap to the end of the existing North/South overhead line at the 
power pole as shown. 

5. AccuSnap to the end of the existing east/west overhead line at the 
power pole as shown. 

 

Snap here for the first point 

Snap here for the second point 
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6. Turn off the display of the Topo/Survey reference to better see the 
proposed graphics. 

7. <T> on the end of the proposed overhead electrical line you just placed. 

 

 

 

Note that even though the active depth is 0, since Depth lock is turned 
off the line was placed at the elevation of the existing overhead line 
(6627.317). 

8. <T> on the other end of the proposed overhead electrical line to check its 
elevation. 

 

Proposed OH electrical line. 

<T> here 
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Place proposed gas lines 
1. Turn off the display of the Design reference and turn on the display of 

the Survey/Topo reference. 

2. Follow the steps below to place a proposed gas line to service the west 
side of the intersection cross road. 

 On the CDOT Menu, select the Gas category. 
 Select the Gas Line item. 

 

The active level is automatically set to UTIL_GAS. 
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 <T> on the end of the existing gas line on the east side of the 
road. 

 Place data points to draw the gas line in the approximate 
location shown. 

 <R> when done. 

 

3. <T> anywhere on the proposed gas line you just placed and note the 
elevation. 

 

Since Depth lock is off, the gas line was placed at an elevation of 
6622.514, which is the elevation of the existing gas line at the endpoint 
where you snapped. You actually want to place the proposed gas line at 0 
so that InRoads can later import it as a utility feature at the correct 
elevation. 

4. Delete the proposed gas utility line you just placed. 

5. Select the Locks from the status bar. 

6. Toggle on Depth Lock. 

 

<D> here 

<D> here 

<T> here 
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7. On the Snap Mode toolbar, toggle AccuSnap off. 

 

Note: AccuSnap doesn’t work consistently when Depth Lock is on. 
Therefore, to ensure Depth lock works correctly, toggle 
AccuSnap off. 

8. Place the proposed gas line again by a <T> on the end of the existing gas 
line and then placing the other data points in the approximate location 
shown. 

9. <T> anywhere on the proposed gas line you just placed and note the 
elevation. 

 

 

Since Depth lock is on, the proposed gas line was placed at an elevation 
of 0. 

10. Turn Depth lock off. 

11. Toggle AccuSnap back on. 

 

<T> here
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Place fiber optic lines using parallel copy 
Follow the steps below to place a fiber optic line by parallel copying an 
existing telephone line. 

Locate reference graphics for copying 

1. Turn off the TOPO_TERRAIN_Break-Lines level in the SurveyTopo 
reference. 

2. Window in on the existing overhead electrical line in the southeast 
quadrant of the intersection as shown. 

 

3. Select the Move Parallel tool from the Manipulate toolbar. 

4. In the Tool Settings box, set the options as shown. 
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5. <D> on the existing overhead line 

6. Move the cursor down to specify the direction of the parallel copy. 

7. <D> to place the copy. 

 

Change element attributes 
Change the overhead electrical line to an underground fiber optic line 
using the Change command. 

8. Set the active level to UTIL_FIBEROPTICS (hint: use a filter to help you set 
the level). 

 

9. Select the Change Element Attributes command from the Change 
Attributes toolbar. 

Parallel copy

Existing OH line  
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10. Set Method to Change. 

11. Toggle on Use Active Attributes. 

12. Toggle on Level (this picks up the active level). 

 

13. <D> on the overhead electrical line you just copied as the element to 
change. 

14. <R> when done. 

 

Since the Use Active Attributes option was turned on, the element was 
changed to the active level UTIL_FIBEROPTICS. 
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Set the elevation 

15. <T> on the fiber-optics line you just placed. 

 

The proposed fiber-optics line is in the 6620 elevation range (your exact 
elevation may be vary depending on where you placed a tentative point). 
This elevation is wrong for the fiber optic line since you copied the 
overhead electrical line. For now, you can set the elevation of this line to 
0 and later, it can be placed as a feature in the InRoads surface at the 
correct elevation. One way to set the elevation of an element is to use the 
ModZ command on the CDOT Menu. 

16. On the CDOT Menu, select Add On’s > ModZ. 

 

17. In the ModZ tool settings box, set the elevation to 0. 

 

18. Select Single (to identify a single element). 

19. <D> on the new fiber-optics line you created. 

20. <D> to accept. 

21. <R> when done. 

22. <T> on the fiber-optics line to check its elevation. 
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The Z value is now at 0. Use the ModZ command to easily set the 
elevation of any element or group of elements (selected with a fence). 

Trim graphics 
The new fiber optic line is only going in on the east side of the 
intersection cross road. Follow the steps below to use the Trim command 
to edit the fiber optic graphics. 

23. Select the Trim command from the Modify toolbar. 

 

24. <D> on the north/south proposed overhead electrical line as the cutting 
element. 

25. <D> on the fiber optic line (left side of the cutting element) as the 
element to trim. 

26. <D> to accept. 

 

Cutting 
Element 

Element side 
to trim 
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The fiber-optics lines are trimmed as shown. 

 

27. Turn off the display of the Survey/Topo references. 

28. Fit the view. 

 

Only the proposed gas, electric and fiber-optic utility graphics appear in 
the CU12345UtilityModel01.dgn file.  



Colorado Department of Transportation 

Page 284  CDOT MicroStation Essentials 

29. Turn the display of the Design reference on and window into the 
intersection as shown. 

 

Move the utility model to the Reference Files folder 
Move the utility model so that other groups can reference your work. 

1. Select File > Save As and set the directory to the project’s 
\Utilities\Drawings\Reference_Files folder. 

2. Remove the CU initials from the file name and select OK. 

 

The file is saved to the new location. 
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Note: The project template delivers standard dgn’s for model and sheet 
files as starter files.  You may be prompted to confirm saving 
over an existing file.  Please use caution when performing these 
tasks as you could lose data.  Be sure the files are empty or you 
are working with the latest files. 

3. Select File > Close. 

4. In the MicroStation Manager, verify that the file was saved to the 
Reference_Files folder. 

 

5. Then, set the directory to \Utilities\Working. 

6. Select File > Delete and delete the file from the Working folder. 

 

7. Cancel the MicroStation Manager to exit. 
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7. Cells and Patterns 

Understanding cells 
Cells are a permanent group of graphics. They are typically used for standard 
graphics (symbols, details, notes, borders, etc.), which may be used over and over 
on multiple projects. Cells are stored in a separate cell library file. 

When you’re ready to place the cell in your design file, attach the cell library to the 
file.  You can then place the cell out of the library multiple times, like a rubber 
stamp.  Once the cell is placed in the design file, it is a single element that exists in 
the design file. You do not have to have the cell library attached to see the cell. 

Cell libraries 
Cell libraries are just ordinary MicroStation design files that have a .cel 
extension.  Cells can be organized into different libraries or you can place all 
cells in one library.  CDOT uses discipline-specific cell libraries, where each 
group has its own library (Design, Bridge, Traffic, etc.) 

Cell Library = DGN file 

The cell library file contains multiple models and each cell is stored in a separate 
model. 

Cell = Model 

What Are MicroStation Models? 
Models are “containers” for graphics within a DGN.  Design files must have at least 
one model (named CDOT Default in the CDOT workspace), but can have many.  
Models in a DGN file are analogous to workbook in an XLS file.  Just like each 
workbook is a separate spreadsheet, each model is a separate set of graphics.  And, 
you can have multiple models in a DGN just like multiple spreadsheets in a XLS 
file. 

Note: Do not confuse Model files with MicroStation Models. They are 
two totally separate concepts. A Model file is a generic term 
used to describe any working file that contains graphics. A 
MicroStation Model is a separate container for graphics inside 
any MicroStation file – Model or Sheet file. 
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Models are accessed from the Primary toolbar.  They can be entirely different sets 
of graphics or different components of the same project (e.g. three separate models 
for plan, profile and cross sections in one project DGN file). 

  

In almost all cases, you will work in one model -- the CDOT Default model in all 
model files and sheet files. 

 

The one exception is when you’re working directly in a cell library.  Each cell in a 
cell library is actually just a separate model inside the cell library design file 
(cell=model).  The design file containing the model (cell) can be attached to any 
other design file as a cell library, and then the model (cell) can be placed out of this 
file. 

  

 

Models in a cell 
library. Each 
model is a cell. 
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In order for models to be placed as cells, the option Can be placed as cell must 
be toggled on in the model’s properties.  In the Models dialog box, select the Edit 
Models Properties command to turn this option on/off.  

  

The design file’s levels are shared among all models; however each model can 
have different levels turned on/off for different views.  A Global Display or 
Global Freeze mode on the Level Display box carries through to all models. 

Models can also be imported from other DGN files.  This is a good way to copy 
a lot of graphics from one DGN to another, or a good way to build a cell library. 
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CDOT Cell Libraries 
Many of the CDOT standard cells have been created and are stored in discipline-
specific cell libraries (e.g. Design, Bridge, ROW).  The appropriate cell library 
or libraries are attached to the discipline seed file.  When you create a new file 
from a discipline seed file, the associated cell library is automatically attached to 
the new file. 

The standard CDOT cell libraries are stored in the CDOT workspace in the 
folder C:\Program Files\Workspace-CDOT\Standards-
Global\MicroStation\Cells. The discipline-specific as well as general cell 
libraries (used by all groups) are shown below. 
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The Cell Library Dialog 
To view all cells contained in a library, you can open the Cell Library dialog 
box. Select Element > Cells, or select Cells from the Primary toolbar. 

 

 

This opens your discipline cell library (attached via your seed file) and a list of 
cells is shown in the Cell Library dialog box. 

If you want to access cells form a different library, you can manually attach a 
library to your active design file. From the Cell Library dialog box, select File > 
Attach.  
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When working in the CDOT workspace, the configuration automatically sets the 
correct path for .cel files. Select the library to open and then select OK to attach 
the library. 
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Note: You can only attach one cell library at a time (when you attach a 
library, it automatically detaches the current library and attaches 
the new one). Only the cells from the active library are shown in 
the list of cells. However, if you toggle on Display All Cells in 
Path, MicroStation displays cells from all of the CDOT libraries 
that are pathed in the CDOT configuration. 

  

Types of cells 
Cells are either Graphic cells or Point cells. Graphic and Point cells have 
different properties after they are placed in the design file.  The properties of 
each type of cell are as follows: 

 Graphic Cell Point Cell 
Symbology Maintains active settings used 

when created 
Takes on active settings when 
placed 

Level Level(s) as created (relative or 
absolute mode) when placed 

Active level when placed 

Snappable points Keypoints Cell Origin 

View View dependent — appears 
different according to the view 
(top, front, etc.) 

View independent — appears 
as originally drawn in all 
views 
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Placing cells with the Place Active Cell Command 
You can place cells out of the cell library into your design file using the Place 
Active Cell command located on the Cells toolbar. 

 

The command places either a point or graphic cell in the design file using the 
active placement parameters including: 

 Active cell name (you can browse out to the cell library and select the 
cell from a list – double-click the cell to make it active) 

 Active scale (as=<scale factor > ) 
 Active angle (aa=<angle > ) 
 Active element symbology — for point cells only, and 
 Active level — for point cells only. 
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Note: You can also place a cell by right-clicking on it in the cell library 
dialog box.  This sets the cell as the active Placement cell and 
automatically selects the Place Active Cell command. 

 

Shared Cells 
Cells can be placed as Shared.  Then, when you place multiple cells in a design 
file, MicroStation stores the shared cell definition data once, and all other 
instances of the cell placement reference this definition.  Shared cells keep your 
design file efficient by writing the cell graphics to the file only once. 

Note:  To place a shared cell, toggle on Use Shared Cells in the cells 
dialog box. 

 

 



Colorado Department of Transportation 

Page 296  CDOT MicroStation Essentials 

If you’re placing a sheet border cell, do not place it as shared.  If you do, you 
will not be able to edit the cell text.  If you want to remove the share status of a 
cell, you can do so with the Drop Element command.  You can drop a Shared 
Cell to a Normal Cell (for text editing) or to Geometry (individual graphics). 
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Placing cells with the CDOT Menu 
The CDOT Menu streamlines the process of placing cells. After selecting the 
Group, Status and Category, a list of available cells for that category is shown 
in the item selection window. Just select the cell item and then place it in your 
file. The proper level is set active and the Place Active Cell command is 
automatically selected. The specified cell is automatically set active and placed 
out of the appropriate cell library.  

 

 

Note: You can set the Filter to Show Cells to filter only the cell items 
for a category. 
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Cell Divide Program 
The Cell Divide program located on the CDOT Menu (Add On’s > Cell Divide 
Load), will divide any linear or curvilinear elements with the active cell. The 
program allows you to specify a length and angle to place the cell along the 
element. 

More information 
For more information on cells and cell libraries, see the CDOT CADD Manual, 
Chapter Five – Drafting Standards, Section 5.1 Cell Libraries. 

 

 

Creating Cells 
For information on how to create a cell library and cells, see Chapter 9, lab exercise  
9B – Create a project specific border. 
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Understanding patterns 
You may have a need to pattern areas with a hatch, crosshatch or special pattern 
(concrete, rip-rap, etc.).  Or, you may need to pattern linear elements like pavement 
lines with an asphalt pattern.  For these situations, you’ll use MicroStation’s 
patterning tools. 

Patterns toolbar 

 

The Patterns toolbar contains tools for hatching and cross-hatching shapes or 
areas.  You can also pattern any line, shape or area with a cell.  The Pattern 
tools include: 

Hatch Area 
The Hatch Area command hatches a closed shape or area in the active model or 
a reference.  Set the Spacing (in master units) and Angle of the hatch line and 
turn on Snappable Pattern if you later want to snap to the pattern graphics (the 
hatch lines in this case).  If you’re patterning curved element, key in a 
Tolerance or minimum distance for chording off the pattern around the curve. 
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Toggle on Associative Patterning if you want the pattern to update if the 
element is modified.  In addition, broken patterns can be re-associated by re-
connecting the pattern shapes. 

Toggle on Associative Region Boundary to place the pattern on different level 
from the patterned element (useful for removing the “box” around text  

The icon bar at the top of the dialog box allows you to select the pattern method 
(how the area will be patterned), which includes (items listed in order from left 
to right on the icon bar): 

 

 Element —a closed shape.  
 Flood — the area enclosed by a set of elements.  
 Union — area defined by the union of two or more closed shapes. 
 Intersection — area defined by the intersection between two or more 

closed shapes. 
 Difference — area defined by the difference between two or more closed 

shapes. 
 Points — an area defined by a series of data points where you 

dynamically define an area.  
 Fence — the area inside the fence. 

Cross Hatch Area 
The Cross Hatch Area command uses similar settings to the Hatch Area 
command to cross-hatch an area. 
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Pattern Area 
This command patterns an area or closed shape with a cell.  The pattern 
element(s) can be in the active design file or in references. 

     

Key in the active Pattern cell or set it in the Cells dialog box (Element > Cells). 
If you toggle on Display All Cells in Path, all pattern cells begin with the cell 
name PATTERN. 

 

 
Set the active Scale to size the cell, the active Angle to determine the 
placement angle for the pattern graphics, and the pattern Row and Column 
Spacing in master units (distance between the tiled cells).  The True Scale 
option will reconcile the difference between the cell model’s working units and 
the working units of the design file model in which it is placed (e.g. patterning 
with a metric cell in an imperial design file model). For this option to work, the 
pattern cell must be a shared cell. 

Other options are the same as noted for the Hatch and Crosshatch commands. 
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Linear Pattern 
Linear Pattern patterns with a cell along an existing linear element.  You can 
pattern both linear and curvilinear elements.  Specify the Cell, Scale and 
Tolerance just like the Pattern Area command.  In addition, the Linear Pattern 
command has the following Cycle options: 

 Truncated – places the cell for the linear pattern using the specified 
active scale. Based on this scale, the last instance of the pattern may be 
truncated.  

 Complete – adjusts the scale for pattern cell so that only complete 
instances of the cell are placed along the linear element. 

 Single – patterns with one instance of a cell on each linear segment.   
 Multiple– adjusts the scale for pattern cell so that only complete 

instances of the cell are placed along each segment of the linear element. 

 

After patterning, you can turn off Patterns in the Settings>View Attributes.  
Doing so will display the original linear element. 
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Placing patterns with the CDOT Menu 
The CDOT Menu streamlines the process of placing patterns. After selecting the 
Group, Status and Category, a list of available patterns for that category is 
shown in the item selection window. Just select the pattern item and then data 
point inside the region to pattern. (The CDOT Menu uses the Flood method of 
patterning, so you must data point inside the region to pattern). The proper 
pattern level is set active and the appropriate pattern command is automatically 
selected (Hatch Area, Cross Hatch Area, Pattern Area or Linear Pattern). If 
patterning with a cell, the appropriate patter cell is automatically set active.  

  

Note: You can set the Filter to Show Patterns to filter only the pattern 
items for a category. 

 



Colorado Department of Transportation 

Page 304  CDOT MicroStation Essentials 



 Cells and Patterns 

 

CDOT MicroStation Essentials  Page 305 

Lab 7A – Create Landscape graphics 
In this lab you’ll create a Landscape & Environmental (L&E) model file and then 
use the CDOT Menu to place silt fence lines, hay bale cells and wetlands regions. 

Objectives 
After completing this exercise you will know how to: 

 Use the CDOT Menu to place L&E custom lines. 
 Use the CDOT Menu to place L&E cells. 
 Use the CDOT Menu to place L&E shapes (wetlands). 
 Use the CDOT Menu to pattern areas. 

Create the L&E model file 
1. Start MicroStation. 

2. Re-set Project to 12345. 

3. Set the directory to 
\Landscape_Environmental\Drawings\Reference Files. 

4. Select the file 12345LAND_ENVI_Model.dgn and select OK to open. 

 

 

5. After opening the file, select File > Save As… and set the directory to 
C:\Projects\12345\Landscape_Environmental\Working. 
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6. Change the file name to CU12345LAND_ENVI_Model.dgn and select 
OK to save a copy to the Working folder. 

 

 

7. Select References from the Primary toolbar. 

8. Using what you’ve learned, attach the Design model reference (from 
Design’s \Drawings\ Reference_Files folder), Coincident-World and 
at a 1:1 scale. Copy Attachments at a depth of 1 to bring in the 
Survey/Topo as direct attachments. See below.  

  

9. Fit the view. 
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10. From the Reference dialog, Turn off the display of Design’s raster 
references. 

  

Place silt fence 
1. Window around the end of the project just east of the existing bridge. 

 

2. From the CDOT Menu, select Group Displays > Landscape 
Environmental. 

3. Set Status to Proposed. 

4. Set the category to Erosion Other / Sediment Control. 
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5. Select the Silt Fence item. 

  

This automatically sets the active level to LAND_ENVI_Erosion-Silt-
Fence and selects the Place SmartLine tool. 

 

6. Place data points to draw the silt fence along the toe-of-fill line on the 
south side of the proposed road (similar to the one shown). 

 

7. <R> when done. 

Silt Fence 
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Place Haybales 
1. Set the category to Checks / Silt Dike. 

2. Select the item No Plot Line. 

  

This automatically sets the active level to DRAFT_INFO_No-Plot and 
selects the Place SmartLine tool. The No Plot level allows you to place 
a construction line representing the location of haybales, silt dikes, etc. 
that you can later divide with a cell. 

 

3. Place data points to draw the haybale construction line on the north side 
of the proposed road as shown. 

 

No Plot line 
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4. <R> when done. 

5. On the CDOT Menu, select Settings and set Active Scale to 100, 
Apply and then Close. 

  

6. Set Placement to 50’ Spacing. 

7. Set the item to Haybale. 

 

This automatically selects the Place Cell command and starts the Cell 
Divide program. 

8. When prompted to Identify Element, <D> on the No Plot line you just 
placed. 
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9. <D> to accept. 

 

The No Plot line is divided with the haybale cells at 50 ft. intervals. 

Create wetlands 

Draw the wetland shapes 

1. Pan over to the left to the area around the bridge as shown. 

 

2. Open Level Display, highlight the Survey/Topo reference, right-click in 
the list of levels and turn on all of the Survey/Topo reference levels. 
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Note: You can also turn reference settings (Display, Snap and Locate) 
on/off from Level Display just like the Reference dialog. 

3. While in the Level Display box, turn on all Survey/Topo levels. 

 

4. On the CDOT Menu, set the category to Wetlands. 

5. Select the item Wetland Right. 

 

This automatically sets the active level LAND_ENVI_Wetland-Right and 
selects the Place Shape tool. 
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6. Place data points to define the wetlands region as shown. To close the 
shape, select Close Element in the Place Shape Tool Settings box. 

 

 

 

7. <R> when done. 

8. Repeat for the area on the other side of the bridge as shown. 

 

Wetlands shape
on north side of 
bridge 

Wetlands shape
on south side of 
bridge 
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Pattern the wetlands 

9. On the CDOT Menu, select the Mitigation item from the Wetlands 
category. 

 

This automatically selects the Pattern Area command and sets the active 
pattern cell. 

10. When prompted, <D> on the wetland shape you just drew and then <D> 
to accept. 

11. Repeat for the other wetlands shape on the north side of the bridge. 

12. Turn off the display of the Survey/Topo reference. 

 

 

13. Save Settings. 

14. Proceed to the next lab. 
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Lab 7B – Create Hydraulics graphics 

Objectives 
After completing this exercise you will know how to: 

 Use the CDOT Menu to place Hydraulics custom lines (pipes). 
 Use the CDOT Menu to place Hydraulics cells (inlets). 
 Use the CDOT Menu to place Hydraulics terminators (RCES). 

Create the Hydraulics model file 
1. In MicroStation, select File > Open. 

2. Set the directory to \12345\Hydraulics\Drawings\Reference Files 

3. Select the file 12345HydraulicsModel##.dgn and select OK to open. 

 

4. Select File > Save As… and set the directory to \Hydraulics\Working 

5. Change the file name to CU12345ydraulicsModel.dgn and select OK to 
save a copy to the Working folder. 
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6. Select References from the Primary toolbar. 

7. Using what you’ve learned, attach the Design model reference (from 
Design’s \Drawings\ Reference_Files folder), Coincident-World and 
at a 1:1 scale. Copy Attachments at a depth of 1 to bring in the 
Survey/Topo file as direct attachments. See below.  

 

8. From the References dialog, turn off the display of the design model’s 
raster references. 

Place Inlets 
Using known coordinates and the CDOT Menu, place proposed Type R inlets 
along the curb flowline at the end of the project. 

1. Window into the area shown near the end of the project. 

 

This area of the projects is a proposed 2-Lane urban section with curb, 
gutter and sidewalk. You’ll first place inlets along the curb flowline. 

2. Select Locks from the status bar and make sure Depth lock is turned off. 

3. On the CDOT Menu, select Group Displays > Hydraulics. 

4. Select the Hydraulics group and then set Status to Proposed. 
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5. Select the Inlets (Plan) category and then select the Type R L 10 item. 

 

6. Select Settings and set Active Scale to 1 and Active Angle to 180.  
Apply and then Close. 

 

This automatically sets the active level to HYDR_Inlets and selects the 
Place Cell command. The inlet cell is attached to your cursor at the 
origin point. Since you know the coordinate location for the inlets, you 
can place them with precision keyins. 

7. For the 1st inlet, key in  
xy=3292424.652, 1553316.387, 6351.8 
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The inlet appears in the location shown. 

 

Note: If you don’t see the inlet, it could be outside your display depth. 
Key in dp=0,7000  Enter, and then select the view. You could 
also fit the view and then window back to this location. 

8. For the 2nd inlet, key in  
xy=3292674.652, 1553320.404, 6350.4 

9. For the 3rd inlet, key in  
xy= 3292900.384, 1553324.031, 6348.8 

Inlet 
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10. Turn off the Design reference levels shown to better see the inlets. 

 

 

 

 
Inlets 
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Connect the inlets with pipes 

Place the pipes 

1. Zoom in on the first inlet. 

 

2. Verify that Depth lock is still turned off. 

Note: When placing pipes, you want to pick up the elevation of the 
inlets, therefore you need to turn Depth lock off. 

3. On the CDOT Menu, set the category to Pipes (Plan). 

4. Select the item Reinforced Concrete. 
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This automatically set the active level to HYDR_PIPES_Concrete and 
selects the SmartLine tool. 

5. AccuSnap on the right-side midpoint of the inlet to begin the pipe. 

6. Pan to the right and AccuSnap on the left-midpoint of the second inlet. 

7. Pan to the right and AccuSnap on the right-midpoint of the third inlet. 

8. <R> when done. 

 

This connects the inlets with the concrete pipe. Notice how the 
directional arrow on the pipe custom line style falls on top of the last 
inlet. You can correct this by shifting the custom line style. 

 

Shift the line 

9. Select the Change Element Attributes toolbar off the Main toolbar. 

10. Select the Modify Line Style Attribute command. 

11. Set the Modify option to Shift. 

 

Note: The Shift command is also located on the CDOT Misc. Toolbar. 

 

Concrete pipe
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12. <D> on the concrete pipe that you just placed and move your cursor to 
the left. Note how the custom line style shifts as you move your cursor. 
When the arrow is moved off of the inlet, <D> to accept. 

 

Note: Use the Modify Line Style command to shift custom lines styles 
as needed, especially in corners where there may be gaps. 

Place a Type C inlet and connect pipes 

Turn on the Survey/Topo reference 
To help determine the location of the inlet, turn on the Survey/Topo 
Reference and the Contour reference.  

1. On the Reference dialog, select the Design reference set the Copy 
Attachment Depth to 2. 

 

This brings in the Contour reference since the Contour model file is 
referenced to the Survey/Topo file. 

Turn on reference levels 

1. In the Level Display box, turn on all of the Survey/Topo reference 
levels. 

2. Turn on all Contour reference levels. 
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3. Window into the location shown. 

 

4. On the CDOT Menu, select the Inlets (Plan) category and then select the 
Type C item. 

 

This automatically sets the active level to HYDR_Inlets and selects the 
Place Cell command. The inlet cell is attached to your cursor at the 
origin point.  

5. Key in xy= 3292986.899, 1553291.431, 6345.2 
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6. <R> When done. 

 

 

7. On the CDOT Menu, set the category to Pipes (Plan) and select the 
Reinforced Concrete item again. 

This automatically set the active level to HYDR_PIPES_Concrete and 
selects the SmartLine tool. 

8. AccuSnap on the right-midpoint of the last Type R L 10 inlet (see 
below). 

9. Select the Origin snap mode and AccuSnap on the Type C inlet. (see 
below). 

 

Type C inlet 
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10. Place a final <D> in the location shown for the end of the pipe near the 
contour line (see below). 

 

 

11. <R> when done. 

Snap to right-
midpoint 

Snap to cell 
origin

<D> here to end
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12. Use the Modify Line Style again command and Shift the pipe line style as 
necessary to ensure the arrow does not fall on top of an inlet. 

 

 

Shift line
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Place the pipe terminator 
The pipe terminates at a 36” RCES, which you can place as a cell line 
terminator. 

1. On the CDOT Menu, set the category to FES (Plan). 

2. Set Type to Concrete – Round. 

3. Select the 36 inch item. 

 

This automatically set the active level to HYDR_FES and selects the Place 
Active Line Terminator tool off the Cells toolbar. 

4. <D> on the end of the concrete pipe as shown. 
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5. <D> to accept. 

 

The RCES terminator is automatically rotated to the appropriate angle 
and placed on the end of the pipe. 

6. Save Settings. 

7. Exit MicroStation. 
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8. Grouping Design Graphics 
There are times when it is necessary to group elements because it is more efficient 
to place, modify or manipulate groups of elements rather than perform repetitive 
commands on individual elements.  Element groups can be: 

 Temporary — fences and selection sets or  
 Semi-permanent — graphic groups and complex elements. 

Temporary groups 
If you want to perform a one-time manipulation on a group of elements (i.e. copy 
them or delete them), create a selection set or use a fence to group the elements. 

Using Selection Sets 

 

The Element Selection toolbar provides various methods for temporarily 
grouping elements.  Once grouped, elements can be modified, manipulated or 
deleted as a group.  When elements are grouped with these tools, they are placed 
in a selection set and remain in the selection set until you clear the set. 

When elements are added to a selection set, they highlight.  You can set the 
selection set color under Settings > Design File > Color > Selection Set Color.  
You can also quickly see the number of elements in the selection set from the 
indicator on the Status Bar. 
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These tools include: 

Element Selection 
Selects individual elements and adds them to the selection set. You can select 
multiple elements by either holding down the Ctrl key or by holding down the 
data button and dragging across the elements. 

 

Power Selector 
Power Selector provides more options for how elements are added to or deleted 
from the selection set.  This includes filtering elements based on their attributes 
(color, style, weight, etc.) In many cases, you can find and add elements to a set 
much more quickly by filtering on attributes (e.g. all elements on level 
Design_Guradrail_Type-3), than individually picking them with the Element 
Selection tool. 

     

Power Selector also provides several methods for selecting elements including: 

 Individual — <D> on individual elements. 
 Block — selects all elements inside a block you draw.  You can toggle 

the Block option to either inside or overlap. 
 Shape — selects all elements inside an irregular shape your draw.  You 

can toggle the Shape option to either inside or overlap. 
 Line — selects elements by drawing a line through the elements. 

Show/Hide information 
drop down arrow 
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The Mode option gives you options for adding and removing elements from the 
set including: 

 Add — places elements in the set. 
 Subtract — removes elements from the set. 
 Invert — toggles an element (adds a removed element or removes an 

added element). 
 New — clears the current selection set and creates a new set. 
 Clear/Select All — removes all selected elements from the current set, or 

adds all elements if the set is empty. 

To access the attribute filtering option, select the Show Selection Information 
drop down arrow on the PowerSelector Tool Settings box. 

Using Fences 

 

The Fence toolbar provides another set of tools to temporarily group elements.  
Once placed in the fence, the elements can be deleted, manipulated or the 
attributes changed.  When the fence is removed, the elements are no longer 
grouped. 
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Place Fence 
Temporarily groups elements by drawing a fence boundary around the elements.  
There are several types of fences you can place including blocks (drawn corner 
to opposite corner), shapes, and circles, also by element, view or design file. 

     

The fence mode determines which elements will be affected by the fence.  These 
include: 

 Inside — to select elements entirely inside the fence. 
 Overlap — to select elements inside or overlapping the fence. 
 Clip — to select elements inside the fence and cut or break all elements 

that intersect the fence. 
 Void — to select all elements outside the fence. 
 Void-Overlap — to select all elements outside or overlapping the fence. 
 Void-Clip — to select elements outside the fence and cut or break all 

elements that intersect the fence. 

Once the elements are grouped in the fence, they can be deleted, manipulated, 
etc.  You can use MicroStation view controls (Zoom In, Zoom Out, Pan etc.) 
and the fence remains persistent. 

To remove the fence, select the Place Fence command again. 

Note:  check the fence indicator on the Status Bar to quickly determine 
is there is a fence placed in the design file. 

The Void and Clip modes are two features not available with selection sets.  
However, there may be times when attribute filtering (not available with fences) 
is easier to use — especially when grouping graphics in high-density areas. 

Delete Fence Contents 
Deletes the contents of the fence based on the fence mode.  Note that the Delete 
Element tool on the Main toolbar does not work for fenced elements. 
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Semi-permanent groups 
For groups that require more frequent manipulation, it is often more efficient for the 
elements to remain grouped until you “ungroup” them.  These groups — complex 
chains, complex shapes or graphic groups are created using the Groups toolbar. 

Groups toolbar 

 

Drop Element 
Drop Element returns a complex element to its original graphics.  In addition to 
breaking up complex elements, this command is also used to drop other types of 
groups including linestrings and cells (discuss later). 

     

 



Colorado Department of Transportation 

Page 334  CDOT MicroStation Essentials 

Creating Complex elements 

Create Complex Chain 
The Create Complex Chain command joins a series of lines, linestrings and/or 
arcs into one element with two end points.  This command uses two methods: 

 Manual — you graphically select each element to add to the complex 
chain. 

 Automatic — adds all elements to the complex chain that are within the 
specified Max Gap distance (handy for numerous elements which would 
be tedious to pick individually). 

     

If you toggle on Simplify geometry, the new element is created as a linestring 
instead of a complex element.  The advantage is that you can more easily 
modify a linestring than a complex element. 

The new complex chain takes on the active element attributes, regardless of the 
attributes of the original elements that make up the chain.  Be sure to set your 
active element attributes before creating the complex chain. 

Create Complex Shape 
Create Complex Shape joins a series of lines, linestrings and/or arcs into one 
closed element.  A “filler” segment is added, if needed, to close the shape.  The 
same Manual and Automatic methods found in the Complex Chain command 
are also available on the Complex Shape command. 
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Add to Graphic Group 
Add to Graphic Group creates a group of individual elements that can be 
named.  Graphic groups are more efficient than a fence or a selection set for 
items that must be frequently grouped and manipulated.  This command can also 
add elements to an existing named group or can combine groups. 

     

After creating the graphic group, the elements behave as a group as long as the 
Graphic Group lock is on (Settings > Locks or Locks button on the Status 
Bar).  If the Graphic Group lock is off, you can manipulate, modify or delete 
individual elements in the group.  However, the elements retain their group 
status and can be manipulated again as a group if the Graphic Group lock is 
turned back on. 

 

The Open Named Group option (magnifying glass icon) is used to manage 
your named groups (create new groups, add or removed elements from the 
group, create group hierarchies, etc.) 

    

Open Named Group Dialog

Create New Named Group
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Drop from Graphic Group 
Removes individual elements from a graphic group or named group.  The 
command is also used to drop an entire group (break up the entire group into its 
component elements). 
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Lab 8 – Draw a bridge typical section 
In this lab, you’ll practice all of the drawing concepts you’ve learned so far to 
create a bridge typical section. 

 

 

Objectives 
After completing lab 8, you will know how to: 

 Use the Bridge Menu to set active attributes (level, color, line style, 
weight). 

 Use basic drawing tools (AccuDraw, AccuSnap, Modify and 
Manipulation tools, cells, patterns, etc.) to draw a bridge typical section 
and a reinforcement detail. 

 Use Fences and Selection Sets to group graphics. 

Asphalt

Girder

Bridge rail 

Bridge slab
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Create a Bridge Model file for details 
Note: Since you have already selected xxMulti-Discipline from the 

Select Group utility, you have access to all Bridge levels. 
However, you could also select the Bridge Group before starting 
MicroStation to limit your levels to just those needed for Bridge. 

1. Start MicroStation. 

2. In the MicroStation Manager dialog box, re-set Project to 12345. 

3. set the directory path to \Bridge\Drawings\Reference_Files. 

4. Select the file 12345BRDG_Model.dgn and then select OK. 

 

The blank model file opens. 

5. Select File > Save As… and set the directory to the project’s 
\Bridge\Working folder. 

6. Rename the file CU12345BRDG_Detail.dgn and select OK. 

Note that you are renaming this file from “Model” to “Detail”.  

 

The file is copied to the working folder with the initials CU (CDOT 
User, for training purposes). 
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7. Select Settings > Design File > Coordinate Readout and set the 
Format to Working Units. 

 

8. Select OK to change the coordinate readout. 

You will now readout values in feet and inches. 
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Draw a bridge typical section 
In the next series of steps, you’ll use AccuDraw and MicroStation tools 
(drawing tools, manipulation and modify tools, grouping tools, etc.) to create the 
bridge typical section shown. 

You’ll begin by drawing construction lines on a drafting level, and then create 
the final detail on the appropriate bridge level. 

Draw the slab construction lines 
You’ll draw the right side of the top of slab starting at the crown point of 
the road. The right side consists of a 12 ft. travel lane and a 6 ft. 
shoulder, both at a 2% cross slope. 

1. On the CDOT Menu Drafting group, select Linework category. 

2. Set the filter to WT and select Weight 1. 

 

This sets the active level to DRAFT_WT-1. 

3. <D> anywhere to place the first point. 

4. Make sure your AccuDraw compass is in Rectangular mode. If not 
press <spacebar>. 

5. In the SmartLine Tool Settings box, make sure Rotate AccuDraw to 
Segments is turned off. 

  

This will keep the X axis horizontal as you draw SmartLine segments. 
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6. Move your cursor down and to the right to establish the direction of the 
SmartLine. 

7. In AccuDraw, key in 12 for X, then <TAB>. 

8. In AccuDraw, key in 12*.02 for Y, then <TAB>. 

9. <D> to place the first SmartLine segment. 

10. Zoom In if needed to see the line. 

Note: Do not reset out of the SmartLine command. This will break the 
SmartLine, which you do not want to do. You want the top slab 
line to be all one element. 

 

This creates the 12 ft. travel lane at a 2% slope. 

11. For the next shoulder segment, move your cursor down and to the right 
to establish the direction of the SmartLine. 

12. In AccuDraw, key in 6 for X, then <TAB>. 

13. In AccuDraw, key in 6*.02 for Y, then <TAB>. 

 

14. <D> to place the second SmartLine segment. 

This creates the 6 ft. shoulder at a 2% slope. 

15. <R> out of the SmartLine command. 
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Create the bottom slab construction line 
Vertically copy the top slab line down 8 inches for the bottom of slab on the 
right side. 

1. Select the Copy command from the Manipulate toolbar. 

 

2. AccuSnap on the right end of the top slab to identify the element to 
copy. 

3. Move your cursor down and lock on to the –Y AccuDraw axis to 
establish the copy direction. In AccuDraw, key in :8 for Y and the press 
<TAB> to accept the entry. The value converts to 0.667 feet. 

Notes: Don’t forget to key in the colon before the 8 to specify 8 inches.  

You can also use .. instead of a colon to specify inches  
(e.g. ..8 for 8 inches) 

 

4. <D> to place the copy, then <R> to complete. 

Create the slab left side 
Since the right and left sides of the road are symmetrical, you can mirror 
the right side to create the left side. 

1. Select the Place Fence command from the Fence toolbar and set the 
Tool Settings as shown. 
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2. Place a fence around the slab graphics (<D> for upper left corner and 
then <D> for lower right corner). 

 

3. Select the Mirror command from the Manipulate toolbar: 

 Set Mirror About to Vertical. 
 Toggle on Make Copy. 
 Toggle on Use Fence and set to Inside. 

 

4. <D> on the left endpoint of the upper slab line (the crown point) for the 
mirror copy. 

 

 

5. <R> when done. 

6. Select the Place Fence command again to remove the fence. 

7. Fit the view. 

Fence 
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Place the girders 
1. On the CDOT menu, select the Bridge Group. 

 Set the Category to Bridge Levels 
 Set the Type to Basic 
 Select the Outline item 

This changes the active level from a DRAFT level to the BRIDGE_OUTLINE 
level for placing the girders. 

 

2. On the CDOT menu, select the Bridge Group. 

 Set the Category to Cells 
 Set the Type to Girders-BT 
 Select the BT54 item 

3. On the CDOT menu, select the Settings button 

 Set Active Scale to 1. 
 Set Active Angle to 0. 

This automatically selects the correct girder cell from the bridge cell 
library and activates the Place Cell command. 

4. With the girder cell attached to your cursor, hover over right endpoint of 
the bottom slab line (don’t AccuSnap, just hover and lock on to the 
point). 

 

5. Click into the AccuDraw box to set it active and press the letter O on the 
keyboard to move the AccuDraw compass origin to this point. 

 

Hover here
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6. Move you cursor to the left to establish the placement direction, and key 
in 3:6 in the X field. 

 

7. With your cursor locked on the X axis <D> to place the girder cell. 

 

This places the first girder 3 ft. – 6 in. from the right side of the slab. 
You’ll later move the girder down for the proper haunch depth. 

Place additional girders 
Copy the girder cells to space them 7 ft. 3 in on center. 

1. Select the Copy command. 

2. In the Tool Settings box, key in 4 for the number of copies. 

 

3. Click into the AccuDraw window to set it active. 

4. <D> on the girder at the top midpoint. 
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5. Move your cursor to the left to establish the copy direction and key in 
7:3 in the X field in AccuDraw. 

 

6. With your cursor locked on the X axis, <D> to place the copies. 
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Move the girders down to establish the haunch depth 
1. Select the Move command from the Manipulate toolbar. 

 

2. Click into the AccuDraw window to set active. 

3. <D> on the right end girder at the top midpoint for the move from 
location. 

4. Move your cursor up and lock on the Y axis to establish the direction, 
then press <Enter> on the keyboard. 

 

By pressing <Enter> you “smartlock” the AccuDraw X and Z axes, so 
that you can only move in the Y direction. 

   

X and Z axis 
“smartlocked” 
so that you can 
only move in Y 



Colorado Department of Transportation 

Page 348  CDOT MicroStation Essentials 

5. Press N on the keyboard for the Nearest snap mode. 

6. Hover over (do not data point) at the nearest snap point on the bottom 
slab line. 

 

Press the letter O on the keyboard to move the AccuDraw origin to this point. 

 

7. Move your cursor down to establish the move direction, lock on to the  
-Y axis and key in :4 in the AccuDraw Y field. 
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8. <D> to move the girder. 

 

This moves the girder down 4 inches from the bottom of the slab for the 
correct haunch thickness. 

9. Repeat the above steps to vertically move the remaining girders down 4 
inches from the bottom of the slab. 

 

Place the Bridge Rail 
1. On the CDOT menu, select the Bridge Group. 

 Set the Category to Bridge Rail 
 Select the Rail Type 7 item 

2. AccuSnap on the left end of the top of slab as shown. 

 

4” 



Colorado Department of Transportation 

Page 350  CDOT MicroStation Essentials 

3. For the right-side rail, select the Place Active cell again. 

4. In the Tool Settings box, unlock the axes and set the X scale to -1. 

 

Note: -1 X-axis scale will mirror the cell about the X axis. 

5. Place the cell as shown. 

 

6. <R> when done. 

Click to unlock 
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Extend elements 
Extend the slab lines to join up with the bridge rail. To do this, you’ll need to 
drop the bridge rail cell to its original elements. 

1. Select the Drop command from the Groups toolbar. 

 

2. Select Drop Element, and toggle on Complex (the cell is considered a 
complex element). 

3. <D> on the right-side bridge rail cell. 

The cell is dropped to its original elements. 

4. Select the Extend Elements to Intersection from the Modify toolbar. 
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5. <D> on the bottom slab line and then <D> on the back of rail line to 
extend these elements. 

 

6. Repeat the above steps for the right side. 

Draw the slab 
1. With the active level set to BRIDGE_OUTLINE, select the Place 

SmartLine tool. 

2. Click in the AccuDraw window to set it active. 

3. Starting on the left side, AccuSnap on the bottom of the bridge rail. 

You want the next point to be 1” below the left-top of the first girder. To 
do this, you’ll need to move the AccuDraw origin to the top of the girder 
and then locate 1” down. 

4. Hover over the left-top of the girder as shown, click in the AccuDraw 
box and press the letter O on the keyboard to move the AccuDraw origin 
to this point. 

 

AccuSnap 
here to start
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5. Move your cursor down, lock on the Y axis and key in a value of :1 (1 
inch). 

    

6. <D> to place the SmartLine segment. 

7. AccuSnap on the left-top of the girder as shown. 

  

Note: Remember, if you make a mistake, Undo the last data point, 
don’t reset out of the SmartLine command. 

8. AccuSnap on the right-top of the girder as shown. 

 

 

9. Move your cursor up, lock on to the Y axis and press <Enter> to 
smartlock the axis. 

You can now only move in the Y direction. 

10. Press N on the keyboard for the nearest snap point. 

 

 

11. <D> on the bottom slab line as shown. 
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12. Hover over the next girder’s top-left endpoint as shown. 

 

13. Press O on the keyboard to move the AccuDraw origin to this point (do 
not data point). 

14. Move your cursor up, lock on to the Y axis and press <Enter> to 
smartlock the axis. 

15. Press N  for the nearest snap point. 

16. <D> on the bottom slab line as shown. 

 

17. <D> on the top left girder edge as shown. 
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18. Continue these steps on each girder to place SmartLine segments as 
shown until you get to the last girder location shown below. 

 

Remember to Undo, not reset, if you make a mistake on a segment. 

19. On the last girder (far right), move your cursor down, lock on to the Y 
axis and key in a Y value of :1 (1 inch). 

20. <D> to place the point. 
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21. <D> on the right end of the bottom slab line. 

 

22. Reset out of the Place SmartLine command. 

23. Select the Extend Element to Intersection tool from the Modify toolbar. 

 

24. <D> on the blue top of slab line and then <D> on the back of bridge rail 
line to extend these elements. 

 

 

25. Repeat for the left side. 

26. Delete the blue bottom of slab lines. 
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27. Fit the view. 

 

 

Create the top of pavement 
1. Fit the view. 

2. Select the Copy command. 

3. <D> on the right-side top slab line (blue construction line) at the crown 
point to select it for copying. 

Note: If you select the bridge slab shape (red element), <R> until the 
top slab line highlights. 

4. Move your cursor up and lock-in on AccuDraw’s Y axis. 

5. In AccuDraw, key in a Y value of :3 (3 inches). 

 

6. <D> to copy the top slab line. 

7. Repeat for the left side. 

Note: You can move your cursor up and lock in on the last distance tic 
mark of 3 inches, eliminating the need to key in the Y value. 
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8. On the CDOT menu, select the Bridge Group. 

 Set the Category to Bridge Levels 
 Set the Type to Outline 
 Select the Outline-Asphalt item 

This sets the active level to the asphalt level. 

9. Change the top of pavement lines to the active asphalt level. 

 

 

Clean-up lines at the rails 
You now need to trim the top of pavement lines that run through the bridge rails, 
as well as the bottom of the rail that extends below the top of slab.  

1. Select the Trim command from the Modify toolbar. 
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2. Follow the prompts and <D> on the vertical edge of the rail to select it as 
the cutting element. 

3. <D> on the top of pavement line inside the rail as the portion to trim. 

  

4. <D> to accept. 

 

5. Repeat the above steps for the left-side rail. 

Cutting element

Portion to trim 
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Complex the bridge rail graphics 
Since you dropped the bridge rail cell to trim the graphics, it is no longer 
one entity. Instead it was dropped to individual lines. You will now 
group the lines into a complex chain. 

1. Select the SmartMatch command and <D> on any red bridge line to 
match it. 

 

This sets the active level to Bridge_Outline to match the slab. 

 

2. Select Create Complex Chain from the Groups toolbar. 

 Set the Method to Automatic. 

With the Automatic method, you do not have to individually identify 
each element to add to the complex chain. The elements are found 
automatically within a maximum gap range. 

 Toggle on Simplify Geometry. 

 

Note: Simplify geometry will make the new element a SmartLine 
instead of a complex element. 

3. <D> on the first segment of the bridge rail as shown. 
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4. <D> anywhere above this element to define the direction for adding 
elements. 

The remaining bridge rail elements are added to the chain and place on 
the active Bridge_Outline level. 

5. <D> to accept. 

Note: With some MicroStation commands (like the Complex Chain 
command), if you hover over the complex element it will still 
show you the individual elements that make up the chain. 
However, notice that pop-up information tells you it really is a 
complex chain. When you use the Copy command in the next 
step, you’ll see the chained elements behave as one element. 

 

6. Select the Copy command from the Primary toolbar and copy the bridge 
rail to a clear area of the design file. 

 

Note the individual graphics are now chained together into one element. 

7. Undo the copy. 

Note: You can use the Create Complex Shape in a similar fashion to 
create closed shapes from individual graphics. 
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Create a Selection Set of the Bridge Section 
1. Fit the view. 

2. Choose the Element Selection tool from the Main toolbar. 

3. Hold down the data button <D> and drag across the bridge section 
(corner to opposite corner). Be sure to include all of the section graphics 
in this area. 

Notes: The elements are added to the selection set and are highlighted 
purple (the selection set color). To change the color, choose 
Settings > Design File > Color > Select Set Color.  
 
The lower right corner of the status bar shows how many 
elements are now in the selection set. 

4. <D> in the center of the typical section, hold down the data button and 
drag the selection set to a new location in the file. 

5. Drag the select set back to its original location. 

6. <D> anywhere in a clear area of your design file to remove the selection 
set. 

The selection set is a temporary group of graphics until you drop the set. 

Create a Graphic Group of the Bridge Section 
1. Use the Element Selection and place the bridge typical section graphics 

into a selection set again. 

2. From the Groups toolbar, select Add to Graphic Group. 

 

3. <D> to accept the selection set element to add to the group. 

4. <R> out of the command. 

5. <D> anywhere in a clear area of your design file to remove the selection 
set. 

The elements “un-highlight” and return to their normal symbology. 
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6. On the status bar, check your locks and make sure Graphic Group lock 
is on. 

 

7. Select the Move command. 

8. <D> on the bridge typical section graphics. 

All elements in the graphic group highlight. 

9. Move the graphics and a new location and <D> to accept. 

With Graphic Group lock on, the elements behave as a group. 

10. On the status bar, turn the Graphic Group lock off. 

11. Select the Move command again. 

12. <D> on one of the BT 54 girders. 

Only the girder highlights. 

13. Move it to a new location and <D> to accept. 

 

With the Graphic Group lock off, you can manipulate the individual 
elements in the group. 

14. Undo the Move command on the girder. 

15. Turn the Graphic Group lock back on. 

16. Move the bridge typical section graphics back to their original location. 
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Note: When working in design model files, most InRoads graphics are 
displayed as graphic groups (e.g. contours, profiles, cross 
sections). 

Pattern pavement and slab 
1. Fit the view. 

2. On the CDOT menu, select the Bridge Group. 

 Set the Category to Bridge Levels 
 Set the Type to Basic 
 Select the Pattern item to set the active level 

 

3. From the CDOT Menu Explorer: 

 Select Drafting. 
 Set the category to Patterning. 
 Select the Concrete item. 
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4. In the Pattern Area Tool Settings box and set the Method to Flood,  
Active Scale to 1 and the Active Angle to 0.   

 

5. Make sure the entire region to flood is shown in your view. Then, <D> 
anywhere inside the bridge slab region.  

The region to flood with the pattern highlights. 

  

6. <D> to accept. 

The shape is patterned with the concrete cell. 

 

Flood Method
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7. Select the Hatch Area command from the Patterns toolbar. 

 

8. In Tool Settings, select the Flood method, set Spacing to :3 and the 
Angle to 45. 

 

9. <D> anywhere inside the pavement area. 

A dynamic display shows the flooded area. 

 

10. <D> to accept. 

The region is flooded with the hatch pattern. 

 

11. Save Settings. 

12. Exit MicroStation.
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9.  Creating Sheets 
Roadway Design group 

Plan or Plan/Profile sheets 
The Design group’s sheet file workflow is covered in detail in Chapter 4, The 
CDOT workflow. The following is a summary of the Design group’s Plan or 
Plan/Profile sheet workflow: 

 Create a new MicroStation design file for each sheet.  
 Reference into the sheet file the proposed model file with the 

Survey/Topo model file nested. 
 Rotate the view, if needed, so graphics appear horizontal.  
 Clip the references to show only what graphics are needed for the sheet.  
 Place the he border, north arrow, bar scale and resident engineer 

information cell directly in the sheet file. 
 Check the sheet file’s Model Properties and verify set the Annotation 

Scale to the sheet’s plot scale. The default for all sheet files except 
Typical Section sheets is 1:100. 

 Edit the border text as needed. 
 Annotate with MicroStation text. 
 Dimension reference graphics, if desired. 

 

Note: InRoads Plan/Profile Generator automates this process and can 
quickly generate a set of sheets along an InRoads alignment. Use 
the above workflow for special situations (approach roads, 
intersections, etc.) or where just a few sheets are needed. 
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Typical Section sheets 
Typical Section sheets are an exception to the rule, since graphics are created 
directly in the sheet file using the CDOT Typical Section Program. Use the 
following workflow to create Typical Section sheets (an example is also 
provided in the lab exercises): 

 Create a new sheet file each sheet (you can use the auto-populated file 
JPC#DES_TyplSect##.dgn). 

 If you’re using the auto-populated file, it contains a generic border. You 
can either edit the border information, delete the generic border and place 
a project border, or replace the generic border cell with the project border 
cell using the Replace Cell command. 

 Check the sheet file’s Model Properties and verify set the Annotation 
Scale to 1:10. This is already set-up if you created your file from the 
auto-populated file. 

 Start the Typical Section Program (from the CDOT Menu select Add 
On’s > Launch Typical Section Program).  

 Use the program to create your Typical Section(s). Place the sections 
directly inside the sheet border.  

 Save the typical section input file from the Typical Section Program. 

Other sheets 
Other sheets like detail, title, general notes, etc. have specific requirements, but 
use the same general premise of referencing the model file(s) to the sheet file 
and are illustrated in lab exercises. 
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Specialty Groups 

Plan sheets 
The Specialty group’s sheet file workflow is covered in detail in Chapter 4, The 
CDOT workflow. The following is a summary: 

 The Specialty group creates a new MicroStation design file for each 
sheet.  

 Reference into the sheet file the Specialty group model file with the 
Design model and Survey/Topo model files nested. 

 Rotate the view, if needed, so graphics appear horizontal.  
 Clip the references to show only what graphics are needed for the sheet.  
 Place the he border, north arrow, bar scale and resident engineer 

information cell directly in the sheet file. 
 Check the sheet file’s Model Properties and verify set the Annotation 

Scale to the sheet’s plot scale. The default for all sheet files except 
Typical Section sheets is 1:100. 

 Edit the border text as needed. 
 Annotate with MicroStation text. 
 Dimension reference graphics, if desired. 
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Other sheets 
Other sheets like detail, tab, and notes sheets have specific requirements which 
are illustrated in lab exercises. 

More Information 
For more information on creating sheet file, see CDOT Workflows Sheet File 
Creation, Sheet File Creation Multiple Scales, Creating Multiple Plan 
Sheets, Note Sheets, and Title Vicinity Map. 

 

See also the CDOT CADD Manual, Chapter Eight – Drawing Information, 
Section 8.4 Project Sheets. This contains several useful links for sheet 
workflows. 
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Rotating Views 
It is often necessary, especially with highway design projects, to rotate a plan view 
so that the alignment is horizontal to the view.  This is especially useful when 
creating plan sheets.  You can accomplish this using the following methods. 

Rotate the Plan View with a Keyin 
If you know the degree of rotation, you can rotate the view using the rv= keyin 
(rv=X axis rotation, Y axis rotation, Z axis rotation). 

Rotate the Plan View by 3 Points 
Use this method to define a view’s new positive horizontal (X) axis and new 
positive vertical (Y) axis. The first two data points define the view’s new X axis 
and the third data point defines the direction for rotation. 

 

Rotate the Plan View by Element 
You can use the direction of an element to rotate a view so that the view is 
horizontal to the element (e.g. a horizontal alignment). Key in Rotate View 
Element and then <D> on the element to rotate the view. 

Note: The view is rotated based on the direction the element was 
drawn.  The positive X axis is based on the positive direction of 
the element. 
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Placing Borders 

Using the CDOT Menu for Border Placement 
The Border and Border RE Categories under Drafting on the CDOT Menu 
provide a convenient method of placing the border and related information in a 
sheet file. 

  

You have the option of placing different types of border cells, as well as other 
cells for the bar scale, north arrow and resident engineer. 
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Creating a Project-Specific Border Cell 
If you use the generic border in the auto-populated sheet files, or if you place a 
border cell in a sheet file using the CDOT Menu or the Place Active Cell 
command, then you will need to edit the border to specify all of the project-
specific information for every sheet. This can be a time-consuming process. 

Instead, you can create a project-specific border cell. Place the cell in a blank 
file, and then edit the cell text to fill in all of the project information (number, 
code, initials, etc.). You can either place this border in a blank sheet file, or 
replace the generic border cell with the project border cell in the auto-populated 
file. MicroStation’s Replace Cell command is handy for this. 

 

Editing text on the Border 
Text in the border cell can be edited using the Edit Text command on the Text 
toolbar. Select the text to edit, key in the new text in the Text Editor window, 
and then <D> to accept the edit. 
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Note: If you place the border cell as a Shared Cell, you must first drop 
the cell status to a regular cell if order to edit the cell text. 
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Measurement Tools 

 

The Measure toolbar is used to measure distances, angles, radii and areas.  Use 
Settings > Design File > Coordinate Readout to define how measurement 
values will display (units, precision, etc.). If you reference your model file 
graphics into your sheet file at 1:1, you can measure graphics in the sheet file 
with accurate results. Otherwise, you’ll need to measure graphics in the model 
file. 

Measuring in 3D 
Important! In a 3D file, if you want planar measurements, turn on Depth lock 
before using the appropriate measure command. Make sure AccuSnap is off if 
you’re snapping to points when measuring in 3D. Use Tentative snaps instead. 

If you want true slope(3D) measurements, turn Depth lock off. 
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Some of the more commonly used measuring tools include: 

Measure Distance 
Measures distance using one of the following methods: 

     

 Between Points 
 Along Element 
 Perpendicular 

Note:  This command locks on the element’s depth you are measuring 
perpendicular from to start the measurement.  If you want a 
horizontal measurement (2D measurement in a 3D file), you 
must first set the Active Depth to the depth of the element and 
make certain Depth lock is on. 

 Minimum Between. 

Measure Radius 
Measures the radius of a circle or an arc, or a circular segment of a complex 
chain or shape, or the primary and secondary axes of an ellipse. 

 

Measure Angle 
Measures the angle between two lines or linestrings, or the angle between two 
segments of a shape. 

 

Measure Length 
Measures the length of an element or the perimeter of a shape. 
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Measure Area 
Measures area using the same method options as the Pattern tools. This includes 
the area of a shape (Element method) or an area you dynamically define using 
the Points method.  In addition, you can Flood an area or measure the area of the 
Intersection, Union or Difference between elements (see Pattern commands 
for an explanation of these methods). 

     

Note: If you’re measuring the area of 3D graphics, the Points method 
is the only method that will provide a planar measurement with 
Depth lock turned on. 
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The CDOT Custom Measure XY Distance tool 
From the CDOT Menu, select Add On’s > Measure XY Distance to open this 
custom tool, which allows you to easily obtain both planar XY distances along 
with true 3D slope measurements without having to check or set active depth or 
the depth lock. You can use this tool the standard MicroStation Measurement 
tools for options shown below, including the Perpendicular from element 
option. 
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Lab 9A – Create a plan/profile sheet for the intersection 
Several plan/profile sheets have already been created by Design using the InRoads 
Plan/Profile Generator. However, there are times when you need to create special 
plan or plan/profile sheets not created by the Generator. In this case, you’ll create 
a plan/profile sheet for the side road that runs through the intersection. 

Objectives 
After completing this exercise you will know how to: 

 Create a sheet file using a generic project file. 
 Attach model files coincident-world 
 Attach model files as saved views. 
 Rotate the view to horizontal 
 Use the CDOT Menu to place a border and associated information (bar 

scale, north arrow, region cell, etc.) 
 Use the CDOT Menu to place a clipping boundary. 
 Clip references 
 Work with reference levels. 
 Move references 

Review Plan/Profile sheets 
Review the Plan/Profile sheets for this project previously created by the InRoads 
Plan/Profile Generator. 

1. Start MicroStation. 

2. In the MicroStation Manager, open 12345DES_PnP10.dgn from the 
project’s …\Design\Drawings folder. 
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The InRoads Plan/Profile Generator automates the creation of sheet files 
along the mainline alignment. This includes rotating the plan-view to 
horizontal, placing the corresponding profile, placing the border, north 
arrow and match lines. MicroStation references are used to bring in plan 
and profile graphics to the active sheet file. 

3. Use Level Display to review the reference levels on which plan and 
profile graphics are placed in the sheet file. 

 

Note that the only levels with graphics in the sheet file are sheet levels 
for the border, match line, north arrow, etc. 

4. Open other plan/profile sheets, as desired, from the Drawings folder and 
review the sheets. 

Create a new sheet file 
Since the InRoads Plan/Profile Generator did not create a sheet for the county 
cross road at the intersection, you’ll create this P&P sheet file manually. 

1. Select File > New. 

2. Set the directory to the project’s  \Design\Drawings folder. 

3. In the New box, make sure that the seed file is set to  
3D-Seed_CDOT.dgn. If not, pick the Select button and then select this 
file. 
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4. Key in the name 12345DES_PnP19.dgn. 

Nineteen is the next number in the plan/profile set of sheets. 

 

5. Select OK to create the file. 

Attach the Model file 
1. Select the Reference icon from the Primary Tools toolbar. 

2. In the References dialog box, select Tools > Attach. 

3. Use the Directory pull-down menu and select the   
C:\Projects\12345\Design\Drawings\Reference_Files folder and 
select the file 12345DES_Model.dgn 

 

4. Verify the Attachment Method is set to Interactive. Select OK.   
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5. In the Reference Attachment Settings box: 

 Key in a logical name of Design and Proposed 
Intersection for a Description.   

 Verify that Orientation is set to Coincident-World and the 
Scale is set at 1:1  

 Set Nested Attachment to Live Nesting and set Depth to 
1. 

 Turn off Display Raster References. 

 

6. Select OK. 

Note:  The Coincident World option ensures that references are 
attached with their true coordinate information.  
A scale factor of 1:1 ensures that plan graphics are referenced in 
actual size. These two options allow plan sheet graphics to 
maintain their true model coordinates and size.  

7. Turn on the Show Hierarchy and expand the hierarchy list. 

 

Note that with nested references, the Survey/Topo reference is nested 
below the Design model file. 
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Note: You can typically reference model files as nested to sheet files 
instead of using the Copy Attachment command (as in this 
case, you want to show both Design and Survey/Topo graphics 
in the sheet file). However, if you need to control individual 
references in the sheet file, then use the Copy Attachment 
command. 

8. Close the References dialog. 

9. Fit View using the icon so all graphics are displayed.  

10. Select File > Save Settings from the menu. 

Rotate the View using the 3-point method 
Rotate the view so that the side road appears horizontal in the view. 

1. Window around the intersection as shown. 

 

2. Select the Rotate View command and set the Method to 3 Points. 
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3. Follow your prompts and AccuSnap on the end of the PI leader line 
shown. 

4. For the second point (X axis of the view), AccuSnap POE leader line. 

5. For the third point (Y direction), <D> anywhere to the left of the first two 
points.  

 

The view is rotated so that the side road appears horizontal.  

 

Snap here 
for first point 

Snap here 
for second

point

<D> 
anywhere to 

the left for 
third point
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Note: Remember that you are rotating the view, not the graphics. The 
graphics maintain their original coordinate position in the sheet 
file.  
 

Note: The leader lines are both placed at elevation 0. If you pick points 
at different elevations, you’ll need to first turn on Depth lock 
before choosing the 3-Point rotation command to avoid a skewed 
rotation. 

Place the Border Cell 
1. Zoom out as shown. 

 

2. From the CDOT Menu Explorer, select Drafting and then select the 
Border category and choose the Border (PnP 11”x17”) Item. 
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3. Select Settings and set Active Scale to 100 and  
Active Angle to 0.     

 

Notes:  Coordinate with the Region Surveyor when you are creating 
sheets that are not at a 1:100 scale.  They will provide you with 
the topography and survey MicroStation files at a different scale.  
Otherwise, the line work and cells will not be the correct size for 
the print scale.      

The Active Angle is view independent and not associated with 
view rotation. Therefore, the x-axis is always horizontal 
regardless of the view rotation.  You will not need to set this for 
correct placement of the North Arrow or other cells. 

4. Select Apply and Close in the Active Settings box. 

5. When prompted to locate the cell origin of the sheet border, <D> in the 
approximate location shown to place it. Don’t worry about an exact 
location – you’ll move it in the next step. 

 

 

<D> here to place lower
left corner of border
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6. If necessary, use the Move command and move the border cell so that 
the intersection is centered in the upper plan portion as shown. 
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Placing a Clip Boundary 
1. From the CDOT Menu Explorer select Drafting.  

 Set the Category to Border 
 Select the Item Clip Boundary 
 Verify the SHEET_Clip-Boundary level is active. 

 

Note:  Since Plot is turned off for the level SHEET_Clip-Boundary in 
the Level Manager, it will not print. 

The Place SmartLine command is now automatically selected, allowing 
you to draw an irregular closed shape that represents your clipping 
boundary of the model file. However, if your clipping boundary is a 
rectangle, you can use the Place Block command.   

2. Select the Place Block icon from the Main toolbar and draw the clipping 
boundary as shown (corner to opposite corner on the blue inside margin). 

 

Snap here 
for first 
corner 

Snap here 
for opposite 
corner 
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Clip the Reference File 
1. In the References dialog box, highlight the Design reference. 

2. Select the Clip Reference icon. 

 

Note:  You can select more than one reference file at a time by holding 
the <Shift> or <Control> keys down while you are making your 
selection.  You can clip multiple drawings in one step when they 
are all selected.       

3. In the Tool Settings box, verify Method is set to Element. 

 

4. When prompted to Identify Clipping Element, <D> on the rectangular 
clipping boundary you just placed.  

5. <D> to accept. 

6. Fit the MicroStation view and Save Settings after clipping the reference 
files.  
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Note:  Once the clipping boundary is placed, do not delete it.  The 
clipping region of the reference file will be lost if the boundary is 
deleted. 

In the next Chapter, you’ll edit the border text to add project specific 
information.  

Turn off the profile grid and text 
1. Open the Level Display box and turn off the following levels: 

 SHEET_Grid 
 SHEET_Grid-Minor 
 SHEET_Grid-Text 

This turns off the border’s grid for the profile. You’ll use the grid 
provided by the InRoads profile. 

Attach the Design Profile 
1. In the References dialog box, select Tools > Attach. 

2. Use the Directory pull-down to navigate to the 
C:\Projects\12345\Design\Drawings\Reference_Files folder and 
select the file 12345DES_Prof03.dgn 

3. Verify the Attachment Method is set to Interactive. Select OK.   

4. In the Reference Attachment Settings box: 

 Set Orientation to Top 
 Key in a Logical Name of Profile Side Road and 

Proposed profile for side road as the Description. 
 Set Scale to 1:1 
 Set Nested Attachment to No Nesting. 

 

5. Select OK. 
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6. The outline of the profile reference is attached to your cursor. <D> in the 
approximate location shown to place the profile. 

 

Move the profile reference 
Since you attached the profile reference by a top view, it did not come in 
at a precise location.  Next, you’ll move the profile to line it up better 
with the plan. 

1. Turn on AccuDraw if it’s not already on. 

2. Highlight the Profile in the Reference dialog and select the Move 
Reference icon or select Tools > Move. 

 

 Click into the AccuDraw window to set it active. 
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 Snap to the left end of the vertical alignment (the first VPI) 
as the Move From point.                  

                       

 Move your cursor to the left along AccuDraw’s X axis to set 
the focus (blinking cursor) in the AccuDraw X field, then 
Press Enter. 

 

Note: The Enter key executes AccuDraw’s SmartLock.  It locks the Y 
and Z axes to 0 so you can only move in the X direction. 

 Move your cursor and AccuSnap on the end of the shoulder 
line as shown.  You can zoom in, if needed.  

 

The beginning of the vertical alignment is now aligned with the 
beginning of the horizontal alignment. 

Move From 
point

Move To
point
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3. <R> when done. 

4. Fit the MicroStation view. 

 

Place the bar scale, north arrow and RE cells 
Follow the steps on the next page and use the diagram below to place the 
various border cells. 

 

<D> here for 
bar scale

<D> here for 
north arrow

Snap here 
for RE cell



Colorado Department of Transportation 

Page 394  CDOT MicroStation Essentials 

1. From the CDOT Menu Explorer, select Drafting.  Set the Category to 
Border. 

2. Select the Item Scale Horizontal. 

 

3. When prompted to locate the cell origin of the Bar Scale. <D> inside the 
sheet border as shown in the diagram on the previous page. 

4. Select the Item North Arrow Standard 

 

5. When prompted to locate the cell origin of the North Arrow, <D> inside 
the sheet border as shown on the previous page. 
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6. Set the Category to Border RE. 

7. Select the Item Default. 

 

8. When prompted to locate the cell origin of the Region Engineer cell, 
Zoom in as necessary on the bottom portion of the border and <T> to the 
location shown in the previous diagram and then <D> to accept.   
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Turn on the reference display 
1. On the References dialog, select the Survey/Topo reference nested 

under the Design Reference. 

2. Toggle on Display for the Survey/Topo reference. 

3. Use Level Display to turn on all Survey/Topo levels. 

4. Fit the view. 

 

5. Save Settings. 

Optional exercise 
Change the Design reference’s nested depth to 2 and turn on the display 
of the contour reference – 12345SURV_Contour100.dgn. Use Level 
Display to turn on the contour levels to display the existing contours in 
the plan sheet.  
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Lab 9B – Create a project specific border 
In the last section, you placed a generic border for your plan/profile sheet from 
the CDOT menu. This is handy when you have only one or two sheets to create 
since you have to edit the border with project specific information for each 
sheet. But what if you had several sheets to create? You wouldn’t want to edit 
every sheet to add the project information. Instead, you can create a project-
specific border that can be used for all sheets of the same type. This way, you 
only have to fill in the project information one time. 

Objectives 
After completing this exercise you will know how to: 

 Create a project-specific border cell library. 
 Use the CDOT Menu to place the border and associated information. 
 Edit the border text to place project-specific information. 
 Make the border graphics a cell. 

Create the border file 
Since you will use this border for multiple sheets, create one project border to 
avoid editing multiple borders later. 

1. In MicroStation Manager, select File > New. 

2. Set the directory to C:\Projects\12345\Miscellaneous. 

3. Verify the Seed File is set to 3D-Seed_CDOT.dgn, if not then select it 
as the seed file. 

4. In the Name field, key in a drawing file name 
12345DesignPlanBorder.cel. 

Note: The .cel extension denotes this file as a cell library. 

5. In the New dialog box, select OK.  

 

6. The file you created will be highlighted. Select OK to open that file. 
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Use the CDOT Menu to create the border 
1. From the CDOT Menu Explorer, select Drafting and set the Category to 

Border. 

2. Select the Item Border (Plan 11”x17”) 

 

3. Select Settings and set Active Scale to 1 and Active Angle to 0.     

 

Note:  You will create the generic project border cell at a scale of 1  
(11 x 17 master units). You’ll actually scale the border, 
according to your plot scale, later when the cell is placed in the 
sheet file. 

4. Select Apply and Close in the Active Settings box. 

5. <D> to place the border anywhere in the blank file. 
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6. Set the Category to Border RE. 

7. Select the Item Default. 

 

8. When prompted to locate the Region Engineer cell, <T> to the location 
shown and then <D> to accept. 

9. Fit the view. 

 

 

Note: You will not place the bar scale and north arrow cell now, but 
later in each individual sheet. 

 

Snap here 
for RE cell
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Move the border 
The lower left corner of the border must be located at the 0,0 coordinate 
in the file since this will be the origin of the cell. So, move it to this 
location. 

1. Place a Fence block around the entire border. 

2. Select the Move command and toggle on Use Fence.  Set the mode to 
Inside. 

 

3. Snap to the lower-left corner of the yellow block (outside edge) as the 
move from point. 

 

4. Key in xy=0,0 as the move to point. 

The border moves to the new location. 

5. Reset <R>. 

6. Fit the view. 

7. <T> on the lower-left edge to verify it’s at 0,0. 

 

Move From 
point
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Edit the border text with project specific information 
1. Zoom in on the lower-right corner of the border as shown. 

 

2. Select the Edit Text command from the Text toolbar. 

 

3. <D> on the Project Number text. 

4. In the Text Editor, replace this with STA 086A-039. 

 

5. <D> anywhere to accept. 

6. <D> on the Code text. 

7. In the Text Editor, replace this with 12345 and <D> to accept. 

8. Edit the X’s beside Designer and replace with your initials (CU is used in 
the illustration, but you can use yours). 

9. Edit the X’s beside Detailer and replace with your initials. 

 

10. Fit the view. 
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Make the border a cell 
1. Select Models from the Primary toolbar. 

 

2. In the Models dialog box, select Edit Model Properties. 

3. In the Model Properties box: 

 Toggle on Can be placed as cell. 
 Change the Name to 12345 Design Plan Border. 
 Change the Description to Project Border Cell. 
 For Ref. Logical key in Plan Border. 
 Leave all other options as shown 

 

4. Select OK. 

5. Close the Models box. 

6. Save Settings (File > Save Settings). 

7. Exit MicroStation. 

Edit Model 
Properties
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Lab 9C (Optional) – Create a 40-scale plan sheet 
The CDOT default scale for plan sheets is 100. This lab illustrates how to create a 
special 40-scale plan sheet for the intersection. 

Objectives 
After completing this exercise you will know how to: 

 Create a Plan sheet 
 Scale the border for a 40-scale drawing 
 Set the Annotation Scale to match the border and plot scale. 

Open the model file  
1. Start MicroStation and open 12345DES_Model.dgn form the project’s 

\Design\Drawings\Reference_Files folder. 

2. Select File > Raster Manager and turn off the display of the raster files. 

3. Fit the view. 

 

4. Window around the intersection as shown. 
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Determine the rotation angle for the sheet 
1. On the CDOT Drafting Menu, set Line Weight to 3. 

2. Using AccuDraw, draw temporary horizontal line in the approximate 
location shown. 

 

3. Select the Measure Angle command from the Measure toolbar. 

 

4. <D> on the horizontal line, then <D> on the SH86 proposed centerline. 

 

MicroStation displays the result as approximately 15 degrees. This is the 
rotation angle needed to rotate the view to horizontal at the intersection 
in a counter-clockwise direction.  

5. Delete the temporary measurement line. 

Horizontal line 
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Place the plan limits cell 
1. Select Cells form the Primary toolbar to open the cell library. 

 

2. Toggle on Display All Cells in Path and select the SHEET_Design-Plan-
Limits cell and make it the active placement cell. 

 

Note: This cell helps to define the plan sheet limits in the model file 
before placing the border in the sheet file. It contains text 
characters that can be edited to indicate sheet name, rotation, & 
scale. The outer line-work depicts the maximum display limits 
for graphics as it relates to the border sheet. The inside shape 
reflects ½ inch inside this maximum limit and is the clipping 
boundary. All graphical information for this cell is on to the 
MicroStation level, DRAFT_INFO_No-Plot. 

3. Close the Cell Library dialog box. 

4. Turn on the level DRAFT_INFO_No-Plot if it is not currently on. 

5. Select the Place Active Cell command and set the Active Angle to -15 
and the Scale to 40. 
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Notes: The scale should be set to the plot scale of the sheet. 
 
Since the positive angles are measured counterclockwise in 
MicroStation, enter the 15 degree angle as negative. 
MicroStation converts this to a positive 345 degree angle. 

6. Place plan limit cell in the approximate location shown. 

 

7. Select the Edit Text command and <D> on the text at the bottom of the 
cell. 

   

8. In the Text Editor, make the edits as shown. 

 

9. <D> anywhere in the view to accept. 
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Create the drawing file 
1. From the MicroStation Manager, select File > New. 

2. Set the directory to C:\Projects\12345\Design\Drawings. 

3. Verify the Seed File is set to 3D-Seed_CDOT.dgn, if not then select it 
as the seed file. 

4. In the Name field, key in a drawing file name 12345DES_Plan21.dgn 

5. In the New dialog box, select OK.  

6. The file you created will be highlighted. Select OK to open that file. 

Attach the Model file 
1. Attach the 12345DES_Model.dgn reference form the 

C:\Projects\12345\Design\Drawings\Reference_Files folder (Use 
the Directory pull-down to quickly find the folder). 

2. Verify the Attachment Method is set to Interactive. Select OK.   

3. In the Reference Attachment Settings box: 

 Key in a logical name of Design and Proposed 
Intersection for a Description.   

 Verify that Orientation is set to Coincident-World and the 
Scale is set at 1:1  

 Set Nested Attachment to Live Nesting and set Depth to 
1. 

 Turn off Display Raster References. 

4. Select OK. 

5. Fit the view. 
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6. Turn on the Show Hierarchy and expand the hierarchy list. 

 

Note that with nested references, the Survey/Topo reference is nested 
below the Design model file. 

The Survey/Topo file that is attached nested to the Model file is for a 
100 scale plot. However, you’re creating an intersection sheet at a 40 
scale. Therefore, you need to attach the correct scale Survey/Topo 
reference. 

Note: Coordinate with the Region Surveyor when you are creating 
sheets that are not at a 1:100 scale.  They will provide you with 
the topography and survey MicroStation files at a different scale.  
Otherwise, the line work and cells will not be the correct size for 
the print scale. 

7. Select the Design model reference and change the nesting to No Nesting 
to remove the 100 scale Survey/Topo reference. 
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8. Attach the 12345SURV_Topo40.dgn file from the project’s 
\ROW_Survey_Drawings\Reference_Files folder with the options 
shown. 

 

9. Fit the view.  

Rotate the View  
Rotate the view so that the portion of the mainline alignment through the 
intersection appears horizontal in the view. 

1. Window around the intersection as shown. 

 

2. Use the Rotate View, 3-Point method to rotate the view so that the plan 
limits cell is horizontal to the view 
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Note: You can also use the keyin rv=,,15 since you know the rotation 
angle from the plan limits cell. The commas are used as 
placeholders since you are not rotating about X and Y axis. You 
are only rotating about the Z axis – the perpendicular axis to the 
Top View. 

 

The view is rotated so that the alignment appears horizontal. 

Note: Remember that you are rotating the view, not the graphics. The 
graphics maintain their original coordinate position in the sheet 
file. 

Attach the Border Cell 
1. Select Cells from the Primary toolbar. 

2. In the Cell Library dialog box, select File > Attach and navigate to the 
C:\Projects\12345\Miscellaneous folder. 

3. Select the 12345DesignPlanBorder.cel file. 

 

This is the project-specific border created earlier. 



 Creating Sheets 

 

CDOT MicroStation Essentials  Page 411 

4. Select OK to attach the cell library. 

 

The cell library only has one cell (model) – the 12345 Design Plan 
Border that you previously created. 

5. Select Placement to make the border the active placement cell. 

6. Close the Cell Library dialog box. 

Place the border 
1. Select Place Active Cell from the Cells toolbar. 

2. In the Tool Settings box, set Active Angle to 0 and the Active Scale to 
40 for X, Y and Z. 

 

Note:  The Active Angle is view independent and not associated with 
view rotation. Therefore, the x-axis is always horizontal 
regardless of the view rotation.  You will not need to set this for 
correct placement of the North Arrow or other cells. 
 
The Active Scale scales the border up 40 times around the full-
sized graphics to match the plot scale. 
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3. AccuSnap on the lower left corner of the plan limits cell as shown to 
place the border. 

 

 

AccuSnap
here to place

the border
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Place the Clip Boundary 
1. From the CDOT Menu Explorer select Drafting. 

2. Set the Category to Border. 

3. Select the Item Clip Boundary . 

4. Select the Place Block icon from the Main toolbar and draw the clipping 
boundary by snapping on the opposite corners of the plan limits cell as 
shown (interior most line). 

 

 

Clip the Reference File 
1. In the References dialog box, highlight both the Design and 

Survey/Topo references for clipping. 

2. Select the Clip Reference icon. 

 

Snap here

Snap here 
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3. In the Tool Settings box, verify Method is set to Element. 

4. When prompted to Identify Clipping Element, select the rectangular 
clipping boundary you just placed.  

5. <D> to accept. 

6. Fit the MicroStation view and Save Settings after clipping the reference 
files.  

 

Note:  Once the clipping boundary is placed, do not delete it.  The 
clipping region of the reference file will be lost if the boundary is 
deleted. 



 Creating Sheets 

 

CDOT MicroStation Essentials  Page 415 

Place the bar scale and north arrow 
1. From the CDOT Menu Explorer, select Drafting. 

2. Set the Category to Border. 

3. Select the Item Scale Horizontal. 

 

4. When prompted to locate the origin of the Bar Scale, <D> inside the 
sheet border as shown on next page. 

5. Select the Item North Arrow Standard. 

 



Colorado Department of Transportation 

Page 416  CDOT MicroStation Essentials 

6. When prompted to locate the North Arrow, <D> inside the sheet border 
as shown.  

 

Set the Text Scale Factor 
Set the Text Scale Factor to match the border and plot scale factors. 

1. Select Models from the Primary toolbar. 

2. In the Models box, select Model Properties. 

Note the Annotation Scale is set to 1:100 – the CDOT default. 

3. Change the Annotation Scale to 1:40. 

 

4. Select OK. 

Bar scale

North arrow 
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5. At the Alert message, select Yes to propagate the changes. 

6. Close the Models box. 

The Annotation Scale for the file now matches the border and plot 
scales. Later, when text and dimensions are placed in this file, they will 
be the correct size. 

 

Edit the Bar Scale 
1. Window in to the bar scale cell. 

2. Select the Edit Text command from the Text toolbar. 

3. <D> on the X’ text on the bar scale. 

4. Change the text to 20’ and <D> to accept. 

 

5. Make the other edits as shown. 

 

6. Fit the view. 

7. Save Settings. 

8. Exit MicroStation. 
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Lab 9D – Create a Typical Section Sheet 
Normally, all graphics are created in the model file and referenced to the sheet file. 
The sheet file contains the border, annotations and dimensions. However, typical 
section sheets are an exception to this rule. 

Roadway Design typical sections can be created with the CDOT Typical Section 
Generator Program. The Generator Program not only creates the graphics, but it 
also annotates and dimensions the typical section. It uses a Text Scale Factor of 10 
for all text. Therefore, the program must be run in a sheet file set up at a 10 scale. 
The auto-populated file JPC#DES_TyplSect##.dgn is automatically created with 
the text scale factor set to 10 and the border placed at a 10-scale. Therefore, run the 
Typical Section Generator in the sheet file. 

Objectives 
After completing this exercise you will know how to: 

 Create a Typical Section sheet. 
 Attach a project-specific border cell library. 
 Use the Replace Cell command to replace a generic border with a 

project border. 
 Use the CDOT Typical Section Program to automatically create a 

typical section based on input values. 
 Use AccuDraw and “SmartLock” to align graphics. 
 Save the typical section input file. 

Create a new sheet file 
1. Start MicroStation and open the file 12345DES_TyplSect##.dgn from 

the \12345\Design\Drawings folder. 

 

The file opens and contains the generic border. 
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2. Select File > Save As… and rename the file to 
12345DES_TyplSect01.dgn and select OK. 

The file is copied to the Drawings folder with the new name. 

Attach the border cell library 
1. Select Cells from the Primary toolbar. 

2. In the Cell Library dialog box, select File > Attach and navigate to the 
C:\Projects\12345\Miscellaneous folder. 

3. Select the 12345DesignPlanBorder.cel file. 

This is the project-specific border created earlier. 

4. Select OK to attach the cell library. 

 

The cell library only has one cell (model) – the 12345 Design Plan 
Border that you previously created. 

5. Select Placement to make the border the active placement cell. 

6. Close the Cell Library dialog box. 

Replace the border 
1. Select Replace Cells from the Cells toolbar. 
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2. In the Tool Settings box 

 Set Method to Replace 
 Set Mode to Single 
 Toggle on Use Active Cell 

3. When prompted to Identify Cell, <D> on the Typical Section Border. 

4. <D> to accept. 

The generic border is replaced with the project border. 

 

Edit the border text for a Typical Section sheet 
1. Select the Edit Text Command from the Text toolbar. 

2. <D> on the Plan Sheet text. 

3. Change the text to Typical Section. 

 

4. <D> to accept. 
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Check Model Properties 
1. Select File > Models from the menu (or select the Models icon from 

Primary Tools). 

2. Select the Edit Model Properties icon  

Note that the Annotation Scale factor is set to 1:10 for running the 
CDOT Typical Section Program. The text placed from the program will 
appear the correct size. 

 

Note: You must change the Annotation Scale Factor if you run the 
Typical Section Program in any file other than the 
JPC#DES_TyplSect##.dgn file.  

3. Select the Measure Distance command and set the Distance to 
Between Points. 

 



 Creating Sheets 

 

CDOT MicroStation Essentials  Page 423 

4. Measure the height and length of the border (AccuSnap along the yellow 
edge). 

 

Note that the border measure 110 x 170, or 10 times the actual size. If the 
border cell was scaled to a factor other than 1:10 (like 1:100 for a plan 
sheet), then it must be re-scaled or replaced at the proper scale of 10. 

Start the Typical Section Program 
1. On the CDOT Menu, select Add On’s > Typical Section Program.  

 



Colorado Department of Transportation 

Page 424  CDOT MicroStation Essentials 

The CDOT Typical Section Program lets the user input different values 
based on the desired roadway section.  The various options are 
highlighted in blue.  

Note: Items that require input are shown in red. 

 



 Creating Sheets 

 

CDOT MicroStation Essentials  Page 425 

Create a 2-Lane Rural Typical Section 
1. On the Create Typical Sections dialog box, select Options > Writelock 

to toggle it On (a checkmark). 

Note: If Writelock is On, permanent graphics will be generated in the 
file. If Writelock toggle is Off, the graphics are temporary and if 
you zoom or pan, the graphics will disappear.  A checkmark next 
to Writelock indicates that it is on. 

2. Set the Typical Section Program options as shown. 

 

3. Select Apply. 



Colorado Department of Transportation 

Page 426  CDOT MicroStation Essentials 

4. When prompted to locate the profile grade point, <D> near the top-center 
of the sheet as shown. 

 

The 2-Lane rural section is automatically drawn, annotated and 
dimensioned. 

5. Do not close the Create Typical Section dialog box. 
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Create a 2-Lane Urban Typical Section 
1. Set the Typical Section Program options as shown. 

 

2. Select Apply. 

3. When prompted to locate the profile grade point, <D> near the bottom-
center of the sheet below the first section. 

The 2-Lane urban section is automatically drawn, annotated and 
dimensioned. 

4. Do not close the Create Typical Sections dialog box. 
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Save the 2-Lane urban section input file 
1. From the Create Typical Section dialog box, select File > Save. 

2. Navigate to the C:\Projects\12345\Miscellaneous folder. 

3. Key in a File name SH86_2L_Urban_Typical and select Save. 

The input file is saved. If you need to generate this typical section again, 
Select File > Open form the Create Typical Section dialog box and 
select this text file.  

4. Close the Create Typical Section dialog box. 

Align the Sections 
Since you did not snap to a location for the sections, you may need to align the 
sections at their centerlines as well as move the section graphics into the border. 

1. Place a fence block around the urban section. 

2. Select the Move command from the Manipulation toolbar and toggle on 
Use Fence. 

 

3. AccuSnap on the centerline of the urban section as shown for the move 
from point. 

 

Move from
point
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4. Move your cursor horizontally (either to the right or left), lock on 
AccuDraw’s X-axis then press <Enter> on the keyboard. 

This smartlocks the AccuDraw axis so that you can only move in the 
horizontal direction. 

5. <D> on the rural section centerline as shown for the move to point. 

 

The two sections are now aligned at the centerlines. 

 

6. Fit the view. 

7. Save Settings. 

8. Exit MicroStation. 

Move to 
point 
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Lab 9E – Create a Bridge General Layout Sheet at 
Different Scales 

In this exercise, you’ll create a General Layout sheet using the bridge graphics 
drawn earlier. The exercise will demonstrate how to create a sheet with graphics at 
different scales. 

Objectives 
After completing this exercise you will know how to: 

 Place a border at a 40-scale. 
 Create saved views in the model file for referencing to the sheet. 
 Reference plan graphics coincident-world at 1:1 
 Reference saved-view section and detail graphics at different scales on 

the same sheet 

Open the bridge model file for plan 
1. Start MicroStation. 

2. Open the file CU12345BRDG_Model.dgn in the project’s 
\Bridge\Working folder. 

The blank bridge model file opens. 

Reference the Design Model file 
1. Open Level Display and turn on the BRDG_OUTLINE level. 

2. Fit the view. 

 

The proposed outline graphics for the bridge have been already created 
in plan view. 
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3. Attach the 12345DES_Model.dgn from the project’s 
\Design\Drawings\Reference_Files folder as shown. Attach 
Coincident-World at a Nesting Depth of 1. Do not attach raster 
references. 

 

The design model is attached coincident to the proposed bridge graphics. 
A nested depth of 1 also references the Survey/Topo file (currently the 
Survey/Topo display is off). You will later reference the bridge plan to a 
sheet file. 

4. Zoom out as shown. 

 

5. Save Settings. 
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Move the Bridge Model to the Reference_Files folder 
Since the work in the model file is complete, move from the Working 
folder to the Reference_Files folder so that other groups can reference, 
if needed. 

1. Select File > Save As… 

2. Set the directory to 
C:\Projects\12345\Bridge\Drawings\Reference_Files 

3. Remove the CU (CDOT User) initial prefix and rename the file to 
12345BRDG_Model.dgn. 

Note: Your initials are removed from the file when it is ready to 
transfer to the Reference_Files folder. 

 

Note: The project template delivers standard dgn’s for model and sheet 
files as starter files.  You may be prompted to confirm saving 
over an existing file.  Please use caution when performing these 
tasks as you could lose data.  Be sure the files are empty or you 
are working with the latest files. 

4. Select OK to save the file. 

5. Select File > Close to return to the MicroStation Manager. 

6. In the MicroStation Manager, verify your 12345BRDG_Model.dgn file 
was copied to Reference_Files folder. 
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7. Change the directory to \Bridge\Working. 

8. Select the CU12345BRDG_Model.dgn from the Working folder and 
select File > Delete. 

Note: Make sure you select the BRDG_Model file and not the 
BRDG_Detail file. 

 

9. Select OK to delete the working file. 

Open the bridge model file for section and details 
1. Open the CU12345BRDG_Detail.dgn file from the 

C:\Projects\12345\Bridge\Working folder. 
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Create Saved Views 
1. Fit the view. 

2. Make sure that only the section graphics are showing in the view. If not, 
Window around the bridge section. Be sure that the entire section 
encompasses the view and no other graphics are shown in the view. 

 

3. Key in sv=bridge section 

4. When prompted, <D> to in the view to save it. 

5. Select Utilities > Saved Views to open the Saved Views dialog box and 
verify that the view was saved. 

 

6. Make sure the Graphic Group lock is turned off. 
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7. Select the Copy command and copy one of the BT 54 girder cells to the 
approximate location shown (outside of the section saved view). 

 

This will be used as a reference on your details sheet. 

8. Window around the single girder you just copied to create a saved view 
for the girder detail. Make sure only the girder is shown in the view. 
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9. Key in sv=bridge rebar detail and <D> in the view to save. 

Note: You can either use the sv= keyin or the dialog box option to 
create saved views. 

 

10. Fit the view. 

11. Save Settings. 

Move the model file to the Reference_Files folder 
You’re finished working in this bridge model file, so move it to the 
Reference_Files folder. 

1. Select File > Save As… 

2. Set the directory to 
C:\Projects\12345\Bridge\Drawings\Reference_Files 
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3. Remove the CU (CDOT User) initial prefix and rename the file to 
12345BRDG_Detail.dgn. 

 

4. Select OK to save the file. 

5. Select File > Close to return to the MicroStation Manager. 

6. In the MicroStation Manager, verify your 12345BRDG_Detail.dgn file 
was copied to Reference_Files folder. 

7. Change the directory to the \Bridge\Working folder and select File > 
Delete to delete the CU12345BRDG_Detail.dgn file. 

 

8. Select OK to delete the working file. 
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Create the Sheet file 
Create a new sheet file from a seed file. 

1. In the MicroStation Manager, set the folder location to 
C:\Projects\12345\Bridge\Drawings. 

2. Select File > New from the MicroStation Manager. 

3. In the Seed File section, choose the Select button. 

4. Select the seed file 3D-Seed_CDOT.dgn and select OK. 

5. In the Files field, key in the name 12345BRDG_Plan01.dgn. 

 

6. Select OK. 

The file appears in the folder list. 

7. Select OK to open the file. 

The empty file is created with all of the Bridge default settings from the 
seed file. 
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Reference the Plan graphics 
1. Reference the 12345BRDG_Model.dgn file from the 

\Bridge\Drawings\Reference_Files folder.  

2. In the Attachment Settings box, set the options as shown and select OK. 

 

The bridge plan and the nested design reference are attached to the sheet 
file. Since you attached at a 1:1 scale and Coincident-World, all of the 
bridge plan graphics are in their true coordinate locations and actual size. 

3. Fit the view. 

 

4. Window in on the bridge area as shown. 

Bridge Area
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5. Toggle off the display of the Design reference. 

 

 

6. Only the graphics from the Bridge model are shown. 
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Place the border 
With the bridge plan graphics in place, you can now place the border around 
them. 

1. Select Cells from the Primary toolbar. 

2. Select File > Attach and attach the 12345DesignPlanBorder cell library 
from the C:\Projects\12345\Miscellaneous folder. 

3. Select the Placement option for this cell. 

 

4. Select the Place Active Cell command and place the border at a 40 
scale. 

 

The border scale is the same as the plot scale of 1”=40’. 
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5. <D> to place the border in the location shown. Be sure to position the 
border so that the bridge plan is in the upper left corner. 

 

6. Turn on the display of the design reference. 

 

7. On the CDOT Menu Explorer, select Drafting. 

 Select the Border category. 
 Select the Clip Boundary item. 

8. Select the Place Block command and place the clip boundary block as 
shown. 

Clip boundary 
block
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9. From the Reference dialog box, select the Bridge model reference and 
then select Tools > Clip Boundary. 

 

10. <D> on the clip boundary to clip the design model reference.  

 

The bridge plan is now place inside the border at the proper coordinates. 
Design graphics levels can be turned on/off as needed. 

Reference additional graphics at various scales 
Reference the typical section at a scale of 1” = 10’ 

1. From the References dialog, attach the file 12345BRDG_Detail.dgn from 
the \Bridge\Drawings\Reference_Files folder. 
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2. In the Attachment Settings box: 

 

 Select the saved view Bridge Section (the logical name will 
update to the saved view name). 

 Set the Scale to 40:10 

Note: When working with multiple scales, always key in the border 
scale in the first field (Master) and the detail scale in the second 
field (Ref). MicroStation will calculate the scale for your, or you 
could calculate it yourself and enter 4:1. 

 Set the other options as shown. 

3. Select OK and <D> to position the saved view reference in the location 
shown. 
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4. Reference the 12345RDG_Detail.dgn again and repeat the above process 
and reference the girder detail at a scale of 1”=5’. 

 

 

 

Note: You’ll annotate and dimension this sheet in the next lab. 

5. Fit the view. 

6. Save Settings. 

7. Exit MicroStation. 
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Lab 9F – Create a General Notes Sheet 
The 12345DES_GenNote.dgn has been created in the project’s 
\Design\Drawings folder through the create project utility. This sheet file 
currently is linked to a generic notes doc file in the CDOT workspace. However, 
the sheet files should reference the project-specific notes file, 
12345GemeralNote.dgn located in the \Design\Drawings\Reference Files 
folder. You must first update the references in the sheet file to point to the 
project notes, and then edit the project notes file to be project-specific.  

Note: This process is the same for any specialty group. 

Objectives 
After completing this exercise you will know how to: 

 Open a project notes sheet file. 
 Update the Word document link to point to the 12345 project directory.  
 Edit the project-specific general notes Word file. 
 Re-link the General Notes Word file to the Notes sheet file. 

Updating Links 
1. Start MicroStation and open the file 12345DES_GenNote##.dgn from 

the C:\Projects\12345\Design\Drawings folder. 

 

This file was automatically generated by the create project utility 
program and contains links to a General Notes Word document in the 
generic project template folder. You will need to update these links to the 
General Notes Word document in the project folder.
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2. Select Edit > Links. 

3. Highlight the first link in the list and select Change Source. 

 

4. In the Change Source dialog box, set the Look in folder to 
C:\Projects\12345\Design\Drawings\Tabs and select the file 
12345DES_GenNote.doc. 

 

5. Select Open to update the link. 
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6. Repeat this process for the second link. 

 

7. Close the Links dialog box. 

8. Save Settings (File > Save Settings). 

The General Notes sheet file is now linked to the GenNotes.doc file in 
the project-specific folder. You can now edit the Word file for your 
project-specific requirements. 

Editing the Notes 
1. Double click on the first notes link (left sheet). 

This opens Microsoft Word and the GenNotes.doc file. 

 

 

2. Read the first instructional paragraph (red text) and then delete it. 



Colorado Department of Transportation 

Page 450  CDOT MicroStation Essentials 

3. Delete the following text: 

Prime Coat (MC-70) [XXXX] ...................................................@ .XX Gals./Sq. Yd. 

Seal Coat (RC[XX]) Diluted Emulsified Asphalt [XXXX] .......@ XX Gals./Sq. Yd. (Diluted) 

Cover Coat Material [XXXX].....................................................@ XX Lbs./Sq. Yd. 

Tack Coat (AC[XX]....................................................................@ XX Lbs./Sq. Yd. 

Asphalt Rejuvenating Agent [XXXX]........................................@ XX Gals./Sq. Yd. 

4. Edit the following text to read as follows: 

Tack Coat Diluted Emulsified Asphalt.......................................@ 0.1 Gals./Sq. Yd. (Diluted) 

Bituminous Pavement……….....................................................@ 110 Lbs./Sq. Yd./Inch 

Aggregate Base Course (Class 6).................................. .............@ 133 Lbs/Cu Yd 

5. At the bottom of the first column, add a blank line to place the paragraph 
beginning “The Contractor shall coordinate the shouldering…” at the 
top of the next column. 

 

 

 

Add a blank 
line here… 

…to move the 
paragraph to 
top of next 
column here. 
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6. Look at the top of the next page and note that your edits have adjusted 
the text wrapping. The next page now starts with the note: 
 
It is estimated that [XX] Mobile Pavement Marking Zone will be 
required on this project. 

 

7. Review the text to make sure the edits are correct. If not, edit the text 
again until you’re satisfied. 

8. In Word, select File > Exit and select Yes when prompted to save 
changes. 

You are returned to the General Notes sheet in MicroStation. 
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Review the changes in the sheet file 
1. Zoom in on the notes on the first sheet and notes your text edits have 

been updated in the DGN file. 

 

2. Zoom in on the notes on the second sheet (right side) and notice that your 
edits have not been updated in the file. 

 

Note: If you make edits that change the wrapping of text between 
pages in the Word document, you must re-link the file for the 
edits to update in the MicroStation DGN file. 
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Re-link the Word document 
1. Use the Element Selection tool to select the Word document link on the 

second (right-side) sheet. 

2. Select Delete. 

 

3. Double-click on the Word document link on the first sheet to open the 
GenNotes.doc file. 



Colorado Department of Transportation 

Page 454  CDOT MicroStation Essentials 

4. Highlight all of the text on the second page and select Edit > Copy in 
Word.   

 

5. Do not close Word. 

6. Switch to the MicroStation application. 

7. In MicroStation, select Edit > Paste Special and select the Linked 
Microsoft Office Word Document option and then select Paste. 

 

8. In the Paste OLE box, set Paste As to Link and Method to By Corners. 
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9. Snap to the two ends of the top guideline as shown. 

 

 

1.  Snap here 
(<T>, then 
<D> to accept)

2.  Snap here 
(<T>, then 
<D> to accept)
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10. Zoom in to review the notes and notice that the link has been updated to 
reflect your edits. 

 

11. Switch over to the Word document and select File > Exit. If prompted to 
save the file, select Yes. 

12. In MicroStation, Fit the view. 

13. Save Settings. 

14. Exit MicroStation. 
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Lab 9G – Create the Standard Plans List Sheet 
The M&S standard sheet is created by downloading the M&S Standards Plan List 
Index file from the CDOT web site. You can then update the reference in the M&S 
sheet file to point to this downloaded file. 

Objectives 
After completing this exercise you will know how to: 

 Download the M&S Index file from the CDOT web site. 
 Update the M&S sheet file reference to the downloaded file. 
 Use the Create Region command to update the M&S Index Sheet for 

the project. 

Open the Sheet File 
1. Start MicroStation and open the 12345DES_StdPlanList.dgn file from the 

C:\Projects\12345\Design\Drawings folder. 

 

The file opens and contains the border along with the M&S Standards 
Plan List reference. It also contains the web address to obtain the latest 
M&S Index file. 
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2. Select References from the Primary toolbar. 

 

Note that the M&S StandardPlansListIndex.dgn file is already 
referenced from the project’s \Design\Drawings folder. It was 
automatically placed here from the Create Project Directory utility.  

Note: If you need newer or different version of the M&S 
Standards, you can download it from the following web 
address: www.dot.state.co.us/DesignSupport/.  Save the 
appropriate file to the project’s \Design\Drawings folder and 
then re-attach this reference. 

Update the M&S Index 
1. Turn off the DRAFT_INFO_No-Plot level to turn off the text. 

Note: Since the text is on a “no plot” level, you don’t have to turn off 
the text. However, it just makes working in the file a bit easier. 

2. Set the active level to DRAFT_WT-3. 

 

3. Window in to the top of the sheet as shown. 
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4. Select the Create Region command from the Groups toolbar and set the 
options as shown. 

 

5. For the first plan in the list (M-100-1), <D> inside the block under the 
Plan Number column. 

6. <D> to accept. 

 

The block is filled-in using this tool. 

7. Fill in other blocks as desired. 
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Fill in the Border Information 
1. From the CDOT Menu Explorer, select Drafting, then the Border RE 

category and select the Default Resident Engineer cell. 

 

2. Apply. 

3. Snap to the location shown to place the cell. 

 

 
Snap here
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4. Use the Edit Text command to edit the Project Number and Code as 
shown. 

5. Use the Edit Text command to place your initials in the Designer and 
Detailer blocks. 

 

6. Fit the view. 

7. Save Settings (File > Save Settings). 

8. Exit MicroStation. 
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Lab 9H – Create a Title Sheet 
In this lab, you’ll learn how to insert a Vicinity Map into the Project Title Sheet.  

Objectives 
After completing this exercise you will know how to: 

 Open a project Title Sheet. 
 Locate a vicinity map. 
 Attach a vicinity map as a reference to the Title Sheet. 
 Move and Clip the vicinity reference. 

Open the Title Sheet file 

1. Start MicroStation and open the file 12345DES_TitleSht.dgn for the 
C:\Projects\12345\Design\Drawings folder. 

 

This file was automatically generated by the Create Project Utility 
program and contains a links to an Excel spreadsheet file in the generic 
project template folder. You will need to update these links to the 
12345DES_TitleSht.xls file in the project folder. 
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Updating Links 
1. Select Edit > Links. 

2. Highlight the first link in the list and select Change Source. 

 

3. In the Change Source dialog box, set the Look in folder to 
C:\Projects\12345\Design\Drawings\Tabs and select the file 
12345DES_TitleSht.xls. 

 

4. Select Open to update the link. 
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5. Repeat this process for the second link. 

 

6. Close the Links dialog box. 

7. Save Settings (File > Save Settings). 

The Title sheet design file is now linked to the Excel spreadsheet file in 
the project-specific folder. You can now edit the Excel file for your 
project-specific requirements. 

Edit the spreadsheet file 
1. Double-click on the Tabulation of Length & Design Data link. 

2. Excel starts and opens the 12345DES_TitleSht.xls file. 

3. In the Design Data portion of the file, make the following edits: 
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4. When finished, select File > Exit In Excel. When prompted to save 
changes to the file, select Yes. 

5. Switch back to the MicroStation file and note that the edits are now 
updated in the DGN file. 

 

6. Window in on the Index of Sheets link on the right side of the sheet. 
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7. Using what you’ve learned, Edit the 12345DES_TitleSht.xls file and 
update the DGN file to read as shown below. 

Note:  When entering pages ranges (e.g. 3-4) be sure to put a quote 
mark (‘) at the beginning of text entry, otherwise Excel will 
interpret this as a date (i.e. March 4). 

Hint: You can insert and delete rows as needed in Excel. 

 

Edit the Border Text 
1. Use the Edit Text command to make project specific edits to the border as 

shown. 

2. Window in to the top center of the title sheet and edit the project 
numbers, highway number and county name as shown. 
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3. Window in to the lower-right corner and make the project edits as 
shown. 

 

4. Window in to the upper-right corner and make the project edits as 
shown. 

 

5. Window around the bar scale and edit the text as shown. 
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Place the RE cell 
1. From the CDOT Menu, select Border RE from the Drafting group. 

 

2. Place the Default RE cell in the location shown by snapping to the 
lower-left corner. 

 

 

 

3. Fit the View. 

4. Save Settings. 

Snap here
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Review the Vicinity Map 
Vicinity maps can be referenced to the title sheet. These maps can be in the form 
of vector files (CADD elements) or raster files (images). 

The CDOT standard procedure is to use county maps that have been translated 
from GIS information, these maps can be found on the shared drive at: 
\\public\CADD County Maps\. The county of interest should be copied to your 
project’s …\Design\Drawings\Reference_Files folder and can be attached as 
a reference to the project’s Title Sheet file.  

1. Select File > Open and open Elbert.dgn from the 
C:\Projects\12345\Design\Drawings\Reference_Files folder. 

 

The Elbert county map was translated from GIS and copied from the 
\\public\CADD County Maps\ shared drive. This file contains a Saved 
View to assist in attaching it as a reference file. 

2. Select Utilities > Saved Views from the MicroStation pull-down menu 
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3. <D> on the saved view by the name of plan and select Apply. 

 

The MicroStation view updates to the limits of the saved view.   

4. Close the Saved Views dialog box. 

5. Open the Level Display from the Primary toolbar. Note that all 
information resides on GIS_* levels. 

 

6. Turn level displays on and off to verify the data is on the correct levels. 
Turn all levels on when finished. 
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Attaching a vicinity map as a reference file 
In the next series of steps, you will attach the vicinity file as a reference to the 
title sheet. Once attached, you can move, scale and clip the reference to fit the 
display limits in the sheet file. 

1. Select File > Open and reopen the title sheet 12345DES_TitleSht.dgn 
from the project’s …\Design\Drawings folder. 

2. Select References from the Primary toolbar. 

3. In the References dialog, select Tools > Attach. 

4. Set the directory to the project’s 
…\Design\Drawings\Reference_Files folder and select Elbert.dgn. 

5. In the Attachment Settings box: 

 

 Under Orientation, select plan (the saved view). 
 Key in a Logical Name of Vicinity and a Description of 

GIS locator map for title sheet.  
 Key in a Scale of 1:5280  

Note: CDOT GIS maps are designed based on a 1-mile insertions scale 
(1 inch = 1 mile) for graphics. The linestyle and text scale factors 
are also based on this scale.  

6. Select OK. 

The outline of the saved view reference is attached to your cursor.  

7. <D> anywhere underneath the plan sheet to attach the reference. 
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8. Select the MicroStation Fit command 
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Move the reference file to align with the title sheet 
1. In the References dialog box, select Tools > Move.  

2. When prompted to enter a point to move from, <D> on section 13 on the 
vicinity reference. 
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3. <D> approximately in the center of the project location map block for the 
move to point. 

 

4. Continue to use the Move Reference command as needed to position 
the reference as shown.  

5. <R> when done. 

Clip the vicinity map reference 
1. In the Reference dialog, highlight the Vicinity reference 

2. Select Tools > Clip Boundary from the Reference File dialog.  

3. In the Tool Settings box, set Method to Element. 

MicroStation prompts ‘Select clipping element’ 

4. <D> on the shape representing the limits of the project location map. 

Project limits 
clipping 

boundary 
shape
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5. <D> to accept. 

 

6. Open Level Display and turn off the GIS_Sections-Text and 
GIS_Township-Text. 

7. Fit the view. 

 

8. Save Settings. 

9. Exit MicroStation.
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10. Annotating and Plotting Sheets 

Understanding Text and Text Styles 
After creating the sheet file, you can now annotate the sheet using MicroStation’s 
text tools and dimension the drawing with the dimensioning tools. 

Text styles 
Text Styles provide a method of saving and applying text attributes in 
MicroStation.  They function similar to styles used in word processing software, 
saving text setups that include font, height and width, line spacing, color, etc. 
When you apply a style, it’s like applying a whole set of characteristics in one 
step.  Once the style is applied, the text is linked to the style and any future 
changes to the style will update all text currently using the style.  The text style 
contains attributes like font, height, width, line spacing, line length, text 
justification, etc. 

CDOT Text Styles 
CDOT text styles are saved in a DGNLIB file called CDOT-Text & Dim 
Styles.dgnlib, located in the C:\Program Files\Workspace-
CDOT\Standards-Global\MicroStation\DGNlib\Standard folder. This file 
is automatically attached to any design file opened in the CDOT workspace. 
This way, you will always have your text styles loaded. Using Text Styles is a 
very effective in standardizing text throughout a project or agency. 

CDOT text styles are categorized by text size (e.g. .07”, .10”, .14”, etc.)  Each 
style is one of two types – 100 or 80 (e.g. .07” ENG 80). 100 styles have the 
same text height and width. 80 styles are proportional sized – the text width is 
80% of the text height.  
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Text toolbar 
The Text toolbar is used to place and edit text.  When you place text, you specify 
a Text Style to apply to the text. 

 

Place Text 
Places text that you enter into the Text Editor — Word Processor window.  The 
MicroStation Text Editor uses some basic word processing format options (font, 
bold, underline, italics, etc.), which allows for quick text manipulations.  You 
can change these attribute per letter, word or string within a text block. 

 

 

Other word processing functionality includes checking spelling prior to placing 
text and using Cut, Copy and Paste between MicroStation and other Windows 
applications. 

Text Styles 
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Text is placed using active text and design file parameters including: 

 Active element symbology (color, weight) 
 Active level 
 Active angle and 
 Text style. 

Drawing Scale 
Before placing text, check the Annotation Scale for text under Model 
Properties.  The Annotation Scale is set to 100, by default, in the CDOT seed 
file.  This should be the same as your plot scale.  If you’re plotting at any other 
scale, change the Annotation Scale here.  Any text that you’ve previously 
placed will be updated (i.e. you don’t have to delete and replace the text – it will 
be re-scaled automatically). 
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Note: To enable scaling of text, make sure that the Annotation Scale 
lock is turned on in the Place Text command before placing 
your text. 

  

For more information on text, see the CDOT CADD Manual, Chapter Five – 
Drawing Standards, Section 5.4 Standard Annotation. 
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CDOT Menu text 

Placing general text using the CDOT Menu 
The CDOT Menu streamlines the text placement process by minimizing text 
placement options to those frequently used on CDOT drawings. Select the 
Drafting > Text group to place Standard or Title text. Text Justification, 
Spacing and size can be specified in one location. After setting these main text 
parameters, key-in your text in the Text Editor and then <D> to place the text in 
the file.  
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Placing Specialty Group text with CDOT Menu 
The CDOT Menu also takes the guess work out of placing specialty group text. 
Select the Group and Category, and the menu shows the annotation options for 
the different items in that group. Select the text item and all the text options are 
automatically set in the Place Text command. Just key-in your text in the Text 
Editor and then place in the file. 
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Placing User-defined Utility text 
The Utility Group on the CDOT Menu has special options for placing text that 
allows you to build a database of utility information and then annotate that 
information directly on the utility line. Each different type of utility has its own 
set of annotation options specific to that utility line. 

To create a new Utility text annotation, select the Category and then select the 
<New Text String > item. You can then select from a list of pre-defined utility 
features, or create new ones.  
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After specifying the utility line features, select OK and then <D> on the line to 
place the text. 

 

You can save this text information in the CDOT item list for placement again 
later. 
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Using the Greek characters font 
If you need to place Greek characters on a drawing, then see the CDOT 
Workflow, Greek Characters. 
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Understanding Dimensions and Dimension Styles 

Dimension Styles 
Dimension Styles provide a way of saving and applying dimension attributes in 
MicroStation.  They function similar to the text styles, saving setups that include 
terminators, tolerances, units, etc. When you apply a dimension style, it’s like 
applying a whole set of characteristics in one step.  Once the style is applied, the 
dimension is linked to the style and any future changes to the style update all 
dimensions currently using the style. 

CDOT Dimension styles are saved in the  DGNLIB file CDOT-Text & Dim 
Styles.dgnlib located in the C:\Program Files\Workspace-
CDOT\Standards-Global\MicroStation\DGNlib\Standard folder. This file 
is automatically attached to any MicroStation design file opened in the CDOT 
workspace. This is a very effective in standardizing your dimensions throughout 
CDOT. 

CDOT Dimension Styles 
There are currently three CDOT dimension styles available: 

 CDOT 1 – Accuracy of 0.1234 
 CDOT 2 – Accuracy of 0.12 
 CDOT 3 – Feet and inches. 
 CDOT 4 – Accuracy of 0.12 B spline Notes 
 CDOT 5 – Accuracy of 0 

Note: All CDOT Dimension styles have the option Reference scale 
turned on. This allows you to dimension reference graphics 
actual size if the reference attachment was scaled. 

Placing Dimensions using the CDOT Menu 
The CDOT Menu streamlines the process of dimensioning elements. From the 
CDOT Menu Explore select Drafting , set the category to Dimensions.  Five 
Filters represent the different dimension styles in the configuration. 
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There are five options for each Filter or dimension style: 

 Dimension Linear Size – Dimensions size by specifying a start and end 
point. 

 Dimension Angle Between – Dimensions the angle between two 
points. 

 Dimension Angle Size – Dimensions the angle between lines. 
 Dimension Element - Dimensions an element (line, linestring, shape, 

arc, or circle). 
 Label Line – Labels a line with a bearing and/or distance and labels the 

line. 

 

The three accuracy options, .1234, .12 and x’-xx” allow you to specify the 
CDOT dimension styles CDOT 1, 2 or 3.  

 
The menu automatically selects the proper dimension command and active level 
for placing the dimension. 

 
Toggle on Association if you want the dimension to update if the element is 
modified.  Associative dimensioning also works for reference elements. 

Note:  You must turn on the Association lock in order to activate the 
Association toggle in the dimension command. 

Dimension styles
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Dimension toolbar 
In addition to the CDOT Menu, you can also use the Dimensioning toolbar to 
place dimensions.  However, the most common dimensions are on the toolbar. 

 

Using the Match Dimension tool 
If there are existing dimensions in the design file, you can match the dimension 
and then place it again using the dimension command on the toolbar. 
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Plotting 

Workflows 
CDOT has established workflows for plotting to either 11” x 17” printers or 
plotting to Adobe Portable Document Files (PDFs). These workflows include 
MicroStation Printing for single sheets or Batch Printing for printing multiple 
sheets or PDF files. See the CDOT Workflows for more information. 

 

 

Printer Drivers 
Two CDOT printer drivers are available to select before plotting –  
CDOT-DefaultPrinter.plt and CDOT-PDFdriver.plt. Choose the first if 
you’re plotting to a printer and the second if you’re plotting to PDF. Printer 
drivers control plotting devices, plot sizes, CDOT pen tables, etc.  
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Location of PDF files 
When plotting to PDF files, they should be placed in the project’s  Plot_Sets 
folder under the appropriate subfolder, for use by the reproduction department 
and other disciplines for reference and review.  Only final submittals should be 
stored in this location. 
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Additional Plotting Workflows 
Additional workflows regarding MicroStation printing include Printing 
AutoCAD file in MicroStation, Printing Raster Images, Shaded 
Color and Grayscale Printing and Printer Driver Adjustments. 

 

Additional Plotting Information 
For additional plotting information, see the CDOT CADD Manual, Chapter Ten 
– Plotting. 
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Assembling Plan Sets 
After you’ve plotted your files for a plan set, refer to the CDOT CADD Manual, 
Chapter Eight – Drawing Information, for a comprehensive listing of sheets, 
information to include on each type of sheet, sample project sheets and a final 
checklist. 
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Lab 10A – Annotate the Intersection Plan/Profile Sheet 
In this lab, you’ll annotate the plan/profile sheet with text, notes and custom text 
strings using the CDOT Menu.  

Objectives 
After completing this exercise you will know how to: 

 Set the active angle for placing text. 
 Place Text using the CDOT Menu. 
 Rotate text. 
 Place notes with leader lines and a terminator. 
 Create and place custom text strings for utility lines using the CDOT 

Menu. 

Start MicroStation 
1. Start MicroStation and open 12345DES_PnP19.dgn from the 

C:\Projects\12345\Design\Drawings folder. 
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Check Text Annotation Scale 
1. Select Models from the Primary toolbar. 

2. In the Model box, select Edit Model Properties. 

 

3. Note that the Text Annotation Scale is set to 1:100 (the default setting 
from the seed file). 

Note: The Text Annotation Scale matches the border scale, which 
matches the scale for plotting – 100. 

4. Cancel the Model Properties box. 

5. Close the Models box. 

Work with sheet levels and references 
The plan limits cell placed along the mainline alignment in the Design 
model file appears in the sheet. This is on a No Plot level. However, if 
you don’t want to see it, you can turn it off. 

1. Open Level Display and turn off the DRAFT_INFO_No_Plot level in the 
Design reference. 

2. In Level Display, turn off the Survey/Topo reference. 
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3. Select Settings > View Attributes, turn on Level Symbology and then 
Apply.  

 

This applies the Symbology Overrides set in the CDOT level libraries for 
“graying out” the existing contour levels. 

Edit the bar scale text 
1. Window in on the bar scale cell in the lower left portion of the plan view. 

2. Use the Edit Text command to edit the text as shown for a 100 scale plot. 

 

 

Label the Intersection Alignments 

Set the active angle for placing the county road text 
1. On the CDOT Menu, select Settings. 

2. Set the Active Angle to 0, Apply and then Close the box. 

 



Colorado Department of Transportation 

Page 496  CDOT MicroStation Essentials 

Set the text attributes using the CDOT Menu 
1. On the CDOT Menu Explorer, select Drafting.  Set the category to Text 

and set the following options: 

 Filter: Standard (S) 
 Justification:  Center Center 
 Item: .07” 100% Standard 

 

This sets the active level to DRAFT_Text-3 and automatically selects the 
Place Text command. 

2. In the Word Processor box, key in County Road 101. 

3. <D> to the left of the intersection as shown to label the road. 

 

 

4. <R> out of the Place Text command when done. 
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Set the active angle for the main alignment text 
1. Select Settings > Design File > Coordinate Readout. 

2. Set the Options as shown for Conventional Angle Mode, Decimal 
Degrees. 

 

3. Select the Measure Angle command from the Measure toolbar. 

 

4. <D> on the centerline of the side road. 

5. <D> on the centerline of SH 86. 

The angle reads out at 74.14 degrees. 

6. From the CDOT Menu, select Settings and set the Active Angle to 
74.14, Apply and then Close. 
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Place the SH 86 text at the active angle 
1. On the CDOT Menu select Drafting > Text and select .07 again. 

2. In the Word Processor box, key in SH 86. 

3. <D> when shown to label the road. 

 

4. <R> out of the Place Text command when done. 

Rotate the InRoads alignment text 
1. Window in to the right of the intersection as shown. 

 

2. Select the Rotate command from the Manipulate toolbar. 

3. Set the Method to Active Angle, set the Angle to 180 and toggle on 
About Element Center. 
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4. <D> on the bearing text. 

 

You can’t rotate the text because it’s in a reference. 

Important! If you’re in the Design group and “own” the Design 
reference, you can “exchange” to that reference to make modifications. 
Otherwise, contact Design. 

5. Select File > Save Settings. 

6. On the References dialog, select the Design reference and then select 
Tools > Exchange. 

 

7. Select the Rotate command, <D> on the bearing text and then <D> to 
accept. 

 

8. Select the File pull-down menu and open the sheet file from the list of 
last open files. 
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Place Notes 
1. Window in above the intersection to view the guardrail as shown. 

 

2. On the CDOT Menu Explorer, select Drafting > Text and select the .05” 
100% Place Note item. 

  

3. Click inside the Word Processor box and key in  
Guardrail Type 3. 
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4. <D> on the guardrail as shown to define the start point of the note (note 
terminator). 

5. Drag the cursor to the location shown and <D> to place the note leader. 

 

6. IMORTANT: With your cursor on the LEFT SIDE of the leader line, 
RESET <R> to place the text. 

Note: If your cursor is on the right side of the leader when you reset, 
your note will be placed on the right side. 

7. With the Place Note command still active, click in the Word Processor 
box and key in SH 86 STA 225+57.20. 

8. On the Snap Mode toolbar select the Intersection Snap. 

Note: You can also click in AccuDraw and press I on the keyboard. 

 

9. AccuSnap to the intersection of the two centerlines as shown for the 
note terminator. 

10. Drag your cursor out and <D> to place the leader line. 

 

11. With our cursor on the RIGHT side of the leader, <R> to place the note. 

<D> here for 
the start point 

<D> here for 
the to place 

the leader 

Snap here for 
the start point

<D> here to 
place the 

leader
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Attach Utility Lines 
Next, you’ll annotate proposed utility lines using the CDOT menu. However, the 
Utility model was not attached to plan sheet when it was created. Therefore, you 
must attach the Utility model after-the-fact in order to reference the utility lines for 
annotation. 

Reference the proposed Utility model 
1. Fit the view. 

2. Open the References dialog box. 

3. Attach the 12345UTIL_Model.dgn file from project’s 
\Utilities\Drawings\Reference_Files folder. Be sure to attach 
Coincident-World at a 1:1 scale with No Nesting. 

  

The Utility model is reference, but needs clipping. 
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4. On the References toolbar, select the Utility reference and then select 
Tools > Clip Boundary. 

  

5. <D> on the clip boundary block and then <D> to accept. 
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Annotate the gas line 
1. Window in on the plan sheet area shown. 

 

2. From the CDOT Menu Explorer, select Group Display > Utilities and set 
the following options: 

 Set Status to Proposed 
 Set the Category to Gas 
 Set Filters to All (or Text) 
 Select the item <New Text String> 
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3. In the Create Text String dialog box set the following from the drop 
down options: 

 Set Size to 6” 
 Set Material to PVC 
 For Owner, key in Xcel Energy 

  

4. Select OK. 

5. When prompted to Identify Element, <D> on the proposed gas line. 

6. <D> above the line to accept the text placement. 
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Note: Your custom text 6”, PVC, Xcel Energy is saved as an item in 
the Gas category for placement again. 

 
 
You can right-click on a custom text string and either edit or 
delete it. 

Annotate the fiber optic line 
1. Create a custom text string (6”, Qwest) for the fiber optic line and 

annotate as shown. 

  

 

Note: Be sure to <D> near the bottom of the line to fit the annotation. 
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Measure Graphics 
Since you referenced your plan view graphics at a 1:1 scale, they are the actual size 
in the sheet file. Therefore, you can measure plan graphics in the sheet file and get 
the same results as measuring in the model file. Make sure that Locate is turned on 
for the reference before using the measuring tools on reference graphics. 

Measure Distance 

Between points 

1. Measure the OH Electrical Line with the CDOT custom add-on tool. 

 From the CDOT Menu select Add On’s > Measure XY 
Distance. 

 In the XY Distance Dialog box, set Measurement Option 
to Between points. 

 AccuSnap on the two endpoints of the proposed Overhead 
electrical line as shown (snap to tie-in at power pole symbols 
– see arrows below). 

 

 

 <R> when done. 
 Your results should match the dialog box. 

 

Gas line

Overhead 
electrical line

Note:  This tool provides horizontal 
distance measurements even if the 3D 
graphics you’re measuring between are at 
different elevations. 
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Along element 

2. Measure the Gas Line with standard MicroStation tools. 

 Select the Measure Distance command from the Measure 
toolbar. 

 

 Set the Method to Along Element 
 AccuSnap on the start and end points of proposed 6” gas 

line as shown (see arrows). 

 

 Record your results: ___________________________ft. 

Note: Individual results will vary based on how the line was originally 
drawn. 
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3. Select the Measure Length command. 

 

  <D> on the gas line. 
 Record your results: ___________________________ft. 

Your results should be the same as in step 2. With this command, you 
only have to select the element with a data point to get its entire length. 

4. Use Measure Length to measure the length of the OH Electrical line. 

 

Your results should be the same as step 1 where you measure with the 
CDOT custom XY Distance tool. 

Note: When measuring a straight line with this method, you also get 
the angle of the line. 

Measure perpendicular 

5. In the Design Model reference, turn off the level  
DRAFT_LC-Center_WT-3. 

This element (a blue dashed line) is a coincident to the alignment 
centerline. Since you will only be working with the alignment, turn this 
level off and leave the ALG_PROPOSED_Hor-Alignment turned on. 

6. Turn Depth lock off. 

7. <T> on the side road horizontal alignment and note the Z value. 

  

Horizontal Alignments, like this one, are typically placed at elevation 0.  

8. <T> on the red upper edge of oil line at the beginning of the alignment 
and note the Z value. 
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The edge of oil line is placed at the correct elevation. 

9. In the XY Distance dialog box, set the Option to Perpendicular from 
element. 

 

10. <D> on the side road horizontal alignment. 

MicroStation displays a horizontal tracking line. 

11. AccuSnap on the end of the upper edge of oil line. 

 

12. Review your results:  

 

Note that even though the two elements are at different elevations, the 
CDOT custom XY Distance tool provides both the Horizontal Distance 
of 18 feet along with the true 3D slope measurement (or Total Distance) 
of 6626.672 feet. 

<T> here

1.  <D> on the 
centerline 

alignment to 
measure from

2.  Snap to the end of 
the edge of oil line
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Lab 10B – Annotate the Bridge General Layout Sheet 
In this lab, you’ll annotate the bridge general layout sheet with text, notes and 
dimensions.  

Objectives 
After completing this exercise you will know how to: 

 Set and change the Text Annotation Scale to match the drawing scale. 
 Place dimensions using the following methods: 

 Element 
 Linear 
 Angle between lines 
 Bearing and Distance 

 Edit dimension text. 
 Place notes with curved leaders. 

Start MicroStation 
13. Start MicroStation and open 12345BRDG_Plan01.dgn from the 

C:\Projects\12345\Bridge\Drawings folder. 
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Place Text 
Label the different part of the general layout sheet (plan, typical section, etc.) 

Set text attributes 
1. On the CDOT Menu Explorer, select Drafting > Text and set the 

following options: 

 Filter: Title (T) 
 Justification:  Center Center 
 Item: .30” 100% Title 

  

This sets the active level to DRAFT_Text-2 and automatically selects the 
Place Text command. 

2. In the Word Processor box, key in Plan 

3. Drag your cursor into the view. 

4. <D> to place the text as shown. 

 

Note that the text is extremely large. The text annotation scale is 
obviously wrong. 

5. <R> out of the Place Text command. 
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Change the Text Annotation Scale 
1. Select Models from the Primary toolbar. 

2. In the Model box, select Edit Model Properties. 

3. Note that the Text Annotation Scale is set to 1:100 (the default setting 
from the seed file). 

Note: This is a 40-scale drawing (the border was placed at a 40 scale 
around the graphics). Scaling the text 100 times results is text 
that is the wrong size. 

4. Change the Text Annotation Scale to 1:40 and select OK. 

 

5. In the Alert box, select Yes to propagate the new settings to existing text. 

 

The text “Plan” is automatically resized for a 40-scale drawing and will 
now measure correctly when plotted. 

  

6. Close the Models box. 
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7. Select File > Save Settings to save the new settings. 

8. Using the same text attribute settings, place the following text in the 
locations shown: 

 Typical Section 
 BT 54 Detail 

9. Use the Move command to move the text to the desired location, if 
necessary. 

 

Dimension the Bridge Typical Section 
Use the CDOT Menu to dimension the bridge typical section. 

Dimension the travel lanes and shoulder by element 
1. Window around the typical section. 
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On the CDOT Menu Explorer, select Drafting and set the following options: 

 Category: Dimensions 
 Filter: x’-x” 
 Item: Dimension  Element 

 

The Dimension Element command is automatically selected. 

2. When prompted to select the element to dimension, <D> on the top 
pavement to the right of the centerline. 

Note: This should select the 12 ft SmartLine segment which represents 
the travel lane, if not, <R> until you select the correct element. 

3. Move your cursor up to establish the length of the extension line and 
<D> to place the dimension. 

 

4. Repeat for the 6 ft. right-shoulder segment. <D> on the segment near the 
extension line and then AccuSnap on the 12 ft. dimension’s terminator 
to place the dimension. 
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Note: The elements dimension actual size even though the bridge 
typical section was scaled up 4 times (40: 10 or 1:10 at a 40-
scale). This is because Reference Scale is turned on in the 
Placement category of the dimension style. The units for 
dimensioning are, therefore, read from the model file instead of 
the sheet file. Reference Scale is on by default in all CDOT 
dimension styles. 

 

5. Repeat for the left side of the road. Be sure to AccuSnap on the adjacent 
dimension’s terminator to line up the dimensions. 
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Dimension the bridge rail curb using linear dimensions 
1. On the CDOT Menu Explorer, change the Item to Dimension Linear 

Size 

 

2. Following your prompts, AccuSnap on the end of the back of the rail 
for the start of the dimension. 

3. Move your cursor up to the approximate location shown and <D> to 
define the length of the extension line. 

4. AccuSnap on the face of the curb as shown to define the end of the 
dimension. 

 

Note that the dimension text is too large for the dimension when placed 
inside the extension lines. You can Modify the text to solve this problem. 

Snap here to start 
dimension 

<D> here for 
length of 

extension line 

Snap here for 
dimension endpoint
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5. Select the Modify tool from the Modify toolbar. 

 

6. <D> on the 1’-6” curb dimension text. 

7. Lock your cursor on AccuDraw X axis and move the text to the left as 
shown. 

 

8. <R> when done. 

9. Repeat the above steps and dimension the curb on the right side. 
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Place additional linear dimensions 
1. Using the Linear Dimension command, place additional dimensions for 

the width of the section as shown. 

 

Measure the typical section 
1. Select the Measure Distance command and set the method to Between 

Points. 

2. AccuSnap on the left outside curb line. 

3. AccuSnap on the right outside curb line. 

4. Review your results. 

The typical section measures 144 ft., which is 4 times the actual size 
since the detail was scaled up on the drawing. While dimension 
commands can read reference units (via the Reference Scale option in 
the dimension style), measuring command can not. You should only use 
Measuring command in sheet files where the graphics have been 
referenced 1:1 (like plan view graphics). If graphics have been scaled in 
the sheet, you must return to the model file for true measurements. 

Edit dimensions  

Edit the dimension style 
You can change the dimension style to show secondary units below the 
dimension line. While this is intended for dual dimensioning in metric, 
you can edit this text to add descriptions to your dimensions. 

1. Select Element > Dimension Styles. 

The Dimension Styles box opens. This is where all the CDOT standard 
dimension attributes are set. Typically, you will not need to change these 
settings for most dimensions. 
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2. Select the CDOT 3 style and then select the Unit category and toggle on 
Show Secondary Units. 

 

3. Close the Dimension Styles box. 

Change dimensions 

4. From the Dimension toolbar, select Change Dimension. 

 

5. <D> on the 12 ft travel lane dimension and then <D> to accept. 

The dimension is updated to show the secondary units. 
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6. Repeat for the other dimensions as shown. 

 

Change dimension text 

7. Select the Edit Text command from the Text toolbar. 

8. <D> on the 12 ft lane metric text. 

Note: In the Text Editor, the dimension text appears as an asterisk (*) 
to denote that it is associative text. 

9. Change the text to Lane. 

10. <D> to accept. 

 

The text is updated on the dimension. 
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11. Repeat for the other travel lane and the shoulders as shown. 

 

Edit dimension text 

12. Using the Edit Text command, <D> on the 36 ft text. 

13. In the Text Editor, click to the right of the asterisk to get a blinking 
cursor. 

14. Space once and key in Curb to Curb. 

 

15. <D> to accept. 

 

Since you did not delete the asterisk, the text is still associated with the 
element. You just added text to the associated dimensions. 
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Dimension the Plan 

Dimension the bearing of the centerline 
1. On the CDOT menu, select Label Line. 

  

2. <D> on the SH 86 centerline. 

 

Both Bearing and Distance are placed. If you do not want one of the 
dimensions, you can drop the dimension, turn off the Graphic Group 
lock and then delete the dimension. 

Measure the bridge area 
1. Turn Depth lock on. 

2. Turn AccuSnap off. 

3. Select the Measure Area command from the Measure toolbar. 

4. Set the Method to Points. 
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5. Snap to the four corners of the bridge as shown (see arrows) to 
dynamically draw a shape to measure. 

 

6. Reset <R> to close the shape to compute the area (do not loop back and 
snap on the first point). 

 

Note:  The Points method is the only method that gives you a planar 
area with Depth lock turned on. 

Place a note with a curved leader 
1. From the CDOT Menu, set the text options as shown. 

  

2. Select the Place Note command. 
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3. In the Tool Settings box, set the Dimension Style to CDOT 3. 

 

Note: The Place Note command uses a dimension style for the leader 
and terminator as well as a text style. The CDOT 3 style will 
place a curved leader without an in-line leader. 

4. Place the note as shown. 

 

Note: Since this style does not use an in-line leader, you can place the 
text with a data point instead of a reset point on the side of the 
leader. 
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Dimension the Girder Detail 
1. Use the Element method to dimension the girder as shown. 
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2. Use the Linear method to finish placing dimensions. 
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3. Use the Modify command to move the dimension text as shown. 

 

4. Fit the view. 

5. Save Settings. 

6. Exit MicroStation. 
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Lab 10C – Printing to a Printer 
In this lab, you’ll plot a single sheet to the classroom 11 x 17 printer. 

Objectives 
After completing this exercise you will know how to: 

 Prepare a single sheet for printing. 
 Print an 11x17 sheet to a printer. 

Start MicroStation 
1. Start MicroStation and open 12345PDES_PnP9.dgn from the project’s 

…\Design\Drawings folder. 

2. Fit the view. 

3. Use the Edit Text command and edit the border text to add your initials as 
the Designer. 

Prepare the sheet for plotting 
1. Select Place Fence and set the Fence Type to Block and Fence Mode 

to Inside. 

 

2. Snap (<T>, then <D>) to the corners of the outer-most shape that goes 
all the way around the plan and profile sheet to place the fence.  

 

Snap here

Snap here
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Print the sheet (classroom printer) 
1. Select File > Print or choose the Print icon from the Standard toolbar. 

 

2. From the Print dialog box, select File > Select Windows Printer and 
double-click on the CO-HP 1700 printer. . 

3. Set the dialog as shown here. Be sure to set the Print Scale to 100. 

 

4. Select the Print icon or File > Print. 

The file is printed to the 11X17classroom plotter. 

Note: For tips on printing raster references (e.g. aerial photos), see the 
workflow Printing Raster Images. 

5. Do not exit. You’ll keep MicroStation open for the final plotting 
exercise. 

Print the sheet (CDOT workflow) 
1. Select File > Print or choose the Print icon from the Standard toolbar. 

 

2. If prompted, select CDOT-DefaultPrinter.plt for the print driver, and then 
select OK. 
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3. Set the dialog as shown here. Be sure to set the Print Scale to 100. 

 

4. Select the Print icon or File > Print. 

Note: For tips on printing raster references (e.g. aerial photos), see the 
workflow Printing Raster Images. 

5. Do not exit. You’ll keep MicroStation open for the final plotting 
exercise. 

Optional Exercise 
1. Open the 12345BRDG_Plan01.dgn file from the project’s 

…\Bridge\Drawings folder. 

2. Plot the sheet to the classroom printer. Be sure to set the Print Scale to 
40.  

3. Do not exit. You’ll keep MicroStation open for the final plotting 
exercise. 
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Lab 10D – Batch Printing to PDF 
In this lab, you’ll use Batch Printing to print multiple files at one time. Instead of 
printing to a printer, you’ll print to PDF for the reproduction department (i.e. a plot 
set for a milestone submittals).  

Note: To batch print to a printer, see the workflow CDOT Batch 
Printing. 

Objectives 
After completing this exercise you will know how to: 

 Select files to batch print. 
 Set and change batch process specifications. 
 Create a batch process job file (*.job). 
 Batch print to PDF files. 

Select Files to Batch Print 
1. Select Batch Print in MicroStation from the file pull down menu. 

 

Note:  You can be in any MicroStation file when you run the Batch 
Print process. 

2. In the Batch Print dialog box, select Edit > Add Files. 

Note:  Add Active File adds the design file that is open in 
MicroStation. 

3. Navigate to the C:\Projects\12345\Design\Drawings folder.  Select 
the following files to add to the batch process (you can hold down the 
Ctrl or Shift key to select multiple files): 

 12345DES_GenNote.dgn 
 12345DES_PnP01.dgn – 12345DES_PnP19.dgn 
 12345DES_StdPlanList.dgn 
 12345DES_TitleSheet.dgn 
 12345DES_TyplSect01.dgn   



Colorado Department of Transportation 

Page 534  CDOT MicroStation Essentials 

4. Select Add. 

 

Note: If you want to add other sheets to the batch process, you can 
change folders, select the file(s) and select Add again. 

5. When finished adding files, select Done. 

 

Set Batch Process Specifications 
1. The batch process default specifications are: 

 Printer:  11x17 Printer 
 Print Area:  SHEET_Plot-Boundary 
 Layout:  Maximize 
 Display:  As-Is Display 
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2. Select Specifications > Manage to change the default specifications.    

 

3. Under Types, select PDF Printer 

 Select Properties 

 

 Select Driver and select CDOT-PDFdriver.plt and select 
OK 

 Toggle off Print document set to single file 
 Set the Directory to c:\projects\12345\Plot_Sets\ 

 

 Select OK 
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 Under Types, select Print Area and then select Properties. 

 

Notes: The printable area defaults to the outer boundary of the standard 
CDOT sheet border (the yellow shape on level SHEET_Plot-
Boundary). 
 
Both Master File and References are checked ON under 
Search Files.  If the level SHEET_Plot-Boundary is not found in 
the Master File as a cell, it will search for the level in the 
Reference files associated with the sheet file.   

4. Cancel the Properties box. 
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5. Under Types, select Layout and then select Maximize. 

 

Note: The files you have selected for batch plotting are for different 
plot scales (100-scale, 40-scale, etc.). Therefore, select 
Maximize.  

6. Under Types, select Display 

 Select As-Is Display 
 Select Properties 

 

Notes: The As-Is Display Specification sets up the print properties for 
various elements. The As-Is setting reads MicroStation’s View 
Attributes setting for each design file. 
 
The Pen Table defaults to CDOT-PenTable.tbl, which is the 
table used for black-and-white printing. 

7. Cancel out of the Properties box. 
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8. Close the Batch Print Specification Manager box by selecting the X in 
the upper-right corner. 

Your changes are shown in the main Batch Print dialog box. 

 

Save your Specifications to a Job file (*.job) 
1. From the Batch Print dialog box, select File>Save As… 

2. Navigate to the project’s …Plot_Sets folder. 

Note: You should select one of the subfolders (FIR, FOR, etc.) for the 
appropriate plot set. For training purposes, you’ll plot to the 
upper level Plot Sets folder. 

3. In the Files field, key in 12345 and select OK. 

 

The job file should be saved to the project in the appropriate folder under 
the Plot_Sets. The file is automatically assigned a .job extension. If you 
want to process this job again, select File > Open from the Batch Print 
dialog box and choose the 12345.job file. 
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Create the Batch Prints 
1. Select the Print icon to open the Print Batch dialog box. 

 

2. In the Print Batch dialog box: 

 Set Print Range to All to print all the files selected 

 

Note: The option Selection would print only the files that you 
highlight in the list. 

3. Select OK to start the batch process. 

The process will take a few minutes to complete. If errors are 
encountered, open the error log batchplt.log in the C:\Program 
Files\Bentley\Program\MicroStation folder for more information. 

Review the PDF files 
1. In Windows, open My Computer. 

2. Navigate to the C:\Projects\12345\Plot_Sets\folder. 

 

The folder contains the 12345.pdf file sheets plus the 12345.job file. 
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3. Double-click on one of the pdf files to open.  

 

4. Continue opening sheets as desired. 

 

5. Close My Computer. 

6. Return to MicroStation and Exit.
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